cantor-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. Name: cantor
  2. Summary: Interface for mathematical applications
  3. Version: 4.9.5
  4. Release: 1%{?_dist_release}
  5. License: GPLv2+
  6. Group: Applications/Edutainment
  7. URL: http://edu.kde.org/cantor/
  8. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
  9. ## upstream patches
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: desktop-file-utils
  12. BuildRequires: gcc-gfortran
  13. BuildRequires: kdelibs4-devel >= %{version}
  14. BuildRequires: libspectre-devel
  15. BuildRequires: R libRmath-devel
  16. BuildRequires: soprano-devel
  17. BuildRequires: libqalculate-devel
  18. BuildRequires: analitza-devel
  19. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  20. Conflicts: kdeedu4 < 4.6.50
  21. %description
  22. Cantor is an application to allow you to you use your favorite mathematical applications from within an elegant KDE-integrated worksheet interface. It provides dialogs to assist with common tasks and allows you to share your worksheets with others.
  23. Cantor supports various mathematical applications as backends (provided in external packages):
  24. * KAlgebra
  25. * Maxima Computer Algebra System
  26. * R Project for Statistical Computing (cantor-backend-R)
  27. * Sage Mathematics Software
  28. * Octave
  29. This package is part of the KDE education module.
  30. %package backend-R
  31. Summary: R backend for Cantor
  32. Summary(ja): Cantor の R バックエンド
  33. Group: Applications/Edutainment
  34. Requires: %{name} = %{version}-%{release}
  35. %description backend-R
  36. %{summary}.
  37. %package libs
  38. Summary: Runtime libraries for %{name}
  39. Summary(ja): %{name} のランタイムライブラリ
  40. Group: System Environment/Libraries
  41. Conflicts: kdeedu4-math-libs < 4.6.50
  42. %description libs
  43. %{summary}.
  44. %package devel
  45. Summary: Development files for %{name}
  46. Summary(ja): %{name} の開発用ファイル
  47. Group: Development/Libraries
  48. Requires: %{name}-libs = %{version}-%{release}
  49. Conflicts: kdeedu4-devel < 4.6.50
  50. %description devel
  51. Header files for developing applications using %{name}.
  52. %prep
  53. %setup -q
  54. %build
  55. mkdir -p %{_target_platform}
  56. pushd %{_target_platform}
  57. %cmake \
  58. -DCMAKE_BUILD_TYPE=release \
  59. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  60. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  61. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  62. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  63. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  64. ..
  65. popd
  66. make %{?_smp_mflags} -C %{_target_platform}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %check
  73. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  74. desktop-file-validate $f
  75. done
  76. %post
  77. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  78. %posttrans
  79. update-desktop-database -q &> /dev/null ||:
  80. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  81. %postun
  82. if [ $1 -eq 0 ] ; then
  83. update-desktop-database -q &> /dev/null ||:
  84. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  85. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  86. fi
  87. %post backend-R
  88. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  89. %posttrans backend-R
  90. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  91. %postun backend-R
  92. if [ $1 -eq 0 ] ; then
  93. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  94. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  95. fi
  96. %post libs -p /sbin/ldconfig
  97. %postun libs -p /sbin/ldconfig
  98. %files
  99. %defattr(-,root,root)
  100. %doc COPYING COPYING.DOC
  101. %{_bindir}/cantor
  102. %{_libdir}/libcantor_config.so
  103. %{_libdir}/kde4/*.so
  104. %exclude %{_libdir}/kde4/cantor_rbackend.so
  105. %{_datadir}/applications/kde4/cantor.desktop
  106. %{_datadir}/config/*.knsrc
  107. %exclude %{_datadir}/config/cantor_r.knsrc
  108. %{_datadir}/config.kcfg/*.kcfg
  109. %exclude %{_datadir}/config.kcfg/rserver.kcfg
  110. %{_datadir}/icons/hicolor/*/*/*
  111. %exclude %{_datadir}/icons/hicolor/*/*/rbackend.*
  112. %{_datadir}/kde4/apps/cantor
  113. %{_datadir}/kde4/services/cantor/*.desktop
  114. %exclude %{_datadir}/kde4/services/cantor/rbackend.desktop
  115. %{_datadir}/kde4/servicetypes/cantor_*.desktop
  116. %doc %{_docdir}/HTML/en/cantor/
  117. %files backend-R
  118. %defattr(-,root,root,-)
  119. %{_bindir}/cantor_rserver
  120. %{_libdir}/kde4/cantor_rbackend.so
  121. %{_datadir}/config/cantor_r.knsrc
  122. %{_datadir}/config.kcfg/rserver.kcfg
  123. %{_datadir}/icons/hicolor/*/*/rbackend.*
  124. %{_datadir}/kde4/services/cantor/rbackend.desktop
  125. %files libs
  126. %defattr(-,root,root)
  127. %{_libdir}/libcantorlibs.so.*
  128. %files devel
  129. %defattr(-,root,root)
  130. %{_includedir}/kde4/cantor
  131. %{_libdir}/libcantorlibs.so
  132. %changelog
  133. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
  134. - new upstream release
  135. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
  136. - new upstream release
  137. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
  138. - new upstream release
  139. * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
  140. - new upstream release
  141. * Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
  142. - new upstream release
  143. - add BuildRequires: libqalculate-devel, analitza-devel
  144. * Thu Sep 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
  145. - split from kdeedu