WebKit3-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit3
  15. Version: 1.10.2
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Takemikaduchi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk3-devel
  32. BuildRequires: gtk2-devel
  33. BuildRequires: libicu-devel
  34. BuildRequires: libjpeg-turbo-devel
  35. BuildRequires: libtool
  36. BuildRequires: libxslt-devel
  37. BuildRequires: libXt-devel
  38. BuildRequires: pcre-devel
  39. BuildRequires: sqlite3-devel
  40. BuildRequires: geoclue-devel
  41. BuildRequires: gcr-devel
  42. BuildRequires: gstreamer1-devel
  43. BuildRequires: gstreamer1-plugins-base-devel
  44. BuildRequires: enchant-devel
  45. BuildRequires: gobject-introspection-devel
  46. BuildRequires: gsettings-desktop-schemas
  47. BuildRequires: gtk-doc
  48. %if %{with pango}
  49. BuildRequires: pango-devel
  50. %else
  51. BuildRequires: cairo-devel
  52. BuildRequires: fontconfig-devel
  53. BuildRequires: freetype2-devel
  54. %endif
  55. BuildRequires: libsoup-devel >= 2.28.2
  56. %description
  57. WebKit is an open source web browser engine.
  58. %package gtk
  59. Summary: GTK+ port of WebKit
  60. Summary(ja): WebKit の GTK+ ポート
  61. Group: Development/Libraries
  62. %description gtk
  63. %{name} is an open-source Web content engine library. This package contains
  64. the shared libraries for the WebKit GTK+ port as well as the sample
  65. GtkLauncher tool.
  66. %package gtk-devel
  67. Summary: Development package for %{name}
  68. Summary(ja): %{name} の開発パッケージ
  69. Group: Development/Libraries
  70. Requires: %{name}-gtk = %{version}-%{release}
  71. Requires: pkgconfig
  72. Requires: gtk3-devel
  73. Requires: libsoup-devel >= 2.28.2
  74. %description gtk-devel
  75. The %{name}-gtk-devel package contains libraries, build data, and header
  76. files for developing applications that use %{name}-gtk.
  77. Please note that the WebKit/GTK+ API is not yet stable. This should
  78. only be used as a "preview" rather than a stable platform library.
  79. %package doc
  80. Summary: Documentation for %{name}
  81. Summary(ja): %{name} のドキュメント
  82. Group: Documentation
  83. %description doc
  84. %{name} is an open-source Web content engine library. This package contains
  85. the documentation for %{name}, including various LICENSE, README, and
  86. AUTHORS files.
  87. %prep
  88. %setup -q -n webkitgtk-%{version}
  89. %build
  90. %configure \
  91. --with-gtk=3.0 \
  92. --with-gstreamer=1.0 \
  93. --enable-icon-database \
  94. --enable-geolocation \
  95. --enable-introspection=yes \
  96. --enable-dependency-tracking \
  97. %{?with_coverage: --enable-coverage } \
  98. %{?with_pango: --with-font-backend=pango } \
  99. %{?with_wml: --enable-wml }
  100. make V=1 %{?_smp_mflags}
  101. # workaround for bug 488112
  102. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  103. ##touch JavaScriptCore/AllInOneFile.cpp
  104. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  105. %install
  106. rm -rf %{buildroot}
  107. make install DESTDIR=%{buildroot}
  108. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  109. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  110. # conflict with WebKit-doc
  111. rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
  112. # Finally, copy over and rename the various files for %%doc inclusion.
  113. %add_to_doc_files Source/WebKit/LICENSE
  114. %add_to_doc_files Source/WebKit/gtk/po/README
  115. %add_to_doc_files Source/WebKit/gtk/NEWS
  116. %add_to_doc_files Source/WebCore/icu/LICENSE
  117. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  118. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  119. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  120. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  121. %add_to_doc_files Source/JavaScriptCore/THANKS
  122. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  123. %add_to_doc_files Source/JavaScriptCore/icu/README
  124. %add_to_doc_files Source/JavaScriptCore/icu/LICENSE
  125. %find_lang webkitgtk-3.0
  126. %clean
  127. rm -rf %{buildroot}
  128. %post gtk -p /sbin/ldconfig
  129. %posttrans gtk
  130. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  131. %postun gtk
  132. /sbin/ldconfig
  133. if [ $1 -eq 0 ] ; then
  134. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  135. fi
  136. # %files -f webkit.lang gtk
  137. %files gtk -f webkitgtk-3.0.lang
  138. %defattr(-,root,root,-)
  139. %doc
  140. %{_libdir}/*.so.*
  141. %{_libexecdir}/WebKit3/
  142. %{_libexecdir}/WebKitPluginProcess
  143. %{_libexecdir}/WebKitWebProcess
  144. %{_bindir}/jsc-3
  145. %{_libdir}/girepository-1.0/*.typelib
  146. %{_datadir}/webkitgtk-3.0/*
  147. %files gtk-devel
  148. %defattr(-,root,root,-)
  149. %exclude %{_libdir}/*.la
  150. %{_includedir}/webkitgtk-3.0
  151. %{_libdir}/*.so
  152. %{_libdir}/pkgconfig/*.pc
  153. %{_datadir}/gir-1.0/*.gir
  154. %files doc -f docfiles.list
  155. %defattr(-,root,root,-)
  156. %changelog
  157. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  158. - new upstream release
  159. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  160. - new upstream release
  161. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  162. - new upstream release
  163. - add BuildRequires: ruby, gtk2-devel
  164. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  165. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
  166. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  167. - new upstream release
  168. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  169. - new upstream release
  170. * Sun Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  171. - new upstream release
  172. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  173. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  174. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  175. - new upstream release
  176. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  177. - new upstream release
  178. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  179. - new upstream release
  180. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  181. - initial build for Vine Linux