WebKit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 1.10.2
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk2-devel
  32. BuildRequires: libicu-devel
  33. BuildRequires: libjpeg-turbo-devel
  34. BuildRequires: libtool
  35. BuildRequires: libxslt-devel
  36. BuildRequires: libXt-devel
  37. BuildRequires: pcre-devel
  38. BuildRequires: sqlite3-devel
  39. BuildRequires: geoclue-devel
  40. BuildRequires: gcr-devel
  41. BuildRequires: gstreamer-devel
  42. BuildRequires: gstreamer-plugins-base-devel
  43. BuildRequires: enchant-devel
  44. BuildRequires: gobject-introspection-devel
  45. BuildRequires: gsettings-desktop-schemas
  46. BuildRequires: gtk-doc
  47. %if %{with pango}
  48. BuildRequires: pango-devel
  49. %else
  50. BuildRequires: cairo-devel
  51. BuildRequires: fontconfig-devel
  52. BuildRequires: freetype2-devel
  53. %endif
  54. BuildRequires: libsoup-devel >= 2.28.2
  55. %description
  56. WebKit is an open source web browser engine.
  57. %package gtk
  58. Summary: GTK+ port of WebKit
  59. Summary(ja): WebKit の GTK+ ポート
  60. Group: Development/Libraries
  61. %description gtk
  62. %{name} is an open-source Web content engine library. This package contains
  63. the shared libraries for the WebKit GTK+ port as well as the sample
  64. GtkLauncher tool.
  65. %package gtk-devel
  66. Summary: Development package for %{name}
  67. Summary(ja): %{name} の開発パッケージ
  68. Group: Development/Libraries
  69. Requires: %{name}-gtk = %{version}-%{release}
  70. Requires: pkgconfig
  71. Requires: gtk2-devel
  72. Requires: libsoup-devel >= 2.28.2
  73. %description gtk-devel
  74. The %{name}-gtk-devel package contains libraries, build data, and header
  75. files for developing applications that use %{name}-gtk.
  76. Please note that the WebKit/GTK+ API is not yet stable. This should
  77. only be used as a "preview" rather than a stable platform library.
  78. %package doc
  79. Summary: Documentation for %{name}
  80. Summary(ja): %{name} のドキュメント
  81. Group: Documentation
  82. %description doc
  83. %{name} is an open-source Web content engine library. This package contains
  84. the documentation for %{name}, including various LICENSE, README, and
  85. AUTHORS files.
  86. %prep
  87. %setup -q -n webkitgtk-%{version}
  88. %build
  89. %configure \
  90. --with-gtk=2.0 \
  91. --disable-webkit2 \
  92. --enable-icon-database \
  93. --enable-jit \
  94. --enable-geolocation \
  95. --enable-introspection=yes \
  96. --enable-webgl \
  97. --enable-dependency-tracking \
  98. %{?with_coverage: --enable-coverage } \
  99. %{?with_pango: --with-font-backend=pango } \
  100. %{?with_wml: --enable-wml }
  101. make V=1 %{?_smp_mflags}
  102. # workaround for bug 488112
  103. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  104. ##touch JavaScriptCore/AllInOneFile.cpp
  105. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  106. %install
  107. rm -rf %{buildroot}
  108. make install DESTDIR=%{buildroot}
  109. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  110. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  111. # Finally, copy over and rename the various files for %%doc inclusion.
  112. %add_to_doc_files Source/WebKit/LICENSE
  113. %add_to_doc_files Source/WebKit/gtk/po/README
  114. %add_to_doc_files Source/WebKit/gtk/NEWS
  115. %add_to_doc_files Source/WebCore/icu/LICENSE
  116. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  117. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  118. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  119. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  120. %add_to_doc_files Source/JavaScriptCore/THANKS
  121. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  122. %add_to_doc_files Source/JavaScriptCore/icu/README
  123. %add_to_doc_files Source/JavaScriptCore/icu/LICENSE
  124. %find_lang webkitgtk-2.0
  125. %clean
  126. rm -rf %{buildroot}
  127. %post gtk -p /sbin/ldconfig
  128. %posttrans gtk
  129. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  130. %postun gtk
  131. /sbin/ldconfig
  132. if [ $1 -eq 0 ] ; then
  133. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  134. fi
  135. # %files -f webkit.lang gtk
  136. %files gtk -f webkitgtk-2.0.lang
  137. %defattr(-,root,root,-)
  138. %doc
  139. %{_libdir}/*.so.*
  140. %{_libexecdir}/WebKit/
  141. %{_bindir}/jsc-1
  142. %{_libdir}/girepository-1.0/*.typelib
  143. #%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
  144. %{_datadir}/webkitgtk-1.0/*
  145. %files gtk-devel
  146. %defattr(-,root,root,-)
  147. %exclude %{_libdir}/*.la
  148. %{_includedir}/webkitgtk-1.0
  149. %{_libdir}/*.so
  150. %{_libdir}/pkgconfig/*.pc
  151. %{_datadir}/gir-1.0/*.gir
  152. %files doc -f docfiles.list
  153. %defattr(-,root,root,-)
  154. %{_datadir}/gtk-doc/html/webkitgtk
  155. %changelog
  156. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  157. - new upstream release
  158. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  159. - new upstream release
  160. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  161. - new upstream release
  162. - add BuildRequires: ruby
  163. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  164. - new upstream release
  165. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  166. - new upstream release
  167. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  168. - new upstream release
  169. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  170. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  171. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  172. - new upstream release
  173. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  174. - new upstream release
  175. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  176. - new upstream release
  177. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  178. - new upstream release
  179. * Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
  180. - new upstream release
  181. - delete Patch0
  182. - add BuildRequires: gtk-doc
  183. * Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
  184. - new upstream release
  185. * Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
  186. - new upstream release
  187. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
  188. - new upstream release
  189. - add BuildRequires: gobject-introspection-devel
  190. - add configure option (--enable-introspection=yes)
  191. - add Patch0 (WebKit-1.2.5-gir.patch)
  192. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
  193. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  194. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  195. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  196. - new upstream release
  197. - add Requires: libsoup-devel (devel package)
  198. - fix configure (remove unrecognized option)
  199. - drop Patch100
  200. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  201. - rebuilt again on ppc
  202. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  203. - new upstream release
  204. - rebuilt with libicu-4.4
  205. - added Patch100 for compiling with libicu-4.4
  206. - s/sqlite-devel/sqlite3-devel/
  207. - s/freetype-devel/freetype2-devel/
  208. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  209. - updated to 1.1.18
  210. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  211. - change BR from libsoup to libsoup-devel
  212. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  213. - new upstream release.
  214. - add Vendor, Distribution and Packager.
  215. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  216. - update to webkit-1.1.10 release version
  217. - added BuildRequires: enchant-devel
  218. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  219. - update to webkit-1.1.6 release version
  220. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  221. - update to new upstream snapshot (svn r41944)
  222. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  223. - update to new upstream snapshot (svn r40471)
  224. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  225. - update to new upstream snapshot (svn r37056)
  226. - disable html5video by default
  227. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  228. - update to new upstream snapshot (svn r36882)
  229. - build with gnome-2.24
  230. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  231. - build without pango by default.
  232. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  233. - update to new upstream snapshot (svn r36053)
  234. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  235. - update to new upstream snapshot (svn r34655)
  236. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  237. - initial build for Vine Linux
  238. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  239. - rebuild for new icu
  240. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  241. - Update to new upstream snapshot (SVN 34279) anyway
  242. - Add BR: libXt-devel
  243. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  244. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  245. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  246. subdirectories either.)
  247. - Reference: bug 442200 (RFE: WebKit Migration)
  248. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  249. tree).
  250. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  251. - Update to new upstream snapshot (SVN 32531).
  252. - Fix bug 443048 and hopefully fix bug 444445
  253. - Modify the process of building GTK+ port a bit
  254. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  255. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  256. - Update to new upstream snapshot (SVN 31787).
  257. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  258. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  259. - Switch to using autotools for building the GTK+ port.
  260. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  261. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  262. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  263. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  264. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  265. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  266. file location mismatch)
  267. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  268. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  269. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  270. - Update to new upstream snapshot (SVN 30667)
  271. - Add some build fixes for GCC 4.3:
  272. + gcc43.patch
  273. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  274. - Autorebuild for GCC 4.3
  275. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  276. - Update to new upstream snapshot (SVN 29336).
  277. - Drop TCSpinLock pthread workaround (fixed upstream):
  278. - TCSpinLock-use-pthread-stubs.patch
  279. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  280. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  281. - Add patch to forcibly build the TCSpinLock code using the pthread
  282. implementation:
  283. + TCSpinLock-use-pthread-stubs.patch
  284. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  285. - Package renamed from WebKitGtk.
  286. - Update to SVN 28482.
  287. - Build both the GTK and Qt ports, putting each into their own respective
  288. subpackages.
  289. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  290. the build-webkit script from upstream.
  291. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  292. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  293. - Initial packaging for Fedora.