self-build-pragha-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. %define pkgname pragha
  2. %define name self-build-%{pkgname}
  3. %define version 0.8.9
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://dissonance.googlecode.com/files/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv3+
  13. Group: Restricted Software
  14. # Requires(posttrans) not yet implemented. So we use (post) instead.
  15. Requires(post): self-build-setup >= 0.9.9
  16. # (build)requies of target package.
  17. Requires(post): alsa-lib-devel >= 1.0.15
  18. Requires(post): dbus-glib-devel >= 0.74
  19. Requires(post): gtk2-devel >= 2.16.0
  20. Requires(post): flac-devel >= 1.2.1
  21. %if %{?_dist_release} != "vl5"
  22. Requires(post): keybinder-devel >= 0.2.0
  23. %endif
  24. Requires(post): libao-devel >= 0.8.8
  25. Requires(post): libcddb-devel >= 1.2.1
  26. Requires(post): libcdio-devel >= 0.78
  27. Requires(post): curl-devel >= 7.18
  28. ##Requires(post): libmad-devel >= 0.15
  29. Requires(post): libmodplug-devel
  30. Requires(post): libnotify-devel >= 0.4.4
  31. Requires(post): libsndfile-devel >= 1.0.17
  32. Requires(post): libvorbis-devel >= 1.2.0
  33. Requires(post): sqlite3-devel >= 3.4
  34. Requires(post): taglib-devel >= 1.4
  35. Requires(post): desktop-file-utils
  36. Requires(post): gettext
  37. Requires(post): self-build-libmad >= 0.15
  38. BuildArch: noarch
  39. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  40. Packager: munepi
  41. %description
  42. Pragha is a lightweight GTK+ music manager that aims to be fast, bloat-free,
  43. and light on memory consumption. It is written completely in C and GTK+.
  44. Pragha is a fork of Consonance Music Manager, discontinued by the original
  45. author.
  46. If you install this package, it automaticaly downloads source
  47. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  48. And the created rpm packages are automatically installed
  49. if installation is executed by apt-get command or synaptic
  50. package manager.
  51. [Note]
  52. This package requires many other packages to compile
  53. targetsoftware. So it consume more disk space than usual.
  54. Also installation takes logner time because of compilation.
  55. (This will take a few minutes to quarter or half of an hour,
  56. depends on building environment)
  57. [About self-build package]
  58. For some kind of software, distributing of binary package
  59. may viorate the patent or law. Therefore we chose self-build
  60. packge, create binary package on your machine, for such kind
  61. of softwares instead of distributing binary package.
  62. Please obey the national law when you use the created binary
  63. packages. And if you want to use the softwares using patented
  64. thechnology, it may be required to get a permission, make an
  65. agreement or purchas a license. Please consider it with your
  66. purpose or way of use and take appropriate action.
  67. %description -l ja
  68. Pragha は軽量 GTK+ 楽曲管理アプリケーションです。
  69. このパッケージをインストールすると、自動的にソースコードを
  70. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  71. パッケージを作成します。
  72. また apt-get コマンドや synaptic パッケージマネージャから実行
  73. した場合は、作成された rpm パッケージのインストールも自動的に
  74. 行います。
  75. [注意]
  76. コンパイルに必要な多くの関連パッケージを要求するので通常より
  77. ディスクの領域を多く消費します。
  78. またインストール時にコンパイルを行うため、通常より時間がかか
  79. る場合があります。(環境にもよりますが数分から数十分程度)
  80. [self-build パッケージについて]
  81. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  82. 違反する可能性があるものがあります。その為、このような問題が
  83. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  84. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  85. ジという方法を採っています。
  86. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  87. アのライセンス、および利用する国の各種法令に従ってください。
  88. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  89. センスの購入などが必要となる場合がありますので、利用する目的
  90. や形態に応じて各自で判断し適切な対応を取ってください。
  91. %prep
  92. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  93. %install
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  97. %clean
  98. %{__rm} -rf ${RPM_BUILD_ROOT}
  99. %posttrans
  100. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 66000
  101. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
  102. %files
  103. %defattr(-,root,root)
  104. %{_datadir}/%{name}
  105. %changelog
  106. * Tue Aug 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.9-1
  107. - new upstream release
  108. - added Requires(post): keybinder-devel >= 0.2.0
  109. * Sun Feb 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.5-2
  110. - fixed %%posttrans
  111. * Sat Feb 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.5-1
  112. - new upstream release
  113. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.2-1
  114. - initial bulid