qt5-qtwebengine-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768
  1. %global qt_module qtwebengine
  2. %global _hardened_build 1
  3. # define to build docs, need to undef this for bootstrapping
  4. # where qt5-qttools builds are not yet available
  5. # only primary archs (for now), allow secondary to bootstrap
  6. %ifarch %{arm} %{ix86} x86_64
  7. #global docs 1
  8. %endif
  9. %if 0
  10. # need libvpx >= 1.8.0
  11. %global use_system_libvpx 1
  12. %endif
  13. %if 0
  14. # need libwebp >= 0.4.3
  15. %global use_system_libwebp 1
  16. %endif
  17. #global prerelease rc
  18. # spellchecking dictionary directory
  19. %global _qtwebengine_dictionaries_dir %{_qt5_datadir}/qtwebengine_dictionaries
  20. %global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
  21. # exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
  22. # else)
  23. %global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
  24. # exclude libv8.so (i686, it's static everywhere else)
  25. %global __requires_exclude ^libv8\\.so$
  26. # and designer plugins
  27. %global __provides_exclude_from ^%{_qt5_plugindir}/.*\\.so$
  28. %global qt5_minorver 5.12
  29. %global qt5_version 5.12.5
  30. #global qt5_patchlevel 1
  31. Summary: Qt5 - QtWebEngine components
  32. Name: qt5-qtwebengine
  33. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  34. Release: 1%{?_dist_release}
  35. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  36. # See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
  37. # The other licenses are from Chromium and the code it bundles
  38. License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
  39. URL: https://www.qt.io/
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. # cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
  43. # wget https://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-everywhere-src-5.6.1-1.tar.xz
  44. # ./clean_qtwebengine.sh 5.6.1-1
  45. Source0: %{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
  46. # cleanup scripts used above
  47. Source1: clean_qtwebengine.sh
  48. Source2: clean_ffmpeg.sh
  49. Source3: get_free_ffmpeg_source_files.py
  50. # macros
  51. Source10: macros.qt5-qtwebengine
  52. # pulseaudio headers
  53. Source20: pulseaudio-12.2-headers.tar.gz
  54. # some tweaks to linux.pri (system yasm, link libpci, run unbundling script)
  55. Patch0: qtwebengine-everywhere-src-5.10.0-linux-pri.patch
  56. # quick hack to avoid checking for the nonexistent icudtl.dat and silence the
  57. # resulting warnings - not upstreamable as is because it removes the fallback
  58. # mechanism for the ICU data directory (which is not used in our builds because
  59. # we use the system ICU, which embeds the data statically) completely
  60. Patch1: qtwebengine-everywhere-src-5.11.0-no-icudtl-dat.patch
  61. # fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
  62. # ARM flags with our %%qmake_qt5 macro, including for the next patch
  63. Patch2: qtwebengine-opensource-src-5.12.4-fix-extractcflag.patch
  64. # disable NEON vector instructions on ARM where the NEON code FTBFS due to
  65. # GCC bug https://bugzilla.redhat.com/show_bug.cgi?id=1282495
  66. Patch3: qtwebengine-opensource-src-5.9.0-no-neon.patch
  67. # workaround FTBFS against kernel-headers-5.2.0+
  68. Patch4: qtwebengine-SIOCGSTAMP.patch
  69. # remove Android dependencies from openmax_dl ARM NEON detection (detect.c)
  70. Patch10: qtwebengine-opensource-src-5.9.0-openmax-dl-neon.patch
  71. # Force verbose output from the GN bootstrap process
  72. Patch21: qtwebengine-everywhere-src-5.12.0-gn-bootstrap-verbose.patch
  73. # Fix/workaround FTBFS on aarch64 with newer glibc
  74. Patch24: qtwebengine-everywhere-src-5.11.3-aarch64-new-stat.patch
  75. # fix build error with libicu-65
  76. Patch1000: qtwebengine-icu65.patch
  77. # handled by qt5-srpm-macros, which defines %%qt5_qtwebengine_arches
  78. ExclusiveArch: %{qt5_qtwebengine_arches}
  79. BuildRequires: qt5-rpm-macros
  80. BuildRequires: qt5-srpm-macros
  81. BuildRequires: qt5-qtbase-devel
  82. BuildRequires: qt5-qtbase-private-devel
  83. # TODO: check of = is really needed or if >= would be good enough -- rex
  84. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  85. BuildRequires: qt5-qtdeclarative-devel
  86. BuildRequires: qt5-qtxmlpatterns-devel
  87. BuildRequires: qt5-qtlocation-devel
  88. BuildRequires: qt5-qtsensors-devel
  89. BuildRequires: qt5-qtwebchannel-devel
  90. BuildRequires: qt5-qttools-static
  91. # for examples?
  92. BuildRequires: qt5-qtquickcontrols2-devel
  93. BuildRequires: ninja
  94. BuildRequires: cmake
  95. BuildRequires: bison
  96. BuildRequires: flex
  97. BuildRequires: gcc-c++
  98. # gn links statically (for now)
  99. BuildRequires: libstdc++-static
  100. BuildRequires: git-core
  101. BuildRequires: gperf
  102. BuildRequires: krb5-devel
  103. BuildRequires: libicu-devel
  104. BuildRequires: libjpeg-turbo-devel
  105. #BuildRequires: re2-devel
  106. BuildRequires: snappy-devel
  107. %ifarch %{ix86} x86_64
  108. BuildRequires: yasm
  109. %endif
  110. BuildRequires: pkgconfig(expat)
  111. BuildRequires: pkgconfig(gobject-2.0)
  112. BuildRequires: pkgconfig(glib-2.0)
  113. BuildRequires: pkgconfig(fontconfig)
  114. BuildRequires: pkgconfig(freetype2)
  115. BuildRequires: pkgconfig(gl)
  116. BuildRequires: pkgconfig(egl)
  117. BuildRequires: pkgconfig(jsoncpp)
  118. BuildRequires: pkgconfig(libpng)
  119. BuildRequires: pkgconfig(libudev)
  120. %if 0%{?use_system_libwebp}
  121. BuildRequires: pkgconfig(libwebp) >= 0.6.0
  122. %endif
  123. BuildRequires: pkgconfig(harfbuzz)
  124. BuildRequires: pkgconfig(libdrm)
  125. BuildRequires: opus-devel
  126. BuildRequires: pkgconfig(protobuf)
  127. BuildRequires: pkgconfig(libevent)
  128. BuildRequires: zlib-devel
  129. #BuildRequires: pkgconfig(minizip)
  130. BuildRequires: pkgconfig(x11)
  131. BuildRequires: pkgconfig(xi)
  132. BuildRequires: libXcursor-devel
  133. BuildRequires: pkgconfig(xext)
  134. BuildRequires: pkgconfig(xfixes)
  135. BuildRequires: pkgconfig(xrender)
  136. BuildRequires: pkgconfig(xdamage)
  137. BuildRequires: pkgconfig(xcomposite)
  138. BuildRequires: pkgconfig(xtst)
  139. BuildRequires: pkgconfig(xrandr)
  140. BuildRequires: pkgconfig(xscrnsaver)
  141. BuildRequires: pkgconfig(libcap)
  142. BuildRequires: pkgconfig(libpulse)
  143. BuildRequires: pkgconfig(alsa)
  144. BuildRequires: pciutils-devel
  145. BuildRequires: pkgconfig(dbus-1)
  146. BuildRequires: pkgconfig(nss)
  147. BuildRequires: pkgconfig(lcms2)
  148. BuildRequires: perl
  149. BuildRequires: python
  150. BuildRequires: python-rpm-macros
  151. %if 0%{?use_system_libvpx}
  152. BuildRequires: pkgconfig(vpx) >= 1.7.0
  153. %endif
  154. # extra (non-upstream) functions needed, see
  155. # src/3rdparty/chromium/third_party/sqlite/README.chromium for details
  156. #BuildRequires: pkgconfig(sqlite3)
  157. ## Various bundled libraries that Chromium does not support unbundling :-(
  158. ## Only the parts actually built are listed.
  159. ## Query for candidates:
  160. ## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
  161. ## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
  162. ## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
  163. ## some false positives where only shim headers are generated for some reason
  164. ## some false positives with dummy placeholder dirs (swiftshader, widevine)
  165. ## some false negatives where a header-only library is bundled (e.g. x86inc)
  166. ## Spot's chromium.spec also has a list that I checked.
  167. # Of course, Chromium itself is bundled. It cannot be unbundled because it is
  168. # not a library, but forked (modified) application code.
  169. # Some security fixes are backported, see:
  170. # http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
  171. Provides: bundled(chromium) = 61.0.3163.140
  172. # Bundled in src/3rdparty/chromium/third_party:
  173. # Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
  174. # except where specified otherwise.
  175. Provides: bundled(angle) = 2422
  176. # Google's fork of OpenSSL
  177. # We cannot build against NSS instead because it no longer works with NSS 3.21:
  178. # HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
  179. # completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
  180. # http://kaosx.us/phpBB3/viewtopic.php?t=1235
  181. # https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
  182. # So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
  183. # use the BoringSSL code and the system NSS certificates.
  184. Provides: bundled(boringssl)
  185. Provides: bundled(brotli)
  186. # Don't get too excited. MPEG and other legally problematic stuff is stripped
  187. # out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
  188. # see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
  189. Provides: bundled(ffmpeg) = 3.3
  190. Provides: bundled(hunspell) = 1.6.0
  191. Provides: bundled(iccjpeg)
  192. # bundled as "khronos", headers only
  193. Provides: bundled(khronos_headers)
  194. # bundled as "leveldatabase"
  195. Provides: bundled(leveldb) = 1.20
  196. # bundled as "libjingle_xmpp"
  197. Provides: bundled(libjingle)
  198. # see src/3rdparty/chromium/third_party/libsrtp/CHANGES for the version number
  199. Provides: bundled(libsrtp) = 2.1.0
  200. %if !0%{?use_system_libvpx}
  201. # claims "Version: 1.6.0", but according to the fine print, this is actually a
  202. # snapshot from master from after the 1.6.1 release
  203. Provides: bundled(libvpx) = 1.6.1
  204. %endif
  205. %if !0%{?use_system_libwebp}
  206. Provides: bundled(libwebp) = 0.6.0
  207. %endif
  208. # bundled as "libxml"
  209. # see src/3rdparty/chromium/third_party/libxml/linux/include/libxml/xmlversion.h
  210. Provides: bundled(libxml2) = 2.9.4
  211. # see src/3rdparty/chromium/third_party/libxslt/linux/config.h for version
  212. Provides: bundled(libxslt) = 1.1.29
  213. Provides: bundled(libXNVCtrl) = 302.17
  214. Provides: bundled(libyuv) = 1658
  215. Provides: bundled(modp_b64)
  216. Provides: bundled(openmax_dl) = 1.0.2
  217. Provides: bundled(ots)
  218. # see src/3rdparty/chromium/third_party/protobuf/CHANGES.txt for the version
  219. #Provides: bundled(protobuf) = 3.0.0-0.1.beta3
  220. Provides: bundled(qcms) = 4
  221. Provides: bundled(sfntly)
  222. Provides: bundled(skia)
  223. # bundled as "smhasher"
  224. Provides: bundled(SMHasher) = 0-0.1.svn147
  225. Provides: bundled(sqlite) = 3.20
  226. Provides: bundled(usrsctp)
  227. Provides: bundled(webrtc) = 90
  228. %ifarch %{ix86} x86_64
  229. # bundled by ffmpeg and libvpx:
  230. # header (for assembly) only
  231. Provides: bundled(x86inc)
  232. %endif
  233. # Bundled in src/3rdparty/chromium/base/third_party:
  234. # Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
  235. # numbers, except where specified otherwise.
  236. Provides: bundled(dmg_fp)
  237. Provides: bundled(dynamic_annotations) = 4384
  238. Provides: bundled(superfasthash) = 0
  239. Provides: bundled(symbolize)
  240. # bundled as "valgrind", headers only
  241. Provides: bundled(valgrind.h)
  242. # bundled as "xdg_mime"
  243. Provides: bundled(xdg-mime)
  244. # bundled as "xdg_user_dirs"
  245. Provides: bundled(xdg-user-dirs) = 0.10
  246. # Bundled in src/3rdparty/chromium/net/third_party:
  247. # Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
  248. # numbers, except where specified otherwise.
  249. Provides: bundled(mozilla_security_manager) = 1.9.2
  250. # Bundled in src/3rdparty/chromium/url/third_party:
  251. # Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
  252. # numbers, except where specified otherwise.
  253. # bundled as "mozilla", file renamed and modified
  254. Provides: bundled(nsURLParsers)
  255. # Bundled outside of third_party, apparently not considered as such by Chromium:
  256. Provides: bundled(mojo)
  257. # see src/3rdparty/chromium/v8/include/v8_version.h for the version number
  258. Provides: bundled(v8) = 6.1.534.44
  259. # bundled by v8 (src/3rdparty/chromium/v8/src/base/ieee754.cc)
  260. # The version number is 5.3, the last version that upstream released, years ago:
  261. # http://www.netlib.org/fdlibm/readme
  262. Provides: bundled(fdlibm) = 5.3
  263. %{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
  264. %description
  265. %{summary}.
  266. %package devel
  267. Summary: Development files for %{name}
  268. Requires: %{name}%{?_isa} = %{version}-%{release}
  269. Requires: qt5-qtbase-devel%{?_isa}
  270. Requires: qt5-qtdeclarative-devel%{?_isa}
  271. # not arch'd for now, see if can get away with avoiding multilib'ing -- rex
  272. Requires: %{name}-devtools = %{version}-%{release}
  273. %description devel
  274. %{summary}.
  275. %package devtools
  276. Summary: WebEngine devtools_resources
  277. Requires: %{name}%{?_isa} = %{version}-%{release}
  278. %description devtools
  279. Support for remote debugging.
  280. %package examples
  281. Summary: Example files for %{name}
  282. %description examples
  283. %{summary}.
  284. %if 0%{?docs}
  285. %package doc
  286. Summary: API documentation for %{name}
  287. BuildRequires: qt5-qhelpgenerator
  288. BuildRequires: qt5-qdoc
  289. BuildArch: noarch
  290. %description doc
  291. %{summary}.
  292. %endif
  293. %prep
  294. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  295. %if 0
  296. tar xvf %{SOURCE20}
  297. mv pulse src/3rdparty/chromium/
  298. %endif
  299. %patch0 -p1 -b .linux-pri
  300. %patch1 -p1 -b .no-icudtl-dat
  301. %patch2 -p1 -b .fix-extractcflag
  302. %if !0%{?arm_neon}
  303. %patch3 -p1 -b .no-neon
  304. %endif
  305. %patch4 -p1 -b .SIOCGSTAMP
  306. ## upstream patches
  307. %patch10 -p1 -b .openmax-dl-neon
  308. ## NEEDSWORK
  309. #patch21 -p1 -b .gn-bootstrap-verbose
  310. %patch24 -p1 -b .aarch64-new-stat
  311. # enable to build with libicu-65
  312. %patch1000 -p1 -b .icu65
  313. # fix // in #include in content/renderer/gpu to avoid debugedit failure
  314. #sed -i -e 's!gpu//!gpu/!g' \
  315. # src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
  316. # and another one in 2 files in WebRTC
  317. sed -i -e 's!audio_processing//!audio_processing/!g' \
  318. src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft.cc \
  319. src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft_sse2.cc
  320. # remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
  321. sed -i -e 's!\./!!g' \
  322. src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
  323. src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
  324. # delete all "toolprefix = " lines from build/toolchain/linux/BUILD.gn, as we
  325. # never cross-compile in native Fedora RPMs, fixes ARM and aarch64 FTBFS
  326. sed -i -e '/toolprefix = /d' -e 's/\${toolprefix}//g' \
  327. src/3rdparty/chromium/build/toolchain/linux/BUILD.gn
  328. # http://bugzilla.redhat.com/1337585
  329. # can't just delete, but we'll overwrite with system headers to be on the safe side
  330. #cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/src/re2/
  331. %if 0
  332. #ifarch x86_64
  333. # enable this to force -g2 on x86_64 (most arches run out of memory with -g2)
  334. # DISABLED BECAUSE OF:
  335. # /usr/lib/rpm/find-debuginfo.sh: line 188: 3619 Segmentation fault
  336. # (core dumped) eu-strip --remove-comment $r $g -f "$1" "$2"
  337. sed -i -e 's/symbol_level=1/symbol_level=2/g' src/core/config/common.pri
  338. %endif
  339. # generate qtwebengine-3rdparty.qdoc, it is missing from the tarball
  340. pushd src/3rdparty
  341. %{__python} chromium/tools/licenses.py \
  342. --file-template ../../tools/about_credits.tmpl \
  343. --entry-template ../../tools/about_credits_entry.tmpl \
  344. credits >../webengine/doc/src/qtwebengine-3rdparty.qdoc
  345. popd
  346. # copy the Chromium license so it is installed with the appropriate name
  347. cp -p src/3rdparty/chromium/LICENSE LICENSE.Chromium
  348. %build
  349. export STRIP=strip
  350. export NINJAFLAGS="%{?__ninja_common_opts}"
  351. export NINJA_PATH=%{_bindir}/ninja-build
  352. export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
  353. export CFLAGS="%{optflags}"
  354. #ifnarch x86_64
  355. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  356. export CFLAGS=`echo "$CFLAGS" | sed -e 's/ -g / -g1 /g'`
  357. #endif
  358. export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks"
  359. #ifnarch x86_64
  360. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  361. export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
  362. #endif
  363. mkdir %{_target_platform}
  364. pushd %{_target_platform}
  365. %{qmake_qt5} \
  366. %{?debug_config:CONFIG+="%{debug_config}"} \
  367. CONFIG+="link_pulseaudio" \
  368. QMAKE_EXTRA_ARGS+="-system-webengine-icu" \
  369. QMAKE_EXTRA_ARGS+="-webengine-kerberos" \
  370. ..
  371. # if we keep these set here, gyp picks up duplicate flags
  372. unset CFLAGS
  373. export CFLAGS
  374. unset CXXFLAGS
  375. export CXXFLAGS
  376. # workaround, disable parallel compilation as it fails to compile in brew
  377. make %{?_smp_mflags}
  378. %if 0%{?docs}
  379. make %{?_smp_mflags} docs
  380. %endif
  381. popd
  382. %install
  383. rm -rf %{buildroot}
  384. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  385. %if 0%{?docs}
  386. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  387. %endif
  388. # rpm macros
  389. install -p -m644 -D %{SOURCE10} \
  390. %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
  391. sed -i \
  392. -e "s|@@NAME@@|%{name}|g" \
  393. -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
  394. -e "s|@@VERSION@@|%{version}|g" \
  395. -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
  396. %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
  397. # hardlink files to {_bindir}
  398. mkdir -p %{buildroot}%{_bindir}
  399. pushd %{buildroot}%{_qt5_bindir}
  400. for i in * ; do
  401. ln -v ${i} %{buildroot}%{_bindir}/${i}
  402. done
  403. popd
  404. ## .prl/.la file love
  405. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  406. pushd %{buildroot}%{_qt5_libdir}
  407. for prl_file in libQt5*.prl ; do
  408. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  409. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  410. rm -fv "$(basename ${prl_file} .prl).la"
  411. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  412. fi
  413. done
  414. popd
  415. # explicitly omit, at least until there's a real library installed associated with it -- rex
  416. rm -fv %{buildroot}%{_libdir}/Qt5WebEngineCore.la
  417. mkdir -p %{buildroot}%{_qtwebengine_dictionaries_dir}
  418. # adjust cmake dep(s) to allow for using the same Qt5 that was used to build it
  419. # using the lesser of %%version, %%_qt5_version
  420. %global lesser_version $(echo -e "%{version}\\n%{_qt5_version}" | sort -V | head -1)
  421. sed -i -e "s|%{version} \${_Qt5WebEngine|%{lesser_version} \${_Qt5WebEngine|" \
  422. %{buildroot}%{_qt5_libdir}/cmake/Qt5WebEngine*/Qt5WebEngine*Config.cmake
  423. %post -p /sbin/ldconfig
  424. %postun -p /sbin/ldconfig
  425. %files
  426. %license LICENSE.* src/webengine/doc/src/qtwebengine-3rdparty.qdoc
  427. %{_qt5_libdir}/libQt5*.so.*
  428. %{_bindir}/qwebengine_convert_dict
  429. %{_qt5_bindir}/qwebengine_convert_dict
  430. %{_qt5_libdir}/qt5/qml/*
  431. %{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
  432. #ifarch %{ix86}
  433. %if 0%{?sse2}
  434. # shared V8 library and its SSE2 version
  435. %{_qt5_libdir}/qtwebengine/
  436. %endif
  437. %{_qt5_plugindir}/designer/libqwebengineview.so
  438. %dir %{_qt5_datadir}/resources/
  439. %{_qt5_datadir}/resources/qtwebengine_resources_100p.pak
  440. %{_qt5_datadir}/resources/qtwebengine_resources_200p.pak
  441. %{_qt5_datadir}/resources/qtwebengine_resources.pak
  442. %dir %{_qtwebengine_dictionaries_dir}
  443. %dir %{_qt5_translationdir}/qtwebengine_locales
  444. %lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
  445. %lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
  446. %lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
  447. %lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
  448. %lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
  449. %lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
  450. %lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
  451. %lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
  452. %lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
  453. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
  454. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
  455. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
  456. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
  457. %lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
  458. %lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
  459. %lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
  460. %lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
  461. %lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
  462. %lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
  463. %lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
  464. %lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
  465. %lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
  466. %lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
  467. %lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
  468. %lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
  469. %lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
  470. %lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
  471. %lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
  472. %lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
  473. %lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
  474. %lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
  475. %lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
  476. %lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
  477. %lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
  478. %lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
  479. %lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
  480. %lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
  481. %lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
  482. %lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
  483. %lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
  484. %lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
  485. %lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
  486. %lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
  487. %lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
  488. %lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
  489. %lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
  490. %lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
  491. %lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
  492. %lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
  493. %lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
  494. %lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
  495. %lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
  496. %lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
  497. %files devel
  498. %{rpm_macros_dir}/macros.qt5-qtwebengine
  499. %{_qt5_headerdir}/Qt*/
  500. %{_qt5_libdir}/libQt5*.so
  501. %{_qt5_libdir}/libQt5*.prl
  502. #{_qt5_libdir}/Qt5WebEngineCore.la
  503. %{_qt5_libdir}/cmake/Qt5*/
  504. %{_qt5_libdir}/pkgconfig/Qt5*.pc
  505. %{_qt5_archdatadir}/mkspecs/modules/*.pri
  506. %files devtools
  507. %{_qt5_datadir}/resources/qtwebengine_devtools_resources.pak
  508. %files examples
  509. %{_qt5_examplesdir}/
  510. %if 0%{?docs}
  511. %files doc
  512. %{_qt5_docdir}/*
  513. %endif
  514. %changelog
  515. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  516. - new upstream release.
  517. * Fri Nov 16 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-2
  518. - rebuild with libevent-2.1.8
  519. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  520. - new upstream release.
  521. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  522. - new upstream release.
  523. - initial build for Vine Linux.
  524. - updated Source1.
  525. * Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
  526. - rebuild (glibc)
  527. * Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  528. - add versioned qt5-qtbase runtime dep
  529. * Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
  530. - Update to 5.6.1
  531. - Rebase linux-pri patch (drop the parts already fixed upstream)
  532. - Drop backported chimera-nss-init patch, already applied upstream
  533. - Rebase no-sse2 patch (the core_module.pro change)
  534. - Add the new designer/libqwebengineview.so plugin to the file list
  535. * Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
  536. - workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
  537. * Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
  538. - rebuild (pciutuils)
  539. * Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
  540. - BR: git-core
  541. * Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
  542. - rebuild for ICU 57.1
  543. * Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
  544. - drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
  545. * Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
  546. - Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
  547. - Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
  548. - Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
  549. - Work around debugedit failure by removing "./" from #line commands and
  550. changing "//" to "/" in an #include command
  551. * Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
  552. - Avoid checking for the nonexistent icudtl.dat and silence the warnings
  553. * Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
  554. - Update to 5.6.0 (final)
  555. - Drop system-icu54 patch, fixed upstream
  556. * Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
  557. - Update to 5.6.0 RC
  558. - Rebase linux-pri and no-sse2 patches
  559. - Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
  560. - Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
  561. - Tag translations with correct %%lang tags
  562. * Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
  563. - no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
  564. * Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
  565. - Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
  566. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
  567. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  568. * Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
  569. - Build V8 as a shared library on i686 to allow for swappable backends
  570. - Build both the x87 version and the SSE2 version of V8 on i686
  571. - Add the private library directory to the file list on i686
  572. - Add Provides/Requires filtering for libv8.so (i686) and for plugins
  573. * Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
  574. - Do not require SSE2 on i686
  575. * Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
  576. - Drop nss321 backport (and the related nss-headers patch), it did not help
  577. - Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
  578. - Update License accordingly (add "OpenSSL")
  579. - Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
  580. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
  581. - Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
  582. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
  583. - Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
  584. * Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
  585. - Unbundle prtime.cc, use the system NSPR instead (which is already required)
  586. - Unbundle icu_utf.cc, use the system ICU instead (which is already required)
  587. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
  588. - linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
  589. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
  590. - Build against the system libvpx also on F23 (1.4.0), worked in Copr
  591. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
  592. - Use the system libvpx on F24+ (1.5.0)
  593. - Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
  594. * Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
  595. - Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
  596. - Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
  597. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
  598. - Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
  599. - Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
  600. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
  601. - Use more specific BuildRequires for docs (thanks to rdieter)
  602. - Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
  603. * Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
  604. - Fix License tag
  605. - Use %%_qt5_examplesdir macro
  606. - Add Provides: bundled(*) for all the bundled libraries that I found
  607. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
  608. - linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
  609. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
  610. - linux-pri patch: Add missing newline at the end of the log line
  611. - Use export for NINJA_PATH (fixes system ninja-build use)
  612. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
  613. - Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
  614. - BR yasm only on x86 (i686, x86_64)
  615. - Add dot at the end of %%description
  616. - Rebase no-format patch
  617. - Replace unbundle-gyp.patch with new linux-pri.patch
  618. - Use system ninja-build instead of the bundled one
  619. - Run the unbundling script replace_gyp_files.py in linux.pri rather than here
  620. - Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
  621. * Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
  622. - Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
  623. pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
  624. pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
  625. pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
  626. perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
  627. - Add missing explicit BRs on pkgconfig(x11), pkgconfig(xext),
  628. pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
  629. - Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
  630. - Fix BR python-devel to python
  631. - Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
  632. - Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
  633. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
  634. - Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
  635. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
  636. - Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
  637. - Remove unused BR v8-devel (cannot currently be unbundled)
  638. * Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
  639. - Update to 5.5.1
  640. - Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
  641. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
  642. - Update with unbundle flags. Adapted from original 5.4 Suse package
  643. - Disable vpx and sqlite as unbundle due some compilation issues
  644. - Enable verbose build
  645. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
  646. - Initial spec
  647. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  648. - Update for official RC1 released packages