make-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. Summary: A GNU tool which simplifies the build process for users.
  2. Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
  3. Name: make
  4. Epoch: 1
  5. Version: 3.82
  6. Release: 2%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. URL: http://www.gnu.org/software/make/
  10. Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
  11. Source1: make-3.81-ja.po
  12. Patch1: make-3.82-noclock_gettime.patch
  13. Patch2: make-3.82-j8k.patch
  14. Patch3: make-3.82-getcwd.patch
  15. Patch4: make-3.82-err-reporting.patch
  16. # Upstream: https://savannah.gnu.org/bugs/?30748
  17. Patch6: make-3.82-weird-shell.patch
  18. Patch7: make-3.82-newlines.patch
  19. Patch8: make-3.82-jobserver.patch
  20. Patch9: make-3.82-bugfixes.patch
  21. Patch10: make-3.82-sort-blank.patch
  22. Patch11: make-3.82-copy-on-expand.patch
  23. # Upstream: https://savannah.gnu.org/bugs/?33873
  24. Patch12: make-3.82-parallel-remake.patch
  25. # http://savannah.gnu.org/bugs/?34335
  26. Patch13: make-3.82-warn_undefined_function.patch
  27. # http://lists.gnu.org/archive/html/bug-make/2011-06/msg00032.html
  28. Patch14: make-3.82-trace.patch
  29. # http://lists.gnu.org/archive/html/bug-make/2011-04/msg00002.html
  30. Patch15: make-3.82-expensive_glob.patch
  31. # Upstream: https://savannah.gnu.org/bugs/?30653
  32. Patch16: make-3.82-dont-prune-intermediate.patch
  33. Buildroot: %{_tmppath}/%{name}-%{version}-root
  34. Requires(post): /sbin/install-info
  35. Requires(preun): /sbin/install-info
  36. BuildRequires: automake >= 1.7.3
  37. BuildRequires: perl
  38. BuildRequires: procps
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. %description
  42. A GNU tool for controlling the generation of executables and other
  43. non-source files of a program from the program's source files. Make
  44. allows users to build and install packages without any significant
  45. knowledge about the details of the build process. The details about
  46. how the program should be built are provided for make in the program's
  47. makefile.
  48. The GNU make tool should be installed on your system because it is
  49. commonly used to simplify the process of installing programs.
  50. %description -l ja
  51. プログラムのソースファイルから実行ファイル及びその他のファイルを
  52. 生成する GNU ツールです.Make を使うことでユーザは build 時の
  53. 細かいプロセスを気にせず build しインストールすることが出来ます.
  54. プログラムがどの様に build されるのかは,プログラムの Makefile に
  55. 書かれています.
  56. GNU make ツールは,プログラムのインストールを容易にするのに
  57. 非常によく使われますので,このパッケージは是非インストールして下さい.
  58. %prep
  59. %setup -q
  60. %patch1 -p1
  61. %patch2 -p1
  62. %patch3 -p1
  63. %patch4 -p1
  64. %patch6 -p1
  65. %patch7 -p1
  66. %patch8 -p1
  67. %patch9 -p1
  68. %patch10 -p1
  69. %patch11 -p1
  70. %patch12 -p0
  71. %patch13 -p2
  72. %patch14 -p1
  73. %patch15 -p0
  74. %patch16 -p0
  75. rm -f tests/scripts/features/parallelism.orig
  76. cp %{SOURCE1} po/ja.po
  77. %build
  78. config/missing --run aclocal -I config
  79. config/missing --run automake --gnu Makefile
  80. config/missing --run autoconf
  81. %configure
  82. make
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. %makeinstall
  86. pushd $RPM_BUILD_ROOT
  87. ln -sf make .%{_bindir}/gmake
  88. # gzip -9nf .%{_infodir}/make.info*
  89. rm -f .%{_infodir}/dir
  90. popd
  91. %find_lang %name
  92. %check
  93. echo ============TESTING===============
  94. /usr/bin/env LANG=C make check
  95. echo ============END TESTING===========
  96. %clean
  97. rm -rf ${RPM_BUILD_ROOT}
  98. %post
  99. /sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  100. %preun
  101. if [ $1 = 0 ]; then
  102. /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  103. fi
  104. %files -f %{name}.lang
  105. %defattr(-,root,root)
  106. %doc NEWS README
  107. %{_bindir}/*
  108. %{_mandir}/man*/*
  109. %{_infodir}/*.info*
  110. #%{_datadir}/locale/*/LC_MESSAGES/make*
  111. %changelog
  112. * Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
  113. - rebuild with VineSeed environment
  114. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
  115. - new upstream release
  116. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
  117. - rebuild for Vine6
  118. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
  119. - applied new versioning policy
  120. - added BuildRequires: perl (for %%check)
  121. - spec in UTF-8
  122. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
  123. - updated to 3.81 based on Fedora packages
  124. * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
  125. - Always run testsuite with C locale.
  126. - Resolves: #232607
  127. * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
  128. - Fix newline handling for quoted SHELL.
  129. - Resolves: #219409
  130. * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
  131. - Upstream 3.81:
  132. - Contains several backwards incompatible changes. See NEWS inside
  133. the source package to find out more.
  134. - memory patch and error reporting patch were ported to this version.
  135. - updated ja.po
  136. * Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
  137. - added URL
  138. - s/Copyright/License/
  139. - added some patches from fedora development 3.80-8
  140. * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
  141. - make sure errno for error reporting is not lost accross _() calls
  142. - report EOF on read pipe differently from read returning < 0 reporting
  143. * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
  144. - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
  145. * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  146. - add important bug-fixes from make home-page
  147. * Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
  148. - some patches was included from 3.79.1-17
  149. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
  150. - update ja.po
  151. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
  152. - new upstream release
  153. * Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  154. - 3.79.1-5vl1
  155. - based on 3.79.1-5 from Rawhide
  156. - rebuilt for Vine Linux
  157. - added Japanese summary and description
  158. * Mon Aug 7 2000 Tim Waugh <twaugh@redhat.com>
  159. - change info-dir entry so that 'info make' works (#15029).
  160. * Tue Aug 1 2000 Jakub Jelinek <jakub@redhat.com>
  161. - assume we don't have clock_gettime in configure, so that
  162. make is not linked against -lpthread (and thus does not
  163. limit stack to 2MB).
  164. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  165. - add locale files (#14362).
  166. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  167. - automatic rebuild
  168. * Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
  169. - 3.79.1 bugfix release
  170. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  171. - FHS packaging.
  172. * Sun May 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  173. - Fix build for some odd situations, such as
  174. - previously installed make != GNU make
  175. - /bin/sh != bash
  176. * Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  177. - update to 3.79
  178. * Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
  179. - add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
  180. builds)
  181. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  182. - compress man page.
  183. * Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
  184. - apply patch to fix a /tmp race condition from Thomas Biege
  185. - simplify %install
  186. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  187. - update to 3.78.1.
  188. * Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
  189. - added a serial tag so it upgrades right
  190. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  191. - auto rebuild in the new build environment (release 5)
  192. * Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
  193. - added a patch for large file support in glob
  194. * Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
  195. - update to 3.77
  196. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  197. - translations modified for de, fr, tr
  198. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  199. - udpated from 3.75 to 3.76
  200. - various spec file cleanups
  201. - added install-info support
  202. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  203. - built against glibc