rabbitvcs-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. %define build_vine5 0
  3. %if "%{?_dist_release}" == "vl5"
  4. %define build_vine5 1
  5. %endif
  6. Summary: Integrated Subversion support for Nautilus
  7. Summary(ja): Subversion サポートを Nautilus に追加する拡張
  8. Name: rabbitvcs
  9. Version: 0.14.2.1
  10. Release: 1%{?_dist_release}
  11. Source0: http://rabbitvcs.googlecode.com/files/%{name}-%{version}.tar.gz
  12. Source1: rabbitvcs-0.14.2.1-ja.po
  13. Patch1: rabbitvcs-0.14.1.1-gtk216.patch
  14. License: GPL
  15. Group: Development/Tools
  16. URL: http://rabbitvcs.org/
  17. Requires: nautilus, pygtk2, python-configobj
  18. Requires: pygobject, pygtk2-libglade
  19. Requires: subversion, pysvn, python-simplejson
  20. BuildRequires: python-devel, gettext
  21. Requires(post): gtk2
  22. Requires(postun): gtk2
  23. #BuildArch: noarch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Packager: kazutaka
  26. %description
  27. RabbitVCS is a set of graphical tools written to provide simple
  28. and straightforward access to the version control systems you use.
  29. This package containg core part of RabbitVCS and not connected
  30. to to any file manager or text editor.
  31. Front-ends or clients is privided separetely as a Nautilus
  32. extention, Thunar extention and Gedit plugin, and a command line
  33. utility.
  34. %description -l ja
  35. RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
  36. できるよう設計された GUI のツールです。
  37. このパッケージには RabbitVCS のコアとなる部分だけが含まれており、
  38. 特定のファイルマネージャやテキストエディタに依存しないようになっ
  39. ています。
  40. フロントエンドやクライアントは Nautilus 及び Thunar 用の拡張と、
  41. Gedit 用のプラグイン、そしてコマンドラインのユーティリティが、
  42. 別パッケージとして提供されています。
  43. %package nautilus
  44. Summary: Integrated Subversion support for Nautilus
  45. Summary(ja): Subversion サポートを Nautilus に追加する拡張
  46. Group: Development/Tools
  47. Requires: nautilus >= 2.22.0
  48. Requires: nautilus-python >= 0.7.0
  49. Requires: dbus-python > 0.80
  50. Requires: rabbitvcs >= %{version}-%{release}
  51. Obsoletes: nautilussvn
  52. %description nautilus
  53. RabbitVCS is a set of graphical tools written to provide simple
  54. and straightforward access to the version control systems you use.
  55. With this package, You can acces to the version control systems
  56. by Nautilus file manager.
  57. %description nautilus -l ja
  58. RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
  59. できるよう設計された GUI のツールです。
  60. このパッケージを利用することで、Nautilus ファイルマネージャに
  61. 統合された形でバージョン管理システムにアクセスできるようになり
  62. ます。
  63. %prep
  64. %setup -q
  65. %if %{build_vine5}
  66. %patch1 -p1 -b .gtk216
  67. %endif
  68. %build
  69. %{__python} setup.py build
  70. %install
  71. %{__rm} -rf ${RPM_BUILD_ROOT}
  72. %{__python} setup.py install --skip-build --root ${RPM_BUILD_ROOT}
  73. # install nautilus client
  74. %{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_libdir}/nautilus/extensions-2.0/python/
  75. %{__install} -m644 clients/nautilus/RabbitVCS.py ${RPM_BUILD_ROOT}/%{_libdir}/nautilus/extensions-2.0/python/
  76. # install updated japanese translation
  77. msgfmt %{SOURCE1} -o ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES/RabbitVCS.mo
  78. %clean
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %post
  81. touch --no-create %{_datadir}/icons/hicolor
  82. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  83. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  84. fi
  85. %postun
  86. touch --no-create %{_datadir}/icons/hicolor
  87. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  88. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  89. fi
  90. %files
  91. %defattr(-,root,root)
  92. %doc %{_datadir}/doc/%{name}/
  93. %{_prefix}/lib/python%{pyver}/site-packages/
  94. %{_datadir}/icons/hicolor/scalable/actions/
  95. %{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
  96. %{_datadir}/icons/hicolor/scalable/apps/%{name}-small.svg
  97. %{_datadir}/icons/hicolor/scalable/emblems/
  98. %{_datadir}/locale/
  99. %{_datadir}/%{name}/configspec.ini
  100. # only usefull for ubuntu (and debian??)
  101. #%exclude %{_datadir}/%{name}/do-rabbitvcs-restart-nautilus
  102. #%exclude %{_datadir}/%{name}/rabbitvcs-restart-required.update-notifier
  103. %files nautilus
  104. %defattr(-,root,root)
  105. %doc clients/nautilus/README
  106. %{_libdir}/nautilus/extensions-2.0/python/RabbitVCS.py
  107. %changelog
  108. * Sun May 29 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.2.1-1
  109. - new upstream release
  110. - drop BuildArch: noarch to change installation path for RabbitVCS.py
  111. (need to locate under /usr/lib64 on x86_64)
  112. - add updated japanese translation (Source1)
  113. * Mon Jan 24 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.1.1-2
  114. - fix installation path of RabbitVCS.py
  115. - drop unnecessary Requires: glade2
  116. * Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.1.1-1
  117. - new upstream release
  118. - add Requires: python-simplejson
  119. - add Patch1 to avoid error when gtk+ < 2.18 (only for Vine 5)
  120. * Fri Jul 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13.3-1
  121. - new upstream release
  122. - merge rabbitvcs-nautilus package again (upstream source change)
  123. - requires nautilus-python >= 0.7.0 for rabbitvcs-nautilus
  124. * Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13-1
  125. - new upstream release
  126. - now front-end for nautilus is provided separetely
  127. (as rabbitvcs-nautilus package)
  128. * Wed Oct 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1
  129. - new upstream release with new name
  130. - add Obsoletes: nautilussvn
  131. - drop source1 (japanese translation)
  132. - update description
  133. * Fri Jun 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-3.beta1.2
  134. - update japanese translation
  135. * Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-2.beta1.2
  136. - add japanese translation as Source1
  137. - add BuildRequires: gettext
  138. * Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1.beta1.2
  139. - initial build for Vine Linux