chromium13-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. %define pkgname chromium
  5. #% define with_system_icu 1
  6. #% define with_system_v8 1
  7. #NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
  8. # libvpx doesn't currently supply a pkg-config file, so we assume that
  9. # -lvpx is sufficient.
  10. %define with_system_vpx 1
  11. #Name: chromium13
  12. Name: chromium
  13. Summary: Google's opens source browser project
  14. Summary(ja): Googleのオープンソースウェブブラウザ
  15. #'
  16. Version: 13.0.782.213
  17. Release: 1%{?_dist_release}
  18. License: BSD
  19. Group: Applications/Internet
  20. Source0: %{pkgname}-%{version}.tar.xz
  21. # Script used to create the %{pkgname}-%{version}.tar.xz archive from
  22. # a official tarball:
  23. # http://build.chromium.org/official/chromium-13.0.782.XXX.tar.bz2
  24. Source3: pack_chromium13_source-vine.sh
  25. # Official ffmpeg headers
  26. Source8: ffmpeg-0.6-headers.tar.xz
  27. # Patch template which adds vendor to user agent
  28. ##!!Source20: chromium-vendor.patch.in
  29. Source20: chromium-vendor-vine.patch.in
  30. # Set default prefs
  31. ##!!Source30: master_preferences
  32. Source30: master_preferences.vine
  33. ##!!Source31: default_bookmarks.html
  34. #Source31: default_bookmarks.html.vine
  35. Source99: chrome-wrapper
  36. ##!!Source100: chromium-browser.sh
  37. Source100: chromium-browser-vine.sh
  38. ##!!Source101: chromium-browser.desktop
  39. Source101: chromium-browser-vine.desktop
  40. Source102: chromium-browser.xml
  41. Source103: chromium-browser-rpmlintrc
  42. ##!!Source104: chromium-icons.tar.bz2
  43. %{?nosrc:NoSource: 0}
  44. # Provides: chromium-unstable = %{version}
  45. # Conflicts: chromium-stable
  46. Provides: chromium-stable = %{version}
  47. Conflicts: chromium-unstable
  48. ## Start Patches
  49. # OpenSuse and Fedora
  50. # Many changes to the gyp systems so we can use system libraries
  51. #Patch1: chromium-gcc46.patch
  52. Patch4: chromium-no-sqlite-debug.patch
  53. Patch8: chromium-codechanges-zlib.patch
  54. Patch12: chromium-no-test-sources.patch
  55. Patch13: chromium-no-courgette.patch
  56. Patch14: chromium-master-prefs-path.patch
  57. Patch17: chromium-system-glew.patch
  58. Patch18: chromium-system-expat.patch
  59. Patch19: chromium-system-zlib.patch
  60. Patch20: chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
  61. Patch21: chromium-7.0.542.0-media-probe.patch
  62. Patch25: tcmalloc-factory.patch
  63. Patch26: chromium-remoting-build-fix.diff
  64. Patch28: chromium-7.0.500.0-system-speex.patch
  65. Patch29: chromium-7.0.510.0-system-ffmpeg.patch
  66. Patch32: chromium-7.0.542.0-system-libvpx.patch
  67. Patch34: chromium-7.0.542.0-codechanges-system-minizip-v8.patch
  68. Patch62: chromium-norpath.patch
  69. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  70. # Vine
  71. Patch100: chromium-13.0.782.13-no-tests.patch
  72. ##!!BuildRequires: Mesa-devel
  73. BuildRequires: mesa-libGLU-devel
  74. ##!!BuildRequires: alsa-devel
  75. BuildRequires: alsa-lib-devel
  76. BuildRequires: bison
  77. BuildRequires: cups-devel
  78. BuildRequires: desktop-file-utils
  79. BuildRequires: fdupes
  80. BuildRequires: flex
  81. BuildRequires: freetype2-devel
  82. BuildRequires: gcc gcc-c++
  83. BuildRequires: gperf
  84. BuildRequires: hunspell-devel
  85. ##!!BuildRequires: libbz2-devel
  86. BuildRequires: bzip2-devel
  87. BuildRequires: libevent
  88. ##!!BuildRequires: libexpat-devel
  89. BuildRequires: expat-devel
  90. ##!!BuildRequires: libgnutls-devel
  91. BuildRequires: gnutls-devel
  92. BuildRequires: libjpeg-devel
  93. BuildRequires: libpng-devel
  94. BuildRequires: libstdc++-devel >= 4.4
  95. %{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5}
  96. BuildRequires: libxslt-devel
  97. BuildRequires: libzip-devel
  98. ##!!BuildRequires: lzma
  99. BuildRequires: xz
  100. ##!!BuildRequires: mozilla-nspr-devel
  101. BuildRequires: nspr-devel
  102. ##!!BuildRequires: mozilla-nss-devel
  103. BuildRequires: nss-devel
  104. BuildRequires: openssl-devel
  105. BuildRequires: pam-devel
  106. ##!!BuildRequires: perl(Switch)
  107. BuildRequires: perl
  108. ##!!BuildRequires: pkg-config
  109. BuildRequires: cairo-devel >= 1.6
  110. BuildRequires: dbus-devel
  111. ##!!BuildRequires: gconf2-devel
  112. BuildRequires: GConf2-devel
  113. BuildRequires: glib2-devel
  114. BuildRequires: gtk2-devel
  115. BuildRequires: libxml2-devel
  116. BuildRequires: python
  117. ##!!BuildRequires: python-xml
  118. BuildRequires: python-pyxml
  119. BuildRequires: sqlite3-devel
  120. ##!!BuildRequires: update-desktop-files
  121. %{?with_system_v8:BuildRequires: v8-devel = %{v8_ver}}
  122. ##!!BuildRequires: wdiff
  123. BuildRequires: zlib-devel
  124. BuildRequires: libgnome-keyring-devel
  125. BuildRequires: python-devel
  126. #BuildRequires: glew-devel
  127. BuildRequires: libevent-devel
  128. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  129. #BuildRequires: libjingle-devel >= 0.4.0-7
  130. #BuildRequires: srtp-devel
  131. BuildRequires: speex-devel
  132. ##Vine Linux
  133. #BuildRequires: libpaper-devel
  134. BuildRequires: libXScrnSaver-devel
  135. BuildRequires: libXtst-devel
  136. BuildRequires: libXdamage-devel
  137. BuildRequires: libXt-devel
  138. %ifarch x86_64
  139. Requires: nspluginwrapper
  140. %endif
  141. ##!!Requires: alsa
  142. Requires: alsa-lib
  143. Requires: xdg-utils
  144. %{?with_system_v8:Requires: v8 = %{v8_ver}}
  145. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  146. %description
  147. Chromium is the open-source project behind Google Chrome.
  148. We invite you to join us in our effort to help build a safer, faster,
  149. and more stable way for all Internet users to experience the web,
  150. and to create a powerful platform for developing a new generation of
  151. web applications.
  152. %description -l ja
  153. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  154. ウェブを体験しているすべてのインターネットユーザに対して
  155. より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
  156. そして、ウェブアプリケーションの新しい世代を発展させ、
  157. 強力なプラットホームを作成するために、
  158. 私たちの取り組みにぜひ参加してください。
  159. %prep
  160. #%setup -q
  161. [ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
  162. xz -dc %{SOURCE0} | %__tar -xf - || exit 1
  163. %setup -D -T -n %{pkgname}-%{version}
  164. #%patch1 -p1
  165. %patch62 -p1
  166. %{?with_system_v8:%patch63 -p1}
  167. %patch100 -p1 -b .vine
  168. %patch4 -p1
  169. %patch8 -p1
  170. %patch12 -p1
  171. %patch13 -p1
  172. %patch14 -p1
  173. %patch17 -p1
  174. %patch18 -p1
  175. %patch19 -p1
  176. %patch20 -p1
  177. %patch21 -p1
  178. %patch25 -p1
  179. %patch26 -p1
  180. %patch28 -p1
  181. %patch29 -p1
  182. %{?with_system_vpx:%patch32 -p1}
  183. %{?with_system_v8:%patch34 -p1}
  184. pushd src/third_party/ffmpeg/
  185. %__tar xf %{SOURCE8} || exit 1
  186. ## built header file: avconfig.h
  187. [ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
  188. cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
  189. /* Generated by ffconf */
  190. #ifndef AVUTIL_AVCONFIG_H
  191. #define AVUTIL_AVCONFIG_H
  192. #define AV_HAVE_BIGENDIAN 0
  193. #endif /* AVUTIL_AVCONFIG_H */
  194. EOF
  195. popd
  196. #%__rm -rf src/third_party/libvpx/
  197. %__rm -rf src/third_party/speex/
  198. %__rm -rf src/third_party/nss src/third_party/nspr
  199. # apply vendor patch after substitution
  200. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  201. %build
  202. ## create make files
  203. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  204. for i in src/build/common.gypi; do
  205. %__sed -i "s|'-march=pentium4',||g" $i
  206. %__sed -i "s|'-mfpmath=sse',||g" $i
  207. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  208. %__sed -i "s|'-m32',||g" $i
  209. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  210. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  211. done
  212. # '
  213. pushd src
  214. ./build/gyp_chromium -f make build/all.gyp \
  215. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  216. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  217. -Duse_openssl=0 \
  218. -Duse_system_ffmpeg=1 \
  219. -Duse_system_zlib=1 \
  220. -Duse_system_libpng=1 \
  221. -Duse_system_bzip2=1 \
  222. -Duse_system_libbz2=1 \
  223. -Duse_system_libjpeg=1 \
  224. -Duse_system_libxml=1 \
  225. -Duse_system_libxslt=1 \
  226. -Duse_system_libevent=1 \
  227. %{?with_system_vpx:-Duse_system_vpx=1} \
  228. %{!?with_system_vpx:-Duse_system_vpx=0} \
  229. -Dremove_webcore_debug_symbols=1 \
  230. %{?with_system_v8:-Duse_system_v8=1} \
  231. %{!?with_system_v8:-Duse_system_v8=0} \
  232. %{?with_system_icu:-Duse_system_icu=1} \
  233. %{!?with_system_icu:-Duse_system_icu=0} \
  234. %{?_with_shared_library:-Dlibrary=shared_library} \
  235. -Dproprietary_codecs=1 \
  236. -Djavascript_engine=v8 \
  237. -Dlinux_fpic=1 \
  238. %ifarch %{ix86}
  239. -Dtarget_arch=ia32 \
  240. -Ddisable_sse2=1 \
  241. %endif
  242. %ifarch x86_64
  243. -Dtarget_arch=x64 \
  244. %endif
  245. -Dno_strict_aliasing=1 \
  246. -Drelease_extra_cflags=-fPIC \
  247. %if %{?_dist_release} == "vl6"
  248. -Dgcc_version=44 \
  249. %endif
  250. ;
  251. #%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
  252. %__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
  253. popd
  254. %install
  255. %{__rm} -rf %{buildroot}
  256. %__mkdir -p %{buildroot}%{_bindir}
  257. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  258. # x86_64 capable systems need this
  259. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  260. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  261. %__mkdir -p %{buildroot}%{_mandir}/man1/
  262. pushd src/out/Release
  263. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  264. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  265. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  266. %{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
  267. %{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
  268. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  269. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  270. fdupes %{buildroot}%{_mandir}/man1/
  271. popd
  272. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  273. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  274. for i in 16 22 24 32 48 64 128 256; do
  275. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
  276. %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
  277. done
  278. %__mkdir_p %{buildroot}%{_datadir}/applications/
  279. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  280. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  281. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  282. # # link to browser plugin path. Plugin patch doesn't work. Why?
  283. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  284. # pushd %{buildroot}%{_libdir}/%{pkgname}
  285. # %{__ln_s} %{_libdir}/browser-plugins plugins
  286. # popd
  287. pushd %{buildroot}%{_libdir}/%{pkgname}
  288. %ifarch x86_64
  289. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  290. %else
  291. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  292. %endif
  293. ## support ffmpeg libs
  294. touch %{buildroot}%{_libdir}/libavcodec.so.52
  295. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  296. touch %{buildroot}%{_libdir}/libavformat.so.52
  297. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  298. touch %{buildroot}%{_libdir}/libavutil.so.50
  299. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  300. popd
  301. # Install the master_preferences file
  302. %__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
  303. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
  304. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
  305. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
  306. %clean
  307. %{__rm} -rf %{buildroot}
  308. %post
  309. touch --no-create %{_datadir}/icons/hicolor
  310. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  311. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  312. fi
  313. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  314. %postun
  315. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  316. touch --no-create %{_datadir}/icons/hicolor
  317. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  318. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  319. fi || :
  320. %files
  321. %defattr(-,root,root,-)
  322. %config %{_sysconfdir}/%{pkgname}
  323. %dir %{_datadir}/gnome-control-center
  324. %dir %{_datadir}/gnome-control-center/default-apps
  325. %dir %{_libdir}/chromium/
  326. %{_bindir}/chromium
  327. %{_libdir}/chromium/chromium
  328. %{_libdir}/chromium/plugins/
  329. %{_libdir}/chromium/resources/
  330. %{_libdir}/chromium/xdg-settings
  331. %{_mandir}/man1/chrom*
  332. %{_datadir}/pixmaps/chromium-browser.png
  333. %{_datadir}/icons/hicolor/*/apps/chromium-browser.png
  334. %{_datadir}/applications/*.desktop
  335. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  336. #%{_datadir}/icons/oxygen/
  337. %{_libdir}/chromium/chrome.pak
  338. %{_libdir}/chromium/resources.pak
  339. %{_libdir}/chromium/locales/
  340. %{?_with_shared_library:%{_libdir}/chromium/lib*.so}
  341. %{_libdir}/chromium/libavcodec.so.52
  342. %{_libdir}/chromium/libavutil.so.50
  343. %{_libdir}/chromium/libavformat.so.52
  344. %exclude %{_libdir}/libavcodec.so.52
  345. %exclude %{_libdir}/libavutil.so.50
  346. %exclude %{_libdir}/libavformat.so.52
  347. %changelog
  348. * Fri Aug 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.213-1
  349. - updated to 13.0.782.213
  350. * Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
  351. - changed to Name: chromium
  352. - updated to 13.0.782.107
  353. * Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
  354. - updated to 13.0.782.88
  355. - added BuildRequires: libzip-devel
  356. - added Provides: chromium-unstable = %%{version}
  357. - added Conflicts: chromium-stable
  358. * Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
  359. - fix user-agent string (chromium-vendor-vine.patch.in)
  360. - move vendor string (Vine/12.0.742.91-1vl6) to the end.
  361. * Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
  362. - updated to 12.0.742.93
  363. - fixed icon field of chromium-browser-vine.desktop
  364. * Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
  365. - updated to 12.0.742.91
  366. * Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
  367. - updated to 12.0.742.77
  368. * Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
  369. - updated to 12.0.742.63
  370. * Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
  371. - updated to 12.0.742.42
  372. * Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
  373. - updated to 12.0.742.6
  374. - dropped/upstreamed patches
  375. - updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
  376. * Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
  377. - updated to 11.0.696.50
  378. - dropped some Patches for MeeGo Netbook
  379. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
  380. - updated to 11.0.696.35
  381. * Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
  382. - updated to 11.0.696.29
  383. - dropped "--no-first-run" in command line options of chromium-browser-vine.sh
  384. * Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
  385. - updated to 11.0.696.22
  386. - improved chromium-browser-vine.sh
  387. - merged from chromium-browser-vine.desktop of 11.0.696.17-1
  388. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
  389. - updated to 11.0.696.20
  390. - improved chromium-browser-vine.desktop
  391. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
  392. - updated to 11.0.696.17
  393. * Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
  394. - updated to 11.0.696.15
  395. - ready for Vine Linux 6 release
  396. - dropped BuildRequires: v8-devel, libicu-devel
  397. * Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
  398. - updated to 11.0.696.5 with v8 3.2.0
  399. - added BuildRequires: pam-devel
  400. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
  401. - rebuilt with libevent-2.0.10
  402. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
  403. - updated to 10.0.651.0 with v8 3.0.12
  404. - added BuildRequires:
  405. - libpaper-devel
  406. - python-devel
  407. - added built header file: libavutil/avconfig.h %%prep
  408. - unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
  409. * Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
  410. - updated to 10.0.622.0
  411. - added BuildRequires: libXt-devel
  412. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
  413. - updated to 10.0.605.0
  414. - added BuildRequires:
  415. - libXdamage-devel
  416. - hunspell-devel
  417. * Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
  418. - updated to 9.0.598
  419. * Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
  420. - updated to 9.0.593
  421. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
  422. - updated to 9.0.582
  423. - added Requires: xdg-utils
  424. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
  425. - updated to 9.0.578
  426. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
  427. - updated to 9.0.569
  428. * Mon Oct 25 2010 tittiatcoke@gmail.com
  429. - Update to 9.0.564 build
  430. * Added specific patches for MeeGo.
  431. * We are now using shared libraries for Chromium
  432. * Spec-file cleanup (Thanks to prusnak)
  433. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  434. - updated to snapshot 8.0.556
  435. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  436. - updated to snapshot 8.0.551
  437. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  438. - updated to snapshot 7.0.527
  439. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  440. - updated to snapshot 7.0.519
  441. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  442. - updated to snapshot 7.0.513
  443. - updated chromium-vendor-vine.patch.in
  444. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  445. - updated to snapshot 7.0.507
  446. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  447. - updated to snapshot 7.0.498
  448. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  449. - updated to snapshot 6.0.493
  450. - used with_system_icu (for vl6)
  451. - added BuildRequires: libicu-devel
  452. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  453. - build for Vine Linux 5.x
  454. - add BuildRequires: gnome-keyring-devel
  455. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  456. - updated to snapshot 6.0.454
  457. - added BuildRequires:
  458. - sqlite3-devel
  459. - gnutls-devel
  460. - libgnome-keyring-devel
  461. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  462. - updated to snapshot 6.0.431.0 r49253
  463. - added BuildRequires: cups-devel
  464. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  465. - updated to snapshot 6.0.405.0 r47263
  466. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  467. - unused with_system_icu (for vl6)
  468. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  469. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  470. - updated to snapshot 5.0.378.0 r44472
  471. - used with_system_icu (for vl6)
  472. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  473. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  474. - updated to snapshot 5.0.372.0 r43947
  475. - added BuildRequires: glew-devel
  476. - changed Group tag to Applications/Internet
  477. - added Summary(ja) and %%description -l ja
  478. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  479. - updated to snapshot 5.0.365.0 r42966
  480. - merged 5.0.353.0-4vl5
  481. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  482. - build on Vine Linux 5.1
  483. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  484. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  485. - updated to snapshot 5.0.364.0 r42779
  486. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  487. - updated to snapshot 5.0.359.0 r42116
  488. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  489. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  490. - fixed master_preferences.vine, little
  491. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  492. - fixed to install master_preferences
  493. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  494. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  495. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  496. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  497. - updated to snapshot 5.0.353.0 r41449
  498. * Wed Mar 10 2010 bgmerrell@novell.com
  499. - Add master_preferences source file and install it to /etc/chromium.
  500. - Create a new patch (chromium-master-prefs-path.patch) which tells
  501. chromium to look in /etc/chromium for the master_preferences file
  502. (instead of looking in the default directory, which is the same
  503. directory as the 'chrome' binary).
  504. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  505. - updated to snapshot 5.0.335.0 r39556
  506. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  507. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  508. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  509. - updated to snapshot 5.0.330.0 r39074
  510. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  511. - use_system_ffmpeg
  512. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  513. - added Requires: nspluginwrapper
  514. - fixed a symbolic link of plugins directory with nspluginwrapper
  515. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  516. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  517. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  518. - added BuildRequires: mesa-libGLU-devel
  519. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  520. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  521. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  522. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  523. - Update to 4.0.260
  524. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  525. - Update to 4.0.259
  526. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  527. - Update to 4.0.258
  528. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  529. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  530. changed to having an built-in v8
  531. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  532. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  533. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  534. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  535. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  536. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  537. - update to newer svn snapshot
  538. + Obsoletes fwrite patch (included upstream)
  539. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  540. - update to newer svn snapshot
  541. + Requires newer version of v8
  542. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  543. - do not force SSE on x86 (drop-sse.patch)
  544. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  545. - Update to newer svn snapshot
  546. - Fixed spec file in order to build
  547. - Included patch to build with system zlib
  548. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  549. - package renamed to chromium
  550. - cleaned up spec file
  551. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  552. - v8 is now built as a separate package, and is required
  553. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  554. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  555. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  556. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  557. - initial build
  558. #% changelog
  559. * Sun Jan 24 2010 prusnak@suse.cz
  560. - added vendor to user agent (chromium-vendor.patch.in)
  561. * Sun Nov 29 2009 prusnak@suse.cz
  562. - added --enable-sync to wrapper to enable bookmark sync
  563. * Sun Nov 29 2009 tittiatcoke@gmail.com
  564. - Update to 4.0.260
  565. * Fri Nov 27 2009 tittiatcoke@gmail.com
  566. - Update to 4.0.259
  567. * Thu Nov 26 2009 tittiatcoke@gmail.com
  568. - Update to 4.0.258
  569. * Tue Nov 24 2009 tittatcoke@gmai.com
  570. - In order to complete prevent the wrong v8 version to be used,
  571. the Chromium build has been changed to having an built-in v8
  572. * Tue Nov 24 2009 dbuck@example.com
  573. - Re-base patches.
  574. - Fixed a few patch errors.
  575. - Rename some patches to better correspond with function.
  576. - Removed some patches.
  577. - Minor SPEC changes.
  578. - I changed the v8 requirement to be exact, instead of greater than a specific version.
  579. * Fri Nov 13 2009 tittiatcoke@gmail.com
  580. - update to 247.0 svn 31928
  581. * Fri Oct 30 2009 tittiatcoke@gmail.com
  582. - update to 229.0 svn 30454
  583. + Fix regression where popups and app frames lost their titlebars.
  584. + Makes it so that when a folder is open on the bookmark bar
  585. and the mouse moves over another folder, the menu for that
  586. folder is shown.
  587. + Lazily create the find bar.
  588. + Polish to the gmail checker sample.
  589. * New, crisper icons that are exactly 19x19
  590. * Add a loading animation at the beginning before Gmail
  591. responds.
  592. * Fix a bug where we sometimes don't update the UI after a
  593. logout/login cycle.
  594. + Refactor widget methods to support desktop notifications,
  595. including GTK stubs.
  596. + Find-in-page should not ding while deleting characters.
  597. + Add SSL wrapper for linux and mac. This allows notifier to
  598. use chrome's SSL layer instead of OpenSSL.
  599. + Add three of the six extensions to PAC that Internet Explorer supports.
  600. + WebSocket support in chromium. (Run with --enable-web-sockets
  601. enables WebSocket features.)
  602. + Do not allow GTK File Chooser dialogs to return directories.
  603. + Fix the notifier SSL layer to make notifications work for
  604. Linux Bookmark sync.
  605. + linux: don't override mouse selection behavior in omnibox
  606. * Sun Oct 25 2009 tittiatcoke@gmail.com
  607. - Update to 224.4 svn 30027
  608. + First cut at new page and browser action docs based
  609. on new API. Deleted old stuff.
  610. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  611. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  612. + Minimize dependency of user scripts
  613. + Fixup the flip_framer eof-handling semantics now that we have
  614. the FIN bit in place
  615. + app depends on x11 because of active_window_watcher_x
  616. + Adding two images for the new Extension managment UI
  617. + Removing hard-coded Chrome Frame output path
  618. + Rearrange clipboard code
  619. + Fix crash bug when attempting to download a url with unsupported scheme,
  620. e.g. 'data:', by 'Alt + Click'
  621. + GTK: Change text for extension download UI
  622. + Ignore invalid urls on command line
  623. + Make dropped tabs animate from where they were dropped.
  624. + Make room for the full width of the tab placeholder.
  625. + Make tab dragging as smooth as glass.
  626. + Remove an annoying NOTIMPLEMNETED
  627. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  628. + If we're in the middle of a drag, don't allow the user to middle
  629. click to close or right click for the context menu
  630. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  631. + Remove +x bit from files that shouldn't have it
  632. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  633. + Adding new image needed for the managment UI
  634. + Fix a race bug where content scripts would not apply to the first page load
  635. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  636. + Fix bubbles deactivating the opaque frame
  637. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  638. + ake all pepper plugins default to windowless and transparent
  639. + Add styles for printing
  640. + Implement the new extension management UI
  641. + Add support for to automation interface load install and load extensions
  642. + GTK: theme the info bar border
  643. + Update V8 to version 1.3.16.1
  644. + Introduce WebSecurityPolicy for security related methods
  645. + New button scheme...borders are separate from the inner contents so
  646. that they can be highlighted / depressed independently
  647. + When opening Chrome maximized with an application window already
  648. running, the Chrome window was not activated
  649. + Fix compatibility problems with FileZilla FTP Server
  650. + Remove the extension shelf on Linux
  651. + Fix the proxy host and port string to start with http:// if it does not already
  652. + Enable HTML5 databases for all extension renderer processes
  653. * Sat Oct 24 2009 prusnak@opensuse.org
  654. - don't create desktop files in wrapper
  655. - fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  656. * Tue Oct 20 2009 tittiatcoke@gmail.com
  657. - update to newer svn snapshot
  658. + Obsoletes fwrite patch (included upstream)
  659. * Fri Oct 16 2009 tittiatcoke@gmail.com
  660. - update to newer svn snapshot
  661. + Requires newer version of v8
  662. * Thu Oct 15 2009 prusnak@suse.cz
  663. - do not force SSE on x86 (drop-sse.patch)
  664. * Tue Oct 13 2009 tittiatcoke@gmail.com
  665. - Update to newer svn snapshot
  666. - Fixed spec file in order to build
  667. - Included patch to build with system zlib
  668. * Mon Oct 12 2009 prusnak@suse.cz
  669. - package renamed to chromium
  670. - cleaned up spec file
  671. * Tue Oct 6 2009 dbuck@example.com
  672. - v8 is now built as a separate package, and is required
  673. - included many patches to use system libraries:
  674. v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  675. * Thu Oct 1 2009 dbuck@example.com
  676. - included a newer DEP than is in svn, native_client@823
  677. - things should compile cleanly now
  678. * Mon Aug 31 2009 dbuck@example.com
  679. - initial build