mariadb-vl.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878
  1. %bcond_with source
  2. %define mysqld_user mysql
  3. %define mysqld_group mysql
  4. %define mysqldatadir /var/lib/mysql
  5. # Working around perl dependency problem
  6. %global __perl_requires %{SOURCE998}
  7. %global __perllib_requires %{SOURCE998}
  8. %define _unpackaged_files_terminate_build 1
  9. %define mariadb_base_version 10.0
  10. %define mariadb_version 10.0.17
  11. %define mroonga_version 4.06
  12. %define client_version 18
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: tomop
  16. Name: mariadb
  17. Summary: MariaDB: a very fast and robust SQL database server
  18. Version: %{mariadb_version}
  19. Release: 1%{_dist_release}
  20. Group: Applications/Databases
  21. License: GPL2
  22. URL: http://www.mariadb.org/
  23. Source: mariadb-%{version}.tar.gz
  24. # Don't depend on lib::mtr*
  25. Source998: perl-requires.sh
  26. Source1000: macros.mariadb.in
  27. Patch0: mysql-5.5.15-jp-all.patch
  28. Patch100: mysql-srv_buf_size.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. BuildRequires: bison, cmake, gcc-c++, groff
  31. BuildRequires: libaio-devel, libboost-devel, libevent-devel, libxml2-devel
  32. BuildRequires: ncurses-devel, perl, openssl-devel, readline-devel
  33. BuildRequires: zlib-devel
  34. BuildRequires: mecab-devel
  35. Requires: fileutils sh-utils
  36. Provides: msqlormysql MySQL mysql
  37. Obsoletes: mysql MySQL5
  38. # From the manual
  39. %description
  40. MariaDB: a very fast and robust SQL database server
  41. It is GPL v2 licensed, which means you can use the it free of charge under the
  42. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  43. MariaDB documentation can be found at http://kb.askmonty.org/
  44. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  45. %package server
  46. Version: %{mariadb_version}
  47. Release: %{release}
  48. Summary: MariaDB: a very fast and robust SQL database server
  49. Group: Applications/Databases
  50. Requires: fileutils sh-utils net-tools mariadb-common
  51. Requires(post): mariadb-common
  52. Provides: mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
  53. Obsoletes: MySQL mysql mysql-server
  54. Obsoletes: MySQL-server < 5.6.0
  55. %description server
  56. MariaDB: a very fast and robust SQL database server
  57. It is GPL v2 licensed, which means you can use the it free of charge under the
  58. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  59. MariaDB documentation can be found at http://kb.askmonty.org/
  60. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  61. %package mroonga
  62. ##Version: %{mroonga_version}
  63. Version: %{mariadb_version}
  64. Summary: A fast fulltext searchable storage engine for MariaDB.
  65. Group: Applications/Databases
  66. Requires(pre): mariadb-server = %{mariadb_version}-%{release}
  67. Requires: mariadb-server = %{mariadb_version}-%{release}
  68. Obsoletes: mariadb-mroonga-doc < 4.07
  69. %description mroonga
  70. Mroonga is a fast fulltext searchable storage plugin for MariaDB.
  71. It is based on groonga that is a fast fulltext search engine and
  72. column store. Groonga is good at real-time update.
  73. %package client
  74. Version: %{mariadb_version}
  75. Summary: MariaDB - Client
  76. Group: Applications/Databases
  77. Obsoletes: mysql-client MySQL-client < 5.6.0
  78. Provides: mysql-client MySQL-client mariadbclient-%{mariadb_base_version}
  79. %description client
  80. This package contains the standard MariaDB clients and administration tools.
  81. %package devel
  82. Version: %{mariadb_version}
  83. Summary: MariaDB - Development libraries and headers
  84. Group: Development/Libraries
  85. Requires: %{name}-static, openssl-devel, zlib-devel
  86. Conflicts: MySQL-devel < 5.6.0
  87. Conflicts: libmysqlclient-devel
  88. %description devel
  89. This package contains the development libraries and headers to develop
  90. MariaDB server components (e.g. plugins or embedded applications).
  91. %package static
  92. Version: %{mariadb_version}
  93. Summary: MariaDB - static libraries
  94. Group: Development/Libraries
  95. Requires: %{name}-devel
  96. %description static
  97. This package provides static libraries of MariaDB.
  98. %if %{with source}
  99. %package source
  100. Version: %{mariadb_version}
  101. Summary: MariaDB - Source
  102. Group: Development/Libraries
  103. Requires: mariadb-devel = %{version}-%{release}
  104. Obsoletes: MySQL-source < 5.6.0
  105. AutoReqProv: no
  106. %description source
  107. This package contains the sources files of MariaDB.
  108. %endif
  109. %package test
  110. Version: %{mariadb_version}
  111. Requires: %{name}-client = %{version}-%{release} perl-DBI perl
  112. Summary: MariaDB - Test suite
  113. Group: Applications/Databases
  114. Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
  115. Provides: perl(mtr_misc.pl)
  116. %description test
  117. This package contains the MariaDB regression test suite.
  118. %package embedded
  119. Version: %{mariadb_version}
  120. Summary: MariaDB as an embeddable library
  121. Group: System Environment/Libraries
  122. Obsoletes: mysql-embedded MySQL-embedded
  123. Provides: mysql-embedded MySQL-embedded
  124. %description embedded
  125. This package contains a version of the MariaDB server that can be embedded
  126. into a client application instead of running as a separate process.
  127. %prep
  128. %setup -q
  129. #%patch0 -p1 -b .jp
  130. %patch100 -p1 -b .srv_buf_size
  131. %build
  132. # Be strict about variables, bail at earliest opportunity, etc.
  133. set -eu
  134. # Optional package files
  135. touch optional-files-devel
  136. export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
  137. export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
  138. # Build full release
  139. mkdir release
  140. (
  141. cd release
  142. cmake ../ \
  143. -DINSTALL_LAYOUT=RPM \
  144. -DBUILD_CONFIG=mysql_release \
  145. -DCMAKE_BUILD_TYPE=Release \
  146. -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
  147. -DMANUFACTURER="Vine Linux" \
  148. -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
  149. -DWITH_PIC="ON" \
  150. -DWITH_EMBEDDED_SERVER="ON" \
  151. -DWITH_ZLIB="system" \
  152. -DWITH_LIBEVENT="system" \
  153. -DWITH_LOCALES="yes" \
  154. -DWITH_UNIT_TESTS="no" \
  155. -DWITH_CONNECT_STORAGE_ENGINE="ON" \
  156. -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
  157. -DWITH_XTRADB_STORAGE_ENGINE="ON" \
  158. -DWITHOUT_TOKUDB=1 \
  159. -DWITH_JEMALLOC="no" \
  160. -DGRN_WITH_MECAB="yes"
  161. # -DWITH_PCRE="system"
  162. echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
  163. make %{?_smp_mflags} VERBOSE=1
  164. )
  165. %install
  166. rm -rf %{buildroot}
  167. install -d %{buildroot}%{mysqldatadir}/mysql
  168. install -d %{buildroot}%{_infodir}
  169. # Install all binaries
  170. (
  171. cd release
  172. make DESTDIR=%{buildroot} install
  173. )
  174. install -m 0644 Docs/mysql.info %{buildroot}%{_infodir}
  175. rm -rf ./doc
  176. mv -f %{buildroot}%{_docdir} ./
  177. %if %{with source}
  178. mkdir -p %{buildroot}%{_datadir}/%{name}-source
  179. pushd %{buildroot}%{_datadir}/%{name}-source
  180. tar zxf %{SOURCE0}
  181. find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
  182. popd
  183. %endif
  184. install -d %{buildroot}%{_sysconfdir}/rpm
  185. sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
  186. rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
  187. rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
  188. rm -f %{buildroot}%{_sysconfdir}/my.cnf
  189. rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
  190. rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
  191. rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
  192. # force linking statically.
  193. perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
  194. perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
  195. ##############################################################################
  196. %pre server
  197. # Create a MySQL user and group. Do not report any problems if it already
  198. # exists.
  199. datadir=/var/lib/mysql
  200. groupadd -r mysql 2> /dev/null || true
  201. useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
  202. # The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
  203. usermod -g mysql mysql 2> /dev/null || true
  204. %post server
  205. # Make MySQL start/shutdown automatically when the machine does it.
  206. if [ $1 = 1 ] ; then
  207. if [ -x /sbin/chkconfig ] ; then
  208. /sbin/chkconfig --add mysql
  209. fi
  210. basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
  211. if [ -z "$basedir" ] ; then
  212. basedir=/usr
  213. fi
  214. datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
  215. if [ -z "$datadir" ] ; then
  216. datadir=/var/lib/mysql
  217. else
  218. # datadir may be relative to a basedir!
  219. if ! expr $datadir : / > /dev/null; then
  220. datadir=$basedir/$datadir
  221. fi
  222. fi
  223. # Change permissions so that the user that will run the MySQL daemon
  224. # owns all database files.
  225. chown -R mysql:mysql $datadir
  226. if [ ! -e $datadir/mysql ]; then
  227. # Create data directory
  228. mkdir -p $datadir/{mysql,test}
  229. # Initiate databases
  230. /usr/bin/mysql_install_db --rpm --user=mysql
  231. fi
  232. # Change permissions again to fix any new files.
  233. chown -R mysql:mysql $datadir
  234. # Fix permissions for the permission database so that only the user
  235. # can read them.
  236. chmod -R og-rw $datadir/mysql
  237. fi
  238. %preun server
  239. if [ $1 = 0 ] ; then
  240. # Stop MySQL before uninstalling it
  241. if [ -x /etc/init.d/mysql ] ; then
  242. /etc/init.d/mysql stop > /dev/null
  243. fi
  244. # Don't start it automatically anymore
  245. if [ -x /sbin/chkconfig ] ; then
  246. /sbin/chkconfig --del mysql
  247. fi
  248. fi
  249. %postun server
  250. if [ $1 -ge 1 ]; then
  251. if [ -x /etc/init.d/mysql ] ; then
  252. # only restart the server if it was alredy running
  253. /etc/init.d/mysql status > /dev/null 2>&1 && \
  254. /etc/init.d/mysql restart
  255. fi
  256. fi
  257. %pre mroonga
  258. if [ $1 -gt 1 ]; then
  259. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
  260. An error occured when to register plugin.
  261. Please run a command below:
  262. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
  263. EOF
  264. fi
  265. %post mroonga
  266. if [ $1 -eq 1 ] ; then
  267. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
  268. An error occured when to register plugin.
  269. Please run a command below:
  270. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
  271. EOF
  272. fi
  273. %postun mroonga
  274. if [ $1 -gt 0 ] ; then
  275. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
  276. An error occured when to register plugin.
  277. Please run a command below:
  278. /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
  279. EOF
  280. fi
  281. # Clean up the BuildRoot
  282. %clean
  283. [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
  284. %files server
  285. %defattr(-,root,root)
  286. %doc doc/*
  287. %doc release/support-files/my-*.cnf
  288. %doc %{_infodir}/mysql.info*
  289. %doc %{_mandir}/man1/aria_*.1*
  290. %doc %{_mandir}/man1/innochecksum.1*
  291. %doc %{_mandir}/man1/my_print_defaults.1*
  292. %doc %{_mandir}/man1/myisam_ftdump.1*
  293. %doc %{_mandir}/man1/myisamchk.1*
  294. %doc %{_mandir}/man1/myisamlog.1*
  295. %doc %{_mandir}/man1/myisampack.1*
  296. %doc %{_mandir}/man1/mysql_convert_table_format.1*
  297. %doc %{_mandir}/man1/mysql_fix_extensions.1*
  298. %doc %{_mandir}/man8/mysqld.8*
  299. %doc %{_mandir}/man1/mysqld_multi.1*
  300. %doc %{_mandir}/man1/mysqld_safe.1*
  301. %doc %{_mandir}/man1/mysqldumpslow.1*
  302. %doc %{_mandir}/man1/mysql_install_db.1*
  303. %doc %{_mandir}/man1/mysql_plugin.1*
  304. %doc %{_mandir}/man1/mysql_secure_installation.1*
  305. %doc %{_mandir}/man1/mysql_setpermission.1*
  306. %doc %{_mandir}/man1/mysql_upgrade.1*
  307. %doc %{_mandir}/man1/mysqlhotcopy.1*
  308. %doc %{_mandir}/man1/mysql.server.1*
  309. %doc %{_mandir}/man1/mysqltest.1*
  310. %doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
  311. %doc %{_mandir}/man1/mysql_zap.1*
  312. %doc %{_mandir}/man1/mysqlbug.1*
  313. %doc %{_mandir}/man1/perror.1*
  314. %doc %{_mandir}/man1/replace.1*
  315. %doc %{_mandir}/man1/resolve_stack_dump.1*
  316. %doc %{_mandir}/man1/resolveip.1*
  317. %{_bindir}/aria_*
  318. %{_bindir}/innochecksum
  319. %{_bindir}/my_print_defaults
  320. %{_bindir}/myisam_ftdump
  321. %{_bindir}/myisamchk
  322. %{_bindir}/myisamlog
  323. %{_bindir}/myisampack
  324. %{_bindir}/mysql_convert_table_format
  325. %{_bindir}/mysql_fix_extensions
  326. %{_bindir}/mysql_install_db
  327. %{_bindir}/mysql_plugin
  328. %{_bindir}/mysql_secure_installation
  329. %{_bindir}/mysql_setpermission
  330. %{_bindir}/mysql_tzinfo_to_sql
  331. %{_bindir}/mysql_upgrade
  332. %{_bindir}/mysql_zap
  333. %{_bindir}/mysqlbug
  334. %{_bindir}/mysqld_multi
  335. %{_bindir}/mysqld_safe
  336. %{_bindir}/mysqldumpslow
  337. %{_bindir}/mysqlhotcopy
  338. %{_bindir}/mysqltest
  339. %{_bindir}/perror
  340. %{_bindir}/replace
  341. %{_bindir}/resolve_stack_dump
  342. %{_bindir}/resolveip
  343. #%{_bindir}/tokuftdump
  344. %{_sbindir}/mysqld
  345. %exclude %{_libdir}/mysql/plugin/ha_mroonga.so
  346. %exclude %{_datadir}/mysql/mroonga
  347. %{_libdir}/mysql
  348. %config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
  349. #%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
  350. %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
  351. %{_sysconfdir}/init.d/mysql
  352. %{_datadir}/mysql
  353. %attr(755, mysql, mysql) %dir %{mysqldatadir}
  354. %files mroonga
  355. %defattr(-, root, root)
  356. %{_libdir}/mysql/plugin/ha_mroonga.so
  357. %{_datadir}/mysql/mroonga
  358. %files client
  359. %defattr(-, root, root)
  360. %config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
  361. %{_bindir}/msql2mysql
  362. %{_bindir}/mysql
  363. %{_bindir}/mysql_find_rows
  364. %{_bindir}/mysql_waitpid
  365. %{_bindir}/mysqlaccess
  366. %{_bindir}/mysqladmin
  367. %{_bindir}/mysqlbinlog
  368. %{_bindir}/mysqlcheck
  369. %{_bindir}/mysqldump
  370. %{_bindir}/mysqlimport
  371. %{_bindir}/mysqlshow
  372. %{_bindir}/mysqlslap
  373. %{_bindir}/mytop
  374. %doc %{_mandir}/man1/msql2mysql.1*
  375. %doc %{_mandir}/man1/mysql.1*
  376. %doc %{_mandir}/man1/mysql_find_rows.1*
  377. %doc %{_mandir}/man1/mysql_waitpid.1*
  378. %doc %{_mandir}/man1/mysqlaccess.1*
  379. %doc %{_mandir}/man1/mysqladmin.1*
  380. %doc %{_mandir}/man1/mysqlbinlog.1*
  381. %doc %{_mandir}/man1/mysqlcheck.1*
  382. %doc %{_mandir}/man1/mysqldump.1*
  383. %doc %{_mandir}/man1/mysqlimport.1*
  384. %doc %{_mandir}/man1/mysqlshow.1*
  385. %doc %{_mandir}/man1/mysqlslap.1*
  386. %files devel -f optional-files-devel
  387. %defattr(-, root, root)
  388. %doc %{_mandir}/man1/mysql_config.1*
  389. %{_bindir}/mysql_config
  390. %{_includedir}/mysql
  391. %{_datadir}/aclocal/mysql.m4
  392. %{_libdir}/*.so
  393. %{_sysconfdir}/rpm/*
  394. %{_bindir}/mysql_embedded
  395. %files static
  396. %defattr(-,root,root)
  397. %{_libdir}/lib*.a
  398. %if %{with source}
  399. %files source
  400. %defattr(-, root, root)
  401. %{_datadir}/mariadb-source
  402. %endif
  403. %files test
  404. %defattr(-, root, root)
  405. %attr(-, root, root) %{_datadir}/mysql-test
  406. %{_bindir}/mysql_client_test
  407. %{_bindir}/mysql_client_test_embedded
  408. %{_bindir}/mysqltest_embedded
  409. %doc %{_mandir}/man1/mysql_client_test.1*
  410. %doc %{_mandir}/man1/mysql-stress-test.pl.1*
  411. %doc %{_mandir}/man1/mysql-test-run.pl.1*
  412. %doc %{_mandir}/man1/mysql_client_test_embedded.1*
  413. %doc %{_mandir}/man1/mysqltest_embedded.1*
  414. %files embedded
  415. %defattr(-,root,root)
  416. %{_libdir}/libmysqld.so.*
  417. %changelog
  418. * Tue Mar 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
  419. - new upstream release.
  420. * Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
  421. - new upstream release.
  422. * Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
  423. - new upstream release.
  424. - enabled bundled Mroonga.
  425. * Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
  426. - new upstream release.
  427. * Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
  428. - new upstream release.
  429. * Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
  430. - fixed Conflicts: and Obsoletes:.
  431. * Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
  432. - new upstream release.
  433. * Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
  434. - new upstream release.
  435. * Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
  436. - new upstream release.
  437. * Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
  438. - removed duplicated files.
  439. * Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
  440. - switched to MariaDB.
  441. * Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
  442. - new upstream release.
  443. * Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
  444. - new upstream release.
  445. * Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
  446. - new upstream release.
  447. - added a sub-package 'MySQL-source".
  448. - added some macros for rpm.
  449. * Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
  450. - new upstream release.
  451. * Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
  452. - new upstream release.
  453. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
  454. - new upstream release.
  455. - added "Vendor:" and "Distribution:" tag.
  456. * Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
  457. - new upstream release.
  458. - removed NDB cluster support.
  459. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
  460. - Added "BR: zlib-devel" to MySQL-devel.
  461. * Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
  462. - Added "BR: openssl-devel" to MySQL-devel.
  463. * Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
  464. - new upstream release.
  465. * Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
  466. - new upstream release.
  467. - updated jp-patch.
  468. - added ssl support.
  469. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
  470. - new upstream release.
  471. - replaced '%%__find_requires' to '%%__perl_requires'.
  472. - updated jp-patch.
  473. * Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
  474. - added mysql-5.1.44-lib64.patch (on x86_64)
  475. - added -fPIC (on x86_64)
  476. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
  477. - made embedded package again
  478. * Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
  479. - new upstream release.
  480. - updated jp-patch.
  481. * Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
  482. - VineSeed: rebuilt with new toolchain.
  483. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
  484. - new upstream release.
  485. - fixed CVE-2009-4484.
  486. * Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
  487. - new upstream release.
  488. * Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
  489. - added net-tools to 'Requires'.
  490. - added groff to 'BuildRequires'.
  491. - renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
  492. * Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
  493. - new upstream release.
  494. * Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
  495. - new upstream release.
  496. * Sun Jul 5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
  497. - new upstream release.
  498. - dropped %%Patch100 (fixed in upstream).
  499. * Sat Jun 6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
  500. - new upstream release.
  501. - add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
  502. * Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
  503. - new upstream release.
  504. - rename 'MySQL-bench' to 'MySQL-test'.
  505. - update Patch0.
  506. - change default charset to 'utf8'.
  507. * Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
  508. - new upstream release.
  509. - update Patch0.
  510. - add "--with-client-charset=ujis".
  511. - sync %%files to official RPM.
  512. - remove MySQL-Max.
  513. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
  514. - for VineSeed
  515. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
  516. - move shared library from /usr/lib/ to /usr/lib/mysql/
  517. - add /etc/ld.so.conf.d/*.conf
  518. - fix broken libmysqlcient*.la files (or should we remove them permanently?)
  519. * Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
  520. - rebuild <BTS:VineLinux:534>
  521. * Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
  522. - added -fPIC
  523. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
  524. - fixed dependency. <BTS:338>
  525. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
  526. - add %%Patch1. <BTS:320>
  527. * Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
  528. - new upstream release.
  529. * Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
  530. - new upstream release.
  531. * Sat Jun 3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
  532. - new upstream release.
  533. * Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
  534. - release++.
  535. * Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
  536. - new upstream release.
  537. - for VineSeed.
  538. * Wed Feb 8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
  539. - new upstream release.
  540. - replace Patch0 for MySQL-4.1.16.
  541. * Thu Oct 6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
  542. - new upstream release.
  543. - add Patch0.
  544. * Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
  545. - new upstream version
  546. -- mysql-4.0.25
  547. * Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
  548. - new upstream version
  549. -- mysql-4.0.23
  550. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
  551. - new upstream version
  552. -- mysql-4.0.22
  553. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
  554. - new upstream version
  555. -- mysql-4.0.21
  556. * Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
  557. - new upstream version
  558. -- mysql-4.0.20
  559. * Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
  560. - modify CFLAGS, CXXFLAGS and configure options for alpha
  561. * Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
  562. - Upgraded to MySQL-4
  563. - added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
  564. - merged to MySQL Official packages
  565. -- renamed package "MySQL" to "MySQL-server"
  566. -- when using gcc, _always_ use CXX=gcc
  567. -- replaced Copyright with License field (Copyright is obsolete)
  568. -- added myisam_ftdump to the Server package
  569. -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
  570. -- fixed file permissions (BUG 1672)
  571. -- removed dependency on MySQL-client from the MySQL-devel subpackage
  572. -- as it is not really required. (BUG 1610)
  573. -- Fixed BUG 1162 (removed macro names from the changelog)
  574. -- Really fixed BUG 998 (disable the checking for installed but
  575. -- unpackaged files)
  576. -- Fixed BUG 959 (libmysqld not being compiled properly)
  577. -- Fixed BUG 998 (RPM build errors): added missing files to the
  578. -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
  579. -- mysql_fix_privilege_tables.1), removed "-n" from install section.
  580. -- removed the GIF Icon (file was not included in the sources anyway)
  581. -- removed unused variable shared_lib_version
  582. -- do not run automake before building the standard binary
  583. -- (should not be necessary)
  584. -- add server suffix '-standard' to standard binary (to be in line
  585. -- with the binary tarball distributions)
  586. -- allow overriding CC and CXX (required when building
  587. -- with other compilers)
  588. * Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
  589. - added BuildRequires: automake16
  590. * Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
  591. - add '-fPIC -DPIC' to CFLAGS on alpha
  592. - little fix of spec file
  593. * Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
  594. - enable MySQL-shared subpackage for alpha
  595. - delete 'BuildPrereq: kernel24-headers' for alpha
  596. - fix shared %files (exclude sparc)
  597. * Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
  598. - new upstream version
  599. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
  600. - fixed devel %files (dropped *.la files)
  601. * Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
  602. - new upstream version
  603. - fixed document permission
  604. * Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
  605. - new upstream version
  606. * Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
  607. - dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
  608. -- don't work
  609. * Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
  610. - new upstream version
  611. - diseble-assembler in configure on sparc,sparc64,alpha
  612. * Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
  613. - new upstream version
  614. - moved some man files to main package
  615. - added enable-local-infile in configure
  616. - changed --with-extra-charsets=all in configure
  617. * Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
  618. - fixed changelog
  619. * Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
  620. - updated to mysql-3.23.51
  621. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
  622. - rebuild on zlib-1.1.4(security fix.)
  623. * Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
  624. - updated to mysql-2.23.49
  625. * Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
  626. - add 'BuildPrereq: kernel24-headers' on alpha
  627. - remove shared library and max on alpha
  628. * Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
  629. - updated to mysql-3.23.48
  630. * Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
  631. - updated to mysql-3.23.47
  632. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
  633. - updated to mysql-3.23.46
  634. * Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
  635. - updated to mysql-3.23.45
  636. * Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
  637. - updated to mysql-3.23.44
  638. * Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
  639. - updated to mysql-3.23.43
  640. - removed shared library and max on sparc
  641. * Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
  642. - updated to mysql-3.23.42
  643. - changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
  644. * Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
  645. - updated to mysql-3.23.41
  646. * Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
  647. - updated to mysql-3.23.40
  648. * Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
  649. - updated to mysql-3.23.39
  650. * Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  651. - added configure --with-charset=ujis
  652. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  653. - used some rpmmacro
  654. * Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
  655. - updated to MySQL-3.23.38
  656. * Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
  657. - removed Bench pakages
  658. * Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
  659. - removed pt_BR locale
  660. - build on Vine Linux
  661. - partially used rpmmacros
  662. - added %clean tag
  663. * Fri Aug 18 2000 Tim Smith <tim@mysql.com>
  664. - Added separate libmysql_r directory; now both a threaded
  665. and non-threaded library is shipped.
  666. * Tue Sep 28 1999 David Axmark <davida@mysql.com>
  667. - Added the support-files/my-example.cnf to the docs directory.
  668. - Removed devel dependency on base since it is about client
  669. development.
  670. * Wed Sep 8 1999 David Axmark <davida@mysql.com>
  671. - Cleaned up some for 3.23.
  672. * Thu Jul 1 1999 David Axmark <davida@mysql.com>
  673. - Added support for shared libraries in a separate sub
  674. package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
  675. - The --enable-assembler switch is now automatically disables on
  676. platforms there assembler code is unavailable. This should allow
  677. building this RPM on non i386 systems.
  678. * Mon Feb 22 1999 David Axmark <david@detron.se>
  679. - Removed unportable cc switches from the spec file. The defaults can
  680. now be overridden with environment variables. This feature is used
  681. to compile the official RPM with optimal (but compiler version
  682. specific) switches.
  683. - Removed the repetitive description parts for the sub rpms. Maybe add
  684. again if RPM gets a multiline macro capability.
  685. - Added support for a pt_BR translation. Translation contributed by
  686. Jorge Godoy <jorge@bestway.com.br>.
  687. * Wed Nov 4 1998 David Axmark <david@detron.se>
  688. - A lot of changes in all the rpm and install scripts. This may even
  689. be a working RPM :-)
  690. * Sun Aug 16 1998 David Axmark <david@detron.se>
  691. - A developers changelog for MySQL is available in the source RPM. And
  692. there is a history of major user visible changed in the Reference
  693. Manual. Only RPM specific changes will be documented here.