file-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. %define __libtoolize :
  2. Summary: A utility for determining file types.
  3. Summary(ja): ファイルの種類を判別するユーティリティー
  4. Name: file
  5. Version: 5.39
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: BSD
  12. URL: http://www.darwinsys.com/file/
  13. # master site is toooooooooooooooooo slow
  14. # Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  15. %define altver %(echo %{version} | sed -e 's/\\./_/')
  16. Source0: https://github.com/file/file/archive/FILE%{altver}.tar.gz#/file-FILE%{altver}.tar.gz
  17. # Addtional magic file for Vine
  18. Source10: magic.printer-j
  19. # Upstream says it's up to distributions to add a way to support local-magic.
  20. Patch0: file-localmagic.patch
  21. # not yet upstream
  22. Patch3: file-4.17-rpm-name.patch
  23. Patch4: file-5.04-volume_key.patch
  24. # Vine
  25. Patch1000: file-5.14-magicbuild-fix.patch
  26. Buildroot: %{_tmppath}/%{name}-%{version}-root
  27. #BuildRequires: automake
  28. #BuildRequires: autoconf
  29. BuildRequires: zlib-devel
  30. Obsoletes: file-static
  31. %description
  32. The file command is used to identify a particular file according to the
  33. type of data contained by the file. File can identify many different
  34. file types, including ELF binaries, system libraries, RPM packages, and
  35. different graphics formats.
  36. You should install the file package, since the file command is such a
  37. useful utility.
  38. %description -l ja
  39. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  40. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  41. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  42. を含む、多くの異なるファイルの種類を見分けることができます。
  43. %package devel
  44. Summary: Libraries and header files for file development
  45. Summary(ja): libmagic の開発用ファイル
  46. Group: programming
  47. Requires: %{name} = %{version}-%{release}
  48. %description devel
  49. The file-devel package contains the header files and libmagic library
  50. necessary for developing programs using libmagic.
  51. %package -n python-magic
  52. Summary: Python bindings for the libmagic API
  53. Group: programming
  54. BuildRequires: python-devel
  55. BuildRequires: python-setuptools
  56. BuildRequires: python-rpm-macros
  57. Requires: %{name} = %{version}-%{release}
  58. %description -n python-magic
  59. This package contains the Python bindings to allow access to the
  60. libmagic API. The libmagic library is also used by the familiar
  61. file(1) command.
  62. %package -n python3-magic
  63. Summary: Python bindings for the libmagic API
  64. Group: programming
  65. BuildRequires: python3-devel
  66. BuildRequires: python3-setuptools
  67. BuildRequires: python3-rpm-macros
  68. Requires: %{name} = %{version}-%{release}
  69. %description -n python3-magic
  70. This package contains the Python bindings to allow access to the
  71. libmagic API. The libmagic library is also used by the familiar
  72. file(1) command.
  73. %debug_package
  74. %prep
  75. %setup -q -n file-FILE%{altver}
  76. autoreconf -ivf
  77. # Don't use -b -- it will lead to problems when compiling magic file!
  78. %patch0 -p1
  79. %patch3 -p1
  80. %patch4 -p1
  81. # Vine
  82. %patch1000 -p1
  83. cat %{SOURCE10} >> ./magic/Localstuff
  84. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  85. touch -r doc/libmagic.man doc/libmagic.man_
  86. mv doc/libmagic.man_ doc/libmagic.man
  87. %build
  88. autoreconf
  89. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  90. %configure --enable-fsect-man5 --disable-rpath
  91. # remove hardcoded library paths from local libtool
  92. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  93. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  94. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  95. make
  96. cd python
  97. %py_build
  98. %py3_build
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  102. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  103. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  104. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  105. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  106. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  107. make install DESTDIR=$RPM_BUILD_ROOT
  108. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  109. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  110. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  111. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  112. cd python
  113. %py_install
  114. %py3_install
  115. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  116. # LIBTOOL=/usr/bin/libtool
  117. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  118. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  119. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  120. #{ cd ${RPM_BUILD_ROOT}
  121. # strip .%{_bindir}/file
  122. # cp %SOURCE1 .%{_datadir}/magic.mime
  123. #}
  124. # remove unuse files
  125. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  126. %clean
  127. rm -rf $RPM_BUILD_ROOT
  128. %post -p /sbin/ldconfig
  129. %postun -p /sbin/ldconfig
  130. %files
  131. %defattr(-,root,root)
  132. %license COPYING
  133. %doc ChangeLog README
  134. %{_bindir}/*
  135. %{_libdir}/libmagic.so.*
  136. %{_datadir}/file/*
  137. %{_datadir}/magic*
  138. %{_datadir}/misc/*
  139. %{_mandir}/man[15]/*
  140. %files devel
  141. %defattr(-,root,root,-)
  142. %{_libdir}/*.so
  143. %{_libdir}/pkgconfig/*
  144. %{_includedir}/magic.h
  145. %{_mandir}/man3/*
  146. %files -n python-magic
  147. %defattr(-, root, root, -)
  148. %license python/LICENSE
  149. %doc python/README* python/example.py
  150. %{python_sitelib}/magic.py
  151. %{python_sitelib}/magic.pyc
  152. %{python_sitelib}/magic.pyo
  153. %{python_sitelib}/*egg-info
  154. %files -n python3-magic
  155. %defattr(-, root, root, -)
  156. %license python/LICENSE
  157. %doc python/README* python/example.py
  158. %{python3_sitelib}/*
  159. %changelog
  160. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.39-1
  161. - new upstream release.
  162. - dropped Patch14 and 9000: fixed in upstream.
  163. * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-2
  164. - added Patch9000.
  165. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-1
  166. - new upstream release.
  167. - added python3 support.
  168. - updated Patch0.
  169. - dropped Patch1, 5-17 and 100: fixed in upstream.
  170. - imported Patch14 from rawhide.
  171. * Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
  172. - new upstream release.
  173. - dropped Patch200: fixed in upstream.
  174. - updated patches.
  175. - imported Patch15,17 and 100.
  176. * Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
  177. - new upstream release
  178. - update/drop patches based on fc22
  179. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
  180. - reflected 6.0 updates and bumped release
  181. * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
  182. - drop patch230 (moved to patch320)
  183. - add Patch240 for fix CVE-2014-0207
  184. - add Patch250 for fix CVE-2014-0237
  185. - add Patch260 for fix CVE-2014-0238
  186. - add Patch270 for fix CVE-2014-3478
  187. - add Patch280 for fix CVE-2014-3479
  188. - add Patch290 for fix CVE-2014-3480
  189. - add Patch300 for fix CVE-2014-3487
  190. - add Patch310 for fix CVE-2014-3538
  191. - add Patch320 for fix CVE-2014-3587
  192. These patches are from debian/ubuntu, thanks.
  193. * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
  194. - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
  195. * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
  196. - add patch110,220 for fix regression of CVE-2014-2270
  197. * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
  198. - add patch210 for fix CVE-2014-2270
  199. * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
  200. - add patch200 for fix CVE-2014-1943
  201. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
  202. - rebuild with VineSeed environment
  203. * Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
  204. - new upstream reelase
  205. - add patch100 to fix build error
  206. - remove -static subpackage and add Obs: file-static
  207. - fix old changelog date...
  208. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  209. - new upstream reelase
  210. - drop all local patches
  211. - import fedora patches
  212. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  213. - rebuild with python-2.7.2
  214. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  215. - rebuild package
  216. - fix Patch100
  217. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  218. - new upstream release
  219. - updated Vine patches (but Patch100 has not been ported yet...)
  220. - split to devel and static subpackcages
  221. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  222. - rebuilt with rpm-4.8.1
  223. - add environment variable LIBTOOL for make command
  224. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  225. - spec in utf-8
  226. - removed *.la
  227. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  228. - applied new versioning policy
  229. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  230. - new upstream release
  231. - import debian/fedora patches
  232. - drop obsolete vine magic.
  233. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  234. - rebuild for VineSeed with new tool chain
  235. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  236. - add patch110 for fix CVE-2007-2799
  237. - add zlib-devel to BuildPreReq tag
  238. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  239. - add patch100 for fix CVE-2007-1536
  240. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  241. - changed Group to Applications/System
  242. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  243. - new upstream release
  244. - update vine patches
  245. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  246. - update Patch10, use 'size_t' in src/jcode.[ch]
  247. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  248. - update to 4.03
  249. - update Patch0, 1, 10 for 4.03
  250. - s/Copyright/License/
  251. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  252. - update to 4.02
  253. - update Vine patches for 4.02
  254. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  255. - new upstream release
  256. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  257. - remove unneeded patches.
  258. - update Vine patches for 3.41
  259. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  260. - added NPDL2 data [Vine:02348]
  261. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  262. - update to 3.37
  263. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  264. - 3.35-0vl3
  265. - disable some entries in elf for problems on big-endian archs
  266. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  267. - file-3.35-0vl1
  268. - ver.up
  269. - added %doc
  270. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  271. - file-3.33-1vl4
  272. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  273. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  274. - file-3.33-1vl3
  275. - fix again jtext patch (file-3.33-vinejtext.patch)
  276. - added file-3.33-vinenames.patch to avoid miss-judgement
  277. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  278. - file-3.33-1vl2
  279. - update jtext patch (file-3.33-vinejtext.patch)
  280. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  281. - file-3.33-1vl1
  282. - modify description-ja and spec
  283. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  284. - file-3.28-2vl2
  285. - fixed %files section to handle compressed man pages
  286. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  287. - marged RH 3.28-2 and Vine 3.27-3vl3
  288. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  289. - add ia64 patch from rth
  290. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  291. - handle compressed manpages
  292. - update to 3.28
  293. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  294. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  295. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  296. - patch dues not apply bug.
  297. * Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  298. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  299. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  300. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  301. - identify ELF stripped files correctly (#4665).
  302. - use SPARC (not sparc) consistently throughout (#4665).
  303. - add entries for MS Office files (#4665).
  304. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  305. - diddle magic so that *.tfm files are identified correctly.
  306. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  307. - update to 3.27.
  308. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  309. - experimental support for realmedia files added
  310. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  311. - auto rebuild in the new build environment (release 5)
  312. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  313. - strip binary.
  314. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  315. - add SPARC V9 magic.
  316. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  317. - update to 3.26.
  318. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  319. - update to 3.25.
  320. - detect gimp XCF versions.
  321. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  322. - translations modified for de, fr, tr
  323. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  324. - updated to 3.24
  325. - buildrooted
  326. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  327. - built against glibc
  328. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  329. - Fixed problems caused by 64 bit time_t.
  330. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  331. - Improved recognition of Linux kernel images.