authconfig-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750
  1. Summary: Command line tool for setting up authentication from network services
  2. Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
  3. Name: authconfig
  4. Version: 6.2.8
  5. Release: 2%{?_dist_release}
  6. License: GPLv2+
  7. ExclusiveOS: Linux
  8. Group: System Environment/Base
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. URL: https://fedorahosted.org/authconfig
  11. Source: https://fedorahosted.org/releases/a/u/%{name}/%{name}-%{version}.tar.bz2
  12. Patch10: authconfig-6.2.3-fprintd-pam.patch
  13. Patch11: authconfig-6.2.3-fix-broken-strings.patch
  14. # remove selinux staff
  15. Patch100: authconfig-6.2.8-noselinux.patch
  16. Requires: pam
  17. Conflicts: samba-common < 3.0, samba-client < 3.0
  18. Conflicts: nss_ldap < 254
  19. BuildRequires: glib2-devel, python >= 2.4.1, python-devel
  20. BuildRequires: desktop-file-utils, intltool, gettext, perl-XML-Parser
  21. %description
  22. Authconfig is a command line utility which can configure a workstation
  23. to use shadow (more secure) passwords. Authconfig can also configure a
  24. system to be a client for certain networked user information and
  25. authentication schemes.
  26. %description -l ja
  27. authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
  28. コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
  29. サービスを利用するように設定することもできます。
  30. %package gtk
  31. Summary: Graphical tool for setting up authentication from network services
  32. Summary(ja): ネットワークサービスからの認証を設定するためのグラフィカルツール
  33. Group: System Environment/Base
  34. Requires: %{name} = %{version}-%{release}, pygtk2-libglade
  35. Requires: usermode-gtk
  36. %description gtk
  37. Authconfig-gtk is a GUI program which can configure a workstation
  38. to use shadow (more secure) passwords. Authconfig-gtk can also configure
  39. a system to be a client for certain networked user information and
  40. authentication schemes.
  41. %prep
  42. %setup -q -n %{name}-%{version}
  43. %patch10 -p1
  44. %patch11 -p1
  45. %patch100 -p1
  46. %build
  47. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  48. %configure
  49. make
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make install DESTDIR=$RPM_BUILD_ROOT
  53. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.a
  54. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.la
  55. rm $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
  56. ln -s authconfig.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
  57. %find_lang %{name}
  58. find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %post
  62. authconfig --updateall --nostart &>/dev/null ||:
  63. %post gtk
  64. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  65. %postun gtk
  66. if [ $1 -eq 0 ] ; then
  67. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  68. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  69. fi
  70. %posttrans gtk
  71. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  72. %triggerin -- authconfig <= 6.2.3
  73. if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
  74. authconfig --updateall --nostart >/dev/null 2>&1 || :
  75. fi
  76. if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
  77. cd %{_sysconfdir}/pam.d; \
  78. ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
  79. fi
  80. %files -f %{name}.lang
  81. %defattr(-,root,root,-)
  82. %doc COPYING NOTES TODO README.samba3
  83. %ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
  84. %ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
  85. %ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
  86. %ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
  87. %ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
  88. %ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
  89. %{_bindir}/authconfig
  90. %{_bindir}/authconfig-tui
  91. %{_sbindir}/cacertdir_rehash
  92. %{_sbindir}/authconfig
  93. %{_sbindir}/authconfig-tui
  94. %{_mandir}/man8/*
  95. %{_mandir}/man5/*
  96. %{python_sitearch}/acutilmodule.so
  97. %dir %{_datadir}/%{name}
  98. %{_datadir}/%{name}/authconfig.py*
  99. %{_datadir}/%{name}/authconfig-tui.py*
  100. %{_datadir}/%{name}/authinfo.py*
  101. %{_datadir}/%{name}/shvfile.py*
  102. %{_datadir}/%{name}/dnsclient.py*
  103. %{_datadir}/%{name}/msgarea.py*
  104. %config(noreplace) %{_sysconfdir}/pam.d/authconfig
  105. %config(noreplace) %{_sysconfdir}/pam.d/authconfig-tui
  106. %config(noreplace) %{_sysconfdir}/security/console.apps/authconfig
  107. %config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-tui
  108. %attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
  109. %files gtk
  110. %defattr(-,root,root,-)
  111. %{_bindir}/authconfig-gtk
  112. %{_bindir}/system-config-authentication
  113. %{_sbindir}/authconfig-gtk
  114. %{_sbindir}/system-config-authentication
  115. %{_datadir}/%{name}/authconfig.glade
  116. %{_datadir}/%{name}/authconfig-gtk.py*
  117. %config(noreplace) %{_sysconfdir}/pam.d/authconfig-gtk
  118. %config(noreplace) %{_sysconfdir}/pam.d/system-config-authentication
  119. %config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-gtk
  120. %config(noreplace) %{_sysconfdir}/security/console.apps/system-config-authentication
  121. %{_datadir}/applications/*
  122. %{_datadir}/icons/hicolor/*/*/*
  123. %changelog
  124. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.2.8-2
  125. - add Patch100 to remove selinux staff (again)
  126. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
  127. - update to 6.2.8
  128. - remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  129. * Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
  130. - update to 6.2.4
  131. - run "authconfig --updateall --nostart" on %%post script
  132. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
  133. - update to 6.2.3
  134. - update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
  135. - update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
  136. - add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  137. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
  138. - rebuild with python-2.7.2
  139. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
  140. - rebuilt with rpm-4.8.1-3
  141. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
  142. - rebuilt with python-2.6.4
  143. * Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
  144. - update Patch11
  145. - old patch does not fix problem on some environment..
  146. * Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
  147. - add Patch10
  148. - Fingerprint auth requires fprintd-pam package not pam_fprintd
  149. - add Patch11 to fix broken help messages on some locale.
  150. * Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
  151. - new upstream release
  152. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
  153. - new upstream release
  154. - historical changelogs are following:
  155. * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
  156. - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
  157. - added BuildRequires: desktop-file-utils
  158. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
  159. - rebuilt with python-2.4.1-0vl1
  160. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
  161. - rebuilt with python-2.3.3-0vl1
  162. * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
  163. - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
  164. * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
  165. - updated to 4.6.1
  166. - updated Patch0 and Source1
  167. - rebuild with new toolchains
  168. - Reqyires: glib2, BuildRequires: glib2-devel
  169. * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
  170. - add vinized color palette
  171. * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
  172. - rebuild for Vine Linux
  173. - based on Red Hat Linux 7.2, merged with Vine Linux package.
  174. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  175. - 3.0.3-1vl5
  176. - change checkbox color
  177. * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
  178. - add %patch1 to fix mandir
  179. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
  180. - build with gcc-2.95.3
  181. - partially used rpmmacros
  182. * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  183. - 3.0.3-1vl2
  184. - modified %files section to handle compressed man page
  185. * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
  186. - 3.0.3-1vl1
  187. - build for Vine
  188. * Tue Aug 5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
  189. - do not call domainname when run with --nostart (#457697)
  190. * Fri Jun 6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
  191. - remove the --enableldapssl alias and add some help to GUI tooltips
  192. to clear up some confusion (#220973)
  193. - add option --enablepreferdns to prefer DNS over NIS or WINS in
  194. hostname resolution
  195. * Tue Apr 8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
  196. - read wins setting from nsswitch.conf correctly (#440459)
  197. - do not ignore --enablemd5/--disablemd5 options
  198. * Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
  199. - fixed backup directory in Makefile and spec (#437040)
  200. * Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
  201. - include config-util in console.apps files
  202. - add support for saving/restoring backups of configuration
  203. files affected by authconfig (#433776)
  204. - improve the authconfig manual page (#432023, #432938)
  205. * Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
  206. - correct the fix for bug #237956
  207. * Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
  208. - update translations
  209. * Wed Jan 9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
  210. - support new sha256 and sha512 password hash algorithms
  211. - add support for pam_mkhomedir (#212790)
  212. - do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
  213. the idea how to fix that
  214. - setup password hash algorithm in /etc/login.defs (#218652)
  215. - update translations
  216. * Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
  217. - improve krb5.conf handling (#238766)
  218. * Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
  219. - remove obsolete pam_krb5afs support (#250704)
  220. - add support for pam_access (#251360)
  221. - update translations
  222. * Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
  223. - license tag fix
  224. * Thu Aug 9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
  225. - require newt-python (#251359)
  226. * Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
  227. - add support for winbind offline login (#232955)
  228. * Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
  229. - dnsclient fixes by Simo Sorce
  230. - add Categories to .desktop file (#245868)
  231. - fixed traceback when calling joinDomain (#245374)
  232. - disable smart card action setting when gnome-screensaver
  233. not installed (#209643)
  234. - do not change protocols and services in nsswitch.conf (#236669)
  235. * Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
  236. - authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
  237. - drop explicit requirement on python version as it is now
  238. generated automatically
  239. - improve writing /etc/samba/smb.conf (based on patch by
  240. Simo Sorce)
  241. - merge changes upstream
  242. * Fri May 4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
  243. - local nis domain is obtained from sysconfig/network (#235927)
  244. - set "local authorization is sufficient" on by default
  245. * Thu Apr 5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
  246. - minor changes and cleanups for merge review (#225293)
  247. * Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
  248. - nss_ldap is now in /usr/lib (#232975)
  249. * Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
  250. - another traceback in --probe and other fixes (#218874)
  251. - make smbRealm a default realm when appropriate (#219300)
  252. - added missing languages in LINGUAS
  253. * Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
  254. - when pam_krb5 auth fails with smartcard login don't enforce it
  255. in the account stack (#214931)
  256. - updated translations (#216570)
  257. - winbind should be added only to user tables (#216862)
  258. * Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
  259. - fixed --smartcardaction command line option (#211552)
  260. * Fri Oct 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
  261. - fixed passwd PAM stack when PKCS11 enabled (#195960)
  262. - make authconfig --probe work again (#209676)
  263. * Mon Oct 2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
  264. - updated translations (#207095)
  265. - correctly write pam_smb.conf with only one server specified (#208365)
  266. * Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
  267. - move options to another tab to fit on 800x600 screen (#207357)
  268. * Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
  269. - improve PAM setup for smart card login
  270. - support smart card login with kerberos (PKINIT)
  271. - add pam_pkcs11 to password PAM stack
  272. * Mon Sep 4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
  273. - skip pam_unix for session for crond service
  274. - fixed a bug in saving when smartcard settings changed (#204838)
  275. - removed allow_ypbind setsebool as it is now handled in ypbind
  276. * Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
  277. - improve smart card related UI strings
  278. - removed possibility to set smart card type from authconfig-gtk
  279. as only coolkey will be supported for now
  280. * Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
  281. - pass options given to authconfig-gtk to authconfig (#203955)
  282. * Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
  283. - write out new "wait_for_card" config option if we're
  284. forcing smart card authentication
  285. - add "use_uid" option to smart card pam_succeed_if line to
  286. work around bug where pam_succeed_if checks user information
  287. even in cases where the conditional doesn't depend on it.
  288. - remove unimplemented "logout" smart card removal action from
  289. settings
  290. - remove unnecessary "card_only" argument
  291. * Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
  292. - don't start sceventd when smartcard login is enabled
  293. - improve pam config for smartcard login
  294. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
  295. - don't require pam_pkcs11 to run
  296. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
  297. - screensavers should be authenticated by smartcard too
  298. - add feature to download a CA certificate for LDAP from
  299. an URL (#197103)
  300. - add pam_keyinit session module to the PAM configuration (#198638)
  301. * Fri Jul 7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
  302. - added support for smartcard authentication
  303. - fixed parsing kerberos realms
  304. * Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
  305. - write ldap servers as URIs and not HOSTs (#191842)
  306. - fix a typo in --test output
  307. - updated summary, converted changelog to UTF-8
  308. * Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
  309. - added crond to the services restarted after firstboot (#187334)
  310. - when checking nscd status redirect output to /dev/null (#188555)
  311. * Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
  312. - make smb.conf and krb5.conf loading more robust (#185766)
  313. * Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
  314. - add try_first_pass option to pam_unix for better integration
  315. with individual service configurations (#182350)
  316. - updated translations
  317. * Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
  318. - don't crash in TUI when some options aren't set (#182151)
  319. * Fri Feb 3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
  320. - redesigned GUI (#178112)
  321. - added man page for system-config-ac (#179584)
  322. - disable authentication of system accounts by network services
  323. by default, added option for changing that (#179009)
  324. - updated translations, new languages
  325. * Mon Jan 9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
  326. - fixed regression when saving nsswitch.conf
  327. * Fri Jan 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
  328. - print warning if PAM module is missing when the PAM configuration
  329. is saved (#168880)
  330. * Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
  331. - make child dialog preset code more robust (#176462)
  332. * Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
  333. - update only configuration files which settings were modified (#72290)
  334. * Mon Dec 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
  335. - don't ignore krb5realm command line option (#174838)
  336. - read dns_lookup_realm and dns_lookup_kdc values correctly
  337. - the PAM configuration is now written in system-auth-ac file
  338. which is then symlinked from system-auth, the symlink is not
  339. overwritten so local PAM configuration is now possible (#165342)
  340. * Mon Nov 7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
  341. - add symlinks to python scripts in sbindir
  342. - don't override nullok setting from system-auth (#96996)
  343. * Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
  344. - authinfo-tui.py is now symlink
  345. - reword the CA certificate message (#154317)
  346. - use include instead of pam_stack in pam config
  347. - don't break yp.conf with multiple domains (#127306)
  348. * Mon Sep 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
  349. - fixed a few errors catched by pychecker
  350. * Sat Sep 3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
  351. - C code completely rewritten in Python
  352. - some bugs fixed in the process (and no doubt new introduced)
  353. - TUI deprecated, opens only when run as authconfig-tui
  354. * Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
  355. - set domain and ypserver option correctly when multiple servers
  356. specified in kickstart (#159214)
  357. * Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
  358. - replaced deprecated gtk.TRUE/FALSE (#153034)
  359. - updated translations
  360. * Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
  361. - propagate the --enablewinbindauth option to the configuration (#151018)
  362. * Fri Mar 4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
  363. - changed version propagation
  364. * Thu Mar 3 2005 Tomas Mraz <tmraz@redhat.com>
  365. - updated translations
  366. - fixed build on gcc4
  367. * Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
  368. - updated translations
  369. * Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
  370. - improved the code that writes tls_cacertdir to ldap.conf
  371. * Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
  372. - renamed functions in authconfigmodule to be more clear
  373. - implemented cacertdir for LDAP with TLS
  374. * Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
  375. - fixed a bug in authinfo_differs when called from python
  376. * Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
  377. - add option for making local authorization sufficient for local users
  378. this is attempt to 'solve/workaround' the problem with blocking local logins by
  379. pulling out network cable (#115181)
  380. * Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
  381. - remove dependency on nscd
  382. - don't show warning messages when switching options off
  383. * Mon Dec 6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
  384. - updated translations
  385. - winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
  386. - use GtkComboBox instead of deprecated GtkOptionMenu
  387. - disable options with not installed binaries, remove unnecessary deps of
  388. authconfig-gtk
  389. * Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
  390. - merged patches from dist
  391. - fix versioning
  392. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
  393. - rebuild against python 2.4
  394. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  395. - Fix setsebool patch to turn off boolean
  396. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  397. - Add setsebool for NIS
  398. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  399. - force broken_shadow option on network auth (#136760)
  400. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  401. - force restart of autofs on firstboot call when using NIS (#133035, #124498)
  402. * Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
  403. - require python to install (#134654)
  404. * Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
  405. - updated translations from upstream
  406. - autogeneration of build stripts in prep phase
  407. * Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
  408. - fixed man page
  409. - added dependency on nscd
  410. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
  411. - regenerated build scripts
  412. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
  413. - fixed all po files to translate correctly messages with modified accelerators (#133742)
  414. - added translations for Arabic, Bulgarian and other languages (#133716, #133158)
  415. * Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
  416. - added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
  417. * Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
  418. - corrected package dependencies #132411
  419. - regenerated glade.strings.h #132369
  420. * Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
  421. - modified authconfig-gtk interface to fit lower resolution screens (#127175)
  422. - modified accelerators in authconfig-gtk (#125797)
  423. - updated package dependencies (#125306)
  424. * Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
  425. - updated configure scripts
  426. - warnfixes and minor hacks
  427. * Mon Jun 7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
  428. - tweak account management to fix #55193 correctly
  429. - require anything we might want to run in the gui subpackage because it
  430. doesn't warn about missing things and you don't have a terminal to see
  431. error messages about missing commands
  432. - properly display the domain in the GUI join dialog (#124621)
  433. * Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
  434. - omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
  435. - properly warn about missing "net" (samba-client) and libnss_winbind and
  436. pam_winbind (samba-common) in text mode (#122802)
  437. * Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
  438. - learn all about pam_passwdqc
  439. - preserve arguments to pam_cracklib and pam_passwdqc
  440. - short-circuit PAM authorization checks for users with UID < 100
  441. - remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
  442. * Fri Feb 6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
  443. - fix man page: --enableldapssl should be --enableldaptls
  444. - make --enableldapssl an alias for --enableldaptls
  445. * Thu Jan 8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
  446. - authconfig-gtk.py: require rhpl, which is required by the script (#104209)
  447. - both: require usermode (authconfig-gtk transitively), else leave a dangling
  448. symlink (#104209)
  449. - the great redhat-config-authentication/system-config-authentication renaming,
  450. as was foretold in the fedora-config-list archives
  451. * Wed Jan 7 2004 Nalin Dahyabhai <nalin@redhat.com>
  452. - preserve "compat" if it's used in /etc/nsswitch.conf
  453. * Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
  454. - add options for toggling krb5's use of DNS
  455. * Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
  456. - rework tui to include winbind options. there wasn't enough room in the old
  457. dialog to include the important options, so the whole thing's been reworked
  458. * Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
  459. - conflict with older versions of samba which expect different configuration
  460. * Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
  461. - initial support for configuring winbind
  462. * Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
  463. - make pam_cracklib requisite instead of required in generated PAM configs
  464. * Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
  465. - rebuild with current translations
  466. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
  467. - make the tarball name include the release number
  468. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
  469. - authconfig-gtk: condrestart certain additional services if invoked with
  470. the --firstboot flag (half of #91268, needs cooperating firstboot)
  471. - translation updates
  472. * Mon Jul 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
  473. - translation updates
  474. * Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
  475. - add 'redhat-config-authentication' as an alias for authconfig-gtk
  476. - make authconfig-gtk exec authconfig if gui startup fails and it looks like
  477. we're connected to a tty
  478. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  479. - rebuilt
  480. * Mon May 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
  481. - translation updates
  482. - close unusable file descriptors if locking fails
  483. * Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
  484. - learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
  485. * Fri Feb 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
  486. - look in /lib64 for modules for nsswitch and PAM by default on
  487. x86_64, ppc64, and s390x (#83049)
  488. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  489. - rebuilt
  490. * Mon Nov 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
  491. - update translations
  492. - update copyright strings (only took 10 months!)
  493. * Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
  494. - require a version of PAM (0.75-43) which supports $ISA
  495. - use $ISA in our own PAM config files
  496. * Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
  497. - add $ISA to the name of the directory in which we expect PAMs to be stored
  498. * Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
  499. - build with -fPIC, necessary on some arches
  500. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
  501. - update translations
  502. * Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
  503. - Update translations
  504. * Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
  505. - modify spacing and layout in authconfig-gtk
  506. * Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
  507. - translation updates
  508. - rebuild to pick up dependency changes
  509. * Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
  510. - include the userhelper configuration file
  511. - require sufficiently-new pam package in the gui subpackage
  512. * Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
  513. - actually include the icon in the package
  514. - translation updates
  515. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
  516. - use desktop-file-install (#69376)
  517. - include an icon for the menu item (#68577)
  518. * Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
  519. - own the pkgdatadir
  520. - pull in translation updates
  521. * Mon Jun 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
  522. - add --enable-experimental to enable some of that experimental code
  523. - add --enable-local to enable local policies
  524. - update translations
  525. * Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
  526. - use the current revision of python by default
  527. - get the intltool/gettext situation sorted out
  528. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  529. - automated rebuild
  530. * Fri May 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
  531. - remove bogus buildrequires left over from when authconfig-gtk was C code
  532. - buildrequires python-devel in addition to python (to build the python module,
  533. but we still need python to byte-compile the python script)
  534. * Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
  535. - add missing translations back in
  536. - convert .mo files at install-time
  537. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
  538. - refresh translations
  539. * Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
  540. - actually add the .desktop files
  541. * Tue Apr 9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
  542. - refresh translations
  543. - destroy the python object correctly
  544. * Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
  545. - add the .desktop file
  546. * Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
  547. - rework the auth stack logic to require all applicable auth modules
  548. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
  549. - allow pam_krb5afs to be used for account management, too
  550. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
  551. - refresh translations
  552. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
  553. - refresh translations
  554. * Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
  555. - actually free authInfo structures when asked to
  556. - use pam_krb5's account management facilities
  557. - conflict with versions of pam_krb5 which don't offer account management
  558. * Mon Feb 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
  559. - add python bindings for the back-end
  560. - redo the gui so that it exercises the python bindings
  561. - take a shot at getting authconfig to work in a firstboot container
  562. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
  563. - rebuild again
  564. * Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
  565. - rebuilt against new glib
  566. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
  567. - rebuild in new environment
  568. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
  569. - add some more experimental options
  570. - clean up the glade files a bit
  571. - don't destroy a garbage pointer on main cancel, destroy the main dialog
  572. * Thu Jan 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
  573. - bump release and rebuild
  574. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
  575. - make setting of experimental options only possible through
  576. /etc/sysconfig/authconfig, to keep accidents from happening
  577. - add some more support for experimental stuff
  578. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
  579. - fix setting of LDAP TLS option in authconfig-gtk
  580. - change Apply to Ok, Close to Cancel, because that's how they work
  581. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
  582. - add the glade XML file to the -gtk subpackage (fix from katzj)
  583. * Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
  584. - port to glib2
  585. - move post code to the back-end
  586. - add a libglade GUI in a -gtk subpackage
  587. - set up to use userhelper