xorg-x11-drv-intel-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate1 20130611
  4. %define gputoolsdate2 20110817
  5. %if "%{?_dist_release}" >= "vl7"
  6. %define accel sna
  7. %define gputoolsdate 20130611
  8. %else
  9. %define accel sna
  10. %define gputoolsdate 20110817
  11. %endif
  12. Summary: Xorg X11 Intel video driver
  13. Summary(ja): Xorg X11 Intel ビデオドライバ
  14. Name: xorg-x11-drv-intel
  15. Epoch: 1
  16. Version: 2.99.916
  17. Release: 1%{?_dist_release}
  18. URL: http://intellinuxgraphics.org/
  19. License: MIT
  20. Group: User Interface/X Hardware Support
  21. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  22. Source2: intel.xinf
  23. Source3: intel-gpu-tools-%{gputoolsdate1}.tar.bz2
  24. Source4: intel-gpu-tools-%{gputoolsdate2}.tar.bz2
  25. # vine patch
  26. ExclusiveArch: %{ix86} x86_64 ia64
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. BuildRequires: autoconf, automake, libtool
  29. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  30. BuildRequires: libXvMC-devel
  31. BuildRequires: libGL-devel >= 7.10
  32. BuildRequires: libdrm-devel >= 2.4.25
  33. BuildRequires: kernel-headers >= 2.6.33
  34. BuildRequires: eudev-libudev-devel
  35. BuildRequires: libxcb-devel >= 1.5
  36. BuildRequires: xcb-util-devel
  37. BuildRequires: cairo-devel
  38. Requires: hwdata
  39. Requires: xorg-x11-server-Xorg
  40. Requires: xcb-util
  41. Obsoletes: xorg-x11-drv-i810
  42. Provides: xorg-x11-drv-i810
  43. #Conflicts: kudzu < 1.2.42-1
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: daisuke
  47. %description
  48. X.Org X11 Intel video driver.
  49. %package devel
  50. Summary: Xorg X11 Intel video driver XvMC development package
  51. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  52. Group: Development/System
  53. Requires: %{name} = %{epoch}:%{version}-%{release}
  54. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  55. %description devel
  56. X.Org X11 Intel video driver XvMC development package.
  57. %package -n intel-gpu-tools
  58. Summary: Debugging tools for Intel graphics chips
  59. Group: Development/Tools
  60. %description -n intel-gpu-tools
  61. Debugging tools for Intel graphics chips
  62. %prep
  63. %setup -q -n xf86-video-intel-%{version} -b3 -b4
  64. %build
  65. autoreconf -vi
  66. %if "%{?_dist_release}" < "vl7"
  67. export CFLAGS="-I/usr/include/X11/dri"
  68. %endif
  69. %configure \
  70. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  71. --enable-dri --enable-xvmc \
  72. --enable-sna --enable-uxa \
  73. --with-default-accel=%{accel} \
  74. --enable-xaa=no
  75. make
  76. pushd ../intel-gpu-tools-%{gputoolsdate}
  77. autoreconf -v --install
  78. %configure --disable-nouveau --disable-dumper
  79. make
  80. popd
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  85. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  86. pushd ../intel-gpu-tools-%{gputoolsdate}
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. popd
  89. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %triggerpostun -- XOrg < 7.0
  93. if (grep -q i810 /etc/X11/xorg.conf)
  94. then
  95. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  96. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  97. fi ||:
  98. %files
  99. %defattr(-,root,root,-)
  100. %{driverdir}/intel_drv.so
  101. %{_datadir}/hwdata/videoaliases/intel.xinf
  102. %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
  103. %{_libdir}/libI810XvMC.so.*
  104. %{_libdir}/libIntelXvMC.so.*
  105. %{_libexecdir}/xf86-video-intel-backlight-helper
  106. %{_mandir}/man4/i*
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_libdir}/libI810XvMC.so
  110. %{_libdir}/libIntelXvMC.so
  111. %files -n intel-gpu-tools
  112. %defattr(-,root,root,-)
  113. %{_bindir}/*
  114. %{_mandir}/man1/intel_*.1*
  115. %changelog
  116. * Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
  117. - update to 2.99.916
  118. * Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
  119. - update to 2.99.912
  120. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
  121. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  122. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
  123. - rebuild with VineSeed environment
  124. * Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
  125. - new upstream release
  126. * Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
  127. - new upstream release
  128. - change default accel method to sna.
  129. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
  130. - new upstream release
  131. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
  132. - new upstream release
  133. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  134. - new upstream release
  135. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  136. - new upstream release
  137. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  138. - new upstream release
  139. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  140. - new upstream release
  141. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  142. - new upstream release
  143. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  144. - new upstream release
  145. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  146. - new upstream release
  147. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  148. - new upstream release
  149. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  150. - rebuild with xcb-util-0.3.9
  151. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  152. - disable sna, enable uxa
  153. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  154. - new upstream release
  155. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  156. - rebuild with xserver-1.12.0
  157. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  158. - new upstream release
  159. - enable sna
  160. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  161. - disable sna/vmap
  162. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  163. - new upstram release
  164. - disable copy-fb patch
  165. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  166. - rebuild with xserver-1.11.1.902
  167. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  168. - add --enable-sna --enable-vmap
  169. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  170. - new upstream release
  171. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  172. - rebuild with xcb-util-0.3.8
  173. - drop Patch200
  174. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  175. - update to disable copy_fb on sandybridge/ivybridge
  176. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  177. - update intel.xinf
  178. - add patch10 from fedora
  179. - Clamp VGA pixel clock to 250MHz,
  180. anything higher's going to look awful anyway. (#559426)
  181. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  182. - drop patch1-3 and replaced with new patch1 from git master
  183. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  184. - update intel-gpu-tools
  185. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  186. - add Patch1-3 from upstream
  187. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  188. - new upstream release
  189. - drop upstream patches: 107-115
  190. - temporary disabled patch101
  191. - BR: libdrm >= 2.4.25
  192. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  193. - add Patch101-115 from ubuntu/debian package
  194. - Patch101: Plymouth integration patch
  195. - Patch107: Check null return from uxa_acquire_solid()
  196. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  197. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  198. - Patch110,114: Cherry picks to fix a large number of build warnings.
  199. - Patch111: Fix clipped window plane offset
  200. - Patch112: Fix issue where vertical green line and strange colors
  201. shows up when playing gstreamer with certain videos,
  202. when dragged. (LP 460677)
  203. - Patch113: Fixes GPU lockup during login with
  204. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  205. error messages listed in the gpu dump text. (LP 710321)
  206. - Patch115: Don't fill up Xorg.0.log with
  207. "get vblank counter failed: Invalid argument" warnings.
  208. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  209. - rebuild with xserver-1.10.0
  210. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  211. - new upstream release
  212. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  213. - new upstream release
  214. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  215. - rebuild with xserver-1.9.2
  216. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  217. - new upstream release
  218. - add Patch40: fix uxa planemask (backported)
  219. - add Patch61: add support for backlight on macbooks
  220. - add Patch62: disable page flipping for stability
  221. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  222. - new upstream release
  223. - drop patch70
  224. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  225. - rebuild again with xserver-1.8rc
  226. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  227. - add intel-gpu-tools as sub-package
  228. - rebuild with libdrm-2.4.18
  229. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  230. - new upstream release
  231. - import Patch1,2,60,70 from fedora
  232. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  233. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  234. - add BR; libudev-devel and autoreconf for Patch60
  235. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  236. - rebuild with libdrm-2.4.17
  237. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  238. - new upstream release
  239. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  240. - new upstream release (hopefully fixes severe issues w/ efifb)
  241. - drop all patches already upstreamed; import Patch20/21 from Fedora
  242. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  243. - import Patch121,122 from ubuntu
  244. - build with libdrm-2.4.12 which fixes vt switch crash
  245. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  246. - apply patch114 to fix Xv with non-GEM kernel
  247. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  248. - update to 2.6.3
  249. - add patch106,107,115,118,119,120 from ubuntu
  250. - add Patch106: remove triple buffering
  251. - add Patch107: remove page flipping
  252. - add Patch115: fix crash Xv overlay
  253. - add Patch118: drop legacy3d
  254. - add Patch119: fix crashes in drm bo
  255. - add Patch120: fix vt switch
  256. - add patch130-134 from upstream git
  257. - add Patch130: fix another vt switch leak
  258. - add Patch131: Create known output configuration at EnterVT time
  259. - add Patch132: fix leak of some 965 render state on VT switch
  260. - add Patch133: fix crash with fake bufmgr and UXA
  261. - add Patch134: fix EnterVT/LeaveVT
  262. - add Patch135: add new chip supoprt
  263. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  264. - revert to 2.6.1, add Epoch
  265. - add Patch103-121 from ubuntu
  266. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  267. - new upstream release
  268. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  269. - new upstream release
  270. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  271. - new upstream release
  272. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  273. - add Patch5 - Dont die on irq handler failure
  274. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  275. - new upstream release
  276. - add BR: libdrm-devel >= 2.4.0-3
  277. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  278. - import Patch10,11,12 from ubuntu
  279. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  280. - new upstream release
  281. - add triggerpostun script to replace i810 driver to intel driver
  282. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  283. - new upstream release
  284. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  285. - new upstream release
  286. - rename i810.xinf to intel.xinf
  287. - update intel.xinf (add Intel 4 series)
  288. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  289. - rebuild with new xserver
  290. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  291. - new upstream release
  292. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  293. - new upstream release
  294. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  295. - new upstream release
  296. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  297. - initial build for Vine Linux
  298. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  299. - Rebuild for new server ABI.
  300. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  301. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  302. - hook up ch7017 (bz#408471)
  303. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  304. - xf86-video-intel 2.2.0
  305. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  306. - xf86-video-intel 2.1.99.
  307. - Drop the i810 driver. Time to move on.
  308. - Require xserver 1.4.99.1
  309. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  310. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  311. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  312. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  313. for textured Xv to use as an offscreen pixmap so xv actually works under
  314. compiz - granted it may be unusably slow but at least stuff shows up.
  315. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  316. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  317. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  318. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  319. - intel-2.1.1-quirk-update.patch - update quirks from master
  320. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  321. - i810.xinf: Flip everything over to -intel by default now. Still install
  322. i810 driver just in case.
  323. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  324. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  325. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  326. - xf86-video-intel 2.1.1.
  327. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  328. - xf86-video-intel 2.1.0.
  329. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  330. - Update Requires and BuildRequires.
  331. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  332. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  333. 965GME, G33, Q33, and Q35 chips.
  334. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  335. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  336. DRI clients are active, for better battery life.
  337. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  338. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  339. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  340. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  341. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  342. rename this at some point.
  343. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  344. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  345. 915GM.
  346. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  347. - i810.xinf: More intel whitelisting (#214011, #234877)
  348. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  349. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  350. - i810.xinf: Point 965GM support at the intel driver since it's not present
  351. in old i810.
  352. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  353. - xf86-video-intel-1.9.93 (RC3).
  354. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  355. - fix typo with 945GM pci id from my laptop
  356. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  357. - xf86-video-intel 1.9.92 (RC2).
  358. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  359. - Updated modesetting driver to one that will actually work with a 1.3 server.
  360. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  361. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  362. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  363. code anywhere
  364. - Disown the module
  365. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  366. - update modesetting driver to git snapshot from today
  367. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  368. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  369. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  370. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  371. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  372. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  373. actually require kudzu to run.
  374. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  375. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  376. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  377. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  378. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  379. driver match the corresponding terrible heuristic in the server.
  380. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  381. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  382. correctly distinguish between Mac Mini and Macbook Pro.
  383. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  384. - i810.xinf: PCI IDs for i965.
  385. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  386. - i810.xinf: Uppercase PCI IDs.
  387. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  388. - Update i810 to 1.6.5, should fix DRI.
  389. - Add kuzdu requires.
  390. - i810.xinf: Start whitelisting devices over to intel.
  391. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  392. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  393. you know, load.
  394. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  395. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  396. LFP special casing in favor of the blacklist.
  397. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  398. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  399. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  400. and is selected with Driver "intel" in xorg.conf. Individual devices will
  401. whitelist over to "intel" until that branch gets merged into head.
  402. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  403. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  404. the BIOS is known to lie.
  405. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  406. - Today's snapshot: I2C bus creation fix.
  407. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  408. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  409. clock when computing the modes list.
  410. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  411. in centimeters as the size of the display in pixels.
  412. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  413. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  414. probing.
  415. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  416. - Update again for a mode comparison bugfix.
  417. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  418. - Update to today's git; crash fixes, better pre-915 support, slightly better
  419. autoconfigurability.
  420. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  421. - rebuild
  422. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  423. - Fix Revision number to match naming policy.
  424. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  425. - Add back modesetting changes.
  426. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  427. - Roll back modesetting changes and build for fc5 aiglx repo.
  428. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  429. - Snapshot of the git modesetting branch.
  430. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  431. - Update i810.xinf to include entries for E7221 and 945GM.
  432. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  433. - Add with_dri macro to spec file, and conditionalize build time DRI support
  434. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  435. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  436. to pick up proto-devel as well.
  437. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  438. - Rebuild for 7.1 ABI fix.
  439. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  440. - Bump for fc5-bling build.
  441. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  442. - Update to 1.6.0 from 7.1RC1.
  443. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  444. - Add patch to add missing #include's, specifically assert.h.
  445. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  446. - Update to CVS snapshot of 20060322.
  447. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  448. - rebuilt for new gcc4.1 snapshot and glibc changes
  449. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  450. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  451. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  452. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  453. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  454. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  455. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  456. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  457. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  458. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  459. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  460. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  461. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  462. - Fix *.la file removal.
  463. - Added 'devel' subpackage for XvMC .so
  464. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  465. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  466. - Update BuildRoot to use Fedora Packaging Guidelines.
  467. - Deglob file manifest.
  468. - Limit "ExclusiveArch" to x86, x86_64, ia64
  469. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  470. - Initial spec file for i810 video driver generated automatically
  471. by my xorg-driverspecgen script.