texlive-collection-documentation-japanese-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-documentation-japanese
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Japanese documentation
  22. Summary(ja): TeX Live: Japanese documentation
  23. Name: texlive-collection-documentation-japanese
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: GPL+
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires(post): texlive = %{version}
  31. Requires(postun): texlive = %{version}
  32. BuildRequires: texlive-sources = %{version}
  33. BuildArch: noarch
  34. Buildroot: %{_tmppath}/%{name}-%{version}-root
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: munepi
  38. %description
  39. The TeX Live software distribution offers a complete TeX system for a
  40. variety of Unix, Macintosh, Windows and other platforms. It
  41. encompasses programs for editing, typesetting, previewing and printing
  42. of TeX documents in many different languages, and a large collection
  43. of TeX macros and font libraries.
  44. The distribution includes extensive general documentation about TeX,
  45. as well as the documentation for the included software packages.
  46. This package is a collection of Japanese documentation:
  47. This package contains the following CTAN packages:
  48. lshort-japanese: Japanese version of A Short Introduction to LaTeX2e
  49. %description -l ja
  50. TeX Live ソフトウェアディストリビューションは、
  51. さまざまな Unix, Macintosh, Windows、および
  52. 他のプラットホームに対して完全な TeX システムを提供します。
  53. 多くの異なった言語を含む TeX ドキュメントの
  54. 編集、組版、閲覧、印刷するためのプログラム、
  55. そして、TeX マクロやフォントライブラリの大きなコレクションを
  56. 同梱しています。
  57. このディストリビューションは
  58. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  59. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  60. このパッケージは以下のようなパッケージ集です。
  61. Japanese documentation:
  62. このパッケージは以下の CTAN パッケージを含んでいます:
  63. lshort-japanese: Japanese version of A Short Introduction to LaTeX2e
  64. %prep
  65. %build
  66. %install
  67. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  68. PREF=%{buildroot}%{tex_destdir}
  69. manifest=(
  70. texmf-dist/doc/latex/lshort-japanese/00README
  71. texmf-dist/doc/latex/lshort-japanese/CHANGES.jp
  72. texmf-dist/doc/latex/lshort-japanese/READ.ME
  73. texmf-dist/doc/latex/lshort-japanese/jlshort-1.00.src.tar.gz
  74. texmf-dist/doc/latex/lshort-japanese/jlshort.pdf
  75. )
  76. %__mkdir_p ${PREF}/texmf-dist
  77. for i in "${manifest[@]}"; do
  78. %__install -D %{texlive_src}/$i ${PREF}/$i
  79. done
  80. ## info
  81. %__rm -f %{buildroot}%{_infodir}/dir
  82. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  83. ## man
  84. ## man t1* files are provided by t1utils
  85. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  86. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  87. done
  88. ## man some files are provided by psutils
  89. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  90. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  91. done
  92. ## fix perl path
  93. for i in source/metapost/expressg/expressg.dtx \
  94. doc/metapost/expressg/n2mpsprl.prl \
  95. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  96. [ -f %{build_texmf}-dist/${i} ] && \
  97. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  98. done
  99. ## remove asymptote directries, which provides asymptote package
  100. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  101. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  102. # ## remove xindy
  103. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  104. # ## remove tex4ht
  105. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  106. ## remove arch dependent binaries
  107. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  108. ## remove unpackaging files
  109. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  110. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  111. ## Files list
  112. find %{buildroot} -type f -or -type l | \
  113. %__sed -e "s|%{buildroot}||g" > filelist.full
  114. find %{buildroot}%{texmf}-dist -type d | \
  115. %__sed -e "s|^%{buildroot}|%dir |" \
  116. -e "s|$|/|" >> filelist.full
  117. %clean
  118. %__rm -rf %{buildroot}
  119. %post
  120. %{exec_texhash}
  121. exit 0
  122. %postun
  123. if [ "$1" = 0 ]; then
  124. %{exec_texhash}
  125. fi
  126. exit 0
  127. %files -f filelist.full
  128. %defattr(-,root,root)
  129. %changelog
  130. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  131. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-japanese
  132. - improved %%post
  133. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  134. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-japanese
  135. - removed arch dependent binaries (texlive-collection-latexextra)
  136. - fixed perl path
  137. - improved updmap process in %%post and %%postun
  138. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  139. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-japanese