libtool-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define gcc_version 13.2.1
  3. Summary: The GNU Portable Library Tool
  4. Summary(ja): GNU ポータブルライブラリツール
  5. Name: libtool
  6. Version: 2.4.7
  7. Release: 2%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2+ and LGPLv2+ and GFDL
  12. URL: http://www.gnu.org/software/libtool/
  13. Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
  14. # ~> downstream
  15. # ~> remove possibly once #1158915 gets fixed somehow
  16. Patch0: libtool-2.4.5-rpath.patch
  17. # See the rhbz#1289759 and rhbz#1214506. We disable hardening namely because
  18. # that bakes the CFLAGS/LDFLAGS into installed /bin/libtool and ltmain.sh files.
  19. # At the same time we want to have libltdl.so hardened. Downstream-only patch.
  20. %undefine _hardened_build
  21. Patch1: libtool-2.4.6-hardening.patch
  22. # The testsuite seems to not properly handle template instantiation and as
  23. # a result fails. libtool itself appears to be OK from my by-hand testing. (by Jeff Law)
  24. # Disable LTO for link-order2 test (Related: #1988112)
  25. Patch2: libtool-2.4.6-disable-lto-link-order2.patch
  26. # non-PIC libraries are not supported on ARMv7
  27. # Since we removed "-fPIC" from global CFLAGS this test fails on this arch (as expected)
  28. # Please refer to the following ticket regarding PIC support on ARM:
  29. # https://bugs.launchpad.net/ubuntu/+source/gcc-4.4/+bug/503448
  30. Patch3: libtool-2.4.6-disable_non-pic_arm.patch
  31. # rhbz#2047389, patch sent upstream
  32. # https://lists.gnu.org/archive/html/libtool-patches/2022-02/msg00000.html
  33. Patch4: libtool-2.4.6-keep-compiler-deps.patch
  34. # Patch sent upstream
  35. # https://lists.gnu.org/archive/html/libtool-patches/2022-12/msg00004.html
  36. Patch5: 0001-tests-Fix-grep-warning-about-stray-before.patch
  37. Patch101: libtool-c99.patch
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
  40. Requires: autoconf >= 2.58, automake >= 1.4
  41. # make sure we can configure all supported langs
  42. BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
  43. #BuildRequires: gcc-java
  44. # /usr/bin/libtool includes paths within gcc's versioned directories
  45. # Libtool must be rebuilt whenever a new upstream gcc is built
  46. Requires: gcc = %{gcc_version}
  47. Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
  48. Requires: libtool-ltdl = %{version}-%{release}, mktemp
  49. %description
  50. GNU Libtool is a set of shell scripts which automatically configure UNIX and
  51. UNIX-like systems to generically build shared libraries. Libtool provides a
  52. consistent, portable interface which simplifies the process of using shared
  53. libraries.
  54. If you are developing programs which will use shared libraries, but do not use
  55. the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
  56. should install the libtool package.
  57. The libtool package also includes all files needed to integrate the GNU
  58. Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
  59. (ltdl) into a package built using the GNU Autotools (including GNU Autoconf
  60. and GNU Automake).
  61. This package includes a modification from the original GNU Libtool to allow
  62. support for multi-architecture systems, such as the AMD64 Opteron and the Intel
  63. 64-bit Xeon.
  64. %description -l ja
  65. GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
  66. にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
  67. 共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
  68. スを提供します。
  69. もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
  70. ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
  71. する必要があります。
  72. このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
  73. システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
  74. %package ltdl
  75. Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
  76. Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
  77. Group: system
  78. Provides: libtool-libs = %{version}-%{release}
  79. Obsoletes: libtool-libs < 1.5.20
  80. License: LGPL
  81. %description ltdl
  82. The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
  83. library that provides a consistent, portable interface which simplifies the
  84. process of using dynamic modules.
  85. These runtime libraries are needed by programs that link directly to the
  86. system-installed ltdl libraries; they are not needed by software built using the
  87. rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
  88. %description -l ja ltdl
  89. libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
  90. ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
  91. 利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
  92. %package ltdl-devel
  93. Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
  94. Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
  95. Group: programming
  96. Requires: libtool-ltdl = %{version}-%{release}
  97. License: LGPL
  98. %description ltdl-devel
  99. Static libraries and header files for development with ltdl.
  100. %description -l ja ltdl-devel
  101. ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
  102. ## to build compat32 for x86_64 architecture support
  103. %package -n compat32-%{name}-ltdl
  104. Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
  105. Group: system
  106. %description -n compat32-%{name}-ltdl
  107. The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
  108. library that provides a consistent, portable interface which simplifies the
  109. process of using dynamic modules.
  110. %package -n compat32-%{name}-ltdl-devel
  111. Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
  112. Group: programming
  113. Requires: compat32-%{name}-ltdl = %{version}-%{release}
  114. %description -n compat32-%{name}-ltdl-devel
  115. Static libraries and header files for development with ltdl.
  116. %debug_package
  117. %prep
  118. %autosetup -p1
  119. autoreconf -v
  120. %build
  121. %configure
  122. %make_build \
  123. CUSTOM_LTDL_CFLAGS="%{?_hardening_cflags}" \
  124. CUSTOM_LTDL_LDFLAGS="%{?_hardening_ldflags}"
  125. #check
  126. #make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
  127. %install
  128. rm -rf %{buildroot}
  129. make install DESTDIR=$RPM_BUILD_ROOT
  130. rm -f %{buildroot}%{_infodir}/dir
  131. rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
  132. %clean
  133. rm -rf %{buildroot}
  134. %files
  135. %defattr(-,root,root)
  136. %license COPYING
  137. %doc AUTHORS NEWS README THANKS TODO ChangeLog
  138. %{_bindir}/libtool
  139. %{_bindir}/libtoolize
  140. %{_datadir}/aclocal/*.m4
  141. %{_datadir}/libtool
  142. %{_infodir}/libtool.info*.gz
  143. %{_mandir}/man1/libtool.1.gz
  144. %{_mandir}/man1/libtoolize.1.gz
  145. %files ltdl
  146. %defattr(-,root,root)
  147. %license libltdl/COPYING.LIB
  148. %doc libltdl/README
  149. %{_libdir}/libltdl.so.*
  150. %files ltdl-devel
  151. %defattr(-,root,root)
  152. %{_libdir}/libltdl.so
  153. %{_includedir}/ltdl.h
  154. %{_includedir}/libltdl/*
  155. %if %{build_compat32}
  156. ## to build compat32 for x86_64 architecture support
  157. %files -n compat32-%{name}-ltdl
  158. %defattr(-,root,root)
  159. %{_libdir}/libltdl.so.*
  160. %files -n compat32-%{name}-ltdl-devel
  161. %defattr(-,root,root)
  162. %{_libdir}/libltdl.so
  163. %endif
  164. %changelog
  165. * Fri Sep 22 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-2
  166. - rebuilt with gcc-13.2.1.
  167. * Sat Sep 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
  168. - new upstream release.
  169. - dropped install-info scriptltes.
  170. * Thu Aug 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-9
  171. - rebuilt with gcc-11.2.1.
  172. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-8
  173. - rebuilt with gcc-10.3.1.
  174. - dropped ldconfig scriptltes.
  175. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-7
  176. - rebuilt with gcc-10.2.1.
  177. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-6
  178. - rebuilt with gcc-9.3.1.
  179. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-5
  180. - rebuilt with gcc-8.3.1.
  181. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-4
  182. - imported Patch1-4 from rawhide.
  183. * Mon Jan 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-3
  184. - rebuilt with gcc-8.2.0.
  185. * Sun Jun 26 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
  186. - rebuild with gcc-5.4.0
  187. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
  188. - new upstream release
  189. - update Patch0 (libtool-2.4.6-rpath.patch)
  190. * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
  191. - rebuild with gcc-4.8.2-1
  192. * Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
  193. - rebuild with gcc-4.8.1-2
  194. * Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
  195. - rebuild with gcc-4.8.1
  196. - add BuildRequires: help2man
  197. * Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
  198. - new upstream release
  199. * Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
  200. - rebuilt with gcc-4.6.2
  201. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
  202. - new upstream release
  203. - update Patch0
  204. * Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
  205. - rebuilt with gcc-4.4.5
  206. * Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
  207. - new upstream release
  208. * Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
  209. - rebuilt with gcc-4.4.3-1 (w/o gcc-java)
  210. * Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
  211. - remove comment before compat32 scriptlet to avoid scriptlet failure.
  212. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
  213. - removed %%if !%%{build_compat32} case condition
  214. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
  215. - update to 2.2.6a
  216. - remove libltdl static library
  217. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
  218. - updated to 1.5.26, importing changes from Fedora 1.5.26-2
  219. - new versioning policy; spec in UTF-8
  220. - define gcc_version to 4.1.2 for Vine
  221. * Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
  222. - rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
  223. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
  224. - remove BuildRequires: libstdc++3-devel
  225. - add Requres: libtool-ltdl instead of libtool-libs
  226. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
  227. - rebuilt with gcc4 (F77=gfortran now)
  228. - import Patch2 and Patch3 from FC6 1.5.22-6.1
  229. - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
  230. - detect gcc path at runtime instead of requiring one specific version
  231. - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
  232. - miscellaneous upstream fixes
  233. * Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
  234. - new upstream release
  235. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
  236. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  237. - changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
  238. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
  239. - added compat32-* packages for x86_64 architecture support
  240. * Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
  241. - add Japanese Summaries and descriptions
  242. * Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
  243. - new upstream release
  244. * Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
  245. - updated to 1.5.18 based on Fedora package
  246. * Sun Feb 6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
  247. - update to the 1.5.12 bugfix release
  248. - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
  249. - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
  250. - Interpret `include' statements in toplevel ld.so.conf file.
  251. - While "parsing" /etc/ld.so.conf, skip comments.
  252. - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
  253. gcc's internal directories
  254. - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
  255. * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
  256. - update to the 1.5.10 bugfix release
  257. - obsoletes libtool-1.4-nonneg.patch
  258. - obsoletes libtool-1.5-libtool.m4-x86_64.patch
  259. - obsoletes libtool-1.4.2-multilib.patch
  260. - obsoletes libtool-1.4.2-demo.patch
  261. - obsoletes libtool-1.5-testfailure.patch
  262. * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
  263. - compile libltdl.a PIC
  264. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
  265. - rebuild with gcc-3.3.5
  266. * Sun May 2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
  267. - new upstream release
  268. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
  269. - merged with fedora-1.5.2-2
  270. * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
  271. - update to 1.5.2 bugfix release
  272. - update libtool-1.5-libtool.m4-x86_64.patch
  273. - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
  274. libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
  275. libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
  276. * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
  277. - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
  278. [Joe Orton]
  279. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
  280. - merged with rawhide 1.5-5
  281. * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
  282. - based on 1.4.3-2 from Rawhide and built for Vine Linux
  283. - added BuildPreReq: automake14
  284. * Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
  285. - bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
  286. and s390x again
  287. * Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
  288. - Fix misapplied chunk for expsym-linux patch
  289. * Tue Jul 8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
  290. - remove the quotes around LD in AC_PROG_LD_GNU (#97608)
  291. [reported by twaugh]
  292. - use -nostdlib also when linking with g++ and non-GNU ld in
  293. _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
  294. - use %%configure with CC and CXX set
  295. * Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
  296. - don't use %%configure since target options caused libtool to assume
  297. i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
  298. - add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
  299. searched when relinking (#91110) [patch from Joe Orton]
  300. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  301. - rebuilt
  302. * Thu May 1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
  303. - update to 1.5
  304. - no longer override config.{guess,sub} for rpmbuild %%configure,
  305. redhat-rpm-config owns those now
  306. - update and rename libtool-1.4.2-s390_x86_64.patch to
  307. libtool-1.5-libtool.m4-x86_64.patch since s390 now included
  308. - buildrequire autoconf and automake, no longer automake14
  309. - skip make check on s390 temporarily
  310. - no longer skip demo-nopic.test on x86_64, s390 and s390x
  311. - from Owen Taylor
  312. - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
  313. - add quoting in mktemp patch
  314. - add libtool-1.5-readonlysym.patch
  315. - add libtool-1.5-testfailure.patch workaround
  316. - relink patch no longer needed
  317. * Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
  318. - add config.guess and config.sub, otherwise old versions of
  319. these files can creep into /usr/share/libtool/
  320. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  321. - rebuilt
  322. * Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
  323. - fix mktemp to work when running mktemp fails (#76602)
  324. [reported by (Oron Peled)]
  325. - remove info dir file, don't exclude it
  326. - fix typo in -libs description (#79619)
  327. - use buildroot instead of RPM_BUILD_ROOT
  328. * Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
  329. - use lib64 on s390x, too.
  330. * Thu Dec 5 2002 Jens Petersen <petersen@redhat.com>
  331. - add comment to explain why we use an old Automake for building
  332. - buildrequire automake14
  333. * Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
  334. - add --without check build option to allow disabling of "make check"
  335. - exclude info dir file rather than removing
  336. * Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
  337. - define SED in ltmain.sh for historic ltconfig files
  338. - define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
  339. - leave old missing file for now
  340. - general spec file cleanup
  341. - don't copy install files to demo nor mess with installed ltdl files
  342. - don't need to run make in doc
  343. - force removal of info dir file
  344. - don't need to create install prefix dir
  345. - don't bother gzipping info files ourselves
  346. * Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
  347. - update to 1.4.3
  348. - remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
  349. - apply the multilib patch to just the original config files
  350. - update x86_64/s390 patch and just apply to original config files
  351. - use automake-1.4 in "make check" for demo-make.test to pass!
  352. - remove info dir file that is not installed
  353. - make autoreconf update missing
  354. * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 1.4.2-12.2
  355. - Added s390x and x64_64 support.
  356. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
  357. - rebuild
  358. * Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
  359. - patch to find the proper libdir on multilib boxes
  360. * Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
  361. - don't include demo in doc, specially now that we "make check" (#71609)
  362. * Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
  363. - don't hardcode "configure.in" in libtoolize (#70864)
  364. [reported by bastiaan@webcriminals.com]
  365. - make check, but not on ia64
  366. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
  367. - automated rebuild
  368. * Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
  369. - automated rebuild
  370. * Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
  371. - add old patch from aoliva to fix relinking when installing into a buildroot
  372. - backport dup-deps fix from cvs stable branch
  373. * Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
  374. - run ldconfig in postin and postun
  375. * Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
  376. - rebuild in new environment
  377. * Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
  378. - revert filemagic and archive-shared patches following cvs (#54887)
  379. - don't change "&& test" to "-a" in ltmain.in
  380. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
  381. - automated rebuild
  382. * Mon Dec 3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
  383. - test quoting patch should be on ltmain.in not ltmain.sh (#53276)
  384. - use file_magic for Linux ELF (#54887)
  385. - allow link against an archive when building a shared library (#54887)
  386. - include ltdl.m4 in manifest (#56671)
  387. * Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
  388. - added URL to spec
  389. * Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
  390. - 1.4.2 - sync up with autoconf...
  391. * Thu Jul 5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
  392. - extend s390 patch to 2 more files
  393. - s/Copyright/License/
  394. * Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
  395. - add s390 patch for deplibs_check_method=pass_all
  396. * Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  397. - add patches from Tim Waugh #42724
  398. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  399. - add patches from cvs mainline
  400. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  401. - fix a "test" bug in ltmain.sh
  402. * Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  403. - disable the post commands to modify /usr/share/doc/
  404. * Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
  405. - Require automake 1.4p1
  406. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  407. - update to libtool 1.4
  408. - adjust or remove patches
  409. * Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
  410. - Fix recognition of ^0[0-9]+$ as a non-negative integer.
  411. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  412. - automatic rebuild
  413. * Fri Jul 7 2000 Nalin Dahyabhai <nalin@redhat.com>
  414. - patch to use mktemp to create the tempdir
  415. - use %%configure after defining __libtoolize to /bin/true
  416. * Mon Jul 3 2000 Matt Wilson <msw@redhat.com>
  417. - subpackage libltdl into libtool-libs
  418. * Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
  419. - running libtoolize on the libtool source tree ain't right :)
  420. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  421. - FHS packaging.
  422. * Thu Jun 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  423. - update to 1.3.5.
  424. * Fri Mar 3 2000 Jeff Johnson <jbj@redhat.com>
  425. - add prereqs for m4 and perl inorder to run autoconf/automake.
  426. * Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
  427. - functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
  428. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  429. - update to 1.3.4.
  430. * Mon Dec 6 1999 Jeff Johnson <jbj@redhat.com>
  431. - change from noarch to per-arch in order to package libltdl.a (#7493).
  432. * Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
  433. - update to 1.3.3.
  434. * Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
  435. - update to 1.3.2.
  436. * Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
  437. - explicitly disable per-arch libraries (#2210)
  438. - undo hard links and remove zero length file (#2689)
  439. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  440. - update to 1.3.
  441. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  442. - disable the --cache-file passing to ltconfig; this breaks the older
  443. ltconfig scripts found around.
  444. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  445. - auto rebuild in the new build environment (release 2)
  446. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  447. - update to 1.2f
  448. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  449. - completed arm patch
  450. - added patch to make it more arm-friendly
  451. - upgrade to version 1.2d
  452. * Thu May 07 1998 Donnie Barnes <djb@redhat.com>
  453. - fixed busted group
  454. * Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
  455. - Update to 1.0h
  456. - added install-info support
  457. * Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
  458. - Update to 1.0f
  459. - BuildRoot it
  460. - Make it a noarch package