minitube-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. # Qt4 version auto-detection -- inagaki
  2. %define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.1)
  3. %define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
  4. # Move original binary to libexec dir and replace it by wrapper script
  5. %define MINITUBE_BIN %{_libexecdir}/%{name}
  6. Summary: Native YouTube Client
  7. Summary(ja): YouTube 専用クライアント
  8. Name: minitube
  9. Version: 1.6
  10. Release: 1%{?_dist_release}
  11. Source0: http://flavio.tordini.org/files/minitube/minitube.tar.gz
  12. Source10: minitube.sh
  13. Source20: minitube-ja.desktop
  14. License: GPLv3+
  15. Group: Applications/Multimedia
  16. URL: http://flavio.tordini.org/minitube
  17. Requires: phonon-backend-gstreamer
  18. Requires(post): desktop-file-utils
  19. Requires(postun):desktop-file-utils
  20. BuildRequires: qt4-devel > 4.5
  21. BuildRequires: qt4-designer
  22. BuildRequires: phonon-devel
  23. BuildRequires: python-devel
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Minitube is a native YouTube client. With it you can watch
  29. YouTube videos in a new way: you type a keyword, Minitube
  30. gives you an endless video stream. Minitube does not require
  31. the Flash Player.
  32. Minitube is not about cloning the original YouTube web interface,
  33. it aims to create a new TV-like experience.
  34. You should install following packages to play videos.
  35. - self-build-gstreamer-plugins-bad
  36. - self-build-gstreamer-plugins-ffmpeg
  37. %description -l ja
  38. Minitube は YouTube の新しい視聴方法を提案する、専用のクライ
  39. アントソフトウェアです。キーワードを入力すると、Minitube は
  40. 関連する動画をエンドレスで再生します。
  41. また Minitube を使うと Flash Player 無しでビデオが再生できます。
  42. Minitube は YouTube のウェブインターフェースのクローンでは無
  43. く、新たなテレビ風の視聴スタイルを目指しています。
  44. ビデオの再生には以下のパッケージが必要となります。併せてイン
  45. ストールしてください。
  46. - self-build-gstreamer-plugins-bad
  47. - self-build-gstreamer-plugins-ffmpeg
  48. %prep
  49. %setup -q -n %{name}
  50. %build
  51. %{qt4qmake} prefix=%{_prefix}
  52. %{__make} %{?_smp_mflags}
  53. %install
  54. %{__rm} -rf $RPM_BUILD_ROOT
  55. %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
  56. ## wrapper
  57. %{__mkdir_p} $RPM_BUILD_ROOT%{_libexecdir}
  58. %{__mv} $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{MINITUBE_BIN}
  59. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  60. # desktop file with japanese messages
  61. %{__install} -m 644 %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  62. %clean
  63. %{__rm} -rf $RPM_BUILD_ROOT
  64. %post
  65. update-desktop-database %{_datadir}/applications>& /dev/null ||:
  66. touch --no-create %{_datadir}/icons/hicolor
  67. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  68. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  69. fi
  70. %postun
  71. update-desktop-database %{_datadir}/applications>& /dev/null ||:
  72. touch --no-create %{_datadir}/icons/hicolor
  73. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  74. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  75. fi
  76. %files
  77. %defattr(-,root,root)
  78. %doc AUTHORS COPYING CHANGES INSTALL TODO
  79. %{MINITUBE_BIN}
  80. %{_bindir}/%{name}
  81. %{_datadir}/applications/%{name}.desktop
  82. %{_datadir}/icons/hicolor
  83. %{_datadir}/%{name}/locale
  84. %changelog
  85. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
  86. - new upstream release
  87. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-1
  88. - new upstream release
  89. * Wed May 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  90. - new upstream release
  91. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-1
  92. - new upstream release
  93. * Fri Jul 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.1-1
  94. - new upstream release
  95. * Sat May 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.0-1
  96. - initial build for Vine Linux
  97. - add minitube.desktop with japanese translation
  98. - add wrapper script to check necessary packages at runtime