123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437 |
- Summary: A Full-Featured IDE for Mono and Gtk#
- Summary(ja): Gtk# 版 Mono 統合開発環境
- Name: monodevelop
- Version: 5.9
- Release: 1%{?_dist_release}
- License: LGPLv2.1 and MIT
- Group: Applications/Development
- URL: http://www.monodevelop.org/
- Source0: http://download.mono-project.com/sources/%{name}/%{name}-%{version}.0.431.tar.bz2
- Patch0: downgrade_to_mvc3.patch
- # Vine patch(es)
- Patch70: monodevelop-5.9-exec.patch
- BuildArch: noarch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: gconf-sharp2-devel
- BuildRequires: gnome-sharp2-devel
- BuildRequires: gnome-vfs-sharp2-devel
- BuildRequires: gtk-sharp2-devel
- BuildRequires: gtksourceview-sharp2-devel
- BuildRequires: libgnomeui-devel
- BuildRequires: mono-addins-devel
- BuildRequires: mono-data
- BuildRequires: mono-devel
- BuildRequires: mono-mvc-devel
- BuildRequires: mono-nuget-devel
- BuildRequires: mono-wcf-devel
- BuildRequires: monodoc
- BuildRequires: nunit-devel
- BuildRequires: intltool perl-XML-Parser shared-mime-info
- BuildRequires: dos2unix shared-mime-info desktop-file-utils
- BuildRequires: git
- # Mono.Cecil.dll requires rsync after it's build
- BuildRequires: rsync
- Requires: mono-basic
- Requires: mono-web
- Requires: nunit
- Requires: xsp
- Requires: mono-devel
- Requires: mono-tools
- Requires: git
- Requires: pkgconfig
- Requires(post,postun): shared-mime-info
- %description
- MonoDevelop is a full-featured integrated development
- environment (IDE) for Mono and Gtk# primarily designed
- for C-Sharp and other .NET languages. It allows to quickly
- create desktop and ASP.NET Web applications. Support
- for Visual Studio file formats eases porting to Linux.
- %description -l ja
- MonoDevelop は主として C# やその他の .NET 言語向けの、mono 及び Gtk# の
- すべての機能を取り込んだ統合 IDE 環境です.デスクトップアプリケーション及び
- ASP.NET ウェブアプリケーションを迅速に作成することができます.Visual Studio
- 形式のファイルをサポートしており、Linux へのポーティングを簡易にします.
- %package devel
- Summary: Development files for MonoDevelop
- Summary(ja): MonoDevelop の開発用ファイル
- Group: Development/Libraries
- Requires: monodevelop = %{version}-%{release}
- %description devel
- This package contains development files for the IDE and plugins.
- %prep
- %setup -q
- %patch0 -p1
- %patch70 -p1
- %build
- export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
- %configure \
- --libdir=%{_prefix}/lib \
- --disable-update-mimedb \
- --disable-update-desktopdb
- #./configure \
- # --prefix=%{_prefix} \
- # --enable-subversion \
- # --enable-monoextensions \
- # --enable-aspnet \
- # --disable-update-mimedb \
- # --disable-update-desktopdb
- make
- %install
- rm -rf $RPM_BUILD_ROOT
- export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
- make install DESTDIR=$RPM_BUILD_ROOT \
- GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_prefix}/lib"
- mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
- mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
- cp -a %{_prefix}/lib/mono/nuget/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/
- cp -a %{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/
- ln -s %{_prefix}/lib/mono/nunit/nunit.core.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
- ln -s %{_prefix}/lib/mono/nunit/nunit.core.interfaces.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
- ln -s %{_prefix}/lib/mono/nunit/nunit.framework.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
- ln -s %{_prefix}/lib/mono/nunit/nunit.util.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
- rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/locale
- %find_lang %{name}
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- touch --no-create %{_datadir}/icons/hicolor || :
- %postun
- if [ $1 -eq 0 ] ; then
- touch --no-create %{_datadir}/icons/hicolor &>/dev/null
- gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
- update-desktop-database -q &> /dev/null
- update-mime-database %{_datadir}/mime &> /dev/null
- fi
- %posttrans
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- update-desktop-database -q &> /dev/null
- update-mime-database %{_datadir}/mime &> /dev/null
- %files -f %{name}.lang
- %defattr(-,root,root)
- %doc AUTHORS ChangeLog COPYING README
- %{_prefix}/bin/*
- %{_prefix}/lib/monodevelop
- %{_datadir}/applications/monodevelop.desktop
- %{_datadir}/mime/packages/monodevelop.xml
- %{_datadir}/icons/hicolor/*/apps/monodevelop.png
- %{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
- %{_mandir}/man1/mdtool.1.gz
- %{_mandir}/man1/monodevelop.1.gz
- %files devel
- %defattr(-,root,root)
- %{_datadir}/pkgconfig/monodevelop.pc
- %{_datadir}/pkgconfig/monodevelop-core-addins.pc
- %changelog
- * Tue May 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.9-1
- - new upstream release
- - added Patch0 from OpenSUSE
- - added Patch70 for launching monodevelop
- - split pkgconfig file into devel subpackage
- * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-2
- - rebuilt with mono-2.10.1-3
- * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
- - updated monodevelop to 2.4.2
- * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-2
- - rebuild with mono-addins-0.5
- * Thu Jun 17 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-1
- - updated monodevelop to 2.4
- - changed source url
- * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.2-1
- - updated monodevelop to 2.2.2
- * Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
- - updated monodevelop to 2.2
- - changed licencse to LGPL2.1
- * Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
- - added description in japanease
- * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
- - rebuilt with latest rpm to update mono-dependencies
- * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
- - changed Group to Applications/Development
- * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
- - updated monodevelop to 2.0
- * Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
- - updated monodevelop to 1.9.1
- - rebuilt with mono-2.0.1
- * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
- - initial build for VineSeed
- - applied vine versioning policy
- - added japanese summary
- - spec in utf-8
- * Wed Apr 9 2008 wberrier@suse.de
- - Remove vte-sharp2 from build requires. It's not needed,
- and that package doesn't exist anymore.
- * Wed Mar 26 2008 wberrier@suse.de
- - Update to 1.0
- - Bug fixes:
- - MD Crashes when you drag a menu inside its own submenu
- (bnc#363865)
- - Monodevelop and stetic destroy forms (bnc#362596)
- - Problem with subclassing any container widget (bnc#361650)
- - Version Control doesn't behave propertly (bnc#363858)
- - Comment and uncomment function (bnc#325469)
- - Create Package fails on projects with translations (bnc#362567)
- - Exception with null arguments or nonexistant paths when
- compiling/cleaning C project (bnc#361045)
- - MonoDevelop crashes when creating/opening C++ Console Project
- (bnc#359567)
- - Build Output autohide button missing (bnc#368436)
- - Have to hit esc twice to close the file/new file dialog
- (bnc#358361)
- - Changes in 0.19 (1.0 RC1)
- - Will use 2.0 runtime as default
- - Icons have been tango-ified
- - More than 85 bugs fixed
- * Mon Jan 14 2008 wberrier@suse.de
- - Fixed .desktop file to adhear to standards
- - Fix naming of Slovenian translation
- - Update to 0.18
- - packaging split (database, boo, and java in separate packages)
- - Improved Dock Manager
- - Circa 75 bugfixes
- - Update to 0.17
- - Deployment of ASP.NET projects
- - Support for VS 2005 Web Application projects
- - ASP.NET Codebehind Generation Improvements
- - Generation of Satellite Assemblies
- - Makefile generation improvements
- - Various other IDE enhancements
- - Circa 90 bugfixes
- * Wed Oct 10 2007 wberrier@suse.de
- - Don't use fdupes afterall (fails build)
- * Tue Oct 9 2007 wberrier@suse.de
- - Update to 0.16
- - C/C++ Support
- - New Database Add-in
- - Text editor improvements
- - On-the-fly error underlining
- - Auto-generation of XML comment tags
- - New ASP.NET features
- - Multiple GTK# versions
- - ChangeLog add-in
- - More than 100 bugs fixed
- * Mon Sep 24 2007 wberrier@suse.de
- - monodevelop-fix_kde_crash_r86138.patch: fix #309204
- * Fri Aug 3 2007 maw@suse.de
- - Use %%fdupes.
- * Fri Aug 3 2007 wberrier@suse.de
- - Remove upstream monodevelop-rename_ja_JP.patch
- - Update to 0.15
- - Configurable keybindings
- - Output pad pinning
- - Makefile integration
- - Standard header support for source files
- - Localization add-in preview
- - Text editor improvements
- - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
- - Assembly signing
- - Message log for internal messages
- - More than 60 bugs fixed
- * Thu Jun 14 2007 wberrier@novell.com
- - Put ja_JP locale files in valid location
- (monodevelop-rename_ja_JP.patch)
- - Update to 0.14
- - Improved Toolbox and Properties pad
- - Subversion add-in updates
- - auth prompts
- - supports newer versions of subversion
- - New refactory operations:
- - rename
- - implement interface
- - encapsulate field
- - Search by filename or classname in Open Solution File Dialog
- - New class and member selector when browsing source
- - Improved smart indenting for C#
- - Project export/conversion
- - Packaging features: automatic bundling of an app
- - Desktop integration: automatically generate shell wrappers,
- .desktop and .pc files
- - Improved New Project dialog
- - New Navigation Toolbar
- - Gtk# Designer updates:
- - better widget defaults
- - supports internal and custom widgets
- - images assigned to widgets are automatically added to project
- - Can add file to project while creating them
- - Improved VS2005 support and VS integration
- - VB.Net support utilizes new vbnc compiler
- - Close to 100 bugs fixed
- * Wed May 16 2007 wberrier@novell.com
- - Remove gtkhtml2-devel from BuildRequires (not needed, allows
- building on sle10)
- * Tue Apr 24 2007 wberrier@novell.com
- - Depend on version of boo found at build time
- * Fri Apr 13 2007 wberrier@novell.com
- - add %%debug_package so debug packages get created
- * Wed Apr 11 2007 wberrier@novell.com
- - Add mono dep/req for older distros
- * Thu Apr 5 2007 wberrier@suse.de
- - Update to 0.13.1:
- - Bugfix release to fix some asp.net compilation issues
- - Adapt for buildservice
- - Clean up unnecessary BuildRequires
- * Thu Mar 1 2007 wberrier@suse.de
- - Update to 0.13:
- - More than 70 bugs fixed
- - Revamped VersionControl addin
- - New task view features (TODO type lists)
- - Code completion improvements and fixes
- - Native support for VisualStudio 2005 Project files
- - Custom commands in projects
- - Makefile integration
- - New Generic Project Type
- - New Deployment infrastruction
- - Automatic project reloading when changes in files detected
- while the project is open
- - Gtk# designer improvements (Undo/Redo support)
- - Context sensitive help for classes when F1 is pressed
- - Support for Win32Icon and Win32Resource options in C# projects
- - New Layout toolbar which includes a combobox for fast layout
- switching
- - Support for files outside of a project directory
- - Editor wrap mode selector
- - File viewer selector (possible to have multiple viewers for
- a filetype)
- - Improvements in ASP.NET support:
- - added a new option that can be used to disable compilation-time
- CodeBehind verification for different configurations
- - Several important stability fixes in AspNetEdit
- - Improvements to toolbox, now includes default items with icons
- - New Go to Type dialog, for easily jumping to a class defined
- in a project
- * Mon Jan 22 2007 ro@suse.de
- - drop requires for gnome-filesystem
- * Wed Jan 3 2007 wberrier@suse.de
- - handle mime files properly
- - spec file fixes from Andreas Hanke to fix bnc #225812
- * Thu Oct 19 2006 ro@suse.de
- - added mono-devel to buildrequires
- * Tue Sep 5 2006 wberrier@suse.de
- - Update to 0.12
- - Better code completion support, supports C# 2.0
- - Class information is shown using the syntax of the current
- language
- - New "Open With" Menu
- - stetic menu designer
- - autotools project support
- - additional addin management features
- - Support for multiple text file encodings
- - ASP.NET Support
- - Lots of bug fixes and better stability
- * Wed Aug 30 2006 wberrier@suse.de
- - Add mono-nunit to BuildRequires
- * Mon Jul 31 2006 wberrier@suse.de
- - Update to 0.11
- - Lots of new features and fixes, too many to list here. One big
- addition is the stetic gui designer integration
- - 2.4.0 -> 2.8.0 hack now unnecessary
- * Sun Mar 26 2006 ro@suse.de
- - removed ifarch from noarch package
- * Fri Mar 24 2006 wberrier@suse.de
- - Require mono-basic so that vbnet templates will compile
- * Wed Mar 15 2006 wberrier@suse.de
- - Update references for gtk# 2.4 to 2.8 in template files
- * * Otherwise all the gtk#2 template projects will fail to compile **
- * Mon Mar 13 2006 wberrier@suse.de
- - Remove mime.cache and quote update_desktop args
- * Fri Feb 17 2006 gekker@suse.de
- - fixup desktop file for UI team
- * Wed Feb 1 2006 aj@suse.de
- - Fix Requires and BuildRequires to build again.
- * Wed Jan 25 2006 mls@suse.de
- - converted neededforbuild to BuildRequires
- * Fri Jan 13 2006 gekker@suse.de
- - Fixup nfb and Requires for new gtk-sharp2 packaging
- * Mon Jan 9 2006 gekker@suse.de
- - Fix to build against new mono version 1.1.13
- * Mon Dec 12 2005 wberrier@suse.de
- - Convert to noarch package, and clean up build deps
- * Tue Nov 29 2005 wberrier@suse.de
- - Update to 0.9 (which obsoletes the version control patch)
- * Fri Nov 18 2005 wberrier@suse.de
- - Patch VersionControl AddIn to compile with mcs 1.1.10
- * Mon Nov 7 2005 sbrabec@suse.cz
- - Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
- * Tue Oct 25 2005 ro@suse.de
- - remove mono-debugger from nfb for the moment
- * Thu Oct 20 2005 ro@suse.de
- - rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
- * Thu Oct 13 2005 wberrier@suse.de
- - Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
- * Thu Sep 22 2005 ro@suse.de
- - remove libgdiplus-devel from nfb (dropped)
- * Tue Sep 13 2005 gekker@suse.de
- - Disable boo support so monodevelop will run (113802)
- * Sun Sep 4 2005 aj@suse.de
- - Update check-build.sh.
- * Tue Aug 30 2005 ro@suse.de
- - do not require mono-debugger on ppc (can not build there)
- * Fri Aug 26 2005 ro@suse.de
- - nfb: monodoc -> monodoc-core
- * Thu Aug 18 2005 gekker@suse.de
- - Fix desktop category for menus.
- * Tue Aug 16 2005 aj@suse.de
- - Add check-build script.
- * Tue Aug 9 2005 gekker@suse.de
- - Fix requirements
- - Remove files that conflict with shared-mime-info
- - Verify that bugs #71734 and #71735 are fixed
- * Sun Aug 7 2005 ro@suse.de
- - rename nfb and deps for gtksourceview-sharp and gecko-sharp
- * Thu Aug 4 2005 gekker@suse.de
- - Update to version 0.7
- - Remove upstreamed patches
- * Wed May 18 2005 gekker@suse.de
- - fix to build with mono-1.1.7
- * Tue Mar 1 2005 gekker@suse.de
- - fix requires (66770).
- * Tue Feb 15 2005 ro@suse.de
- - fix build on x86_64
- * Tue Feb 8 2005 gekker@suse.de
- - Add patches to fix namespacing issues.
- - Add suse_update_desktop_config
- * Mon Dec 13 2004 clahey@suse.de
- - New package.
|