123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312 |
- %define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
- %define _udevrulesdir /lib/udev/rules.d
- Summary: Utilities for Linux md devices (software RAID arrays)
- Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
- Name: mdadm
- Version: 3.3
- Release: 1%{?_dist_release}
- Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
- Source1: mdmonitor.init
- Source2: raid-check
- Source3: mdadm.rules
- Source4: mdadm-raid-check-sysconfig
- Source5: mdadm-cron
- Source6: mdmonitor.service
- Source7: mdadm.conf
- Source8: mdadm_event.conf
- Patch1: mdadm-3.3-Be-consistent-in-return-types-from-byteswap-macros.patch
- Patch93: mdadm-3.2.6-Remove-offroot-argument-and-default-to-always-settin.patch
- Patch94: mdadm-3.2.6-Add-support-for-launching-mdmon-via-systemctl-instea.patch
- Patch95: mdadm-3.2.6-In-case-launching-mdmon-fails-print-an-error-message.patch
- Patch96: mdadm-3.2.6-mdmon-add-foreground-option.patch
- # Fedora customization patches
- Patch97: mdadm-3.3-udev.patch
- Patch98: mdadm-2.5.2-static.patch
- URL: http://www.kernel.org/pub/linux/utils/raid/mdadm/
- License: GPL
- Group: System Environment/Base
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Obsoletes: mdctl,raidtools
- Requires: smtpdaemon
- BuildRequires: glibc-static
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- mdadm is used to create, manage, and monitor Linux MD (software RAID)
- devices. As such, it provides similar functionality to the raidtools
- package. However, mdadm is a single program, and it can perform
- almost all functions without a configuration file, though a configuration
- file can be used to help with some common tasks.
- %prep
- %setup -q
- %patch1 -p1 -b .types
- # Fedora customization patches
- %patch97 -p1 -b .udev
- %patch98 -p1 -b .static
- %build
- make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
- %install
- rm -rf %{buildroot}
- #make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=%{_sbindir} SYSTEMD_DIR=%{_unitdir} install install-systemd
- make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
- install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
- install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
- install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
- install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
- # tmpfile
- mkdir -p %{buildroot}%{_tmpfilesdir}
- install -m 0644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/%{name}.conf
- mkdir -p %{buildroot}%{_localstatedir}/run/
- install -d -m 0710 %{buildroot}%{_localstatedir}/run/%{name}/
- # initscript
- mkdir -p %{buildroot}%{_initdir}
- install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
- # systemd
- #mkdir -p %{buildroot}%{_unitdir}
- #install -m644 %{SOURCE6} %{buildroot}%{_unitdir}
- # abrt
- #mkdir -p %{buildroot}/etc/libreport/events.d
- #install -m644 %{SOURCE8} %{buildroot}/etc/libreport/events.d
- %clean
- rm -rf %{buildroot}
- %post
- /sbin/chkconfig --add mdmonitor
- %preun
- if [ "$1" = 0 ]; then
- service mdmonitor stop > /dev/null 2>&1 ||:
- /sbin/chkconfig --del mdmonitor
- fi
- if [ -e %{_initrddir}/mdmpd ]; then
- service mdmpd stop > /dev/null 2>&1 ||:
- /sbin/chkconfig --del mdmpd
- fi
- %postun
- if [ "$1" -ge "1" ]; then
- service mdmonitor condrestart > /dev/null 2>&1
- fi
- %files
- %defattr(-,root,root)
- %doc TODO ChangeLog mdadm.conf-example COPYING misc/*
- /sbin/*
- %{_sbindir}/*
- %{_initdir}/*
- %{_mandir}/man*/md*
- %{_udevrulesdir}/*
- %config(noreplace) %{_sysconfdir}/sysconfig/*
- %config(noreplace) %{_sysconfdir}/cron.d/*
- %dir %{_localstatedir}/run/%{name}/
- %config(noreplace) %{_tmpfilesdir}/%{name}.conf
- %changelog
- * Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
- - new upstream release.
- * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
- - rebuild with VineSeed environment
- * Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
- - added BR: glibc-static
- * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
- - rebuilt with rpm-4.8.1-3
- * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
- - new upstream release
- * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
- - applied new versioning policy, spec in utf-8
- * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
- - new upstream release
- * Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
- - initial build for Vine Linux
- * Mon Aug 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
- - Update to 2.5.3 which upstream calls a "bug fix" release
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
- - rebuild
- * Fri Jul 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
- - Update to 2.5.2
- - Remove auto default patch as upstream now has a preferred default auto method
- * Wed Mar 8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
- - fix build on ppc64
- * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
- - fix build on ppc
- * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
- - update to 2.3.1 to fix raid5 (#184284)
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
- - 2.2 upgrade (#167897)
- - disable diet because we don't ship it anymore
- and we don't actually use mdassemble now
- * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
- - Make the mdmonitor init script use the pid-file option, major cleanup
- of the script now possible (#134459)
- * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
- - Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
- * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
- - Change the default auto= mode so it need not be on the command line to
- work with udev, however it is still supported on the command line (#132706)
- - Add a man page (from Luca Berra) for mdassemble
- * Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
- - Upgrade to 1.11.0
- * Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
- - fix mdmonitor initscript (#144717)
- * Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
- - Build mdadm.static and mdassemble (static as well) to be used in initrd
- images
- * Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
- - Initial upgrade to 1.9.0 and update of doc files
- - Fix an s390 build error
- * Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
- - Remove /etc/mdadm.conf from the file list. Anaconda will write one out
- if it's needed.
- * Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
- - Update to newer upstream version
- - Make mdmpd work on kernels that don't have the event interface patch
- * Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
- - Create a directory /var/run/mdadm to contain mdadm.pid
- - This cleans up SELinux problem
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
- - Fix Makefile and build method to satisfy bz #123769
- - Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
- - Make sure mdadm --monitor closes all md device files so that md devices
- can be stopped while mdadm is still running - bz #119532
- * Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
- - remove unneeded patch, can use --run instead
- * Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
- - add patch with reallyforce mode on creation to be used by anaconda
- * Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
- - Fix a bug in the %postun scriptlet related to downgrading to a version
- of mdadm that doesn't include the mdmpd daemon.
- * Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
- - Disable service mdmpd by default to avoid [Failed] messages on
- current 2.6 kernels. Possibly re-enable it by default once the
- 2.6 kernels have the md event interface.
- * Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
- - Update mdmonitor script to start daemon more cleanly
- - Repackage mdmpd tarball to include gcc-3.4 changes and to make
- mdmpd properly daemonize at startup instead of forking and leaving
- the child attached to the terminal.
- * Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
- - ship /var/run/mpmpd (#117497)
- * Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
- - Add a default MAILADDR line to the mdadm.conf file installed by default
- (Bugzilla #92447)
- - Make it build with gcc-3.4
- * Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
- - Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
- * Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
- - fix problem with recovery thread sleeping in mdmpd
- * Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
- - sync upstream
- - add mdmpd package into mdadm package
- * Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
- - sync upstream
- * Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
- - sync upstream
- * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
- - update for rebuild
- * Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
- - fix references to %%install in the changelog so that it will build
- * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
- - Rebuild
- * Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
- - Changed RPM Group to System Environment/Base
- * Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
- - minor cleanups to the text, conditionalize rm -rf
- - added mdmonitor init script
- * Fri May 10 2002 <neilb@cse.unsw.edu.au>
- - update to 1.0.0
- - Set CXFLAGS instead of CFLAGS
- * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
- - change %%install to use "make install"
- * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
- - beautification
- - made mdadm.conf non-replaceable config
- - renamed Copyright to License in the header
- - added missing license file
- - used macros for file paths
- * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
- - Added Obsoletes: mdctl
- - missingok for configfile
- * Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
- - Add md.4 and mdadm.conf.5 man pages
- * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
- - builds properly as non-root.
- * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
- - updated for 0.7, fixed /usr/share/doc and added manpage
- * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
- - initial RPM build
|