sudo-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291
  1. Summary: Allows command execution as root for specified users
  2. Summary(ja): スーパーユーザ権限でのコマンドの実行
  3. Name: sudo
  4. Version: 1.7.2p7
  5. Release: 4%{?_dist_release}
  6. License: ISC-style
  7. Group: Applications/System
  8. URL: http://www.sudo.ws/
  9. Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
  10. Source1: sudo-sudoers-vine
  11. Patch1: sudo-1.6.7p5-strip.patch
  12. Patch2: sudo-1.7.2-login.patch
  13. Patch3: sudo-1.7.2p4-getgrouplist.patch
  14. Patch4: sudo-1.7.1-envdebug.patch
  15. Patch5: sudo-1.7.1-libtool.patch
  16. # reset HOME when using the -i' option (#635250)
  17. Patch6: sudo-1.7.4p4-sudoi.patch
  18. # security
  19. Patch100: sudo-1.7.2p7_CVE-2010-2956.patch
  20. Patch110: sudo-1.7.2p7_CVE-2011-0010.patch
  21. Patch111: sudo-1.7.2p7_user_in_group.patch
  22. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: pam-devel
  24. BuildRequires: groff
  25. BuildRequires: flex
  26. BuildRequires: bison
  27. BuildRequires: openldap-devel
  28. BuildRequires: automake autoconf libtool
  29. BuildRequires: libcap-devel
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. %description
  33. Sudo (superuser do) allows a system administrator to give certain users
  34. (or groups of users) the ability to run some (or all) commands as root while
  35. logging all commands and arguments. Sudo operates on a per-command basis,
  36. it is not a replacement for the shell.
  37. %description -l ja
  38. sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
  39. いくつかのコマンド操作を行うことを許可するためのプログラムです。
  40. %prep
  41. %setup -q
  42. %patch1 -p1 -b .strip
  43. %patch2 -p1 -b .login
  44. %patch3 -p1 -b .getgrouplist
  45. %patch4 -p1 -b .envdebug
  46. %patch5 -p1 -b .libtool
  47. %patch100 -p1 -b .CVE-2010-2956
  48. %patch110 -p1 -b .CVE-2011-0010
  49. %patch111 -p1 -b .user_in_group
  50. libtoolize --force && rm acsite.m4 && mv aclocal.m4 acinclude.m4 && autoreconf
  51. %build
  52. %configure \
  53. --prefix=%{_prefix} \
  54. --sbindir=%{_sbindir} \
  55. --libdir=%{_libdir} \
  56. --sysconfdir=%{_sysconfdir} \
  57. --with-pam \
  58. --with-pam-login \
  59. --with-logging=syslog \
  60. --with-logfac=authpriv \
  61. --with-tty-tickets \
  62. --with-ignore-dot \
  63. --with-editor=/bin/vi \
  64. --with-env-editor \
  65. --with-ldap \
  66. --with-passprompt="[sudo] password for %p: " \
  67. --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
  68. --without-interfaces
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. mkdir $RPM_BUILD_ROOT
  73. make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
  74. chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
  75. install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
  76. install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
  77. mkdir -p $RPM_BUILD_ROOT/etc/pam.d
  78. cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
  79. #%PAM-1.0
  80. auth include system-auth
  81. account include system-auth
  82. password include system-auth
  83. session optional pam_keyinit.so revoke
  84. session required pam_limits.so
  85. EOF
  86. cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
  87. #%PAM-1.0
  88. auth include sudo
  89. account include sudo
  90. password include sudo
  91. session optional pam_keyinit.so force revoke
  92. session required pam_limits.so
  93. EOF
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %files
  97. %defattr(-,root,root)
  98. %doc HISTORY LICENSE README* TROUBLESHOOTING UPGRADE
  99. %doc ChangeLog
  100. %doc *.pod schema.* sudoers2ldif sample.*
  101. %attr(0440,root,root) %config(noreplace) /etc/sudoers
  102. %config(noreplace) /etc/pam.d/sudo
  103. %config(noreplace) /etc/pam.d/sudo-i
  104. %dir /var/run/sudo
  105. %attr(4111,root,root) %{_bindir}/sudo
  106. %attr(4111,root,root) %{_bindir}/sudoedit
  107. %attr(0755,root,root) %{_sbindir}/visudo
  108. %{_libexecdir}/sudo_noexec.*
  109. %{_mandir}/man5/sudoers*.5*
  110. %{_mandir}/man8/sudo.8*
  111. %{_mandir}/man8/sudoedit.8*
  112. %{_mandir}/man8/visudo.8*
  113. %post
  114. /bin/chmod 0440 /etc/sudoers || :
  115. %changelog
  116. * Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
  117. - update sudoers
  118. - enable "%wheel ALL=(ALL) ALL" by default.
  119. * Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
  120. - add patch110,111 for fix CVE-2011-0010 ("-g" option)
  121. * Wed Sep 8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
  122. - add Patch100 for fix CVE-2010-2956 (sudo Runas)
  123. - add _smp_mflags flag into make section
  124. - fix doc filelist (no longer exist BUGS, CHANGSE)
  125. * Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
  126. - new upstream release with security fix (CVE-2010-1646)
  127. - change specfile name (-vl)
  128. * Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
  129. - new upstream release with security fix (CVE-2010-1163)
  130. - add sudoers.ldap.5 into files section
  131. * Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
  132. - new upstream release with security fix (CVE-2010-0426)
  133. - update Patch3
  134. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
  135. - new upstream release
  136. * Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
  137. - new upstream release
  138. - update patches
  139. - disable "Defaults requiretty"
  140. * Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
  141. - rebuilt with openldap-2.4.11
  142. * Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
  143. - new upstream release with security fix (CVE 2009-0034)
  144. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
  145. - new upstream release
  146. - merge some changes from fedoraproject
  147. - include [sudo] in password prompt
  148. - compiled with secure path
  149. - also use getgrouplist() to determine group membership
  150. - add sudoers file
  151. - add command aliases, default environment config
  152. - build with openldap
  153. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
  154. - applied new versioning policy, spec in utf-8
  155. * Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
  156. - change PAM configuration to use system-auth
  157. - add --with-ignore-dot, --with-editor and --with-env-editor to
  158. configure option.
  159. * Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
  160. - new upstream release (included security fix)
  161. - add patch1 for fix CVE-2006-0151
  162. * Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
  163. - new upstream release
  164. - use macros
  165. - build with pam
  166. * Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
  167. - new upstream release
  168. * Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
  169. - SECURITY FIX: new upstream release
  170. - update rpmnonroot.patch ( Patch0 )
  171. - add new man page: sudoedit(8)
  172. * Wed Sep 1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
  173. - new upstream release
  174. - update rpmnonroot.patch ( Patch0 )
  175. - change Copyrigh tag to License tag
  176. - update License
  177. - update URL and Source0: official web site moved.
  178. - new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
  179. * Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
  180. - upstream release
  181. * Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
  182. - fixed changelog
  183. -- don't expand macros in changelog ;P
  184. * Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
  185. - changed to use configure in build section
  186. (can't build on sparc)
  187. * Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
  188. - upstream release
  189. - fix security hole : buffer over flow
  190. * Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
  191. - upstream release
  192. - updated sudo.rpmnonroot.diff
  193. * Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
  194. - upstream release
  195. - added configure script option '--disable-root-mailer'
  196. * Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
  197. - upstream release
  198. - eliminated FAQ from %doc
  199. * Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
  200. - upstream release
  201. - added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
  202. - updated sudo.rpmnonroot.diff
  203. * Wed May 09 2001 <sagami@vinelinux.org>
  204. - 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
  205. * Fri Mar 02 2001 sagami@vinelinux.org
  206. - 1.6.3p7-0vl1
  207. - use better macros
  208. * Tue Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
  209. - 1.6.3p6-0vl1
  210. - changed sudo.rpmnonroot.diff for 1.6.3p6
  211. * Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  212. - 1.6.1-2vl5
  213. - patch -p1 -> patch -p0
  214. * Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
  215. - 1.6.1-2vl4
  216. - fix uid/gid to root.root
  217. - add sudo.rpmnonroot.diff to built by non-root users
  218. * Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
  219. - 1.6.1-2vl3
  220. - fix attr
  221. * Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
  222. - 1.6.1-2vl2
  223. - enable to build by non-root useres
  224. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  225. - 1.6.1-2vl1
  226. - modified %files section to handle compressed man page(s)
  227. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  228. - change group
  229. * Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
  230. - version 1.6.1
  231. - build for Vine Linux 2.0
  232. * Fri May 14 1999 Takeda Eiji <keda@flatout.org>
  233. - sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
  234. * Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
  235. - Initial Release