nginx-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.11.12
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.3.5
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. ## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
  51. %define passenger_version 5.1.2
  52. Source1020: passenger-%{passenger_version}.tar.gz
  53. %define upstream_fair_version 2131c73
  54. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  55. %define mod_wsgi_version 6975f0ec7eeb
  56. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  57. # removes -Werror in upstream build scripts. -Werror conflicts with
  58. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  59. Patch0: nginx-auto-cc-gcc.patch
  60. # to fix https://svn.boost.org/trac/boost/ticket/8731
  61. Patch100: boost-changeset_84950.diff
  62. # to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
  63. Patch101: gnosek-nginx-upstream-fair-pull-23.patch
  64. # to fix compile error with C++11.
  65. Patch1000: passenger-5.0.28-boost.patch
  66. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  67. %if "%{_dist_release}" > "vl6"
  68. BuildRequires: libboost-devel
  69. %endif
  70. BuildRequires: pcre-devel
  71. BuildRequires: zlib-devel
  72. BuildRequires: openssl-devel
  73. BuildRequires: gd-devel
  74. BuildRequires: perl
  75. BuildRequires: perl(ExtUtils::Embed)
  76. BuildRequires: libxml2-devel
  77. BuildRequires: libxslt-devel
  78. BuildRequires: curl-devel
  79. %if %{with geoip}
  80. BuildRequires: GeoIP-devel
  81. %endif
  82. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  83. # for /usr/sbin/useradd
  84. Requires(pre): shadow-utils
  85. Requires(post): chkconfig
  86. # for /sbin/service
  87. Requires(preun): chkconfig, initscripts
  88. Requires(postun): initscripts
  89. %if "%{_dist_release}" > "vl6"
  90. Requires(pre): www-common
  91. %endif
  92. Provides: webserver
  93. Vendor: Project Vine
  94. Distribution: Vine Linux
  95. Packager: daisuke
  96. %description
  97. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  98. proxy server written by Igor Sysoev.
  99. %description -l ja
  100. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  101. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  102. - HTTP(S) サーバ
  103. - HTTP(S) リバースプロキシサーバ
  104. - IMAP/POP3 プロキシサーバ
  105. %package passenger
  106. Summary: Nginx with mod_passenger support
  107. Summary(ja): Passenger サポート入りの Nginx
  108. Group: System Environment/Daemons
  109. BuildRequires: ruby, rubygem-rake
  110. Requires: ruby, rubygem-rake
  111. %if "%{_dist_release}" >= "vl7"
  112. BuildRequires: ruby-devel, ruby-rubygems
  113. Requires: ruby-rubygems
  114. %else
  115. BuildRequires: rubygems
  116. Requires: rubygems
  117. %endif
  118. Requires: nginx
  119. %description passenger
  120. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  121. This package contains nginx server with passenger support.
  122. %description -l ja passenger
  123. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  124. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  125. - HTTP(S) サーバ
  126. - HTTP(S) リバースプロキシサーバ
  127. - IMAP/POP3 プロキシサーバ
  128. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  129. %prep
  130. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  131. %patch0 -p0
  132. # pushd passenger-%{passenger_version}/ext/
  133. # %patch100 -p2
  134. # popd
  135. pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
  136. %patch101 -p1
  137. popd
  138. %if %{?_dist_release} == "vl7"
  139. pushd passenger-%{passenger_version}
  140. #% patch1000 -p1
  141. popd
  142. %endif
  143. %build
  144. # nginx does not utilize a standard configure script. It has its own
  145. # and the standard configure options cause the nginx configure script
  146. # to error out. This is is also the reason for the DESTDIR environment
  147. # variable. The configure script(s) have been patched (Patch1 and
  148. # Patch2) in order to support installing into a build environment.
  149. export DESTDIR=%{buildroot}
  150. CONFIGOPTS="\
  151. --user=%{nginx_user} \
  152. --group=%{nginx_group} \
  153. --prefix=%{nginx_datadir} \
  154. --sbin-path=%{_sbindir}/%{name} \
  155. --conf-path=%{nginx_confdir}/%{name}.conf \
  156. --error-log-path=%{nginx_logdir}/error.log \
  157. --http-log-path=%{nginx_logdir}/access.log \
  158. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  159. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  160. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  161. --pid-path=%{_localstatedir}/run/%{name}.pid \
  162. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  163. --with-file-aio \
  164. --with-ipv6 \
  165. --with-http_ssl_module \
  166. --with-http_v2_module \
  167. --with-http_realip_module \
  168. --with-http_addition_module \
  169. --with-http_xslt_module \
  170. --with-http_image_filter_module \
  171. %if %{with geoip}
  172. --with-http_geoip_module \
  173. %endif
  174. --with-http_sub_module \
  175. --with-http_dav_module \
  176. --with-http_flv_module \
  177. --with-http_mp4_module \
  178. --with-http_gunzip_module \
  179. --with-http_gzip_static_module \
  180. --with-http_auth_request_module \
  181. --with-http_random_index_module \
  182. --with-http_secure_link_module \
  183. --with-http_degradation_module \
  184. --with-http_stub_status_module \
  185. --with-http_perl_module \
  186. --with-mail \
  187. --with-mail_ssl_module \
  188. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  189. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  190. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  191. %if %{with wsgi}
  192. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  193. %endif
  194. %ifarch i686
  195. --with-cpu-opt=pentiumpro \
  196. --with-zlib-asm=pentiumpro \
  197. --with-md5-asm \
  198. --with-sha1-asm \
  199. %endif
  200. "
  201. ## build with passenger
  202. ./configure \
  203. $CONFIGOPTS \
  204. --with-cc-opt="%{optflags}" \
  205. --add-module=passenger-%{passenger_version}/src/nginx_module
  206. make %{?_smp_mflags}
  207. mv objs/nginx objs/nginx.passenger
  208. ## build without passenger
  209. ./configure \
  210. $CONFIGOPTS \
  211. --with-cc-opt="%{optflags}"
  212. make %{?_smp_mflags}
  213. %install
  214. rm -rf %{buildroot}
  215. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  216. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  217. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  218. find %{buildroot} -type f -empty -exec rm -f {} \;
  219. find %{buildroot} -type f -exec chmod 0644 {} \;
  220. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  221. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  222. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  223. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  224. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  225. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  226. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  227. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  228. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  229. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  230. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  231. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  232. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  233. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  234. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  235. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  236. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  237. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  238. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  239. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  240. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  241. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  242. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  243. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  244. %if %{with wsgi}
  245. %{__install} -p -m 0644 \
  246. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  247. %{buildroot}%{nginx_confdir}
  248. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  249. %endif
  250. # upstream fair module document
  251. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  252. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  253. # convert to UTF-8 all files that give warnings.
  254. for textfile in CHANGES
  255. do
  256. mv $textfile $textfile.old
  257. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  258. rm -f $textfile.old
  259. done
  260. %clean
  261. rm -rf %{buildroot}
  262. %post
  263. if [ $1 == 1 ]; then
  264. /sbin/chkconfig --add %{name}
  265. fi
  266. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  267. %post passenger
  268. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  269. %preun
  270. if [ $1 = 0 ]; then
  271. /sbin/service %{name} stop >/dev/null 2>&1
  272. /sbin/chkconfig --del %{name}
  273. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  274. fi
  275. %preun passenger
  276. if [ $1 = 0 ]; then
  277. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  278. fi
  279. %postun
  280. if [ $1 == 2 ]; then
  281. /sbin/service %{name} upgrade || :
  282. fi
  283. %files
  284. %defattr(-,root,root,-)
  285. %doc LICENSE CHANGES README
  286. %doc README.upstream_fair
  287. %doc %{?with_wsgi:README.mod_wsgi}
  288. %{nginx_datadir}/
  289. %{_sbindir}/%{name}.normal
  290. %{_mandir}/man3/%{name}.3pm.gz
  291. %{_initrddir}/%{name}
  292. %dir %{nginx_confdir}
  293. %dir %{nginx_confdir}/conf.d
  294. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  295. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  296. %config(noreplace) %{nginx_confdir}/sites.d/*
  297. %config(noreplace) %{nginx_confdir}/win-utf
  298. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  299. %config(noreplace) %{nginx_confdir}/mime.types.default
  300. %config(noreplace) %{nginx_confdir}/fastcgi_params
  301. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  302. %config(noreplace) %{nginx_confdir}/koi-win
  303. %config(noreplace) %{nginx_confdir}/koi-utf
  304. %config(noreplace) %{nginx_confdir}/%{name}.conf
  305. %config(noreplace) %{nginx_confdir}/mime.types
  306. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  307. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  308. %config(noreplace) %{nginx_confdir}/scgi_params
  309. %config(noreplace) %{nginx_confdir}/scgi_params.default
  310. %config(noreplace) %{nginx_confdir}/uwsgi_params
  311. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  312. %if %{with wsgi}
  313. %config(noreplace) %{nginx_confdir}/wsgi_vars
  314. %endif
  315. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  316. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  317. %dir %{perl_vendorarch}/auto/%{name}
  318. %{perl_vendorarch}/%{name}.pm
  319. %{perl_vendorarch}/auto/%{name}/%{name}.so
  320. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  321. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  322. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  323. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  324. %files passenger
  325. %defattr(-,root,root,-)
  326. %doc passenger-%{passenger_version}/doc/*.md
  327. %doc passenger-%{passenger_version}/doc/*.txt
  328. %doc passenger-%{passenger_version}/doc/*.html
  329. %doc passenger-%{passenger_version}/doc/templates
  330. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  331. %doc passenger-%{passenger_version}/doc/images
  332. %{_sbindir}/%{name}.passenger
  333. %changelog
  334. * Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
  335. - updated to 1.11.12
  336. * Tue Mar 7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
  337. - updated to 1.11.10
  338. - updated passenger to 5.1.2
  339. * Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
  340. - updated to 1.11.9
  341. * Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
  342. - updated to 1.11.8
  343. * Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
  344. - updated to 1.11.6
  345. - applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
  346. * Mon Sep 5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
  347. - updated to 1.11.3
  348. - updated passenger to 5.0.30
  349. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
  350. - rebuild with gcc-5.4.0
  351. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  352. - updated to 1.10.1.
  353. - updated passenger to 5.0.28.
  354. * Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
  355. - updated to 1.9.15
  356. * Thu Apr 7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
  357. - updated to 1.9.14
  358. - updated passenger to 5.0.27
  359. * Wed Apr 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
  360. - new upstream release
  361. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  362. - updated to 1.9.12.
  363. - updated passenger to 5.0.26.
  364. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  365. - new upstream release
  366. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  367. - update to 1.9.10
  368. - update passenger to 5.0.24
  369. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  370. - update passenger to 5.0.23
  371. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  372. - new upstream release
  373. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  374. - new upstream release
  375. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  376. - new upstream release
  377. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  378. - new upstream release
  379. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  380. - update to 1.9.3
  381. - update passenger to 5.0.11
  382. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  383. - updated Source4 (ssl.conf).
  384. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  385. - update to 1.9.2
  386. - update passenger to 5.0.10
  387. - update ngx-fancyindex to 0.3.5
  388. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  389. - update to 1.6.2
  390. - update passenger to 4.0.52
  391. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  392. - new upstream release
  393. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  394. - rebuild with new environment
  395. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  396. - update passenger to 4.0.45
  397. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  398. - update to 1.6.0 (stable)
  399. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  400. - update fancyindex to 0.3.3
  401. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  402. - update to 1.5.10
  403. - update passenger to 4.0.37
  404. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  405. - rebuilt with GeoIP-1.6.0.
  406. - added Patch100.
  407. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  408. - update to 1.5.6
  409. - update passenger to 4.0.21
  410. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  411. - rebuilt with gd-2.1.0.
  412. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  413. - update to 1.4.1
  414. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  415. - update to 1.4.0
  416. - enable SPDY module
  417. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  418. - new upstream release
  419. - update passenger to 3.0.19
  420. - update ngx-fancyindex to upstream git master
  421. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  422. - new upstream release
  423. - update passenger to 3.0.17
  424. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  425. - rebuild with pcre-8.31
  426. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  427. - added http_geoip_module.
  428. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  429. - update to 1.2.4
  430. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  431. - update to 1.2.2
  432. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  433. - update to 1.2.1
  434. - change nginx user from nginx to www-data
  435. - R(pre): www-common
  436. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  437. - update to 1.2.0
  438. - update passenger to 3.0.12
  439. - drop http_upstream_keepalive
  440. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  441. - new upstream release
  442. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  443. - update to 1.0.12
  444. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  445. - update to 1.0.11
  446. - update passenger to 3.0.11
  447. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  448. - update to 1.0.10
  449. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  450. - update passenger to 3.0.9
  451. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  452. - update to 1.0.6
  453. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  454. - update to 1.0.4
  455. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  456. - add gnosek-nginx-upstream-fair module
  457. - add ngx_http_upstream_keepalive module
  458. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  459. - add nginx-passenger sub pakckage
  460. - use alternatives to choose nginx with or without passenger
  461. - add BR: ruby, rubygems, rubygem-rake
  462. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  463. - update to 1.0.2
  464. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  465. - update to 1.0.1
  466. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  467. - add bcond_with wsgi for mod_wsgi
  468. - add bcond_with passenger
  469. - you need to install rake.gem to build with this option.
  470. - add Provides: webserver
  471. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  472. - new upstream release 1.0.0!
  473. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  474. - rebuild with perl-5.12.3
  475. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  476. - update to 0.8.54
  477. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  478. - update to 0.8.53
  479. - add nginx_accept_language_module
  480. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  481. - update to 0.8.50
  482. - update ngx-fancyindex to 0.3
  483. - add BR: libxml2-devel, libxslt-devel
  484. - add scgi_params* and uwsgi_params* to %%files
  485. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  486. - update to 0.8.35 (development version)
  487. - add sites.d/ to store vitualhost settings
  488. - split out default server settings to sites.d/default
  489. - add fancyindex module
  490. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  491. - new upstream release
  492. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  493. - update to 0.7.62 (included security fix: VU#180065)
  494. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  495. - fix typo
  496. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  497. - add translated descriptions
  498. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  499. - update 404.html/50x.html to use powered by vine logo.
  500. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  501. - initial build for Vine Linux
  502. - update to 0.7.61
  503. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  504. - init script updates from Gena Makhomed
  505. - remove nginx-upstream-fair
  506. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  507. - update to 0.6.36
  508. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  509. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  510. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  511. - rebuild
  512. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  513. - update to 0.6.35
  514. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  515. - rebuild with new openssl
  516. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  517. - update to 0.6.34
  518. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  519. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  520. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  521. - update to 0.6.33
  522. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  523. - update to 0.6.32
  524. - nginx now supports DESTDIR so removed the patches that enabled it
  525. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  526. - init script fixes
  527. - resolve 'listen 80 default' [#447873]
  528. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  529. - update to 0.6.31
  530. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  531. - upate to new upstream stable branch 0.6
  532. - added 3rd party module nginx-upstream-fair
  533. - added default webpages
  534. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  535. - update init script to match recommended guidelines
  536. - add /etc/nginx/conf.d support [#443280]
  537. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  538. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  539. - add Requires for versioned perl (libperl.so)
  540. - drop silly file Requires
  541. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  542. - Autorebuild for GCC 4.3
  543. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  544. - update to 0.5.35
  545. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  546. - update to 0.5.34
  547. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  548. - Rebuild for deps
  549. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  550. - update to 0.5.33
  551. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  552. - updated to 0.5.32
  553. - fixed rpmlint UTF-8 complaints.
  554. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  555. - added --with-http_stub_status_module build option.
  556. - added --with-http_sub_module build option.
  557. - added use of pcre-config --cflags
  558. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  559. - Update to 0.5.31
  560. - specify license is BSD
  561. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  562. - Add BuildRequires: perl-devel - fixing rawhide build
  563. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  564. - Update to 0.5.30
  565. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  566. - Update to 0.5.29
  567. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  568. - Update to 0.5.28
  569. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  570. - Update to 0.5.27
  571. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  572. - Update to 0.5.26
  573. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  574. - Update to 0.5.19
  575. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  576. - Update to 0.5.17
  577. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  578. - Update to 0.5.16
  579. - add ownership of /usr/share/nginx/html (#233950)
  580. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  581. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  582. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  583. - fixed package review bugs (#233522) given by kevin@tummy.com
  584. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  585. - create patches to assist with building for Fedora
  586. - initial packaging for Fedora