rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 3.0.1
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. Patch0: rhythmbox-3.0-disable-python3.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk3-devel
  17. BuildRequires: avahi-glib-devel >= 0.6
  18. BuildRequires: brasero-devel >= 2.32.0
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gstreamer1-plugins-base-devel
  21. BuildRequires: json-glib-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libgnome-keyring-devel >= 2.30.0
  24. BuildRequires: libgpod-devel
  25. BuildRequires: libgudev1-devel
  26. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  27. BuildRequires: libnotify-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: pygobject3-devel
  30. BuildRequires: totem-pl-parser-devel
  31. BuildRequires: WebKit3-gtk-devel
  32. BuildRequires: libpeas-devel
  33. BuildRequires: clutter-gtk-devel
  34. BuildRequires: clutter-gst-devel
  35. BuildRequires: libmx-devel
  36. BuildRequires: check-devel
  37. BuildRequires: libmtp-devel
  38. BuildRequires: libtdb-devel
  39. BuildRequires: grilo-devel
  40. BuildRequires: libdmapsharing-devel
  41. BuildRequires: lirc
  42. BuildRequires: gnome-doc-utils >= 0.3.2
  43. BuildRequires: yelp-tools
  44. Requires: libgpod
  45. Requires: libnotify
  46. Requires: lirc
  47. Requires: libmtp
  48. Requires: brasero
  49. Requires: libgnome-keyring
  50. %if %{enable_DLNA_UPnP}
  51. Requires: python-Coherence
  52. %endif
  53. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  54. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  55. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  56. # # respectively.
  57. # Requires: self-build-gstreamer-plugins-ffmpeg
  58. # Requires: self-build-gstreamer-plugins-ugly
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. %description
  62. Rhythmbox is an integrated music management application based on the powerful
  63. GStreamer media framework. It has a number of features, including an easy to
  64. use music browser, searching and sorting, comprehensive audio format support
  65. through GStreamer, Internet Radio support, playlists and more.
  66. Rhythmbox is extensible through a plugin system.
  67. %description -l ja
  68. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  69. 統合音楽管理アプリケーションです。
  70. 見やすいユーザインターフェースを備え、検索や整列ができ、
  71. GStreamer により数多くの音声フォーマットをサポート、
  72. インターネットラジオをサポート、プレイリスト管理などの
  73. 数多くの特徴を持ちます。
  74. %package devel
  75. Summary: Development tools for rhythmbox applications.
  76. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: pkgconfig
  80. Requires: libxml2-devel
  81. Requires: glib2-devel
  82. Requires: gtk3-devel
  83. Requires: libsoup-devel
  84. Requires: totem-pl-parser-devel
  85. Requires: gstreamer1-devel
  86. %description devel
  87. Header files and libraries for building a extension library for the rhythmbox.
  88. %description devel -l ja
  89. %prep
  90. %setup -q
  91. %patch0 -p1
  92. tar xjf %{SOURCE101}
  93. %build
  94. autoreconf -if
  95. intltoolize --force --copy
  96. %configure --with-ipod \
  97. --with-mtp \
  98. --enable-lirc \
  99. --disable-python \
  100. --disable-vala \
  101. --disable-browser-plugin \
  102. --disable-static \
  103. --enable-browser-plugin \
  104. --without-hal
  105. %__make %{?_smp_mflags}
  106. %install
  107. %__rm -rf $RPM_BUILD_ROOT
  108. %__make install DESTDIR=$RPM_BUILD_ROOT
  109. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  111. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  112. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  113. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  114. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  115. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  116. ## Don't package DLNA/UPnP plugin
  117. %if !%{enable_DLNA_UPnP}
  118. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  119. %endif
  120. %find_lang %{name} --all-name --with-gnome
  121. # Don't package api docs
  122. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  123. # And don't package vala
  124. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  125. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  126. # remove sample plugins
  127. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  128. %clean
  129. %__rm -rf $RPM_BUILD_ROOT
  130. %post
  131. /sbin/ldconfig
  132. update-desktop-database -q
  133. touch --no-create %{_datadir}/icons/hicolor
  134. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  135. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  136. fi
  137. %postun
  138. /sbin/ldconfig
  139. update-desktop-database -q
  140. touch --no-create %{_datadir}/icons/hicolor
  141. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  142. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  143. fi
  144. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  145. %posttrans
  146. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  147. %files -f %{name}.lang
  148. %defattr(-, root, root)
  149. %doc AUTHORS COPYING ChangeLog README NEWS
  150. %{_bindir}/*
  151. %{_libdir}/girepository-1.0/*.typelib
  152. %{_libdir}/lib*.so.*
  153. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  154. %{_libdir}/rhythmbox/plugins
  155. %{_datadir}/applications/rhythmbox.desktop
  156. %{_datadir}/applications/rhythmbox-device.desktop
  157. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  158. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  159. %{_datadir}/icons/*
  160. %{_datadir}/rhythmbox
  161. %{_mandir}/man1/*
  162. %{_libexecdir}/rhythmbox-metadata
  163. %files devel
  164. %defattr(-, root, root)
  165. %{_includedir}/%{name}/*
  166. %{_libdir}/*.so
  167. %{_libdir}/pkgconfig/*.pc
  168. %{_datadir}/gir-1.0/*.gir
  169. %changelog
  170. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  171. - new upstream release
  172. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  173. - new upstream release
  174. - add Patch0 (rhythmbox-3.0-disable-python3.patch)
  175. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
  176. - new upstream release
  177. - add BuildRequies: yelp-tools
  178. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  179. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  180. - rebuild with libimobiledevice-1.1.5
  181. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  182. - new upstream release
  183. - add BuildRequires: grilo-devel, libdmapsharing-devel
  184. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  185. - new upstream release
  186. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  187. - new upstream release
  188. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  189. - new upstream release
  190. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  191. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  192. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  193. - rebuild with cogl-0.8.0
  194. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  195. - rebuild with libnotify-0.7
  196. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  197. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  198. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  199. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  200. - add Source101 (rhythmbox-png.tar.bz2)
  201. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  202. - add BuildRequires: json-glib-devel
  203. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  204. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  205. - new upstream release
  206. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  207. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  208. - new upstream release
  209. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  210. - rebuild with brasero-2.32.0
  211. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  212. - rebuild with rpm-4.8.1 for pkg-config file
  213. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  214. - new upstream release
  215. - fix %files (add rhythmbox-device.desktop)
  216. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  217. - new upstream release
  218. - change BuildRequires: gnome-media-devel instead of gnome-media
  219. - add devel package
  220. - drop Patch0
  221. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  222. - new upstream release
  223. - drop Patch1, Patch2, Patch3
  224. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  225. - change Requires: nautilus-cd-burner -> brasero
  226. - change BuildRequires: hal-devel -> libgudev1-devel
  227. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  228. - change Requires: gnome-keyring -> libgnome-keyring
  229. - add configure option (--without-hal)
  230. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  231. - rebuilt with new environment
  232. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  233. - new upstream release
  234. - dropped upstreamed/obsolete patches
  235. - added patches applied Fedora development
  236. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  237. - new upstream release
  238. - added configure options:
  239. --disable-vala
  240. --disable-browser-plugin
  241. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  242. - added Japanese description
  243. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  244. - new upstream release
  245. - dropped rb-disable-power-plugin-by-default.patch
  246. - added BuildRequires:
  247. - libSM-devel
  248. - gnome-media
  249. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  250. - rebuild with libgpod-0.7.2
  251. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  252. - new upstream release
  253. - corrected License tag
  254. - dropped rhythmbox-0.11.6-libmtp.patch
  255. - added BuildRequires:
  256. - sqlite3-devel
  257. - libffi-devel
  258. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  259. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  260. - applied rhythmbox-0.11.6-libmtp.patch
  261. - added Requires:
  262. - libgpod
  263. - libnotify
  264. - libsexy
  265. - lirc
  266. - libmtp
  267. - libgnomeui
  268. - nautilus-cd-burner
  269. - gstreamer-python
  270. - gnome-vfs2
  271. - gnome-themes
  272. - gnome-keyring
  273. - python-Coherence, if enable_DLNA_UPnP = 1
  274. - added BuildRequires:
  275. - libnotify-devel
  276. - libsexy-devel
  277. - lirc
  278. - libmtp-devel
  279. - gnome-vfs2-devel, instead of gnome-vfs2
  280. - gnome-keyring-devel
  281. - dropped --with-internal-libsexy in configure options
  282. - added in configure options:
  283. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  284. - added %%preun to remove the schema
  285. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  286. - new upstream release
  287. - changed to --with-metadata-helper in configure options
  288. - added BuildRequires:
  289. - gstreamer-python
  290. - intltool >= 0.35.0
  291. - popt-devel
  292. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  293. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  294. - rebuilt with python-2.5.2
  295. - applied new versioning policy
  296. - spec in utf-8
  297. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  298. - rebuilt with libgpod-0.6.0
  299. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  300. - new upstream release
  301. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  302. - new upstream release
  303. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  304. - rebuilt with new toolchain and libgpod-0.4.2
  305. - add BuildRequires: dbus-glib-devel
  306. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  307. - new upstream release
  308. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  309. - rebuilt for VineSeed
  310. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  311. - new upstream release
  312. - added --enable-python option to %%configure
  313. - added Requires: gnome-python
  314. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  315. - new upstream release
  316. - built with libsoup 2.2.99
  317. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  318. - added --with-cd-burner to configure
  319. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  320. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  321. - add BuildRequires:
  322. - gnome-doc-utils >= 0.3.2
  323. - python-devel
  324. - pygtk2-devel
  325. - check >= 0.8.2
  326. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  327. - rebuild with gnutls-1.4.1
  328. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  329. - new upstream release
  330. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  331. - new upstream release
  332. - run scrollkeeper-update at %post and %postun
  333. - added BuildRequires: libnotify-devel
  334. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  335. - new upstream release (dropped patch0)
  336. - added --without-metadata-helper at configure
  337. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  338. - Initial build for Vine Linux based on FC pacakge
  339. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  340. - add patch from James "Doc" Livingston to stop a hang
  341. for new users (bug 183883)
  342. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  343. - bump again for double-long bug on ppc(64)
  344. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  345. - rebuilt for new gcc4.1 snapshot and glibc changes
  346. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  347. - Update to 0.9.3.1
  348. - Use gstreamer (0.10)
  349. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  350. - Remove hack for 173869, as its no longer needed.
  351. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  352. - 0.9.3
  353. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  354. - Newer CVS snapshot
  355. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  356. - Update to latest CVS
  357. - Add hack to workaround bug #173869
  358. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  359. - Rebuild, now that gstreamer08-plugins has been fixed
  360. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  361. - bonobo multilib issue (bug 156982)
  362. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  363. - rebuild with ipod support
  364. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  365. - rebuilt again
  366. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  367. - rebuilt
  368. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  369. - rebuild
  370. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  371. - rebuild for new dbus
  372. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  373. - Update to 0.9.2
  374. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  375. - Update to 0.9.1
  376. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  377. - Add configure flags --with-bonobo --with-dbus
  378. - BR nautilus-cd-burner-devel
  379. - New upstream CVS snapshot for testing
  380. - Drop IDL file and ui .xml
  381. - Add dbus service file
  382. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  383. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  384. * Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  385. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  386. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  387. cell renderer for playback icon (no longer necessary) and
  388. changes the rating renderer to work with non-b&w icons
  389. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  390. - Rebuild for GCC4
  391. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  392. - New upstream version
  393. - Remove librb-nautilus-context-menu.so, killed upstream
  394. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  395. - PreReq desktop-file-utils >= 0.9
  396. * Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  397. - New upstream version
  398. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  399. - Fix postun to use correct syntax, thanks Nils Philippsen
  400. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  401. - New upstream version
  402. - Call update-desktop-database in post and postun
  403. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  404. - New upstream version
  405. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  406. - rebuilt
  407. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  408. - New upstream version
  409. - Remove backported patches
  410. - Gratuitiously bump various BuildRequires versions
  411. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  412. - Remove code to unregister GConf schema for now (Closes: #122532)
  413. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  414. - Apply tiny patch from 0.8 arch to fix GConf key used
  415. for initial sorting
  416. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  417. - Apply patch from 0.8 arch tree to fix a number of memleaks
  418. * Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  419. - Update to 0.8.3: fixes showstopper bug with internet radio
  420. * Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  421. - Update to 0.8.2
  422. - Fix Source url
  423. - Add smp_mflags
  424. - Bump BuildRequires on gstreamer to 0.8.1
  425. * Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  426. - Uninstall GConf schemas on removal
  427. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  428. - Update to 0.8.1
  429. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  430. - Update to 0.8.0
  431. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  432. - Update to 0.7.2
  433. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  434. - Remove BuildRequires on autoconf and libvorbis-devel
  435. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  436. - New major version - I know we are past major version slush, but
  437. this should have been done two weeks ago along with the GNOME 2.6
  438. upload. As upstream author as well, I believe this version is
  439. good enough for FC2.
  440. - Remove --disable-mp3
  441. - Remove id3, flac variables
  442. - Remove GStreamer major version patch
  443. - Fix typo in description
  444. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  445. - rebuild for new gstreamer
  446. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  447. - update to 0.6.8
  448. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  449. - rebuilt
  450. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  451. - update to 0.6.7
  452. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  453. - rebuilt
  454. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  455. - New upstream version
  456. - Don't re-run the autotools; upstream incorporates newer versions.
  457. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  458. - new version
  459. - remove smp_flags
  460. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  461. - remove the initial iradio channels as they all are mp3 based.
  462. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  463. - Fix category from Development/Libraries to Applications/Multimedia.
  464. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  465. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  466. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  467. - Removed unnecessary date expansion define.
  468. - Updated description, including mp3 reference removal.
  469. - Added libid3tag and flac optional support for convenient rebuild.
  470. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  471. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  472. - new version
  473. - use %{_sysconfdir} instead of /etc
  474. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  475. - rebuilt
  476. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  477. - gave up on other archs for the Beta
  478. - new version
  479. - remove werror and add missing files
  480. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  481. - update to newer cvs snap
  482. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  483. - update to cvs snap
  484. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  485. - use %%(lang)
  486. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  487. - fix post to actually install the schema
  488. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  489. - Added gconf file
  490. - Added i18n directory
  491. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  492. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  493. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  494. - removed bonobo dependency
  495. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  496. - created new spec file