nginx-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.5.6
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 20130213
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. %define passenger_version 4.0.21
  51. Source1020: passenger-%{passenger_version}.tar.gz
  52. %define upstream_fair_version 2131c73
  53. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  54. %define mod_wsgi_version 6975f0ec7eeb
  55. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  56. # removes -Werror in upstream build scripts. -Werror conflicts with
  57. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  58. Patch0: nginx-auto-cc-gcc.patch
  59. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  60. BuildRequires: pcre-devel
  61. BuildRequires: zlib-devel
  62. BuildRequires: openssl-devel
  63. BuildRequires: gd-devel
  64. BuildRequires: perl
  65. BuildRequires: perl(ExtUtils::Embed)
  66. BuildRequires: libxml2-devel
  67. BuildRequires: libxslt-devel
  68. BuildRequires: curl-devel
  69. %if %{with geoip}
  70. BuildRequires: GeoIP-devel
  71. %endif
  72. %if "%{?_dist_release}" == "vl4"
  73. Requires: perl >= 5.8.6
  74. %else
  75. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  76. %endif
  77. # for /usr/sbin/useradd
  78. Requires(pre): shadow-utils
  79. Requires(post): chkconfig
  80. # for /sbin/service
  81. Requires(preun): chkconfig, initscripts
  82. Requires(postun): initscripts
  83. %if "%{_dist_release}" > "vl6"
  84. Requires(pre): www-common
  85. %endif
  86. Provides: webserver
  87. Vendor: Project Vine
  88. Distribution: Vine Linux
  89. Packager: daisuke
  90. %description
  91. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  92. proxy server written by Igor Sysoev.
  93. %description -l ja
  94. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  95. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  96. - HTTP(S) サーバ
  97. - HTTP(S) リバースプロキシサーバ
  98. - IMAP/POP3 プロキシサーバ
  99. %package passenger
  100. Summary: Nginx with mod_passenger support
  101. Summary(ja): Passenger サポート入りの Nginx
  102. Group: System Environment/Daemons
  103. BuildRequires: ruby, rubygem-rake
  104. Requires: ruby, rubygem-rake
  105. %if "%{_dist_release}" >= "vl7"
  106. BuildRequires: ruby-devel, ruby-rubygems
  107. Requires: ruby-rubygems
  108. %else
  109. BuildRequires: rubygems
  110. Requires: rubygems
  111. %endif
  112. Requires: nginx
  113. %description passenger
  114. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  115. This package contains nginx server with passenger support.
  116. %description -l ja passenger
  117. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  118. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  119. - HTTP(S) サーバ
  120. - HTTP(S) リバースプロキシサーバ
  121. - IMAP/POP3 プロキシサーバ
  122. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  123. %prep
  124. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  125. %patch0 -p0
  126. %build
  127. # nginx does not utilize a standard configure script. It has its own
  128. # and the standard configure options cause the nginx configure script
  129. # to error out. This is is also the reason for the DESTDIR environment
  130. # variable. The configure script(s) have been patched (Patch1 and
  131. # Patch2) in order to support installing into a build environment.
  132. export DESTDIR=%{buildroot}
  133. CONFIGOPTS="\
  134. --user=%{nginx_user} \
  135. --group=%{nginx_group} \
  136. --prefix=%{nginx_datadir} \
  137. --sbin-path=%{_sbindir}/%{name} \
  138. --conf-path=%{nginx_confdir}/%{name}.conf \
  139. --error-log-path=%{nginx_logdir}/error.log \
  140. --http-log-path=%{nginx_logdir}/access.log \
  141. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  142. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  143. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  144. --pid-path=%{_localstatedir}/run/%{name}.pid \
  145. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  146. --with-file-aio \
  147. --with-ipv6 \
  148. --with-http_ssl_module \
  149. --with-http_spdy_module \
  150. --with-http_realip_module \
  151. --with-http_addition_module \
  152. --with-http_xslt_module \
  153. --with-http_image_filter_module \
  154. --with-http_sub_module \
  155. --with-http_dav_module \
  156. --with-http_flv_module \
  157. --with-http_mp4_module \
  158. --with-http_gzip_static_module \
  159. --with-http_gunzip_module \
  160. --with-http_random_index_module \
  161. --with-http_secure_link_module \
  162. --with-http_degradation_module \
  163. --with-http_stub_status_module \
  164. --with-http_perl_module \
  165. --with-http_degradation_module \
  166. %if %{with geoip}
  167. --with-http_geoip_module \
  168. %endif
  169. --with-http_auth_request_module \
  170. --with-mail \
  171. --with-mail_ssl_module \
  172. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  173. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  174. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  175. %if %{with wsgi}
  176. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  177. %endif
  178. %ifarch i686
  179. --with-cpu-opt=pentiumpro \
  180. --with-zlib-asm=pentiumpro \
  181. --with-md5-asm \
  182. --with-sha1-asm \
  183. %endif
  184. "
  185. ## build with passenger
  186. ./configure \
  187. $CONFIGOPTS \
  188. --with-cc-opt="%{optflags}" \
  189. --add-module=passenger-%{passenger_version}/ext/nginx
  190. make %{?_smp_mflags}
  191. mv objs/nginx objs/nginx.passenger
  192. ## build without passenger
  193. ./configure \
  194. $CONFIGOPTS \
  195. --with-cc-opt="%{optflags}"
  196. make %{?_smp_mflags}
  197. %install
  198. rm -rf %{buildroot}
  199. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  200. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  201. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  202. find %{buildroot} -type f -empty -exec rm -f {} \;
  203. find %{buildroot} -type f -exec chmod 0644 {} \;
  204. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  205. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  206. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  207. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  208. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  209. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  210. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  211. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  212. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  213. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  214. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  215. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  216. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  217. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  218. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  219. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  220. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  221. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  222. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  223. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  224. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  225. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  226. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  227. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  228. %if %{with wsgi}
  229. %{__install} -p -m 0644 \
  230. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  231. %{buildroot}%{nginx_confdir}
  232. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  233. %endif
  234. # upstream fair module document
  235. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  236. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  237. # convert to UTF-8 all files that give warnings.
  238. for textfile in CHANGES
  239. do
  240. mv $textfile $textfile.old
  241. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  242. rm -f $textfile.old
  243. done
  244. %clean
  245. rm -rf %{buildroot}
  246. %post
  247. if [ $1 == 1 ]; then
  248. /sbin/chkconfig --add %{name}
  249. fi
  250. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  251. %post passenger
  252. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  253. %preun
  254. if [ $1 = 0 ]; then
  255. /sbin/service %{name} stop >/dev/null 2>&1
  256. /sbin/chkconfig --del %{name}
  257. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  258. fi
  259. %preun passenger
  260. if [ $1 = 0 ]; then
  261. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  262. fi
  263. %postun
  264. if [ $1 == 2 ]; then
  265. /sbin/service %{name} upgrade || :
  266. fi
  267. %files
  268. %defattr(-,root,root,-)
  269. %doc LICENSE CHANGES README
  270. %doc README.upstream_fair
  271. %doc %{?with_wsgi:README.mod_wsgi}
  272. %{nginx_datadir}/
  273. %{_sbindir}/%{name}.normal
  274. %{_mandir}/man3/%{name}.3pm.gz
  275. %{_initrddir}/%{name}
  276. %dir %{nginx_confdir}
  277. %dir %{nginx_confdir}/conf.d
  278. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  279. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  280. %config(noreplace) %{nginx_confdir}/sites.d/*
  281. %config(noreplace) %{nginx_confdir}/win-utf
  282. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  283. %config(noreplace) %{nginx_confdir}/mime.types.default
  284. %config(noreplace) %{nginx_confdir}/fastcgi_params
  285. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  286. %config(noreplace) %{nginx_confdir}/koi-win
  287. %config(noreplace) %{nginx_confdir}/koi-utf
  288. %config(noreplace) %{nginx_confdir}/%{name}.conf
  289. %config(noreplace) %{nginx_confdir}/mime.types
  290. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  291. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  292. %config(noreplace) %{nginx_confdir}/scgi_params
  293. %config(noreplace) %{nginx_confdir}/scgi_params.default
  294. %config(noreplace) %{nginx_confdir}/uwsgi_params
  295. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  296. %if %{with wsgi}
  297. %config(noreplace) %{nginx_confdir}/wsgi_vars
  298. %endif
  299. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  300. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  301. %dir %{perl_vendorarch}/auto/%{name}
  302. %{perl_vendorarch}/%{name}.pm
  303. %{perl_vendorarch}/auto/%{name}/%{name}.so
  304. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  305. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  306. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  307. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  308. %files passenger
  309. %defattr(-,root,root,-)
  310. %doc passenger-%{passenger_version}/doc/*.txt
  311. %doc passenger-%{passenger_version}/doc/*.html
  312. %doc passenger-%{passenger_version}/doc/template
  313. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  314. %doc passenger-%{passenger_version}/doc/images
  315. %{_sbindir}/%{name}.passenger
  316. %changelog
  317. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  318. - update to 1.5.6
  319. - update passenger to 4.0.21
  320. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  321. - rebuilt with gd-2.1.0.
  322. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  323. - update to 1.4.1
  324. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  325. - update to 1.4.0
  326. - enable SPDY module
  327. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  328. - new upstream release
  329. - update passenger to 3.0.19
  330. - update ngx-fancyindex to upstream git master
  331. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  332. - new upstream release
  333. - update passenger to 3.0.17
  334. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  335. - rebuild with pcre-8.31
  336. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  337. - added http_geoip_module.
  338. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  339. - update to 1.2.4
  340. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  341. - update to 1.2.2
  342. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  343. - update to 1.2.1
  344. - change nginx user from nginx to www-data
  345. - R(pre): www-common
  346. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  347. - update to 1.2.0
  348. - update passenger to 3.0.12
  349. - drop http_upstream_keepalive
  350. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  351. - new upstream release
  352. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  353. - update to 1.0.12
  354. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  355. - update to 1.0.11
  356. - update passenger to 3.0.11
  357. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  358. - update to 1.0.10
  359. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  360. - update passenger to 3.0.9
  361. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  362. - update to 1.0.6
  363. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  364. - update to 1.0.4
  365. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  366. - add gnosek-nginx-upstream-fair module
  367. - add ngx_http_upstream_keepalive module
  368. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  369. - add nginx-passenger sub pakckage
  370. - use alternatives to choose nginx with or without passenger
  371. - add BR: ruby, rubygems, rubygem-rake
  372. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  373. - update to 1.0.2
  374. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  375. - update to 1.0.1
  376. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  377. - add bcond_with wsgi for mod_wsgi
  378. - add bcond_with passenger
  379. - you need to install rake.gem to build with this option.
  380. - add Provides: webserver
  381. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  382. - new upstream release 1.0.0!
  383. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  384. - rebuild with perl-5.12.3
  385. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  386. - update to 0.8.54
  387. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  388. - update to 0.8.53
  389. - add nginx_accept_language_module
  390. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  391. - update to 0.8.50
  392. - update ngx-fancyindex to 0.3
  393. - add BR: libxml2-devel, libxslt-devel
  394. - add scgi_params* and uwsgi_params* to %%files
  395. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  396. - update to 0.8.35 (development version)
  397. - add sites.d/ to store vitualhost settings
  398. - split out default server settings to sites.d/default
  399. - add fancyindex module
  400. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  401. - new upstream release
  402. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  403. - update to 0.7.62 (included security fix: VU#180065)
  404. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  405. - fix typo
  406. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  407. - add translated descriptions
  408. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  409. - update 404.html/50x.html to use powered by vine logo.
  410. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  411. - initial build for Vine Linux
  412. - update to 0.7.61
  413. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  414. - init script updates from Gena Makhomed
  415. - remove nginx-upstream-fair
  416. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  417. - update to 0.6.36
  418. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  419. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  420. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  421. - rebuild
  422. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  423. - update to 0.6.35
  424. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  425. - rebuild with new openssl
  426. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  427. - update to 0.6.34
  428. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  429. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  430. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  431. - update to 0.6.33
  432. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  433. - update to 0.6.32
  434. - nginx now supports DESTDIR so removed the patches that enabled it
  435. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  436. - init script fixes
  437. - resolve 'listen 80 default' [#447873]
  438. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  439. - update to 0.6.31
  440. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  441. - upate to new upstream stable branch 0.6
  442. - added 3rd party module nginx-upstream-fair
  443. - added default webpages
  444. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  445. - update init script to match recommended guidelines
  446. - add /etc/nginx/conf.d support [#443280]
  447. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  448. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  449. - add Requires for versioned perl (libperl.so)
  450. - drop silly file Requires
  451. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  452. - Autorebuild for GCC 4.3
  453. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  454. - update to 0.5.35
  455. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  456. - update to 0.5.34
  457. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  458. - Rebuild for deps
  459. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  460. - update to 0.5.33
  461. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  462. - updated to 0.5.32
  463. - fixed rpmlint UTF-8 complaints.
  464. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  465. - added --with-http_stub_status_module build option.
  466. - added --with-http_sub_module build option.
  467. - added use of pcre-config --cflags
  468. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  469. - Update to 0.5.31
  470. - specify license is BSD
  471. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  472. - Add BuildRequires: perl-devel - fixing rawhide build
  473. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  474. - Update to 0.5.30
  475. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  476. - Update to 0.5.29
  477. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  478. - Update to 0.5.28
  479. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  480. - Update to 0.5.27
  481. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  482. - Update to 0.5.26
  483. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  484. - Update to 0.5.19
  485. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  486. - Update to 0.5.17
  487. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  488. - Update to 0.5.16
  489. - add ownership of /usr/share/nginx/html (#233950)
  490. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  491. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  492. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  493. - fixed package review bugs (#233522) given by kevin@tummy.com
  494. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  495. - create patches to assist with building for Fedora
  496. - initial packaging for Fedora