python-dns-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303
  1. Name: python-dns
  2. Version: 1.10.0
  3. Release: 3%{?_dist_release}
  4. Summary: DNS toolkit for Python
  5. Summary(ja): Python 用 DNS ツールキット
  6. Group: Development/Languages
  7. License: MIT
  8. URL: http://www.dnspython.org/
  9. Source0: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
  10. Source1: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: python-setuptools
  14. BuildRequires: python-devel
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. dnspython is a DNS toolkit for Python. It supports almost all record
  19. types. It can be used for queries, zone transfers, and dynamic
  20. updates. It supports TSIG authenticated messages and EDNS0.
  21. dnspython provides both high and low level access to DNS. The high
  22. level classes perform queries for data of a given name, type, and
  23. class, and return an answer set. The low level classes allow direct
  24. manipulation of DNS zones, messages, names, and records.
  25. %prep
  26. %setup0 -q -n dnspython-%{version}
  27. # strip executable permissions so that we don't pick up dependencies
  28. # from documentation
  29. find examples -type f | xargs chmod a-x
  30. %build
  31. CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
  32. %install
  33. rm -rf %{buildroot}
  34. %{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
  35. %check
  36. pushd tests
  37. # skip one test because it queries the network
  38. for py in *.py
  39. do
  40. if [ $py != resolver.py ]
  41. then
  42. PYTHONPATH=%{buildroot}%{python_sitelib} %{__python} $py
  43. fi
  44. done
  45. %clean
  46. rm -rf %{buildroot}
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc ChangeLog LICENSE README examples
  50. %{python_sitelib}/*egg-info
  51. %{python_sitelib}/dns
  52. %changelog
  53. * Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
  54. - rebuild with VineSeed environment
  55. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  56. - add BR: python-devel, python
  57. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  58. - new upstream release
  59. * Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
  60. - initial build for Vine Linux
  61. * Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
  62. -
  63. - dnspython 1.9.4 has been released and is available at
  64. - http://www.dnspython.org/kits/1.9.4/
  65. -
  66. - There is no new functionality in this release; just a few bug fixes
  67. - in RRSIG and SIG code.
  68. -
  69. - I will be eliminating legacy code for earlier versions of DNSSEC in a
  70. - future release of dnspython.
  71. * Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
  72. -
  73. - New since 1.9.2:
  74. -
  75. - A boolean parameter, 'raise_on_no_answer', has been added to
  76. - the query() methods. In no-error, no-data situations, this
  77. - parameter determines whether NoAnswer should be raised or not.
  78. - If True, NoAnswer is raised. If False, then an Answer()
  79. - object with a None rrset will be returned.
  80. -
  81. - Resolver Answer() objects now have a canonical_name field.
  82. -
  83. - Rdata now have a __hash__ method.
  84. -
  85. - Bugs fixed since 1.9.2:
  86. -
  87. - Dnspython was erroneously doing case-insensitive comparisons
  88. - of the names in NSEC and RRSIG RRs.
  89. -
  90. - We now use "is" and not "==" when testing what section an RR
  91. - is in.
  92. -
  93. - The resolver now disallows metaqueries.
  94. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  96. * Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
  97. - It's brown paper bag time :) The fix for the import problems was
  98. - actually bad, but didn't show up in testing because the test suite's
  99. - conditional importing code hid the problem.
  100. -
  101. - Any, 1.9.2 is out.
  102. -
  103. - Sorry for the churn!
  104. * Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
  105. - New since 1.9.0:
  106. -
  107. - Nothing.
  108. -
  109. - Bugs fixed since 1.9.0
  110. -
  111. - The dns.dnssec module didn't work with DSA due to namespace
  112. - contamination from a "from"-style import.
  113. -
  114. - New since 1.8.0:
  115. -
  116. - dnspython now uses poll() instead of select() when available.
  117. -
  118. - Basic DNSSEC validation can be done using dns.dnsec.validate()
  119. - and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
  120. - later installed. Complete secure resolution is not yet
  121. - available.
  122. -
  123. - Added key_id() to the DNSSEC module, which computes the DNSSEC
  124. - key id of a DNSKEY rdata.
  125. -
  126. - Added make_ds() to the DNSSEC module, which returns the DS RR
  127. - for a given DNSKEY rdata.
  128. -
  129. - dnspython now raises an exception if HMAC-SHA284 or
  130. - HMAC-SHA512 are used with a Python older than 2.5.2. (Older
  131. - Pythons do not compute the correct value.)
  132. -
  133. - Symbolic constants are now available for TSIG algorithm names.
  134. -
  135. - Bugs fixed since 1.8.0
  136. -
  137. - dns.resolver.zone_for_name() didn't handle a query response
  138. - with a CNAME or DNAME correctly in some cases.
  139. -
  140. - When specifying rdata types and classes as text, Unicode
  141. - strings may now be used.
  142. -
  143. - Hashlib compatibility issues have been fixed.
  144. -
  145. - dns.message now imports dns.edns.
  146. -
  147. - The TSIG algorithm value was passed incorrectly to use_tsig()
  148. - in some cases.
  149. * Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
  150. - Add a patch from upstream to fix a Python 2.7 issue.
  151. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
  152. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  153. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
  154. - Fix error
  155. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
  156. - New since 1.7.1:
  157. -
  158. - Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
  159. - hmac-sha512 has been contributed by Kevin Chen.
  160. -
  161. - The tokenizer's tokens are now Token objects instead of (type,
  162. - value) tuples.
  163. -
  164. - Bugs fixed since 1.7.1:
  165. -
  166. - Escapes in masterfiles now work correctly. Previously they were
  167. - only working correctly when the text involved was part of a domain
  168. - name.
  169. -
  170. - When constructing a DDNS update, if the present() method was used
  171. - with a single rdata, a zero TTL was not added.
  172. -
  173. - The entropy pool needed locking to be thread safe.
  174. -
  175. - The entropy pool's reading of /dev/random could cause dnspython to
  176. - block.
  177. -
  178. - The entropy pool did buffered reads, potentially consuming more
  179. - randomness than we needed.
  180. -
  181. - The entropy pool did not seed with high quality randomness on
  182. - Windows.
  183. -
  184. - SRV records were compared incorrectly.
  185. -
  186. - In the e164 query function, the resolver parameter was not used.
  187. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  189. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
  190. - New since 1.7.0:
  191. -
  192. - Nothing
  193. -
  194. - Bugs fixed since 1.7.0:
  195. -
  196. - The 1.7.0 kitting process inadventently omitted the code for the
  197. - DLV RR.
  198. -
  199. - Negative DDNS prerequisites are now handled correctly.
  200. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
  201. - New since 1.6.0:
  202. -
  203. - Rdatas now have a to_digestable() method, which returns the
  204. - DNSSEC canonical form of the rdata, suitable for use in
  205. - signature computations.
  206. -
  207. - The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
  208. -
  209. - An entropy module has been added and is used to randomize query ids.
  210. -
  211. - EDNS0 options are now supported.
  212. -
  213. - UDP IXFR is now supported.
  214. -
  215. - The wire format parser now has a 'one_rr_per_rrset' mode, which
  216. - suppresses the usual coalescing of all RRs of a given type into a
  217. - single RRset.
  218. -
  219. - Various helpful DNSSEC-related constants are now defined.
  220. -
  221. - The resolver's query() method now has an optional 'source' parameter,
  222. - allowing the source IP address to be specified.
  223. -
  224. - Bugs fixed since 1.6.0:
  225. -
  226. - On Windows, the resolver set the domain incorrectly.
  227. -
  228. - DS RR parsing only allowed one Base64 chunk.
  229. -
  230. - TSIG validation didn't always use absolute names.
  231. -
  232. - NSEC.to_text() only printed the last window.
  233. -
  234. - We did not canonicalize IPv6 addresses before comparing them; we
  235. - would thus treat equivalent but different textual forms, e.g.
  236. - "1:00::1" and "1::1" as being non-equivalent.
  237. -
  238. - If the peer set a TSIG error, we didn't raise an exception.
  239. -
  240. - Some EDNS bugs in the message code have been fixed (see the ChangeLog
  241. - for details).
  242. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
  243. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  244. * Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
  245. - Rebuild for Python 2.6
  246. * Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
  247. - fix license tag
  248. * Tue Dec 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
  249. - Update to 1.6.0
  250. * Tue Oct 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
  251. - Follow new Python egg packaging specs
  252. * Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
  253. - Update to 1.5.0
  254. * Fri Dec 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
  255. - Bump release for rebuild with Python 2.5
  256. * Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
  257. - No longer ghost *.pyo files, thus further simplifying the files section.
  258. * Sat Aug 5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
  259. - Update to 1.4.0
  260. - Remove unneeded python-abi requires
  261. - Remove unneeded python_sitearch macro
  262. * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
  263. - First version for Fedora Extras