python-cssutils-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. %define betaversion b3
  3. Summary: CSS Cascading Style Sheets library for Python
  4. Summary(ja): Python 用 CSS カスケーディング・スタイル・シート ライブラリ
  5. Name: python-cssutils
  6. Version: 0.9.7
  7. Release: 3%{?betaversion:.%betaversion}%{?_dist_release}
  8. License: LGPLv3+
  9. Group: Development/Libraries
  10. URL: http://cthedot.de/cssutils/
  11. Source: http://cssutils.googlecode.com/files/cssutils-%{version}%{?betaversion:%betaversion}.zip
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. # Required at runtime for the css* executables
  14. Requires: python-setuptools
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. BuildArch: noarch
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. A Python package to parse and build CSS Cascading Style Sheets. DOM only, not
  22. any rendering facilities.
  23. %description -l ja
  24. CSS カスケーディング・スタイル・シートの作成と構文解析用の Pythonパッケージ
  25. です。ただし DOM にのみ対応しており、レンダリングには対応していません。
  26. %package doc
  27. Summary: Documentation for the CSS Cascading Style Sheets library for Python
  28. Summary(ja): Python 用 CSS カスケーディング・スタイル・シート ライブラリのドキュメント
  29. Group: Applications/Documentation
  30. %description doc
  31. This is the documentation for python-cssutils, a Python package to parse and
  32. build CSS Cascading Style Sheets.
  33. %description doc -l ja
  34. CSS カスケーディング・スタイル・シートの作成と構文解析用の Pythonパッケージ
  35. である、python-cssutils のドキュメントです。
  36. %prep
  37. %setup -q -n cssutils-%{version}%{?betaversion:%betaversion}
  38. # Convert all CRLF files, keeping original timestamps
  39. for FILE in `find . -type f -exec grep -Gl '\r\n' {} \;`; do
  40. tr -d '\r' < ${FILE} > ${FILE}.tmp
  41. touch -r ${FILE} ${FILE}.timestamp
  42. cat ${FILE}.tmp > ${FILE}
  43. touch -r ${FILE}.timestamp ${FILE}
  44. %__rm -f ${FILE}.timestamp ${FILE}.tmp
  45. done
  46. %build
  47. %{__python} setup.py build
  48. %install
  49. %{__rm} -rf ${RPM_BUILD_ROOT}
  50. %{__python} setup.py install \
  51. --single-version-externally-managed \
  52. -O1 \
  53. --skip-build \
  54. --root ${RPM_BUILD_ROOT}
  55. %clean
  56. %{__rm} -rf ${RPM_BUILD_ROOT}
  57. %files
  58. # The sources have some 2755 mode directories (as of 0.9.5.1), fix here
  59. %defattr(-,root,root,0755)
  60. %doc CHANGELOG.txt COPYING* docs/ README.txt
  61. %{_bindir}/csscapture
  62. %{_bindir}/csscombine
  63. %{_bindir}/cssparse
  64. %{python_sitelib}/cssutils-*.egg-info/
  65. %{python_sitelib}/cssutils/
  66. %{python_sitelib}/encutils/
  67. # # This is a way too generic name!
  68. # %exclude %{python_sitelib}/tests/
  69. %files doc
  70. %defattr(-,root,root,-)
  71. %doc docs/* examples/
  72. %changelog
  73. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.7-3.b3
  74. - rebuild with VineSeed environment
  75. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.7-2.b3
  76. - rebuild with python-2.7.2
  77. * Thu Aug 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.b3
  78. - new upstream release
  79. * Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.6-1
  80. - new upstream release
  81. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.5.1-2
  82. - rebuild with python-2.6
  83. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.9.5.1-1
  84. - initial build for Vine Linux based on fedora package
  85. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.9.5.1-4
  86. - Rebuild for Python 2.6
  87. * Fri Oct 10 2008 Matthias Saou <http://freshrpms.net/> 0.9.5.1-3
  88. - Add missing python-setuptools BR, split off doc sub-package (mschwendt).
  89. * Thu Oct 9 2008 Matthias Saou <http://freshrpms.net/> 0.9.5.1-2
  90. - Update license, group, add python-setuptools requirement (mschwendt).
  91. * Tue Aug 19 2008 Matthias Saou <http://freshrpms.net/> 0.9.5.1-1
  92. - Update to 0.9.5.1.
  93. * Fri Aug 8 2008 Matthias Saou <http://freshrpms.net/> 0.9.5-1
  94. - Update to 0.9.5 final.
  95. * Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.9.5b2-0.2.rc2
  96. - Convert CRLF end of lines.
  97. - Patch out #!/... magic from python files meant to be included and not run.
  98. * Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.9.5b2-0.1.rc2
  99. - Initial RPM release.