bash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584
  1. %define bashversion 4.3
  2. %define patchlevel 25
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 2%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
  17. Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
  18. Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
  19. Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
  20. Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
  21. Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
  22. Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
  23. Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
  24. Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
  25. Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
  26. Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
  27. Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
  28. Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
  29. Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
  30. Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
  31. Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
  32. Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
  33. Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
  34. Patch19: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-019
  35. Patch20: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-020
  36. Patch21: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-021
  37. Patch22: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-022
  38. Patch23: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-023
  39. Patch24: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-024
  40. Patch25: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025
  41. # Other patches
  42. Patch101: bash-2.02-security.patch
  43. Patch102: bash-2.03-paths.patch
  44. Patch103: bash-2.03-profile.patch
  45. Patch104: bash-2.05a-interpreter.patch
  46. Patch105: bash-2.05b-debuginfo.patch
  47. Patch106: bash-2.05b-manso.patch
  48. Patch107: bash-2.05b-pgrp_sync.patch
  49. Patch108: bash-2.05b-readline-oom.patch
  50. Patch109: bash-2.05b-xcc.patch
  51. Patch110: bash-3.2-audit.patch
  52. Patch111: bash-3.2-ssh_source_bash.patch
  53. Patch112: bash-bashbug.patch
  54. Patch113: bash-infotags.patch
  55. Patch114: bash-requires.patch
  56. Patch115: bash-setlocale.patch
  57. Patch116: bash-tty-tests.patch
  58. # 484809, check if interp section is NOBITS
  59. Patch117: bash-4.0-nobits.patch
  60. # Do the same CFLAGS in generated Makefile in examples
  61. Patch118: bash-4.1-examples.patch
  62. # Builtins like echo and printf won't report errors
  63. # when output does not succeed due to EPIPE
  64. Patch119: bash-4.1-broken_pipe.patch
  65. # Enable system-wide .bash_logout for login shells
  66. Patch120: bash-4.2-rc2-logout.patch
  67. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  68. Patch121: bash-4.2-coverity.patch
  69. # Don't call malloc in signal handler
  70. Patch122: bash-4.1-defer-sigchld-trap.patch
  71. # 799958, updated info about trap
  72. Patch123: bash-4.2-manpage_trap.patch
  73. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  74. Patch125: bash-4.2-size_type.patch
  75. # CVE-2014-7169
  76. # http://www.openwall.com/lists/oss-security/2014/09/25/10
  77. Patch1000: bash-eol-pushback.patch
  78. Buildroot: %{_tmppath}/%{name}-%{version}-root
  79. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  80. Obsoletes: bash <= 1.14.7
  81. Obsoletes: bash2
  82. %description
  83. Bash is a GNU project sh-compatible shell or command language
  84. interpreter. Bash (Bourne Again shell) incorporates useful features
  85. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  86. can be run by bash without modification.
  87. Bash offers several improvements over sh, including command line
  88. editing, unlimited size command history, job control, shell
  89. functions and aliases, indexed arrays of unlimited size and
  90. integer arithmetic in any base from two to 64. Bash is ultimately
  91. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  92. Tools standard.
  93. %package doc
  94. Summary: Documentation for the GNU Bourne Again shell (bash).
  95. Summary: GNU Bourne Again シェル向けドキュメント
  96. Group: Applications/Documentation
  97. Requires: %{name} = %{version}-%{release}
  98. Obsoletes: bash2-doc
  99. %description doc
  100. This is a separate documentation package for the GNU Bourne
  101. Again shell.
  102. %prep
  103. %setup -q -n %{name}-%{bashversion}
  104. # Official upstream patches
  105. %patch1 -p0 -b .001
  106. %patch2 -p0 -b .002
  107. %patch3 -p0 -b .003
  108. %patch4 -p0 -b .004
  109. %patch5 -p0 -b .005
  110. %patch6 -p0 -b .006
  111. %patch7 -p0 -b .007
  112. %patch8 -p0 -b .008
  113. %patch9 -p0 -b .009
  114. %patch10 -p0 -b .010
  115. %patch11 -p0 -b .011
  116. %patch12 -p0 -b .012
  117. %patch13 -p0 -b .013
  118. %patch14 -p0 -b .014
  119. %patch15 -p0 -b .015
  120. %patch16 -p0 -b .016
  121. %patch17 -p0 -b .017
  122. %patch18 -p0 -b .018
  123. %patch19 -p0 -b .019
  124. %patch20 -p0 -b .020
  125. %patch21 -p0 -b .021
  126. %patch22 -p0 -b .022
  127. %patch23 -p0 -b .023
  128. %patch24 -p0 -b .024
  129. %patch25 -p0 -b .025
  130. # Other patches
  131. %patch101 -p1 -b .security
  132. %patch102 -p1 -b .paths
  133. %patch103 -p1 -b .profile
  134. %patch104 -p1 -b .interpreter
  135. %patch105 -p1 -b .debuginfo
  136. %patch106 -p1 -b .manso
  137. %patch107 -p1 -b .pgrp_sync
  138. %patch108 -p1 -b .readline_oom
  139. %patch109 -p1 -b .xcc
  140. %patch110 -p1 -b .audit
  141. %patch111 -p1 -b .ssh_source_bash
  142. %patch112 -p1 -b .bashbug
  143. %patch113 -p1 -b .infotags
  144. %patch114 -p1 -b .requires
  145. %patch115 -p1 -b .setlocale
  146. %patch116 -p1 -b .tty_tests
  147. %patch117 -p1 -b .nobits
  148. %patch118 -p1 -b .examples
  149. %patch119 -p1 -b .broken_pipe
  150. %patch120 -p1 -b .logout
  151. %patch121 -p1 -b .coverity
  152. %patch122 -p1 -b .defer_sigchld_trap
  153. %patch123 -p1
  154. %patch125 -p1 -b .size_type
  155. %patch1000 -p0 -b .CVE-2014-7169
  156. echo %{version} > _distribution
  157. echo %{release} |sed 's/vl.*//' > _patchlevel
  158. %build
  159. %configure --with-bash-malloc=no
  160. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  161. %install
  162. rm -rf %{buildroot}
  163. # Fix bug #83776
  164. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  165. make DESTDIR=$RPM_BUILD_ROOT install
  166. pushd $RPM_BUILD_ROOT
  167. mkdir ./bin
  168. mv ./usr/bin/bash ./bin/bash
  169. ln -s bash ./bin/sh
  170. rm -f .%{_infodir}/dir
  171. popd
  172. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  173. # make manpages for bash builtins as per suggestion in DOC/README
  174. pushd doc
  175. sed -e '
  176. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  177. /^\.SH NAME/d
  178. s/^bash, //
  179. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  180. s/,//g
  181. b
  182. }
  183. d
  184. ' builtins.1 > man.pages
  185. for i in echo pwd test kill; do
  186. perl -pi -e "s,$i,,g" man.pages
  187. perl -pi -e "s, , ,g" man.pages
  188. done
  189. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  190. for i in `cat man.pages` ; do
  191. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  192. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  193. done
  194. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  195. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  196. # Not for printf, false and true (conflict with coreutils)
  197. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  198. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  199. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  200. popd
  201. %find_lang %{name}
  202. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  203. %clean
  204. rm -rf %{buildroot}
  205. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  206. # to prevent prereq loops
  207. # post is in lua so that we can run it without any external deps. Helps
  208. # for bootstrapping a new install.
  209. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  210. %post -p <lua>
  211. bashfound = false;
  212. shfound = false;
  213. f = io.open("/etc/shells", "r");
  214. if f == nil
  215. then
  216. f = io.open("/etc/shells", "w");
  217. else
  218. repeat
  219. t = f:read();
  220. if t == "/bin/bash"
  221. then
  222. bashfound = true;
  223. end
  224. if t == "/bin/sh"
  225. then
  226. shfound = true;
  227. end
  228. until t == nil;
  229. end
  230. f:close()
  231. f = io.open("/etc/shells", "a");
  232. if not bashfound
  233. then
  234. f:write("/bin/bash\n")
  235. end
  236. if not shfound
  237. then
  238. f:write("/bin/sh\n")
  239. end
  240. f:close()
  241. %files -f %{name}.lang
  242. %defattr(-,root,root)
  243. %doc CHANGES COPYING
  244. %doc examples
  245. %config(noreplace) /etc/bashrc
  246. /bin/bash
  247. /bin/sh
  248. %{_infodir}/bash.info*
  249. %{_mandir}/*/*
  250. %{_mandir}/*/..1*
  251. %{_bindir}/bashbug
  252. %files doc
  253. %defattr(-,root,root)
  254. %doc COMPAT NEWS NOTES POSIX RBASH
  255. %doc examples/functions/ examples/misc/
  256. %doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
  257. %doc examples/startup-files/ examples/complete/ examples/loadables/
  258. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  259. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  260. %changelog
  261. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  262. - added patch1000 to fix CVE-2014-7169.
  263. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  264. - updated to 4.3 patch level 25
  265. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  266. - update to 4.3 patch level 18
  267. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  268. - update to 4.3 patch level 11
  269. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  270. - update to 4.2 patch level 45
  271. - import some patch from fedora package (122-127)
  272. - patch122: Don't call malloc in signal handler
  273. - patch123: #799958, updated info about trap
  274. - patch124: #695656, block the signal and unblock it after the
  275. new handler is installed
  276. - patch125: Use unsigned type for size
  277. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  278. - patch126: #903833, Fix missing close(), fixes fd leaks
  279. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  280. - remove postun lua script because bash will be never uninstalled
  281. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  282. - update to 4.2 patch level 37
  283. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  284. - update to 4.2 patch level 20
  285. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  286. - update to 4.2 patch level 8
  287. - use lua script in post/postun
  288. - update patches from fedora
  289. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  290. - update to 4.1 patch level 7
  291. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  292. - check if /bin/grep exists on %%post script
  293. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  294. - rebuilt with gcc-4.4.3-3 on ppc
  295. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  296. - rebuilt with new toolchain
  297. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  298. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  299. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  300. - add Requires(post): grep
  301. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  302. - remove obsolete /bin/bash2 entry from /etc/shells
  303. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  304. - add Requires(post): ncurses (should be added by find-requires..)
  305. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  306. - add upstream patch (from 040 to 048)
  307. - build against ncurses-devel (libtinfo)
  308. - spec in utf-8
  309. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  310. - added upstream patch (from 026 to 039)
  311. - added Japanese summary
  312. - applied new versioning policy
  313. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  314. - rebuilt with libtermcap-devel
  315. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  316. - new upstream release
  317. - add upstream patch (from 001 to 025)
  318. - remove Provides: bash2
  319. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  320. - rebuilt with new toolchain
  321. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  322. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  323. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  324. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  325. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  326. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  327. - update to 2.05b
  328. - rebuild with new toolchains
  329. - add make check
  330. - add %postun script based on Fedora development
  331. - README file moved doc package
  332. - update Patch5 and Patch8 from Fedora development
  333. - change Patch6
  334. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  335. - add Patch11--39 from Fedora development 2.05b-36
  336. * Tim Waugh <twaugh@redhat.com>
  337. - Fix parameter expansion in multibyte locales (bug #112657).
  338. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  339. bug #110777).
  340. - Apply upstream patches (bug #109269 among others).
  341. - Fix bash.info (bug #83776).
  342. - Add bash205b-007 patch to fix bug #106876.
  343. - Avoid crashing on multibyte input when locale is set incorrectly
  344. (bug #74266).
  345. - LFS support (bug #103627).
  346. - Fix completion display when multibyte or control characters are to be
  347. shown (bug #90201).
  348. - Fix a warning message (bug #79629).
  349. - Don't build with AFS support (bug #86514).
  350. - Don't explicitly strip binaries (bug #85995).
  351. - Really fix bug #83331 for good.
  352. - Fix builtins.1.
  353. - Actually apply the patch (bug #83331).
  354. - Fix history/UTF-8 bug (bug #83331).
  355. - More tab-completion fixing (bug #72512).
  356. - Force pgrp synchronization (bug #81653).
  357. - Prevent prompt overwriting output (bug #74383).
  358. - Fix '-rbash' (bug #78455).
  359. - Add readline-init patch (bug #74925).
  360. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  361. - Ship '.' man page, which doesn't get picked up by glob.
  362. - Locale shell variables fix (bug #74701).
  363. * Elliot Lee <sopwith@redhat.com>
  364. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  365. cross compiles.
  366. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  367. - update to 2.05
  368. - add README.jpatch to %doc
  369. - remove patch4 (bash2): revert command name in man pages to "bash"
  370. - fix perl command to remove man pages conflict with sh-utils
  371. - remove section of config.h.in from patch0 to prevent remake of configure
  372. - change patch9: define in config-top.h to avoid conflict with patch100
  373. - remove patches 7, 10 & 101
  374. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  375. - made a link for man sh
  376. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  377. - added missing %%post and %%triggerpostun section
  378. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  379. - 2.04-1vl12
  380. - now bash2 is finally bash
  381. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  382. - build for Playstation2
  383. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  384. - 2.04-1vl10
  385. - Provides: bash = %%{version}
  386. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  387. - added Provides: bash
  388. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  389. - Obsoletes: bash
  390. - changed Copyright to License
  391. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  392. - 2.04-1vl7
  393. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  394. - corrected: bashrc-vine -> bashrc
  395. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  396. - combined bash-1.x and bash-2.x packages
  397. - added some patches from bash-2.04-13mdk
  398. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  399. - fix spec macros
  400. - added tests
  401. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  402. - build with gcc-2.95.3
  403. - partially used rpmmacros
  404. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  405. - minor bug fix in spec file
  406. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  407. - 2.04-1vl3
  408. - modified %install and %files section to handle compressed man page(s)
  409. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  410. - added pcomplete patch to fix complete if the candidate list is NULL.
  411. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  412. - updated to 2.04
  413. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  414. - Remove annoying ^H's from documentation
  415. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  416. - patch to detect what executables are required by a script.
  417. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  418. - auto rebuild in the new build environment (release 4)
  419. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  420. - strip binaries.
  421. - include bash-doc correctly.
  422. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  423. - fixed post/postun /etc/shells work.
  424. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  425. - updated again text in the spec file
  426. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  427. - updated text in spec file.
  428. - update to 2.03.
  429. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  430. - build it as bash2 instead of bash
  431. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  432. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  433. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  434. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  435. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  436. - patch for the arm
  437. - use $RPM_ARCH-redhat-linux as the build target
  438. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  439. - rewrite %pre, axe %postun (to avoid prereq loops)
  440. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  441. - resurrect for RH 6.0.
  442. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  443. - update to 2.02.1
  444. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  445. - Package for 5.2.
  446. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  447. - added POSIX.NOTES doc file
  448. - some extraneous doc files removed
  449. - minor .spec file changes
  450. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  451. - upgraded to version 2.02
  452. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  453. - glibc & signal patches no longer required
  454. - added documentation subpackage (doc)
  455. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  456. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  457. is based on a change made in bash 2.0. Should fix some early exit
  458. problems with suspends and fg.
  459. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  460. - added %clean
  461. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  462. - added comment explaining why install-info isn't used
  463. - added mips patch
  464. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  465. - added BuildRoot
  466. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  467. - built against glibc