R-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. %define pkg_version 2.12.1
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: A language for data analysis and graphics
  4. Summary(ja): データ解析・グラフィック化の言語
  5. Name: R
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
  9. #Patch0: R-release.diff.gz
  10. License: GPLv2+
  11. Group: Applications/Engineering
  12. URL: http://www.r-project.org
  13. Requires: libgfortran
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: gcc-gfortran libgfortran
  17. %if %{?_dist_release} == "vl5"
  18. BuildRequires: tetex
  19. %else
  20. BuildRequires: texlive
  21. BuildRequires: texlive-collection-basic
  22. BuildRequires: texlive-collection-texinfo
  23. %endif
  24. BuildRequires: texinfo tcl tk
  25. BuildRequires: libpng-devel libjpeg-devel libtiff-devel
  26. BuildRequires: readline-devel libtermcap-devel
  27. BuildRequires: zlib-devel bzip2-devel
  28. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  29. BuildRequires: cairo-devel pango-devel
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: Toshiaki Ara <ara_t@384.jp>
  33. %description
  34. 'GNU S' - A language and environment for statistical computing and
  35. graphics. R is similar to the award-winning S system, which was
  36. developed at Bell Laboratories by John Chambers et al. It provides
  37. a wide variety of statistical and graphical techniques (linear and
  38. nonlinear modelling, statistical tests, time series analysis,
  39. classification, clustering, ...).
  40. R is designed as a true computer language with control-flow
  41. constructions for iteration and alternation, and it allows users to
  42. add additional functionality by defining new functions.
  43. For computationally intensive tasks, C, C++ and Fortran code
  44. can be linked and called at run time.
  45. %description -l ja
  46. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  47. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  48. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  49. 幅広い統計解析・視覚化手法を提供する。
  50. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  51. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  52. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  53. 使用することができる。
  54. %package devel
  55. Summary: files for development of R packages.
  56. Summary(ja): Rパッケージ開発用ファイル
  57. Group: Development/Libraries
  58. Requires: R = %{version}-%{release}
  59. %description devel
  60. Install R-devel if you are going to develop or compile R packages.
  61. This is just a stub package containing the documentation on "Writing R
  62. Extensions". However, installing it will ensure that the build
  63. environment for R packages is correct.
  64. %description -l ja devel
  65. Rパッケージを開発したりコンパイルする場合には、このR-develを
  66. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  67. が含まれているだけのサブパッケージですが、正しくRパッケージを
  68. 開発するための助けになるでしょう。
  69. %package -n libRmath
  70. Summary: standalone math library from the R project
  71. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  72. Group: System Environment/Libraries
  73. %description -n libRmath
  74. A standalone library of mathematical and statistical functions derived
  75. from the R project. This packages provides the shared libRmath library.
  76. %description -l ja -n libRmath
  77. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  78. 共有ライブラリを提供する。
  79. %package -n libRmath-devel
  80. Summary: standalone math library from the R project
  81. Summary(ja): libRmathの開発ライブラリ
  82. Group: Development/Libraries
  83. Requires: libRmath = %{version}-%{release}
  84. %description -n libRmath-devel
  85. A standalone library of mathematical and statistical functions derived
  86. from the R project. This packages provides the header files.
  87. %description -l ja -n libRmath-devel
  88. libRmathのヘッダファイル(Rmath.h)
  89. %package -n libRmath-static
  90. Summary: Static R Standalone math library
  91. Summary(ja): libRmath の静的ライブラリ
  92. Group: Development/Libraries
  93. Requires: libRmath-devel = %{version}-%{release}
  94. %description -n libRmath-static
  95. A standalone library of mathematical and statistical functions derived
  96. from the R project. This package provides the static libRmath library.
  97. %prep
  98. %{__rm} -rf ${RPM_BUILD_ROOT}
  99. %setup -q
  100. #%patch0 -p1
  101. %build
  102. export R_PDFVIEWER="%{_bindir}/xdg-open"
  103. export R_PRINTCMD="lpr"
  104. export R_BROWSER="%{_bindir}/xdg-open"
  105. %configure --enable-R-shlib
  106. %{__make} %{?_smp_mflags}
  107. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  108. LANG=C make check-all
  109. %{__make} pdf
  110. #We can only "make info" if we have an up to date version of texinfo
  111. %{?INFO: %{__make} info}
  112. %install
  113. %{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
  114. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  115. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  116. #Install libRmath files
  117. (cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
  118. mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  119. echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  120. #Fix lication of R_HOME_DIR in shell wrapper
  121. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  122. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  123. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  124. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  125. > ${RPM_BUILD_ROOT}%{_bindir}/R
  126. chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  127. %files
  128. %defattr(-, root, root)
  129. %{_bindir}/R
  130. %{_bindir}/Rscript
  131. %{_libdir}/R
  132. %{?INFO:%{_infodir}/R-*.info*}
  133. %{_mandir}/man1/*
  134. /etc/ld.so.conf.d/*
  135. %files devel
  136. %defattr(-, root, root)
  137. %doc doc/manual/R-exts.pdf
  138. %files -n libRmath
  139. %defattr(-, root, root)
  140. %{_libdir}/libRmath.so
  141. %files -n libRmath-devel
  142. %defattr(-, root, root)
  143. %{_libdir}/pkgconfig/*.pc
  144. %{_includedir}/Rmath.h
  145. %files -n libRmath-static
  146. %defattr(-, root, root)
  147. %{_libdir}/libRmath.a
  148. %clean
  149. %{__rm} -rf ${RPM_BUILD_ROOT}
  150. %post
  151. %if 0%{?INFO}
  152. # Create directory entries for info files
  153. # (optional doc files, so we must check that they are installed)
  154. for doc in admin data exts FAQ intro lang; do
  155. file=%{_infodir}/R-${doc}.info.gz
  156. if [ -e $file ]; then
  157. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  158. fi
  159. done
  160. %endif
  161. %{_syssbindir}/ldconfig
  162. %preun
  163. %if 0%{?INFO}
  164. if [ $1 = 0 ]; then
  165. # Delete directory entries for info files (if they were installed)
  166. for doc in admin data exts FAQ intro lang; do
  167. file=%{_infodir}/R-${doc}.info.gz
  168. if [ -e ${file} ]; then
  169. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  170. fi
  171. done
  172. fi
  173. %endif
  174. %postun -p %{_syssbindir}/ldconfig
  175. %post -n libRmath -p %{_syssbindir}/ldconfig
  176. %postun -n libRmath -p %{_syssbindir}/ldconfig
  177. %changelog
  178. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  179. - synchronized to VinePlus/5 package
  180. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  181. - Updated to 2.12.1
  182. - added --enable-R-shlib option to %%configure
  183. - added static subpackage
  184. - use BR: texlive instead of tetex on VineSeed
  185. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  186. - rebuilt with rpm-4.8.1 for pkg-config
  187. * Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  188. - recompiled because tcl/tk were not linked
  189. * Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  190. - Updated to 2.11.0
  191. - added Requires: libgfortran
  192. * Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  193. - Updated to 2.10.1
  194. * Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  195. - patched to 2.10.0
  196. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  197. - spec in UTF-8
  198. * Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  199. - Updated to 2.10.0
  200. * Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  201. - Updated to 2.9.2
  202. - deleted BuildRequires: lapack-devel blas-devel
  203. - rewrote SPEC file
  204. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  205. - Updated to 2.5.1
  206. - added BuildRequires: gcc-gfortran for VineSeed
  207. - added BuildRequires: lapack-devel blas-devel
  208. - fixed %preun script
  209. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  210. - Updated to 2.4.1
  211. - Added INFO option
  212. - Exclude Japanese Rprofile.site
  213. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  214. - Updated to 2.4.0
  215. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  216. - Added optimization flags
  217. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  218. - Packaged for VineLinux3.2
  219. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  220. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  221. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  222. - Packaged for VineLinux3.2
  223. - Slipped texinfo
  224. - Fixed preun error
  225. - Preset Japanese fonts
  226. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  227. - Packaged for VineLinux3.2
  228. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  229. - Restored CAPABILITIES file lost in 2.2.1beta
  230. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  231. - Configure uses --without-blas by default.
  232. - Install pdf manuals.
  233. - All toplevel documentation files are installed into _libdir/R
  234. as they may be required by R (qv note on AUTHORS and THANKS below).
  235. - Legacy scripts for rebuilding package indices removed.
  236. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  237. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  238. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  239. - The files AUTHORS and THANKS need to be installed into _libdir/R
  240. as they are required by the function contributors(). Previously
  241. they were installed only as documentation files.
  242. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  243. - Corrected date error in SPEC file.
  244. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  245. - Dropped support for Red Hat boxed set.
  246. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  247. including support for shared R library.
  248. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  249. with the default optimization flags, so there is a temporary work-around.
  250. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  251. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  252. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  253. - Install R-data.info file as well.
  254. - Make info processing conditional on texinfo version, not platform release,
  255. so that if a new enough version is installed, we will build and install info.
  256. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  257. - Built R 2.1.0. R now supports internationalization, so the patch
  258. to set the locale to "C" is now dropped.
  259. - install.packages() exits gracefully with a helpful message if
  260. the file INSTALL is not present, so this is now included in the
  261. R-devel package.
  262. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  263. - Added support for Scientific Linux (http://www.scientificlinux.org)
  264. A distribution based on RHEL. Thanks to Jon Peatfield.
  265. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  266. - Fixed file ownership in R-devel and libRmath packages
  267. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  268. - R-devel package is now a stub package with no files, except a documentation
  269. file (RPM won't accept sub-packages with no files). R now conflicts
  270. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  271. - Created libRmath subpackage with shared library.
  272. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  273. - Created R-devel and libRmath-devel subpackages
  274. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  275. - Built R 2.0.1
  276. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  277. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  278. gives "lpr".
  279. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  280. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  281. - Info support is now conditional on the macro Rinfo, which is only
  282. defined for Fedora 1 and 2.
  283. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  284. - Built R 2.0.0
  285. - There is no longer a BUGS file, so this is not installed as a
  286. documentation file.