yatex-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366
  1. %define _noVersionedDependencies 1
  2. #% define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %if %{?_dist_release} <= "vl5"
  4. exit 1
  5. %endif
  6. Name: yatex
  7. Version: 1.76
  8. Release: 1.20120511%{?_dist_release}
  9. License: Distributable
  10. #Source0: http://www.yatex.org/yatex%{version}.tar.gz
  11. Source0: http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
  12. Source1: %{name}-install.sh
  13. Source2: %{name}-remove.sh
  14. Source3: %{name}-init.el
  15. Source4: vine-default-%{name}.el
  16. Source5: vine-default-yahtml.el
  17. ## Vine Patch(es)
  18. Patch1: yatexhlp-emacs.diff
  19. Patch2: yatex-make.diff
  20. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  21. # and modified to suit 1.70 release
  22. Patch3: yahtml-1.70-timestamp.patch
  23. Patch10: yatex-1.76-vine-vl7.patch
  24. Patch11: yatex-1.76-vine-vl6.patch
  25. URL: http://www.yatex.org/
  26. Group: Applications/Editors/Emacs
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. Summary: YaTeX - Yet Another TeX mode for Emacs
  29. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  30. BuildArch: noarch
  31. Requires(post): emacsen
  32. Requires(post): emacsen-common
  33. Requires(post): make
  34. BuildRequires: emacsen-common
  35. BuildRequires: nkf perl
  36. Obsoletes: yatex-xemacs
  37. Distribution: Vine Linux
  38. Vendor: Project Vine
  39. Packager: munepi
  40. %description
  41. YaTeX is an intelligent, acquisitive and integrated package which reduces
  42. your efforts of composing LaTeX source on GNU Emacs.
  43. If you are YaTeX user and you install both yatex and auctex on your system,
  44. you may add the following configure in your emacs init file
  45. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  46. ;; I am a YaTeX user!!!
  47. (setq vine-default-auctex nil
  48. vine-default-preview-latex nil)
  49. %description -l ja
  50. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  51. してくれる、LaTeX 入力支援環境です。
  52. yatex と auctex パッケージの両方をインストールする場合、
  53. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  54. に以下の設定を追加するとよいでしょう。
  55. ;; YaTeX ユーザです!!!
  56. (setq vine-default-auctex nil
  57. vine-default-preview-latex nil)
  58. %prep
  59. %setup -n yatex%{version}
  60. %patch1 -p1
  61. %patch2 -p1
  62. %patch3 -p1
  63. %if %{?_dist_release} == "vl7"
  64. %patch10 -p1 -b .vine
  65. %elseif %{?_dist_release} == "vl6"
  66. %patch11 -p1 -b .vine
  67. %endif
  68. (cd docs
  69. # change permissions
  70. chmod 644 *
  71. # encode as utf-8 (LF)
  72. # NOTE: This changes needs to entry info files to Info DIR
  73. for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
  74. )
  75. %build
  76. %install
  77. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  78. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  79. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  80. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  81. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  82. #
  83. # install el files
  84. #
  85. %__cp -a *.el makefile help \
  86. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  87. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  88. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  89. #
  90. # install info files
  91. #
  92. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  93. ${RPM_BUILD_ROOT}%{_infodir}
  94. #
  95. # install script (bytecompile el and install elc, remove)
  96. #
  97. %_installemacsenscript %{name} %{SOURCE1}
  98. %_removeemacsenscript %{name} %{SOURCE2}
  99. %clean
  100. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  101. %post
  102. #
  103. # bytecompile and install
  104. #
  105. if [ "$1" = 2 ] ; then
  106. %_emacsenPackageRemove %{name}
  107. fi
  108. %_addemacsenlist %{name}
  109. %_emacsenPackageInstall %{name}
  110. for i in yatexe yatexj yahtmle yahtmlj; do
  111. /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
  112. %{_infodir}/${i}.gz
  113. done
  114. %preun
  115. if [ "$1" = 0 ]; then
  116. %_emacsenPackageRemove %{name}
  117. %_removeemacsenlist %{name}
  118. for i in yatexe yatexj yahtmle yahtmlj; do
  119. /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
  120. %{_infodir}/${i}.gz
  121. done
  122. fi
  123. %files
  124. %defattr(-,root,root)
  125. %doc 00readme install manifest yatex.new
  126. %doc docs
  127. %{_datadir}/emacs/site-lisp/yatex/
  128. %{_infodir}/yahtmle*
  129. %{_infodir}/yahtmlj*
  130. %{_infodir}/yatexe*
  131. %{_infodir}/yatexj*
  132. %{emacsen_pkgdir}/install/%{name}
  133. %{emacsen_pkgdir}/remove/%{name}
  134. %changelog
  135. * Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
  136. - source snapshot 20120511: testing version 1.76 development
  137. - dropped obsoleted/upstreamed patches
  138. - applied yatex-1.76-vine-vl{6,7}.patch
  139. * Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
  140. - added BuildRequires: nkf perl
  141. - updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
  142. - dropped pre-formatted info files
  143. - use original info files
  144. - encode info files as utf-8
  145. - add INFO-DIR-ENTRY
  146. * Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
  147. - fixed vine-default-yatex.el
  148. - applied yatex-1.74-vine.patch for vl6
  149. - updated yatex-1.74-vine.patch: support some extensions for \includegraphics
  150. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
  151. - new upstream release
  152. - updated vine-default-yatex.el
  153. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
  154. - support TeX Live 2011
  155. - applied yatex-1.74-vine-vl7.patch
  156. - updated vine-default-yatex.el
  157. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  158. - added Requires(post): make
  159. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  160. - updated vine-default-yatex.el
  161. - check 'YaTeX-inhibit-prefix-letter
  162. - used "pbibtex -kanji=utf8" as default bibtex-command
  163. - used "mendex -U" as default makeindex-command
  164. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  165. - updated vine-default-{yatex,yahtml}.el
  166. - revived auto-fill-mode on {yatex,yahtml}-mode
  167. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  168. - updated yatex-init.el
  169. - dropped all pathes of auctex and preview-latex from load-path
  170. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  171. - updated vine-default-yatex.el
  172. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  173. - supported TeX Live
  174. - used "eplatex", "pxdvi", "pdvips" as default commands
  175. - updated yatex-init.el
  176. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  177. - defined vine-default-yahtml
  178. - added vine-default-yahtml.el
  179. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  180. - updated vine-default-yatex.el
  181. - added bbl extension in auto-mode-alist to run yatex-mode
  182. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  183. - updated vine-default-yatex.el
  184. - supported new vine-default
  185. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  186. - new upstream release
  187. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  188. - updated vine-default-yatex.el
  189. - dropped (setq YaTeX-no-begend-shortcut t)
  190. - use %{emacsen_pkgdir}
  191. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  192. - updated vine-default-yatex.el
  193. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  194. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  195. - updated yatex-install.sh
  196. - *-init.el: changed from hard copy to symbolic link
  197. on /etc/emacs-XX.YY/site-start.d
  198. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  199. - fixed yatex-init.el
  200. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  201. - added yatex-init.el, vine-default-yatex.el
  202. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  203. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  204. - spec in utf8
  205. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  206. - applied new versioning policy
  207. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  208. - new upstream release
  209. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  210. - s/Copyright/License/
  211. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  212. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  213. - update yatex-1.72
  214. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  215. - update yatex-1.71
  216. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  217. - added Patch3 to add hhmts timestamp feature
  218. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  219. - update yatex-1.70
  220. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  221. - update yatex10203151806
  222. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  223. - fixed: bytecompile yatex19
  224. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  225. - now emacsen-common aware
  226. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  227. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  228. - 1.68-0vl2
  229. - no kanji code conversion of documents
  230. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  231. - 1.68-0vl1
  232. - update to 1.68
  233. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  234. - 1.67-6vl5
  235. - YATEXHLP.{jp,eng} moved to appropriate dir
  236. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  237. - 1.67-6vl3
  238. - rebuilt for emacs-20.7
  239. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  240. - 1.67-6vl2
  241. - oops ... fixed target dir for help files
  242. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  243. - 1.67-6vl1
  244. - rebuilt for emacs-20.6
  245. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  246. - 1.67-6
  247. - included forgotten info file for YaHTML
  248. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  249. - 1.67-5
  250. - updated for emacs-20.5a release
  251. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  252. - 1.67-4
  253. - change Group to Applications/Editors/EmacsLisp
  254. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  255. - 1.67-3
  256. - %post and %preun section modified
  257. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  258. - 1.67-2
  259. - fixed minor problem in the %files section
  260. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  261. - 1.67-1
  262. - updated to 1.67 release
  263. - rebuilt for emacs-20.4 on Vine Linux 1.9
  264. - updated URL for the new web site of YaTeX
  265. - some typo fix
  266. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  267. - Initial Release