subversion-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494
  1. %define neon_version 0.25.5
  2. %define swig_version 1.3.29
  3. %define apache_dir /usr
  4. %define db_version 4.3.29
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.6.17
  12. Release: 1%{?_dist_release}
  13. License: ASL 1.1
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Packager: iwaim
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch1: subversion-1.6.0-deplibs.patch
  24. Patch3: subversion-1.6.1-rpath.patch
  25. Patch6: subversion-1.5.0-pie.patch
  26. Patch10: subversion-1.5.7-update-neon-m4.patch
  27. Requires: db4 >= %{db_version}
  28. Requires: expat
  29. Requires: neon >= %{neon_version}
  30. BuildRequires: apache2-devel
  31. BuildRequires: apr-devel, apr-util-devel
  32. BuildRequires: autoconf >= 2.53
  33. BuildRequires: db4-devel >= %{db_version}
  34. BuildRequires: expat-devel
  35. BuildRequires: gdbm-devel
  36. BuildRequires: libtool >= 1.4.2
  37. BuildRequires: neon-devel >= %{neon_version}
  38. BuildRequires: openssl-devel
  39. BuildRequires: python
  40. BuildRequires: python-devel
  41. BuildRequires: swig >= %{swig_version}
  42. BuildRequires: texinfo
  43. BuildRequires: zlib-devel
  44. BuildRequires: openldap-devel
  45. BuildRequires: ruby >= 1.8.2
  46. BuildRequires: ruby-devel >= 1.8.2
  47. BuildRequires: perl >= 5.8.0
  48. BuildRequires: sqlite3-devel
  49. BuildRequires: krb5-devel
  50. BuildRequires: keyutils-libs-devel
  51. BuildRequires: dbus-devel
  52. BuildRequires: libgnome-keyring-devel
  53. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  54. %define __perl_requires %{SOURCE3}
  55. %description
  56. Subversion is a concurrent version control system which enables one
  57. or more users to collaborate in developing and maintaining a
  58. hierarchy of files and directories while keeping a history of all
  59. changes. Subversion only stores the differences between versions,
  60. instead of every complete file. Subversion is intended to be a
  61. compelling replacement for CVS.
  62. %package devel
  63. Group: Development/Libraries
  64. Summary: Development package for Subversion developers.
  65. Requires: subversion = %{version}-%{release}
  66. Requires: apr-devel, apr-util-devel
  67. %description devel
  68. The subversion-devel package includes the static libraries and include files
  69. for developers interacting with the subversion package.
  70. %package mod_dav_svn
  71. Group: System Environment/Daemons
  72. Summary: Apache server module for Subversion server.
  73. Requires: httpd >= %{apache_version}
  74. Requires: subversion = %{version}-%{release}
  75. %description mod_dav_svn
  76. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  77. the Apache directories and configuration.
  78. %package tools
  79. Group: Development/Tools
  80. Summary: Tools for Subversion
  81. BuildRequires: perl >= 5.8.0
  82. Requires: perl >= 5.8.0
  83. Requires: subversion = %{version}-%{release}
  84. %description tools
  85. Tools for Subversion.
  86. %package perl
  87. Group: Development/Libraries
  88. Summary: Perl bindings to the Subversion libraries
  89. Requires: subversion = %{version}-%{release}
  90. Requires: perl >= 5.8.0
  91. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  92. %description perl
  93. This package includes the Perl bindings to the Subversion libraries.
  94. %package ruby
  95. Group: Development/Libraries
  96. Summary: Ruby bindings to the Subversion libraries
  97. Requires: subversion = %{version}-%{release}
  98. Requires: ruby >= 1.8.2
  99. %description ruby
  100. This package includes the Ruby bindings to the Subversion libraries.
  101. %package python
  102. Group: Development/Libraries
  103. Summary: Python bindings to the Subversion libraries
  104. Requires: subversion = %{version}-%{release}, python
  105. %description python
  106. This package includes the Python bindings to the Subversion libraries.
  107. %prep
  108. %setup -q
  109. %patch1 -p1 -b .deplibs
  110. %patch3 -p1 -b .rpath
  111. ## comment out: 1.6.9-1
  112. #%patch6 -p1 -b .pie
  113. ## comment out: 1.6.9-1
  114. #%patch10 -p1 -b .nola
  115. rm -rf neon apr apr-util db4
  116. %build
  117. ./autogen.sh
  118. # fix shebang lines, #111498
  119. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  120. # override weird -shrext from ruby
  121. export svn_cv_ruby_link="%{__cc} -shared"
  122. export svn_cv_ruby_sitedir_libsuffix=""
  123. export svn_cv_ruby_sitedir_archsuffix=""
  124. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
  125. export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
  126. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  127. --with-swig --with-neon=%{_prefix} \
  128. --with-ruby-sitedir=%{rarchdir} \
  129. --with-apxs=%{_bindir}/apxs \
  130. --with-gnome-keyring \
  131. --disable-mod-activation \
  132. --disable-static \
  133. --disable-neon-version-check
  134. # 1.3.0 tarball ships with generated swig sources
  135. make extraclean-swig-headers
  136. make %{?_smp_mflags} all
  137. make swig-py swig-py-lib %{swigdirs}
  138. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  139. %install
  140. echo %{rarchdir}
  141. rm -rf $RPM_BUILD_ROOT
  142. make install \
  143. install-swig-py \
  144. install-swig-pl-lib \
  145. install-swig-rb \
  146. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  147. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  148. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  149. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  150. # Add subversion.conf configuration file into httpd/conf.d directory.
  151. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  152. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  153. # Set up tools package files.
  154. mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
  155. cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
  156. # Remove unpackaged files
  157. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  158. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  159. $RPM_BUILD_ROOT%{_libdir}/*.la
  160. # remove stuff produced with Perl modules
  161. find $RPM_BUILD_ROOT -type f \
  162. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  163. -print0 | xargs -0 rm -f
  164. # make Perl modules writable so they get stripped
  165. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  166. xargs -0 chmod 755
  167. # unnecessary libraries for swig bindings
  168. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  169. # Remove unnecessary ruby libraries
  170. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  171. # Trim what goes in docdir
  172. rm -rf tools/*/*.in tools/test-scripts
  173. # Rename authz_svn INSTALL doc for docdir
  174. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  175. %clean
  176. rm -rf $RPM_BUILD_ROOT
  177. %post -p /sbin/ldconfig
  178. %postun -p /sbin/ldconfig
  179. %post tools -p /sbin/ldconfig
  180. %postun tools -p /sbin/ldconfig
  181. %files
  182. %defattr(-,root,root)
  183. %doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
  184. %doc subversion/LICENSE
  185. %{_bindir}/*
  186. %{_libdir}/libsvn_*.so.*
  187. %{_localedir}/*/*/subversion.mo
  188. %{_mandir}/man*/*
  189. %dir %{_sysconfdir}/subversion
  190. %exclude %{_mandir}/man*/*::*
  191. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  192. %exclude %{_libdir}/libsvn_swig_py*.so.*
  193. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  194. %files devel
  195. %defattr(-,root,root)
  196. %{_includedir}/subversion-1
  197. %{_libdir}/libsvn*.so
  198. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  199. %exclude %{_libdir}/libsvn_swig_py*.so.*
  200. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  201. %files mod_dav_svn
  202. %defattr(-,root,root)
  203. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  204. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  205. %files tools
  206. %defattr(-,root,root)
  207. %{_prefix}/lib/subversion/tools
  208. %files perl
  209. %defattr(-,root,root,-)
  210. %{perl_vendorarch}/auto/SVN
  211. %{perl_vendorarch}/SVN
  212. %{_libdir}/libsvn_swig_perl*
  213. %{_mandir}/man*/*::*
  214. %files ruby
  215. %defattr(-,root,root,-)
  216. %{_libdir}/libsvn_swig_ruby*
  217. %{rarchdir}/svn
  218. %files python
  219. %defattr(-,root,root,-)
  220. %{_libdir}/libsvn_swig_py*
  221. %{python_sitearch}/libsvn
  222. %{python_sitearch}/svn
  223. %changelog
  224. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  225. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  226. - add configure option with-gnome-keyring
  227. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  228. - fix Packager name
  229. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  230. - build with perl 5.12.3
  231. - add Requires: perl(:MODULE_COMPAT_...)
  232. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  233. - new upstream release with security fix
  234. - add Vendor/Distri tags
  235. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  236. - new upstream release
  237. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  238. - fix <BTS:VineLinux:941>
  239. - using rpm macro: rarchdir
  240. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  241. - using rpm macros: perl_vendorarch and python_sitearch
  242. - add BuildRequires: sqlite3-devel krb5-devel
  243. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  244. - new upstream release
  245. - update URL
  246. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  247. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  248. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  249. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  250. * Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  251. - new upstream release
  252. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  253. - new upstream release
  254. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  255. - rebuilt with python-2.5.2
  256. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  257. - new upstream release
  258. - rebuild with neon-0.28.2
  259. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  260. - added Patch6, 8, 9, 10 from Fedora Core
  261. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  262. - Correct install location of java stuff (#433295)
  263. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  264. - fix build with new glibc open()-as-macro
  265. - build all swig code in %%build, not %%install
  266. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  267. - build /usr/bin/* as PIEs
  268. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  269. - rebuild with expat-2.0.1
  270. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  271. - new upstream release
  272. - add Patch10 to build with neon.
  273. 1.3.2-0vl5 does not support neon..
  274. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  275. - rebuild with new neon
  276. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  277. - rebuilt with new toolchain and db4-4.3.x
  278. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  279. - modified %%files section for lib64 architecture
  280. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  281. - new upstream release
  282. - rebuild with new openldap-2.3.24
  283. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  284. - new upstream release
  285. - change Group to Develoment/Tools
  286. - build with apr-1.2.7/apr-util-1.2.7
  287. - require apr/apr-util instead of apache2-apr
  288. - build with swig-1.3.29
  289. - split {perl,python,ruby} related files to subpackage.
  290. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  291. - new upstream release
  292. - add noreplace option for config file
  293. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  294. - fix Requires and BuildPreReq.
  295. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  296. - new upstream release.
  297. - add swig-runtime to 'BuildPreReq:'.
  298. - fix %%files.
  299. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  300. - require neon version 0.24.7 for ra_dav
  301. - add BuildPreReq: openldap-devel
  302. - replace BuildPreReq: httpd to BuildPreReq: apache2
  303. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  304. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  305. - new upstream release
  306. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  307. - new upstream release
  308. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  309. - new upstream release
  310. - clean up specfile.
  311. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  312. - new upstream release
  313. - build with apache2-2.0.47
  314. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  315. - build Vine Linux
  316. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  317. - Enabled RA_DAV checking.
  318. Now requires httpd package to build because of RA_DAV tests.
  319. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  320. - Created tools package to hold the tools.
  321. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  322. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  323. version of APR/APR-UTILS as of 2003.01.15.
  324. - Added svnversion command.
  325. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  326. - Create a svnadmin.static which is copied to svnadmin-version-release
  327. when the package is erased, so users can still dump/load their repositories
  328. even after they have upgraded the RPM package.
  329. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  330. - SWIG now builds so we can use cvs2svn.
  331. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  332. - Made cvs2svn conditional (at least until we can get it to build consistently
  333. and work).
  334. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  335. - Added SWIG dependencies to add cvs2svn capabilities.
  336. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  337. - Now requires neon-0.22.0.
  338. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  339. - Took out loading mod_dav_svn from subversion.spec file and put it in
  340. subversion.conf file which goes into the apache conf directory.
  341. - Simplify what gets put into httpd.conf to only the include for the
  342. subversion.conf file.
  343. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  344. me to do this).
  345. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  346. - Updated to APR/APR-UTIL 2002-08-08.
  347. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  348. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  349. - Previous version had a few problems because of missing apache error/ files.
  350. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  351. - Updated to apache-2.0.40-0.3.
  352. - Updated to subversion-0.13.1-2318.
  353. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  354. - Updated for RedHat 7.3 (autoconf253).
  355. - Added a bunch of pre-requisites I didn't know were needed because I built a
  356. new machine that didn't have them already installed.
  357. - Fixed installation of man and info documentation pages.
  358. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  359. - Back to apache-libapr* stuff, hopefully to stay.
  360. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  361. - Fixed expat.patch to not have to make so many changes by writing a small
  362. shell script that changes libexpat to -lexpat.
  363. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  364. - Updated to neon-0.19.2.
  365. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  366. - Back to using apr and apr-util separately from apache.
  367. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  368. - Updated to APR and APR-UTIL 2002.02.11.
  369. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  370. - Took out a (now non-existant) documentation file.
  371. - Moved SPEC file changelog to after all package definitions.
  372. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  373. - Updated to neon-0.18.5.
  374. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  375. apache-apr-utils, and apache-apr-utils-devel.
  376. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  377. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  378. - Now builds without the separate APR package as it is built into and
  379. "exported" from apache-2.0.31-0.3.
  380. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  381. - Took out patches to install procedure now not required because of fixes
  382. in rev 1130.
  383. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  384. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  385. program was added.
  386. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  387. - Release M5-r340: Added the subversion-server package.
  388. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  389. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  390. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  391. - Release M3-r117: Initial Version.