lsb-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797
  1. # Define this to link to which library version eg. /lib64/ld-lsb-x86-64.so.3
  2. %define lsbsover 3
  3. %ifarch %{ix86}
  4. %define ldso ld-linux.so.2
  5. %define lsbldso ld-lsb.so
  6. %endif
  7. %ifarch ia64
  8. %define ldso ld-linux-ia64.so.2
  9. %define lsbldso ld-lsb-ia64.so
  10. %endif
  11. %ifarch ppc
  12. %define ldso ld.so.1
  13. %define lsbldso ld-lsb-ppc32.so
  14. %endif
  15. %ifarch ppc64
  16. %define ldso ld64.so.1
  17. %define lsbldso ld-lsb-ppc64.so
  18. %endif
  19. %ifarch s390
  20. %define ldso ld.so.1
  21. %define lsbldso ld-lsb-s390.so
  22. %endif
  23. %ifarch s390x
  24. %define ldso ld64.so.1
  25. %define lsbldso ld-lsb-s390x.so
  26. %endif
  27. %ifarch x86_64
  28. %define ldso ld-linux-x86-64.so.2
  29. %define lsbldso ld-lsb-x86-64.so
  30. %endif
  31. %ifarch ia64 ppc64 s390x x86_64
  32. %define qual ()(64bit)
  33. %else
  34. %define qual %{nil}
  35. %endif
  36. %define upstreamlsbrelver 2.0
  37. %define lsbrelver 4.0
  38. %define srcrelease 1
  39. Summary: LSB support for Vine Linux
  40. Summary(ja): Vine Linux の LSB サポート
  41. Name: lsb
  42. Version: 4.0
  43. Release: 1%{?_dist_release}
  44. URL: http://www.linuxfoundation.org/
  45. Source0: %{name}-vine-%{version}.tar.bz2
  46. License: GPLv2
  47. Group: System Environment/Base
  48. BuildRoot: %{_tmppath}/%{name}-root
  49. BuildRequires: glibc-static
  50. # dependency for primary LSB application for v1.3
  51. Provides: lsb = %{version}
  52. # dependency for primary LSB application for v2.0, v3.0 and v4.0
  53. %ifarch %{ix86}
  54. %define archname ia32
  55. %endif
  56. %ifarch ia64
  57. %define archname ia64
  58. %endif
  59. %ifarch ppc
  60. %define archname ppc32
  61. %endif
  62. %ifarch ppc64
  63. %define archname ppc64
  64. %endif
  65. %ifarch s390
  66. %define archname s390
  67. %endif
  68. %ifarch s390x
  69. %define archname s390x
  70. %endif
  71. %ifarch x86_64
  72. %define archname amd64
  73. %endif
  74. Provides: lsb-core-%{archname} = %{version}
  75. Provides: lsb-graphics-%{archname} = %{version}
  76. Provides: lsb-core-noarch = %{version}
  77. Provides: lsb-graphics-noarch = %{version}
  78. Provides: lsb-printing-%{archname} = %{version}
  79. Provides: lsb-printing-noarch = %{version}
  80. ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x
  81. %ifarch %{ix86}
  82. # archLSB IA32 Base Libraries
  83. Requires: libatk-1.0.so.0
  84. Requires: libc.so.6
  85. Requires: libcrypt.so.1
  86. Requires: libdl.so.2
  87. Requires: libgcc_s.so.1
  88. Requires: libgdk-x11-2.0.so.0
  89. Requires: libgdk_pixbuf-2.0.so.0
  90. Requires: libgdk_pixbuf_xlib-2.0.so.0
  91. Requires: libglib-2.0.so.0
  92. Requires: libgmodule-2.0.so.0
  93. Requires: libgobject-2.0.so.0
  94. Requires: libgthread-2.0.so.0
  95. Requires: libgtk-x11-2.0.so.0
  96. Requires: libm.so.6
  97. Requires: libncurses.so.5
  98. Requires: libpango-1.0.so.0
  99. Requires: libpangoft2-1.0.so.0
  100. Requires: libpangoxft-1.0.so.0
  101. Requires: libpthread.so.0
  102. Requires: libqt-mt.so.3
  103. Requires: libQtCore.so.4
  104. Requires: libQtGui.so.4
  105. Requires: libQtNetwork.so.4
  106. Requires: libQtOpenGL.so.4
  107. Requires: libQtSql.so.4
  108. Requires: libQtSvg.so.4
  109. Requires: libQtXml.so.4
  110. Requires: libstdc++.so.6
  111. Requires: libutil.so.1
  112. Requires: libz.so.1
  113. %endif
  114. %ifarch ia64
  115. # archLSB IA64 Base Libraries
  116. Requires: libatk-1.0.so.0()(64bit)
  117. Requires: libc.so.6.1()(64bit)
  118. Requires: libcrypt.so.1()(64bit)
  119. Requires: libdl.so.2()(64bit)
  120. Requires: libgcc_s.so.1()(64bit)
  121. Requires: libgdk-x11-2.0.so.0()(64bit)
  122. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  123. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  124. Requires: libglib-2.0.so.0()(64bit)
  125. Requires: libgmodule-2.0.so.0()(64bit)
  126. Requires: libgobject-2.0.so.0()(64bit)
  127. Requires: libgthread-2.0.so.0()(64bit)
  128. Requires: libgtk-x11-2.0.so.0()(64bit)
  129. Requires: libm.so.6.1()(64bit)
  130. Requires: libncurses.so.5()(64bit)
  131. Requires: libpango-1.0.so.0()(64bit)
  132. Requires: libpangoft2-1.0.so.0()(64bit)
  133. Requires: libpangoxft-1.0.so.0()(64bit)
  134. Requires: libpthread.so.0()(64bit)
  135. Requires: libqt-mt.so.3()(64bit)
  136. Requires: libQtCore.so.4()(64bit)
  137. Requires: libQtGui.so.4()(64bit)
  138. Requires: libQtNetwork.so.4()(64bit)
  139. Requires: libQtOpenGL.so.4()(64bit)
  140. Requires: libQtSql.so.4()(64bit)
  141. Requires: libQtSvg.so.4()(64bit)
  142. Requires: libQtXml.so.4()(64bit)
  143. Requires: libstdc++.so.6()(64bit)
  144. Requires: libutil.so.1()(64bit)
  145. Requires: libz.so.1()(64bit)
  146. %endif
  147. %ifarch ppc
  148. # archLSB PPC32 Base Libraries
  149. Requires: libatk-1.0.so.0
  150. Requires: libc.so.6
  151. Requires: libcrypt.so.1
  152. Requires: libdl.so.2
  153. Requires: libgcc_s.so.1
  154. Requires: libgdk-x11-2.0.so.0
  155. Requires: libgdk_pixbuf-2.0.so.0
  156. Requires: libgdk_pixbuf_xlib-2.0.so.0
  157. Requires: libglib-2.0.so.0
  158. Requires: libgmodule-2.0.so.0
  159. Requires: libgobject-2.0.so.0
  160. Requires: libgthread-2.0.so.0
  161. Requires: libgtk-x11-2.0.so.0
  162. Requires: libm.so.6
  163. Requires: libncurses.so.5
  164. Requires: libpango-1.0.so.0
  165. Requires: libpangoft2-1.0.so.0
  166. Requires: libpangoxft-1.0.so.0
  167. Requires: libpthread.so.0
  168. Requires: libqt-mt.so.3
  169. Requires: libQtCore.so.4
  170. Requires: libQtGui.so.4
  171. Requires: libQtNetwork.so.4
  172. Requires: libQtOpenGL.so.4
  173. Requires: libQtSql.so.4
  174. Requires: libQtSvg.so.4
  175. Requires: libQtXml.so.4
  176. Requires: libstdc++.so.6
  177. Requires: libutil.so.1
  178. Requires: libz.so.1
  179. %endif
  180. %ifarch ppc64
  181. # archLSB PPC64 Base Libraries
  182. Requires: libatk-1.0.so.0()(64bit)
  183. Requires: libc.so.6()(64bit)
  184. Requires: libcrypt.so.1()(64bit)
  185. Requires: libdl.so.2()(64bit)
  186. Requires: libgcc_s.so.1()(64bit)
  187. Requires: libgdk-x11-2.0.so.0()(64bit)
  188. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  189. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  190. Requires: libglib-2.0.so.0()(64bit)
  191. Requires: libgmodule-2.0.so.0()(64bit)
  192. Requires: libgobject-2.0.so.0()(64bit)
  193. Requires: libgthread-2.0.so.0()(64bit)
  194. Requires: libgtk-x11-2.0.so.0()(64bit)
  195. Requires: libm.so.6()(64bit)
  196. Requires: libncurses.so.5()(64bit)
  197. Requires: libpango-1.0.so.0()(64bit)
  198. Requires: libpangoft2-1.0.so.0()(64bit)
  199. Requires: libpangoxft-1.0.so.0()(64bit)
  200. Requires: libpthread.so.0()(64bit)
  201. Requires: libqt-mt.so.3()(64bit)
  202. Requires: libQtCore.so.4()(64bit)
  203. Requires: libQtGui.so.4()(64bit)
  204. Requires: libQtNetwork.so.4()(64bit)
  205. Requires: libQtOpenGL.so.4()(64bit)
  206. Requires: libQtSql.so.4()(64bit)
  207. Requires: libQtSvg.so.4()(64bit)
  208. Requires: libQtXml.so.4()(64bit)
  209. Requires: libstdc++.so.6()(64bit)
  210. Requires: libutil.so.1()(64bit)
  211. Requires: libz.so.1()(64bit)
  212. %endif
  213. %ifarch s390
  214. # archLSB S390 Base Libraries
  215. Requires: libatk-1.0.so.0
  216. Requires: libc.so.6
  217. Requires: libcrypt.so.1
  218. Requires: libdl.so.2
  219. Requires: libgcc_s.so.1
  220. Requires: libgdk-x11-2.0.so.0
  221. Requires: libgdk_pixbuf-2.0.so.0
  222. Requires: libgdk_pixbuf_xlib-2.0.so.0
  223. Requires: libglib-2.0.so.0
  224. Requires: libgmodule-2.0.so.0
  225. Requires: libgobject-2.0.so.0
  226. Requires: libgthread-2.0.so.0
  227. Requires: libgtk-x11-2.0.so.0
  228. Requires: libm.so.6
  229. Requires: libncurses.so.5
  230. Requires: libpango-1.0.so.0
  231. Requires: libpangoft2-1.0.so.0
  232. Requires: libpangoxft-1.0.so.0
  233. Requires: libpthread.so.0
  234. Requires: libqt-mt.so.3
  235. Requires: libQtCore.so.4
  236. Requires: libQtGui.so.4
  237. Requires: libQtNetwork.so.4
  238. Requires: libQtOpenGL.so.4
  239. Requires: libQtSql.so.4
  240. Requires: libQtSvg.so.4
  241. Requires: libQtXml.so.4
  242. Requires: libstdc++.so.6
  243. Requires: libutil.so.1
  244. Requires: libz.so.1
  245. %endif
  246. %ifarch s390x
  247. # archLSB S390X Base Libraries
  248. Requires: libatk-1.0.so.0()(64bit)
  249. Requires: libc.so.6()(64bit)
  250. Requires: libcrypt.so.1()(64bit)
  251. Requires: libdl.so.2()(64bit)
  252. Requires: libgcc_s.so.1()(64bit)
  253. Requires: libgdk-x11-2.0.so.0()(64bit)
  254. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  255. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  256. Requires: libglib-2.0.so.0()(64bit)
  257. Requires: libgmodule-2.0.so.0()(64bit)
  258. Requires: libgobject-2.0.so.0()(64bit)
  259. Requires: libgthread-2.0.so.0()(64bit)
  260. Requires: libgtk-x11-2.0.so.0()(64bit)
  261. Requires: libm.so.6()(64bit)
  262. Requires: libncurses.so.5()(64bit)
  263. Requires: libpango-1.0.so.0()(64bit)
  264. Requires: libpangoft2-1.0.so.0()(64bit)
  265. Requires: libpangoxft-1.0.so.0()(64bit)
  266. Requires: libpthread.so.0()(64bit)
  267. Requires: libqt-mt.so.3()(64bit)
  268. Requires: libQtCore.so.4()(64bit)
  269. Requires: libQtGui.so.4()(64bit)
  270. Requires: libQtNetwork.so.4()(64bit)
  271. Requires: libQtOpenGL.so.4()(64bit)
  272. Requires: libQtSql.so.4()(64bit)
  273. Requires: libQtSvg.so.4()(64bit)
  274. Requires: libQtXml.so.4()(64bit)
  275. Requires: libstdc++.so.6()(64bit)
  276. Requires: libutil.so.1()(64bit)
  277. Requires: libz.so.1()(64bit)
  278. %endif
  279. %ifarch x86_64
  280. # archLSB AMD64 Base Libraries
  281. Requires: libatk-1.0.so.0()(64bit)
  282. Requires: libc.so.6()(64bit)
  283. Requires: libcrypt.so.1()(64bit)
  284. Requires: libdl.so.2()(64bit)
  285. Requires: libgcc_s.so.1()(64bit)
  286. Requires: libgdk-x11-2.0.so.0()(64bit)
  287. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  288. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  289. Requires: libglib-2.0.so.0()(64bit)
  290. Requires: libgmodule-2.0.so.0()(64bit)
  291. Requires: libgobject-2.0.so.0()(64bit)
  292. Requires: libgthread-2.0.so.0()(64bit)
  293. Requires: libgtk-x11-2.0.so.0()(64bit)
  294. Requires: libm.so.6()(64bit)
  295. Requires: libncurses.so.5()(64bit)
  296. Requires: libpango-1.0.so.0()(64bit)
  297. Requires: libpangoft2-1.0.so.0()(64bit)
  298. Requires: libpangoxft-1.0.so.0()(64bit)
  299. Requires: libpthread.so.0()(64bit)
  300. Requires: libqt-mt.so.3()(64bit)
  301. Requires: libQtCore.so.4()(64bit)
  302. Requires: libQtGui.so.4()(64bit)
  303. Requires: libQtNetwork.so.4()(64bit)
  304. Requires: libQtOpenGL.so.4()(64bit)
  305. Requires: libQtSql.so.4()(64bit)
  306. Requires: libQtSvg.so.4()(64bit)
  307. Requires: libQtXml.so.4()(64bit)
  308. Requires: libstdc++.so.6()(64bit)
  309. Requires: libutil.so.1()(64bit)
  310. Requires: libz.so.1()(64bit)
  311. %endif
  312. # gLSB Base/Utility/Stdc++/Graphics Libraries
  313. Requires: libasound.so.2%{qual}
  314. Requires: libatk-1.0.so.0%{qual}
  315. Requires: libcrypt.so.1%{qual}
  316. Requires: libcups.so.2%{qual}
  317. Requires: libcupsimage.so.2%{qual}
  318. Requires: libdl.so.2%{qual}
  319. Requires: libfontconfig.so.1%{qual}
  320. Requires: libfreetype.so.6%{qual}
  321. Requires: libgcc_s.so.1%{qual}
  322. Requires: libgdk-x11-2.0.so.0%{qual}
  323. Requires: libgdk_pixbuf-2.0.so.0%{qual}
  324. Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
  325. Requires: libGL.so.1%{qual}
  326. Requires: libglib-2.0.so.0%{qual}
  327. Requires: libgmodule-2.0.so.0%{qual}
  328. Requires: libgobject-2.0.so.0%{qual}
  329. Requires: libgthread-2.0.so.0%{qual}
  330. Requires: libgtk-x11-2.0.so.0%{qual}
  331. Requires: libICE.so.6%{qual}
  332. Requires: libjpeg.so.62%{qual}
  333. Requires: libncurses.so.5%{qual}
  334. Requires: libpam.so.0%{qual}
  335. Requires: libpango-1.0.so.0%{qual}
  336. Requires: libpangoft2-1.0.so.0%{qual}
  337. Requires: libpangoxft-1.0.so.0%{qual}
  338. Requires: libpng12.so.0%{qual}
  339. Requires: libpthread.so.0%{qual}
  340. Requires: libqt-mt.so.3%{qual}
  341. Requires: libQtCore.so.4%{qual}
  342. Requires: libQtGui.so.4%{qual}
  343. Requires: libQtNetwork.so.4%{qual}
  344. Requires: libQtOpenGL.so.4%{qual}
  345. Requires: libQtSql.so.4%{qual}
  346. Requires: libQtSvg.so.4%{qual}
  347. Requires: libQtXml.so.4%{qual}
  348. Requires: librt.so.1%{qual}
  349. Requires: libSM.so.6%{qual}
  350. Requires: libstdc++.so.6%{qual}
  351. Requires: libutil.so.1%{qual}
  352. Requires: libX11.so.6%{qual}
  353. Requires: libXext.so.6%{qual}
  354. Requires: libXft.so.2%{qual}
  355. Requires: libXi.so.6%{qual}
  356. Requires: libxml2.so.2%{qual}
  357. Requires: libXrender.so.1%{qual}
  358. Requires: libXt.so.6%{qual}
  359. Requires: libz.so.1%{qual}
  360. # gLSB Command and Utilities
  361. Requires: /bin/awk
  362. Requires: /bin/basename
  363. Requires: /bin/cat
  364. Requires: /bin/chgrp
  365. Requires: /bin/chmod
  366. Requires: /bin/chown
  367. Requires: /bin/cp
  368. Requires: /bin/cpio
  369. Requires: /bin/cut
  370. Requires: /bin/date
  371. Requires: /bin/dd
  372. Requires: /bin/df
  373. Requires: /bin/dmesg
  374. Requires: /bin/echo
  375. Requires: /bin/ed
  376. Requires: /bin/egrep
  377. Requires: /bin/env
  378. Requires: /bin/false
  379. Requires: /bin/fgrep
  380. Requires: /bin/gettext
  381. Requires: /bin/grep
  382. Requires: /bin/gunzip
  383. Requires: /bin/gzip
  384. Requires: /bin/hostname
  385. Requires: /bin/kill
  386. Requires: /bin/ln
  387. Requires: /bin/ls
  388. Requires: mailx
  389. Requires: /bin/mkdir
  390. Requires: /bin/mknod
  391. Requires: /bin/mktemp
  392. Requires: /bin/more
  393. Requires: /bin/mount
  394. Requires: /bin/mv
  395. Requires: /bin/nice
  396. Requires: /bin/ps
  397. Requires: /bin/pwd
  398. Requires: /bin/rm
  399. Requires: /bin/rmdir
  400. Requires: /bin/sed
  401. Requires: /bin/sh
  402. Requires: /bin/sleep
  403. Requires: /bin/sort
  404. Requires: /bin/stty
  405. Requires: /bin/su
  406. Requires: /bin/sync
  407. Requires: /bin/tar
  408. Requires: /bin/touch
  409. Requires: /bin/true
  410. Requires: /bin/umount
  411. Requires: /bin/uname
  412. Requires: /bin/zcat
  413. Requires: /sbin/fuser
  414. Requires: /sbin/pidof
  415. Requires: /sbin/shutdown
  416. Requires: /usr/bin/[
  417. Requires: /usr/bin/ar
  418. Requires: /usr/bin/at
  419. Requires: /usr/bin/batch
  420. Requires: /usr/bin/bc
  421. Requires: /usr/bin/chfn
  422. Requires: /usr/bin/chsh
  423. Requires: /usr/bin/cksum
  424. Requires: /usr/bin/cmp
  425. Requires: /usr/bin/col
  426. Requires: /usr/bin/comm
  427. Requires: /usr/bin/crontab
  428. Requires: /usr/bin/csplit
  429. Requires: /usr/bin/diff
  430. Requires: /usr/bin/dirname
  431. Requires: /usr/bin/du
  432. Requires: /usr/bin/expand
  433. Requires: /usr/bin/expr
  434. Requires: /usr/bin/fc-cache
  435. Requires: /usr/bin/fc-list
  436. Requires: /usr/bin/fc-match
  437. Requires: /usr/bin/file
  438. Requires: /usr/bin/find
  439. Requires: /usr/bin/fold
  440. Requires: /usr/bin/foomatic-rip
  441. Requires: /usr/bin/gencat
  442. Requires: /usr/bin/getconf
  443. Requires: /usr/bin/groups
  444. Requires: /usr/bin/gs
  445. Requires: /usr/bin/head
  446. Requires: /usr/bin/iconv
  447. Requires: /usr/bin/id
  448. Requires: /usr/bin/install
  449. Requires: /usr/bin/ipcrm
  450. Requires: /usr/bin/ipcs
  451. Requires: /usr/bin/join
  452. Requires: /usr/bin/killall
  453. Requires: /usr/bin/locale
  454. Requires: /usr/bin/localedef
  455. Requires: /usr/bin/logger
  456. Requires: /usr/bin/logname
  457. Requires: /usr/bin/lp
  458. Requires: /usr/bin/lpr
  459. Requires: /usr/bin/m4
  460. Requires: /usr/bin/make
  461. Requires: /usr/bin/man
  462. Requires: /usr/bin/md5sum
  463. Requires: /usr/bin/mkfifo
  464. Requires: /usr/bin/msgfmt
  465. Requires: /usr/bin/newgrp
  466. Requires: /usr/bin/nl
  467. Requires: /usr/bin/nohup
  468. Requires: /usr/bin/od
  469. Requires: /usr/bin/passwd
  470. Requires: /usr/bin/paste
  471. Requires: /usr/bin/patch
  472. Requires: /usr/bin/pathchk
  473. Requires: /usr/bin/pax
  474. Requires: /usr/bin/perl
  475. Requires: /usr/bin/pr
  476. Requires: /usr/bin/printf
  477. Requires: /usr/bin/python
  478. Requires: /usr/bin/renice
  479. Requires: /usr/bin/split
  480. Requires: /usr/bin/strip
  481. Requires: /usr/bin/tail
  482. Requires: /usr/bin/tee
  483. Requires: /usr/bin/test
  484. Requires: /usr/bin/time
  485. Requires: /usr/bin/tr
  486. Requires: /usr/bin/tsort
  487. Requires: /usr/bin/tty
  488. Requires: /usr/bin/unexpand
  489. Requires: /usr/bin/uniq
  490. Requires: /usr/bin/wc
  491. Requires: /usr/bin/xargs
  492. Requires: /usr/sbin/groupadd
  493. Requires: /usr/sbin/groupdel
  494. Requires: /usr/sbin/groupmod
  495. Requires: /usr/sbin/sendmail
  496. Requires: /usr/sbin/useradd
  497. Requires: /usr/sbin/userdel
  498. Requires: /usr/sbin/usermod
  499. %description
  500. The Linux Standard Base (LSB) is an attempt to develop a set of
  501. standards that will increase compatibility among Linux distributions.
  502. The lsb package provides utilities needed for LSB Compliant
  503. Applications. It also contains requirements that will ensure that all
  504. components required by the LSB that are provided by Red Hat Linux are
  505. installed on the system.
  506. %prep
  507. %setup -q -n %{name}-vine-%{version}
  508. %build
  509. cd lsb-release-%{upstreamlsbrelver}
  510. make
  511. %install
  512. rm -rf $RPM_BUILD_ROOT
  513. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  514. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
  515. $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
  516. $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
  517. make DESTDIR=$RPM_BUILD_ROOT install
  518. cd lsb-release-%{upstreamlsbrelver}
  519. make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
  520. cd ..
  521. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-%{archname}
  522. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-noarch
  523. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-%{archname}
  524. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-noarch
  525. touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-%{archname}
  526. touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-noarch
  527. # and claim LSB 3.1/3.2 is supported as well
  528. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
  529. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
  530. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
  531. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
  532. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
  533. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
  534. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
  535. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
  536. for LSBVER in %{lsbsover}; do
  537. ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
  538. done
  539. mkdir -p $RPM_BUILD_ROOT/bin
  540. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  541. # According to the lsb-core documentation provided by
  542. # http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
  543. # it's OK to put non binary in /usr/lib.
  544. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
  545. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
  546. ln -snf mail $RPM_BUILD_ROOT/bin/mailx
  547. gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
  548. -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
  549. install -m 700 lsb_vine_trigger.%{_target_cpu} \
  550. $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
  551. cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
  552. %clean
  553. rm -rf $RPM_BUILD_ROOT
  554. %triggerpostun -- glibc
  555. if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
  556. /usr/sbin/lsb_vine_trigger.%{_target_cpu}
  557. fi
  558. %ifnarch %{ix86}
  559. /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
  560. %else
  561. if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
  562. for LSBVER in %{lsbsover}; do
  563. /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  564. done
  565. else
  566. for LSBVER in %{lsbsover}; do
  567. /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  568. done
  569. fi
  570. %endif
  571. %ifarch %{ix86}
  572. %post
  573. # make this softlink again for /emul
  574. if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
  575. for LSBVER in %{lsbsover}; do
  576. /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  577. done
  578. fi
  579. %endif
  580. %files
  581. %defattr(-,root,root)
  582. %{_sysconfdir}/lsb-vine
  583. %dir %{_sysconfdir}/lsb-release.d
  584. %{_sysconfdir}/lsb-release.d/*
  585. %{_mandir}/*/*
  586. %{_bindir}/*
  587. /bin/lsb_vine_init
  588. /usr/lib/lsb
  589. /%{_lib}/*so*
  590. /lib/lsb*
  591. %{_sbindir}/lsb_vine_trigger.%{_target_cpu}
  592. /bin/mailx
  593. %changelog
  594. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
  595. - update to LSB4.0
  596. - add Provide lsb-printing{,-noarch}
  597. - add BR: glibc-static
  598. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
  599. - initial build for Vine Linux
  600. * Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
  601. - Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
  602. * Wed Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
  603. - Port forward to LSB 3.2
  604. - Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
  605. - Since F10 put mailx under /usr/bin, change the corresponding requires
  606. * Thu Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
  607. - Remove 2 requires which provided by redhat-lsb
  608. - Add comments explaining why hard-coded path is kept
  609. - Resolve some hard-coded path problems
  610. - Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
  611. - Replace %{_libdir}/lsb with /usr/lib/lsb
  612. - Replace /%{_lib}/* with /%{_lib}/*so*
  613. - Replace /lib/lsb with /lib/lsb*
  614. * Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
  615. - remove symlink for mailx (Bug #457241)
  616. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
  617. - Autorebuild for GCC 4.3
  618. * Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
  619. - fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
  620. * Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
  621. - fix build issue in minimal build root (Bug #265241)
  622. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
  623. - Rebuild for selinux ppc32 issue.
  624. * Fri Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
  625. - update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
  626. * Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
  627. - Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
  628. - forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
  629. * Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
  630. - fixed Bug 232918 for new glibc version
  631. * Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
  632. - fixed Bug 226363
  633. * Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
  634. - replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
  635. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
  636. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  637. * Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
  638. - Fix upgrade issue; Bug 202548
  639. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
  640. - rebuild
  641. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
  642. - for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
  643. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
  644. - generate spec file on RHEL5-Alpha system
  645. - fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
  646. * Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
  647. - Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
  648. rather than sniffing through sgml
  649. - remove redundent script and bump up tarball version
  650. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
  651. - bump again for double-long bug on ppc(64)
  652. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
  653. - rebuilt for new gcc4.1 snapshot and glibc changes
  654. * Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
  655. - Migrated back to rawhide
  656. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
  657. - Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
  658. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
  659. - Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
  660. depends on /etc/lsb-release.d/ (Advised by LSB committee)
  661. - Removed /etc/lsb-release (Advised by LSB committee)
  662. * Mon Aug 1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
  663. - Made the /etc/lsb-release useful (RH#154605)
  664. - Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
  665. - Fixed AMD64 base libraries requirement parsing (RH#154605)
  666. * Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
  667. - Fixed redhat-lsb's mkredhat-lsb on fetching lib and
  668. cmd requirements
  669. * Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
  670. - Rebuilt
  671. * Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
  672. - Disabled support for LSB 1.3 and 2.0
  673. * Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
  674. - Upgraded to lsb-release 2.0
  675. * Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
  676. - Moved to LSB 3.0
  677. * Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
  678. - Fixed ix86 package with ia32 emul support
  679. * Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
  680. - Sync what we have changed on the branches
  681. Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
  682. - added post section to recreate the softlink in emul mode (bug 140739)
  683. Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
  684. Tiny correction of bug in new triggers
  685. * Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
  686. - Add support provide on lsb-core-* for each arch
  687. * Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
  688. - Add to support multiple LSB test suite version
  689. - Add %%endif in trigger postun
  690. * Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
  691. - Fixed invalid sln call for trigger in postun on ia64 (#137647)
  692. * Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
  693. - Bump release and rebuilt for RHEL4.
  694. * Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
  695. - fix lsb ld.so name for ia64 (#100613)
  696. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  697. - use /usr/lib/lsb for install_initd, remove_initd
  698. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  699. - add ia64 x86_64 ppc ppc64 s390 s390x
  700. * Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
  701. - 1.3
  702. * Wed Sep 4 2002 Matt Wilson <msw@redhat.com>
  703. - 1.2.0
  704. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  705. - automated rebuild
  706. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  707. - automated rebuild
  708. * Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
  709. - addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
  710. forced downgrade case.
  711. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
  712. - add initscripts support
  713. * Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
  714. - Initial build.