atlas-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822
  1. %define enable_native_atlas 0
  2. Name: atlas
  3. Version: 3.8.4
  4. %if "%{?enable_native_atlas}" != "0"
  5. %define dist .native
  6. %endif
  7. Release: 4%{?_dist_release}
  8. Summary: Automatically Tuned Linear Algebra Software
  9. Group: System Environment/Libraries
  10. License: BSD
  11. URL: http://math-atlas.sourceforge.net/
  12. Source0: http://downloads.sourceforge.net/math-atlas/%{name}%{version}.tar.bz2
  13. Source1: PPRO32.tgz
  14. Source2: K7323DNow.tgz
  15. Source3: README.Fedora
  16. Source4: USII64.tgz
  17. Source5: USII32.tgz
  18. Source6: IBMz1032.tgz
  19. Source7: IBMz1064.tgz
  20. Source8: IBMz19632.tgz
  21. Source9: IBMz19664.tgz
  22. Patch0: atlas-fedora_shared.patch
  23. Patch1: atlas-s390port.patch
  24. Patch2: atlas-fedora-arm.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  26. BuildRequires: gcc-gfortran lapack-static
  27. %description
  28. The ATLAS (Automatically Tuned Linear Algebra Software) project is an
  29. ongoing research effort focusing on applying empirical techniques in
  30. order to provide portable performance. At present, it provides C and
  31. Fortran77 interfaces to a portably efficient BLAS implementation, as
  32. well as a few routines from LAPACK.
  33. The performance improvements in ATLAS are obtained largely via
  34. compile-time optimizations and tend to be specific to a given hardware
  35. configuration. In order to package ATLAS for Fedora some compromises
  36. are necessary so that good performance can be obtained on a variety
  37. of hardware. This set of ATLAS binary packages is therefore not
  38. necessarily optimal for any specific hardware configuration. However,
  39. the source package can be used to compile customized ATLAS packages;
  40. see the documentation for information.
  41. %package devel
  42. Summary: Development libraries for ATLAS
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. Obsoletes: %name-header <= %version-%release
  46. Requires(posttrans): chkconfig
  47. Requires(preun): chkconfig
  48. Requires(post): /usr/sbin/alternatives
  49. Requires(postun): /usr/sbin/alternatives
  50. %description devel
  51. This package contains the libraries and headers for development
  52. with ATLAS (Automatically Tuned Linear Algebra Software).
  53. %define types base
  54. %if "%{?enable_native_atlas}" == "0"
  55. ############## Subpackages for architecture extensions #################
  56. #
  57. %ifarch x86_64
  58. %define types base sse3
  59. %package sse3
  60. Summary: ATLAS libraries for SSE3 extensions
  61. Group: System Environment/Libraries
  62. %description sse3
  63. This package contains the ATLAS (Automatically Tuned Linear Algebra
  64. Software) libraries compiled with optimizations for the SSE3
  65. extensions to the x86_64 architecture. The base ATLAS builds in Fedora for the
  66. x86_64 architecture are made for the SSE2 extensions.
  67. %package sse3-devel
  68. Summary: Development libraries for ATLAS with SSE3 extensions
  69. Group: Development/Libraries
  70. Requires: %{name}-sse3 = %{version}-%{release}
  71. Obsoletes: %name-header <= %version-%release
  72. Requires(posttrans): chkconfig
  73. Requires(preun): chkconfig
  74. Requires(post): /usr/sbin/alternatives
  75. Requires(postun): /usr/sbin/alternatives
  76. %description sse3-devel
  77. This package contains shared and static versions of the ATLAS
  78. (Automatically Tuned Linear Algebra Software) libraries compiled with
  79. optimizations for the SSE3 extensions to the x86_64 architecture.
  80. %endif
  81. %ifarch %{ix86}
  82. %define types base 3dnow sse sse2 sse3
  83. %package 3dnow
  84. Summary: ATLAS libraries for 3DNow extensions
  85. Group: System Environment/Libraries
  86. %description 3dnow
  87. This package contains the ATLAS (Automatically Tuned Linear Algebra
  88. Software) libraries compiled with optimizations for the 3DNow extension
  89. to the ix86 architecture. Fedora also produces ATLAS build with SSE, SSE2
  90. and SSE3 extensions.
  91. %package 3dnow-devel
  92. Summary: Development libraries for ATLAS with 3DNow extensions
  93. Group: Development/Libraries
  94. Requires: %{name}-3dnow = %{version}-%{release}
  95. Obsoletes: %name-header <= %version-%release
  96. Requires(posttrans): chkconfig
  97. Requires(preun): chkconfig
  98. %description 3dnow-devel
  99. This package contains headers and shared versions of the ATLAS
  100. (Automatically Tuned Linear Algebra Software) libraries compiled with
  101. optimizations for the 3DNow extensions to the ix86 architecture.
  102. %package sse
  103. Summary: ATLAS libraries for SSE extensions
  104. Group: System Environment/Libraries
  105. %description sse
  106. This package contains the ATLAS (Automatically Tuned Linear Algebra
  107. Software) libraries compiled with optimizations for the SSE(1) extensions
  108. to the ix86 architecture. Fedora also produces ATLAS build with SSE2 and SSE3
  109. extensions.
  110. %package sse-devel
  111. Summary: Development libraries for ATLAS with SSE extensions
  112. Group: Development/Libraries
  113. Requires: %{name}-sse = %{version}-%{release}
  114. Obsoletes: %name-header <= %version-%release
  115. Requires(posttrans): chkconfig
  116. Requires(preun): chkconfig
  117. %description sse-devel
  118. This package contains headers and shared versions of the ATLAS
  119. (Automatically Tuned Linear Algebra Software) libraries compiled with
  120. optimizations for the SSE(1) extensions to the ix86 architecture.
  121. %package sse2
  122. Summary: ATLAS libraries for SSE2 extensions
  123. Group: System Environment/Libraries
  124. %description sse2
  125. This package contains ATLAS (Automatically Tuned Linear Algebra Software)
  126. shared libraries compiled with optimizations for the SSE2
  127. extensions to the ix86 architecture. Fedora also produces ATLAS build with
  128. SSE(1) and SSE3 extensions.
  129. %package sse2-devel
  130. Summary: Development libraries for ATLAS with SSE2 extensions
  131. Group: Development/Libraries
  132. Requires: %{name}-sse2 = %{version}-%{release}
  133. Obsoletes: %name-header <= %version-%release
  134. Requires(posttrans): chkconfig
  135. Requires(preun): chkconfig
  136. %description sse2-devel
  137. This package contains ATLAS (Automatically Tuned Linear Algebra Software)
  138. shared libraries compiled with optimizations for the SSE2 extensions to the
  139. ix86 architecture.
  140. %package sse3
  141. Summary: ATLAS libraries for SSE3 extensions
  142. Group: System Environment/Libraries
  143. %description sse3
  144. This package contains the ATLAS (Automatically Tuned Linear Algebra
  145. Software) libraries compiled with optimizations for the SSE3.
  146. Fedora also produces ATLAS build with SSE(1) and SSE2 extensions.
  147. %package sse3-devel
  148. Summary: Development libraries for ATLAS with SSE3 extensions
  149. Group: Development/Libraries
  150. Requires: %{name}-sse3 = %{version}-%{release}
  151. Obsoletes: %name-header <= %version-%release
  152. Requires(posttrans): chkconfig
  153. Requires(preun): chkconfig
  154. %description sse3-devel
  155. This package contains ATLAS (Automatically Tuned Linear Algebra Software)
  156. shared libraries compiled with optimizations for the SSE3 extensions to the ix86 architecture.
  157. %endif
  158. %ifarch s390 s390x
  159. %define types base z10 z196
  160. %package z196
  161. Summary: ATLAS libraries for z196
  162. Group: System Environment/Libraries
  163. %description z196
  164. This package contains the ATLAS (Automatically Tuned Linear Algebra
  165. Software) libraries compiled with optimizations for the z196.
  166. %package z196-devel
  167. Summary: Development libraries for ATLAS for z196
  168. Group: Development/Libraries
  169. Requires: %{name}-z196 = %{version}-%{release}
  170. Obsoletes: %name-header <= %version-%release
  171. Requires(posttrans): chkconfig
  172. Requires(preun): chkconfig
  173. %description z196-devel
  174. This package contains headers and shared versions of the ATLAS
  175. (Automatically Tuned Linear Algebra Software) libraries compiled with
  176. optimizations for the z196 architecture.
  177. %package z10
  178. Summary: ATLAS libraries for z10
  179. Group: System Environment/Libraries
  180. %description z10
  181. This package contains the ATLAS (Automatically Tuned Linear Algebra
  182. Software) libraries compiled with optimizations for the z10.
  183. %package z10-devel
  184. Summary: Development libraries for ATLAS for z10
  185. Group: Development/Libraries
  186. Requires: %{name}-z10 = %{version}-%{release}
  187. Obsoletes: %name-header <= %version-%release
  188. Requires(posttrans): chkconfig
  189. Requires(preun): chkconfig
  190. %description z10-devel
  191. This package contains headers and shared versions of the ATLAS
  192. (Automatically Tuned Linear Algebra Software) libraries compiled with
  193. optimizations for the z10 architecture.
  194. %endif
  195. %endif
  196. %global mode %{__isa_bits}
  197. %ifarch %{arm}
  198. %define arch_option -A 38
  199. %define threads_option -t 2
  200. %global mode ' '
  201. %endif
  202. %prep
  203. %setup -q -n ATLAS
  204. %patch0 -p0 -b .shared
  205. %ifarch s390 s390x
  206. %patch1 -p1 -b .s390
  207. %endif
  208. %ifarch %{arm}
  209. %patch2 -p0 -b .arm
  210. %endif
  211. cp %{SOURCE1} CONFIG/ARCHS/
  212. cp %{SOURCE2} CONFIG/ARCHS/
  213. cp %{SOURCE3} doc
  214. cp %{SOURCE4} CONFIG/ARCHS/
  215. cp %{SOURCE5} CONFIG/ARCHS/
  216. cp %{SOURCE6} CONFIG/ARCHS/
  217. cp %{SOURCE7} CONFIG/ARCHS/
  218. cp %{SOURCE8} CONFIG/ARCHS/
  219. cp %{SOURCE9} CONFIG/ARCHS/
  220. %build
  221. for type in %{types}; do
  222. if [ "$type" = "base" ]; then
  223. libname=atlas
  224. %define pr_base %(echo $((%{__isa_bits}+0)))
  225. else
  226. libname=atlas-${type}
  227. fi
  228. mkdir -p %{_arch}_${type}
  229. pushd %{_arch}_${type}
  230. ../configure -b %{mode} %{?threads_option} %{?arch_option} -D c -DWALL -Fa alg '-g -Wa,--noexecstack -fPIC'\
  231. --prefix=%{buildroot}%{_prefix} \
  232. --incdir=%{buildroot}%{_includedir} \
  233. --libdir=%{buildroot}%{_libdir}/${libname} \
  234. --with-netlib-lapack=%{_libdir}/liblapack_pic.a
  235. %if "%{?enable_native_atlas}" == "0"
  236. %ifarch x86_64
  237. if [ "$type" = "base" ]; then
  238. sed -i 's#ARCH =.*#ARCH = HAMMER64SSE2#' Make.inc
  239. sed -i 's#-DATL_SSE3##' Make.inc
  240. sed -i 's#-msse3#-msse2#' Make.inc
  241. elif [ "$type" = "sse3" ]; then
  242. sed -i 's#ARCH =.*#ARCH = HAMMER64SSE3#' Make.inc
  243. %define pr_sse3 %(echo $((%{__isa_bits}+4)))
  244. fi
  245. %endif
  246. %ifarch %{ix86}
  247. if [ "$type" = "base" ]; then
  248. sed -i 's#ARCH =.*#ARCH = PPRO32#' Make.inc
  249. sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
  250. sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
  251. elif [ "$type" = "3dnow" ]; then
  252. sed -i 's#ARCH =.*#ARCH = K7323DNow#' Make.inc
  253. sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
  254. sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
  255. %define pr_3dnow %(echo $((%{__isa_bits}+1)))
  256. elif [ "$type" = "sse" ]; then
  257. sed -i 's#ARCH =.*#ARCH = PIII32SSE1#' Make.inc
  258. sed -i 's#-DATL_SSE3 -DATL_SSE2##' Make.inc
  259. sed -i 's#-msse3#-msse#' Make.inc
  260. %define pr_sse %(echo $((%{__isa_bits}+2)))
  261. elif [ "$type" = "sse2" ]; then
  262. sed -i 's#ARCH =.*#ARCH = P432SSE2#' Make.inc
  263. sed -i 's#-DATL_SSE3##' Make.inc
  264. sed -i 's#-msse3#-msse2#' Make.inc
  265. %define pr_sse2 %(echo $((%{__isa_bits}+3)))
  266. elif [ "$type" = "sse3" ]; then
  267. sed -i 's#ARCH =.*#ARCH = P4E32SSE3#' Make.inc
  268. %define pr_sse3 %(echo $((%{__isa_bits}+4)))
  269. fi
  270. %endif
  271. %ifarch s390 s390x
  272. # we require a z9/z10/z196 but base,z10 and z196
  273. # we also need a compiler with -march=z196 support
  274. # the base support will use z196 tuning
  275. if [ "$type" = "base" ]; then
  276. %ifarch s390x
  277. sed -i 's#ARCH =.*#ARCH = IBMz19664#' Make.inc
  278. %endif
  279. %ifarch s390
  280. sed -i 's#ARCH =.*#ARCH = IBMz19632#' Make.inc
  281. %endif
  282. sed -i 's#-march=z196#-march=z9-109 -mtune=z196#' Make.inc
  283. sed -i 's#-march=z10 -mtune=z196#-march=z9-109 -mtune=z196#' Make.inc
  284. sed -i 's#-march=z10#-march=z9-109 -mtune=z10#' Make.inc
  285. sed -i 's#-DATL_ARCH_IBMz196#-DATL_ARCH_IBMz9#' Make.inc
  286. sed -i 's#-DATL_ARCH_IBMz10#-DATL_ARCH_IBMz9#' Make.inc
  287. sed -i 's#-DATL_ARCH_IBMz9#-DATL_ARCH_IBMz9#' Make.inc
  288. elif [ "$type" = "z10" ]; then
  289. %ifarch s390x
  290. sed -i 's#ARCH =.*#ARCH = IBMz1064#' Make.inc
  291. %endif
  292. %ifarch s390
  293. sed -i 's#ARCH =.*#ARCH = IBMz1032#' Make.inc
  294. %endif
  295. sed -i 's#-march=z196#-march=z10#' Make.inc
  296. sed -i 's#-march=z10 -mtune=z196#-march=z10#' Make.inc
  297. sed -i 's#-march=z9-109#-march=z10#' Make.inc
  298. sed -i 's#-DATL_ARCH_IBMz196#-DATL_ARCH_IBMz10#' Make.inc
  299. sed -i 's#-DATL_ARCH_IBMz9#-DATL_ARCH_IBMz10#' Make.inc
  300. %define pr_z10 %(echo $((%{__isa_bits}+1)))
  301. elif [ "$type" = "z196" ]; then
  302. %ifarch s390x
  303. sed -i 's#ARCH =.*#ARCH = IBMz19664#' Make.inc
  304. %endif
  305. %ifarch s390
  306. sed -i 's#ARCH =.*#ARCH = IBMz19632#' Make.inc
  307. %endif
  308. sed -i 's#-march=z196#-march=z10 -mtune=z196#' Make.inc
  309. sed -i 's#-march=z10#-march=z10 -mtune=z196#' Make.inc
  310. sed -i 's#-march=z9-109#-march=z10 -mtune=z196#' Make.inc
  311. sed -i 's#-DATL_ARCH_IBMz10#-DATL_ARCH_IBMz196#' Make.inc
  312. sed -i 's#-DATL_ARCH_IBMz9#-DATL_ARCH_IBMz196#' Make.inc
  313. %define pr_z196 %(echo $((%{__isa_bits}+2)))
  314. fi
  315. %endif
  316. %endif
  317. make build
  318. cd lib
  319. make shared
  320. make ptshared
  321. popd
  322. done
  323. %install
  324. rm -rf %{buildroot}
  325. for type in %{types}; do
  326. pushd %{_arch}_${type}
  327. make DESTDIR=%{buildroot} install
  328. mv %{buildroot}%{_includedir}/atlas %{buildroot}%{_includedir}/atlas-%{_arch}-${type}
  329. if [ "$type" = "base" ]; then
  330. cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas/
  331. rm -f %{buildroot}%{_libdir}/atlas/*.a
  332. else
  333. cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas-${type}/
  334. rm -f %{buildroot}%{_libdir}/atlas-${type}/*.a
  335. fi
  336. popd
  337. mkdir -p %{buildroot}/etc/ld.so.conf.d
  338. if [ "$type" = "base" ]; then
  339. echo "%{_libdir}/atlas" \
  340. > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}.conf
  341. else
  342. echo "%{_libdir}/atlas-${type}" \
  343. > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}-${type}.conf
  344. fi
  345. done
  346. mkdir -p %{buildroot}%{_includedir}/atlas
  347. %clean
  348. rm -rf %{buildroot}
  349. %post -p /sbin/ldconfig
  350. %postun -p /sbin/ldconfig
  351. %posttrans devel
  352. if [ $1 -eq 0 ] ; then
  353. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  354. %{_includedir}/atlas-%{_arch}-base %{pr_base}
  355. fi
  356. %preun devel
  357. if [ $1 -ge 0 ] ; then
  358. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-base
  359. fi
  360. %if "%{?enable_native_atlas}" == "0"
  361. %ifarch x86_64
  362. %post -n atlas-sse3 -p /sbin/ldconfig
  363. %postun -n atlas-sse3 -p /sbin/ldconfig
  364. %posttrans sse3-devel
  365. if [ $1 -eq 0 ] ; then
  366. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  367. %{_includedir}/atlas-%{_arch}-sse3 %{pr_sse3}
  368. fi
  369. %preun sse3-devel
  370. if [ $1 -ge 0 ] ; then
  371. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
  372. fi
  373. %endif
  374. %ifarch %{ix86}
  375. %post -n atlas-3dnow -p /sbin/ldconfig
  376. %postun -n atlas-3dnow -p /sbin/ldconfig
  377. %posttrans 3dnow-devel
  378. if [ $1 -eq 0 ] ; then
  379. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  380. %{_includedir}/atlas-%{_arch}-3dnow %{pr_3dnow}
  381. fi
  382. %preun 3dnow-devel
  383. if [ $1 -ge 0 ] ; then
  384. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-3dnow
  385. fi
  386. %post -n atlas-sse -p /sbin/ldconfig
  387. %postun -n atlas-sse -p /sbin/ldconfig
  388. %posttrans sse-devel
  389. if [ $1 -eq 0 ] ; then
  390. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  391. %{_includedir}/atlas-%{_arch}-sse %{pr_sse}
  392. fi
  393. %preun sse-devel
  394. if [ $1 -ge 0 ] ; then
  395. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse
  396. fi
  397. %post -n atlas-sse2 -p /sbin/ldconfig
  398. %postun -n atlas-sse2 -p /sbin/ldconfig
  399. %posttrans sse2-devel
  400. if [ $1 -eq 0 ] ; then
  401. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  402. %{_includedir}/atlas-%{_arch}-sse2 %{pr_sse2}
  403. fi
  404. %preun sse2-devel
  405. if [ $1 -ge 0 ] ; then
  406. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse2
  407. fi
  408. %post -n atlas-sse3 -p /sbin/ldconfig
  409. %postun -n atlas-sse3 -p /sbin/ldconfig
  410. %posttrans sse3-devel
  411. if [ $1 -eq 0 ] ; then
  412. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  413. %{_includedir}/atlas-%{_arch}-sse3 %{pr_sse3}
  414. fi
  415. %preun sse3-devel
  416. if [ $1 -ge 0 ] ; then
  417. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
  418. fi
  419. %endif
  420. %ifarch s390 s390x
  421. %post -n atlas-z10 -p /sbin/ldconfig
  422. %postun -n atlas-z10 -p /sbin/ldconfig
  423. %posttrans z10-devel
  424. if [ $1 -eq 0 ] ; then
  425. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  426. %{_includedir}/atlas-%{_arch}-z10 %{pr_z10}
  427. fi
  428. %preun z10-devel
  429. if [ $1 -ge 0 ] ; then
  430. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-z10
  431. fi
  432. %post -n atlas-z196 -p /sbin/ldconfig
  433. %postun -n atlas-z196 -p /sbin/ldconfig
  434. %posttrans z196-devel
  435. if [ $1 -eq 0 ] ; then
  436. /usr/sbin/alternatives --install %{_includedir}/atlas atlas-inc \
  437. %{_includedir}/atlas-%{_arch}-z196 %{pr_z196}
  438. fi
  439. %preun z196-devel
  440. if [ $1 -ge 0 ] ; then
  441. /usr/sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-z196
  442. fi
  443. %endif
  444. %endif
  445. %files
  446. %defattr(-,root,root,-)
  447. %doc doc/README.Fedora
  448. %dir %{_libdir}/atlas
  449. %{_libdir}/atlas/*.so.*
  450. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}.conf
  451. %files devel
  452. %defattr(-,root,root,-)
  453. %doc doc
  454. %{_libdir}/atlas/*.so
  455. %{_includedir}/atlas-%{_arch}-base/
  456. %{_includedir}/*.h
  457. %ghost %{_includedir}/atlas
  458. %if "%{?enable_native_atlas}" == "0"
  459. %ifarch x86_64
  460. %files sse3
  461. %defattr(-,root,root,-)
  462. %doc doc/README.Fedora
  463. %dir %{_libdir}/atlas-sse3
  464. %{_libdir}/atlas-sse3/*.so.*
  465. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
  466. %files sse3-devel
  467. %defattr(-,root,root,-)
  468. %doc doc
  469. %{_libdir}/atlas-sse3/*.so
  470. %{_includedir}/atlas-%{_arch}-sse3/
  471. %{_includedir}/*.h
  472. %ghost %{_includedir}/atlas
  473. %endif
  474. %ifarch %{ix86}
  475. %files 3dnow
  476. %defattr(-,root,root,-)
  477. %doc doc/README.Fedora
  478. %dir %{_libdir}/atlas-3dnow
  479. %{_libdir}/atlas-3dnow/*.so.*
  480. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-3dnow.conf
  481. %files 3dnow-devel
  482. %defattr(-,root,root,-)
  483. %doc doc
  484. %{_libdir}/atlas-3dnow/*.so
  485. %{_includedir}/atlas-%{_arch}-3dnow/
  486. %{_includedir}/*.h
  487. %ghost %{_includedir}/atlas
  488. %files sse
  489. %defattr(-,root,root,-)
  490. %doc doc/README.Fedora
  491. %dir %{_libdir}/atlas-sse
  492. %{_libdir}/atlas-sse/*.so.*
  493. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse.conf
  494. %files sse-devel
  495. %defattr(-,root,root,-)
  496. %doc doc
  497. %{_libdir}/atlas-sse/*.so
  498. %{_includedir}/atlas-%{_arch}-sse/
  499. %{_includedir}/*.h
  500. %ghost %{_includedir}/atlas
  501. %files sse2
  502. %defattr(-,root,root,-)
  503. %doc doc/README.Fedora
  504. %dir %{_libdir}/atlas-sse2
  505. %{_libdir}/atlas-sse2/*.so.*
  506. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse2.conf
  507. %files sse2-devel
  508. %defattr(-,root,root,-)
  509. %doc doc
  510. %{_libdir}/atlas-sse2/*.so
  511. %{_includedir}/atlas-%{_arch}-sse2/
  512. %{_includedir}/*.h
  513. %ghost %{_includedir}/atlas
  514. %files sse3
  515. %defattr(-,root,root,-)
  516. %doc doc/README.Fedora
  517. %dir %{_libdir}/atlas-sse3
  518. %{_libdir}/atlas-sse3/*.so.*
  519. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
  520. %files sse3-devel
  521. %defattr(-,root,root,-)
  522. %doc doc
  523. %{_libdir}/atlas-sse3/*.so
  524. %{_includedir}/atlas-%{_arch}-sse3/
  525. %{_includedir}/*.h
  526. %ghost %{_includedir}/atlas
  527. %endif
  528. %ifarch s390 s390x
  529. %files z10
  530. %defattr(-,root,root,-)
  531. %doc doc/README.Fedora
  532. %dir %{_libdir}/atlas-z10
  533. %{_libdir}/atlas-z10/*.so.*
  534. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-z10.conf
  535. %files z10-devel
  536. %defattr(-,root,root,-)
  537. %doc doc
  538. %{_libdir}/atlas-z10/*.so
  539. %{_includedir}/atlas-%{_arch}-z10/
  540. %{_includedir}/*.h
  541. %ghost %{_includedir}/atlas
  542. %files z196
  543. %defattr(-,root,root,-)
  544. %doc doc/README.Fedora
  545. %dir %{_libdir}/atlas-z196
  546. %{_libdir}/atlas-z196/*.so.*
  547. %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-z196.conf
  548. %files z196-devel
  549. %defattr(-,root,root,-)
  550. %doc doc
  551. %{_libdir}/atlas-z196/*.so
  552. %{_includedir}/atlas-%{_arch}-z196/
  553. %{_includedir}/*.h
  554. %ghost %{_includedir}/atlas
  555. %endif
  556. %endif
  557. %changelog
  558. * Thu Mar 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.8.4-4
  559. - initial build for Vine Linux
  560. * Thu Sep 01 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-3
  561. - Apply patch to enable arm build (Patch provided by Jitesh Shah <jiteshs@marvell.com>)
  562. - Stop turning off throttle checking, upstream frown at it (seems O.K. for Koji)
  563. * Mon Jun 20 2011 Dan Horák <dan[at]danny.cz> - 3.8.4-2
  564. - Use -march=z10 for z196 optimised build because the builder is a z10
  565. (Christian Bornträger)
  566. * Tue Jun 14 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-1
  567. - Update to 3.8.4
  568. - Build the default package for SSE2 and add a SSE3 subpackage on x86_64
  569. - Apply patch (and arch defs.) to build on s390 and s390x (Dan Horák)
  570. - Fix-up build on s390 and s390x (Christian Bornträger)
  571. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  572. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  573. * Mon Jul 26 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-18
  574. - Create a subpackage for SSE2 on x86_64
  575. * Sat Jul 17 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-17
  576. - rebuild against fixed lapack libraries
  577. * Thu Jul 15 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-16
  578. - fix build on s390 (patch by Karsten Hopp)
  579. * Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-15
  580. - Disable the problematic sparc patch
  581. - Change lapack-devel BR to lapack-static, where liblapack_pic.a now resides.
  582. * Wed Feb 03 2010 Dennis Gilmore <dennis@ausil.us> - 3.8.3-14
  583. - fix sparc build
  584. * Fri Jan 29 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-13
  585. - Remove static libraries.
  586. - Fix typo in SSE3 subpackage's summary.
  587. * Sat Oct 24 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-12
  588. - Use alternatives to workaround multilib conflicts (BZ#508565).
  589. * Tue Sep 29 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-11
  590. - Obsolete the -header subpackage properly.
  591. * Sat Sep 26 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-10
  592. - Use the new arch. default for Pentium PRO (Fedora bug #510498)
  593. - (Re-)Introduce 3dNow subpackage
  594. * Sun Sep 6 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 3.8.3-9
  595. - Rebuild against fixed lapack (see #520518)
  596. * Wed Aug 13 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-8
  597. - Revert the last change, it doesn't solve the problem.
  598. * Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-7
  599. - Create a -header subpackage to avoid multilib conflicts (BZ#508565).
  600. * Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-6
  601. - Add '-g' to build flag to allow proper genration of debuginfo subpackages (Fedora bug #509813)
  602. - Build for F12
  603. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-5
  604. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  605. * Sat May 02 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-4
  606. - Use the right -msse* option for the -sse* subpackages (Fedora bug #498715)
  607. * Tue Apr 21 2009 Karsten Hopp <karsten@redhat.com> 3.8.3-3.1
  608. - add s390x to 64 bit archs
  609. * Fri Feb 27 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-3
  610. - Rebuild
  611. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-2
  612. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  613. * Sun Feb 22 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-1
  614. - Update to version 3.8.3
  615. * Sun Dec 21 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-5
  616. - Link in appropriate libs when creating shared libs, reported by Orcan 'oget' Ogetbil (BZ#475411)
  617. * Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-4
  618. - Don't symlink the atlas libdir on i386, cause upgrade issue (BZ#476787)
  619. - Fix options passed to gcc when making shared libs
  620. * Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-3
  621. - Use 'gcc -shared' to build shared libs instead of stock 'ld'
  622. * Sat Dec 13 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-2
  623. - Properly obsolete/provide older subpackages that are no longer packaged.
  624. * Mon Sep 01 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-1
  625. - Upgrade to ver 3.8.2 with refined build procedures.
  626. * Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-15
  627. - Disable altivec package--it is causing illegal instructions during build.
  628. * Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-14
  629. - Enable compilation on alpha (bug 426086).
  630. - Patch for compilation on ia64 (bug 432744).
  631. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.6.0-13
  632. - Autorebuild for GCC 4.3
  633. * Mon Jun 4 2007 Orion Poplawski <orion@cora.nwra.com> 3.6.0-12
  634. - Rebuild for ppc64
  635. * Fri Sep 8 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-11
  636. - Rebuild for FC6.
  637. - Remove outdated comments from spec file.
  638. * Mon Feb 13 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-10
  639. - Rebuild for Fedora Extras 5.
  640. - Add --noexecstack to compilation of assembly kernels. These were
  641. previously marked executable, which caused problems with selinux.
  642. * Mon Dec 19 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-9
  643. - Rebuild for gcc 4.1.
  644. * Mon Oct 10 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-8
  645. - Make all devel subpackages depend on their non-devel counterparts.
  646. - Add /etc/ld.so.conf.d files for -sse and -3dnow, because they don't
  647. seem to get picked up automatically.
  648. * Wed Oct 05 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-7
  649. - Forgot to add the new patch to sources.
  650. * Tue Oct 04 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-6
  651. - Use new Debian patch, and enable shared libs (they previously failed
  652. to build on gcc 4).
  653. - Minor updates to description and README.Fedora file.
  654. - Fix buildroot name to match FE preferred form.
  655. - Fixes for custom optimized builds.
  656. - Add dist tag.
  657. * Wed Sep 28 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-5
  658. - fix files lists.
  659. * Mon Sep 26 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-4
  660. - generate library symlinks earlier for the benefit of later linking steps.
  661. * Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-3
  662. - Change lapack dependency to lapack-devel, and use lapack_pic.a for
  663. building liblapack.so.
  664. * Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-2
  665. - Add "bit" macro to correctly build on x86_64.
  666. * Tue Aug 16 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-1
  667. - Initial version.