ufraw-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221
  1. %bcond_with cinepaint
  2. Summary: Utility for digital camera raw images
  3. Summary(ja): デジタルカメラの RAW 画像ユーティリティ
  4. Name: ufraw
  5. Version: 0.22
  6. Release: 2%{?_dist_release}
  7. License: GPLv2
  8. Group: Applications/Graphics
  9. URL: http://ufraw.sourceforge.net/
  10. Source0: %{name}-%{version}.tar.gz
  11. # added Japanese comment
  12. Source10: %{name}.desktop
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cfitsio-devel
  15. BuildRequires: exiv2-devel
  16. BuildRequires: gimp-devel
  17. BuildRequires: glib2-devel >= 2.12
  18. BuildRequires: gtk2-devel >= 2.12
  19. BuildRequires: gtkimageview-devel >= 1.6.1
  20. BuildRequires: lcms2-devel
  21. BuildRequires: lensfun-devel >= 0.2.5
  22. BuildRequires: libexif-devel
  23. BuildRequires: libjpeg-devel
  24. BuildRequires: libpng-devel
  25. BuildRequires: libtiff-devel
  26. BuildRequires: perl
  27. BuildRequires: zlib-devel
  28. %if %{with cinepaint}
  29. BuildRequires: cinepaint-devel >= 0.22
  30. %define cinepaintplugindir %(pkg-config --variable=programplugindir cinepaint-gtk)/plug-ins
  31. %endif
  32. Requires(post): GConf2, shared-mime-info, desktop-file-utils
  33. Requires(postun): shared-mime-info, desktop-file-utils
  34. Requires(pre): GConf2
  35. Requires(preun): GConf2
  36. %description
  37. Application allowed to read and manipulate raw images from digital
  38. cameras. Takes care of the color management, handles the Nikon curve
  39. formats and has editor for the tone curves. It allows easy process more
  40. images in a batch on command-line.
  41. %description -l ja
  42. デジタルカメラから RAW 画像を読み込み、操作するためのアプリケーション
  43. です。カラーマネージメント機能を持ち、Nikon のカーブフォーマットの読み
  44. 込みやトーンカーブの編集が可能です。また大量のファイルをコマンドライン
  45. から簡単にバッチ処理できます。
  46. #---------------------------------------------------------------------------
  47. %package gimp
  48. Summary: Raw image loader plugin for The GIMP
  49. Summary(ja): GIMP 用の RAW 画像読み込みプラグイン
  50. Group: Applications/Graphics
  51. Requires: gimp
  52. %description gimp
  53. ufraw-gimp is a GIMP plug-in to read and manipulate raw images from
  54. digital cameras.
  55. %description gimp -l ja
  56. ufraw-gimp はデジタルカメラの RAW 画像を読み込み、操作するための GIMP プラグインです。
  57. #---------------------------------------------------------------------------
  58. %if %{with cinepaint}
  59. %package cinepaint
  60. Summary: CinePaint plugin to retrieve raw image data from digital cameras
  61. Group: Applications/Multimedia
  62. Requires: ufraw = %{version}-%{release}
  63. Requires: cinepaint
  64. %description cinepaint
  65. The ufraw-cinepaint package contains a CinePaint plugin for opening raw format
  66. images of digital cameras.
  67. %endif
  68. #---------------------------------------------------------------------------
  69. %prep
  70. %setup -q
  71. cp -p %{SOURCE10} .
  72. %build
  73. %configure --enable-mime --enable-extras --with-gimp DESTDIR=$RPM_BUILD_ROOT
  74. make schemasdir=%{_sysconfdir}/gconf/schemas
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. # don't ship dcraw binary
  79. rm -f $RPM_BUILD_ROOT%{_bindir}/dcraw
  80. # install schemas to sysconfdir manually.
  81. %{__install} -d $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
  82. ./generate_schemas.sh %{_prefix} $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/ufraw.schemas
  83. mv $RPM_BUILD_ROOT%{_datadir}/gconf/schemas/ufraw.schemas $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
  84. rm -rf $RPM_BUILD_ROOT%{_datadir}/gconf/schemas
  85. # install mime-info manually. (But this has been included in shared-mime-info >= 0.21)
  86. %{__install} -d $RPM_BUILD_ROOT%{_datadir}/mime/packages
  87. %{__install} -m 644 ufraw-mime.xml $RPM_BUILD_ROOT%{_datadir}/mime/packages
  88. %find_lang %{name}
  89. %clean
  90. %{__rm} -rf ${RPM_BUILD_ROOT}
  91. %post
  92. update-mime-database %{_datadir}/mime >& /dev/null ||:
  93. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  94. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ufraw.schemas > /dev/null ||:
  95. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  96. %pre
  97. if [ "$1" -gt 1 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. gconftool-2 --makefile-uninstall-rule \
  100. %{_sysconfdir}/gconf/schemas/ufraw.schemas > /dev/null ||:
  101. fi
  102. %preun
  103. if [ "$1" -eq 0 ]; then
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. gconftool-2 --makefile-uninstall-rule \
  106. %{_sysconfdir}/gconf/schemas/ufraw.schemas > /dev/null ||:
  107. fi
  108. %postun
  109. update-mime-database %{_datadir}/mime >& /dev/null ||:
  110. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  111. %files -f %{name}.lang
  112. %defattr(-,root,root)
  113. %doc COPYING MANIFEST README TODO
  114. %{_bindir}/ufraw
  115. %{_bindir}/ufraw-batch
  116. #{_bindir}/dcraw
  117. %{_bindir}/nikon-curve
  118. %{_sysconfdir}/gconf/schemas/ufraw.schemas
  119. %{_datadir}/appdata/%{name}.appdata.xml
  120. %{_datadir}/applications/ufraw.desktop
  121. %{_datadir}/mime/packages/ufraw-mime.xml
  122. %{_datadir}/pixmaps/ufraw.png
  123. %{_mandir}/man1/ufraw.1*
  124. %files gimp
  125. %defattr(-,root,root)
  126. %{_libdir}/gimp/2.0/plug-ins/ufraw-gimp
  127. %if %{with cinepaint}
  128. %files cinepaint
  129. %defattr(-, root, root, -)
  130. %{cinepaintplugindir}/ufraw-cinepaint
  131. %endif
  132. %changelog
  133. * Sat Sep 03 2016 Toshiaki Ara <ara_t@384.jp> 0.22-2
  134. - rebuild with gcc-5.4.0
  135. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-1
  136. - new upstream release
  137. * Tue Mar 10 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21-1
  138. - updated to 0.21
  139. - removed %{_bindir}/dcraw to avoid conflicting with dcraw package
  140. - added BR: lensfun-devel
  141. - added BR: lcms2-devel instead of lcms-devel
  142. * Wed Feb 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.18-6
  143. - rebuilt with cfitsio 3.370
  144. * Wed Jan 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-5
  145. - rebuild with libpng-1.6.12
  146. * Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-4
  147. - rebuild with exiv2-0.23
  148. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-3
  149. - rebuild with exiv2-0.23
  150. * Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-2
  151. - rebuild with exiv2-0.22
  152. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18-1
  153. - new upstream release
  154. - built with exiv2-0.21.1
  155. - added BR: cfitsio-devel, libtiff-devel
  156. * Wed May 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
  157. - new upstream release
  158. - built with exiv2-0.19
  159. * Sun Apr 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-1
  160. - new upstream release
  161. * Sun Oct 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.13-1vl5
  162. - new upstream release
  163. * Thu Sep 25 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.1-1vl5
  164. - applied new versioning policy, spec in utf-8
  165. - built with exiv2
  166. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-0vl1
  167. - new upstream release.
  168. - add Requires(post, postun)
  169. * Tue Aug 07 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-0vl1
  170. - new upstream release.
  171. - add BuildRequires gtkimageview-devel >= 1.3.0
  172. * Mon Jun 11 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.11-0vl1
  173. - initial build for Vine Linux