stunnel-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558
  1. %bcond_with systemd
  2. Summary: An SSL-encrypting socket wrapper
  3. Name: stunnel
  4. Version: 5.56
  5. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  6. Group: Applications/Internet
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: iwaim
  10. License: GPLv2
  11. URL: https://www.stunnel.org/
  12. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  13. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  14. Source2: Certificate-Creation
  15. Source3: sfinger.xinetd
  16. Source4: stunnel-sfinger.conf
  17. Source5: pop3-redirect.xinetd
  18. Source6: stunnel-pop3s-client.conf
  19. Source7: stunnel@.service
  20. Source100: stunnel.init
  21. Patch0: stunnel-5.50-authpriv.patch
  22. Patch3: stunnel-5.56-system-ciphers.patch
  23. Patch4: stunnel-5.56-coverity.patch
  24. Patch5: stunnel-5.56-default-tls-version.patch
  25. Patch6: stunnel-5.56-curves-doc-update.patch
  26. Buildroot: %{_tmppath}/stunnel-root
  27. # util-linux is needed for rename
  28. BuildRequires: openssl-devel
  29. BuildRequires: pkgconfig
  30. BuildRequires: util-linux
  31. %if %{with systemd}
  32. %{?systemd_requires}
  33. %else
  34. Requires(post): chkconfig
  35. Requires(preun): chkconfig /sbin/service
  36. Requires(postun): /sbin/service
  37. %endif
  38. %if %{with systemd}
  39. %global pidfile %{_rundir}/stunnel.pid
  40. %else
  41. %global pidfile %{_localstatedir}/run/stunnel.pid
  42. %endif
  43. # Do not generate provides for private libraries
  44. %global __provides_exclude_from ^%{_libdir}/stunnel/.*$
  45. %description
  46. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  47. Layer) support to ordinary applications. For example, it can be used
  48. in conjunction with imapd to create an SSL secure IMAP server.
  49. %prep
  50. %setup -q
  51. %autopatch -p1
  52. # Fix a testcase with system-ciphers support
  53. sed -i '/client = yes/a \\ ciphers = PSK' tests/recipes/014_PSK_secrets
  54. # modify systemd service unit
  55. sed -i '/Type=forking/a \\PrivateTmp=true' tools/stunnel.service.in
  56. %build
  57. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  58. if pkg-config openssl ; then
  59. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  60. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  61. fi
  62. %configure --disable-fips --enable-ipv6 --with-ssl=%{_prefix} \
  63. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{pidfile}\"'"
  64. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  68. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  69. make install DESTDIR=$RPM_BUILD_ROOT
  70. # Move the translated man pages to the right subdirectories, and strip off the
  71. # language suffixes.
  72. for lang in pl ; do
  73. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  74. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  75. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  76. done
  77. mkdir -p srpm-docs
  78. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  79. %if %{with systemd}
  80. mkdir -p %{buildroot}%{_unitdir}
  81. cp %{buildroot}%{_datadir}/doc/stunnel/examples/%{name}.service %{buildroot}%{_unitdir}/%{name}.service
  82. cp %{SOURCE7} %{buildroot}%{_unitdir}/%{name}@.service
  83. %else
  84. install -d -m755 %{buildroot}%{_initdir}
  85. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  86. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  87. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  88. ENABLED=0
  89. EOF
  90. %endif
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %post
  94. %if %{with systemd}
  95. %systemd_post %{name}.service
  96. %else
  97. /sbin/chkconfig --add stunnel
  98. %endif
  99. %preun
  100. %if %{with systemd}
  101. %systemd_preun %{name}.service
  102. %else
  103. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  104. /sbin/service stunnel stop /dev/null 2>/dev/null ||:
  105. /sbin/chkconfig --del stunnel
  106. fi
  107. %endif
  108. %postun
  109. %if %{with systemd}
  110. %systemd_postun_with_restart %{name}.service
  111. %else
  112. if [ $1 -gt 0 ]; then
  113. if /sbin/service stunnel status >/dev/null; then
  114. /sbin/service stunnel restart
  115. fi
  116. fi
  117. %endif
  118. %files
  119. %defattr(-,root,root)
  120. %doc AUTHORS.md BUGS.md CREDITS.md PORTS.md README.md TODO.md
  121. %doc tools/stunnel.conf-sample
  122. %doc srpm-docs/*
  123. %license COPY*
  124. %lang(en) %doc doc/en/*
  125. %lang(po) %doc doc/pl/*
  126. %{_bindir}/stunnel
  127. %exclude %{_bindir}/stunnel3
  128. %exclude %{_datadir}/doc/stunnel
  129. %{_libdir}/stunnel
  130. %exclude %{_libdir}/stunnel/libstunnel.la
  131. %{_mandir}/man8/stunnel.8*
  132. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  133. %dir %{_sysconfdir}/%{name}
  134. %dir %{_sysconfdir}/%{name}/conf.d
  135. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  136. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  137. %if %{with systemd}
  138. %{_unitdir}/%{name}*.service
  139. %else
  140. %{_initdir}/stunnel
  141. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  142. %endif
  143. %changelog
  144. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.56-1
  145. - new upstream release.
  146. - replaced all patches.
  147. - added systemd support (disabled as default).
  148. * Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
  149. - new upstream release.
  150. - updated Patch0,1.
  151. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
  152. - rebuid with OpenSSL 1.0.2k
  153. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
  154. - new upstream release.
  155. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
  156. - new upstream release.
  157. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  158. - new upstream release.
  159. - fixed dates in %%changelog.
  160. - updated all patches.
  161. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  162. - initial build for Vine Linux
  163. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  164. - 884183: support for full relro.
  165. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  166. - New upstream realease 4.54
  167. - Updated local patches
  168. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  170. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  171. - New upstream realease 4.53
  172. - Updated local patches
  173. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  174. - New upstream realease 4.52
  175. - Updated local patches
  176. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  178. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  179. - New upstream realease 4.50
  180. - Updated local patches
  181. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  182. - New upstream realease 4.44
  183. - Updated local patches
  184. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  185. - New upstream realease 4.42
  186. - Updated local patches
  187. - Fixes #732069
  188. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  189. - New upstream realease 4.41
  190. - Updated local patches to match the new release
  191. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  192. - New upstream realease 4.37
  193. - Updated local patches to match the new release
  194. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  195. - New upstream realease 4.35
  196. - Updated authpriv and sample patches to match the new release
  197. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  199. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  200. - New upstream realease 4.34
  201. - Updated authpriv and sample patches to match the new release
  202. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  203. - New upstream realease 4.33
  204. - Updated authpriv and sample patches to match the new release
  205. - Addresses bz 580117 (inted mode support issue)
  206. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  207. - New upstream realease 4.32
  208. - Updated authpriv and sample patches to match the new release
  209. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  210. - New upstream realease 4.31
  211. - Updated authpriv and sample patches to match the new release
  212. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  213. - New upstream realease 4.30
  214. - Updated authpriv and sample patches for the new release
  215. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  216. - New upstream realease 4.29
  217. - Updated authpriv and sample patches for the new release
  218. - Modified spec file to include dist tag
  219. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  220. - rebuilt with new openssl
  221. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  222. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  223. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  224. - Fix the previous patch.
  225. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  226. - Avoid aliasing undefined by ISO C
  227. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  228. - Update to stunnel-4.27.
  229. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  230. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  231. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  232. - disable openssl upstream fips mode
  233. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  234. - Update to stunnel-4.26.
  235. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  236. - Use a clearer error message if the service name is unknown in "accept"
  237. Resolves: #450344
  238. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  239. - Update to stunnel-4.25
  240. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  241. - Drop stunnel3
  242. Resolves: #442842
  243. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  244. - Update to stunnel-4.24
  245. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  246. - Update to stunnel-4.22
  247. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  248. - Autorebuild for GCC 4.3
  249. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  250. - Rebuild with openssl-0.9.8g
  251. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  252. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  253. Resolves: #301971
  254. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  255. Resolves: #322281
  256. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  257. - Port to NSS
  258. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  259. - Update BuildRequires for the separate tcp_wrappers-devel package
  260. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  261. - Update to stunnel-4.20
  262. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  263. - Update to stunnel-4.19
  264. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  265. - Update to stunnel-4.18
  266. - Remove unused stunnel.cnf from the src.rpm
  267. - Fix some rpmlint warnings
  268. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  269. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  270. (#203001)
  271. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  272. - rebuild
  273. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  274. - Update to stunnel-4.15
  275. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  276. - bump again for double-long bug on ppc(64)
  277. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  278. - rebuilt for new gcc4.1 snapshot and glibc changes
  279. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  280. - Use pthread threading to fix crash on x86_64 (#179236)
  281. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  282. - rebuilt
  283. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  284. - Rebuild with newer openssl
  285. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  286. - Update to stunnel-4.14
  287. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  288. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  289. - Update to stunnel-4.13
  290. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  291. - Update to stunnel-4.12
  292. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  293. - Enable IPv6 (#169050, patch by Peter Bieringer)
  294. - Don't ship another copy of man pages in HTML
  295. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  296. - Update to stunnel-4.11
  297. - Fix int/size_t mismatches in stack_info ()
  298. - Update Certificate-Creation for /etc/pki
  299. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  300. - Fix inetd mode
  301. - Remove unnecessary Requires: and BuildRequires:
  302. - Clean up the spec file
  303. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  304. - update to 4.10
  305. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  306. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  307. coreutils (#133961)
  308. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  309. - update to 4.08
  310. - build stunnel as a PIE binary
  311. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  312. - Convert man pages to UTF-8
  313. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  314. - rebuilt
  315. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  316. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  317. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  318. - update to 4.05
  319. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  320. - rebuilt
  321. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  322. - rebuilt
  323. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  324. - Fix libtool
  325. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  326. - rebuilt
  327. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  328. - fix xinetd configuration samples
  329. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  330. - rebuild
  331. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  332. - rebuilt
  333. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  334. - update to 4.04
  335. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  336. - use pkgconfig for information about openssl, if available
  337. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  338. - update to 4.03
  339. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  340. - update to 4.02
  341. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  342. - don't create a dummy cert
  343. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  344. - update to 4.00
  345. - remove textutils and fileutils as buildreqs, add automake/autoconf
  346. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  347. - automated rebuild
  348. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  349. - automated rebuild
  350. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  351. - rebuild in new environment
  352. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  353. - update to 3.22, correcting a format-string vulnerability
  354. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  355. - update to 3.21a
  356. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  357. - log using LOG_AUTHPRIV facility by default (#47289)
  358. - make permissions on stunnel binary 0755
  359. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  360. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  361. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  362. tcp wrappers not being thrad-safe
  363. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  364. - update to 3.17
  365. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  366. - update to 3.16
  367. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  368. - update to 3.15
  369. - enable tcp-wrappers support
  370. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  371. - remove explicit requirement on openssl (specific version isn't enough,
  372. we have to depend on shared library version anyway)
  373. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  374. - update to 3.14
  375. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  376. - depend on make (#33148)
  377. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  378. - rebuild in new environment
  379. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  380. - update to 3.13 to get pthread, OOB, 64-bit fixes
  381. - don't need sdf any more
  382. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  383. - pull in sdf to build the man page (#22892)
  384. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  385. - update to 3.11
  386. - chuck the SIGHUP patch (went upstream)
  387. - chuck parts of the 64-bit clean patch (went upstream)
  388. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  389. - update to 3.10
  390. - more 64-bit clean changes, hopefully the last bunch
  391. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  392. - change piddir from the default /var/stunnel to /var/run
  393. - clean out pid file on SIGHUP
  394. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  395. - update to 3.9 to get a security fix
  396. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  397. - change all unsigned longs to u_int32_t when dealing with network
  398. addresses
  399. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  400. - make stunnel.pem also be (missingok)
  401. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  402. - move to Applications/Internet group
  403. - clean up %%post script
  404. - make stunnel.pem %%ghost %%config(noreplace)
  405. - provide a sample file for use with xinetd
  406. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  407. - FHS compliance fixes
  408. - modify defaults
  409. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  410. - update to 3.8
  411. - do not create certificate if one already exists
  412. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  413. - update to 3.7
  414. - add patch to find /usr/share/ssl
  415. - change some perms
  416. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  417. - Modify spec file to match Red Hat standards
  418. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  419. - Updated to 3.4a
  420. - Patched for OpenSSL 0.9.4
  421. - Cleaned up files section
  422. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  423. - Updated to 3.3
  424. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  425. - Initial RPMification