meson-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. %{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
  2. %global libname mesonbuild
  3. Name: meson
  4. Summary: High productivity build system
  5. Summary(ja): 高生産性ビルドシステム
  6. Version: 0.54.0
  7. Release: 1%{?_dist_release}
  8. Group: Development/Tools
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildArch: noarch
  12. License: ASL 2.0
  13. URL: https://mesonbuild.com/
  14. Source0: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
  15. Source1: macros.meson
  16. Obsoletes: %{name}-gui < 0.31.0-3
  17. BuildRequires: python3-devel
  18. BuildRequires: python3-setuptools
  19. BuildRequires: python-rpm-macros
  20. BuildRequires: python3-rpm-macros
  21. BuildRequires: ninja
  22. # Various languages
  23. BuildRequires: gcc
  24. BuildRequires: libasan
  25. BuildRequires: gcc-c++
  26. BuildRequires: gcc-objc
  27. BuildRequires: gcc-objc++
  28. BuildRequires: rust
  29. # Various libs support
  30. BuildRequires: libboost-devel
  31. BuildRequires: vala
  32. BuildRequires: flex
  33. BuildRequires: bison
  34. BuildRequires: gettext
  35. BuildRequires: git-core
  36. #BuildRequires: pkgconfig(glib-2.0)
  37. #BuildRequires: pkgconfig(gobject-introspection-1.0)
  38. #BuildRequires: itstool
  39. BuildRequires: zlib-devel
  40. BuildRequires: llvm-devel
  41. BuildRequires: cups-devel
  42. Requires: ninja
  43. Requires: python3-setuptools
  44. %description
  45. Meson is a build system designed to optimize programmer
  46. productivity. It aims to do this by providing simple, out-of-the-box
  47. support for modern software development tools and practices, such as
  48. unit tests, coverage reports, Valgrind, CCache and the like.
  49. %prep
  50. %autosetup -p1
  51. find -type f -name '*.py' -executable -exec sed -i -e '1s|.*|#!%{__python3}|' {} ';'
  52. # Remove MPI tests for now because it is complicated to run
  53. rm -rf "test cases/frameworks/17 mpi"
  54. %build
  55. %py3_build
  56. #python3 setup.py build
  57. %install
  58. %py3_install
  59. #python3 setup.py install --root %{buildroot}
  60. install -Dpm0644 %{SOURCE1} %{buildroot}%{rpmmacrodir}/macros.%{name}
  61. %check
  62. export MESON_PRINT_TEST_OUTPUT=1
  63. python3 ./run_tests.py ||:
  64. %files
  65. %license COPYING
  66. %{_bindir}/%{name}
  67. %{python3_sitelib}/%{libname}/
  68. %{python3_sitelib}/%{name}-*.egg-info/
  69. %{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
  70. %{_mandir}/man1/%{name}.1*
  71. %{rpmmacrodir}/macros.*
  72. %changelog
  73. * Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.54.0-1
  74. - new upstream release.
  75. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.51.2-1
  76. - updated to 0.51.2.
  77. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.49.0-1
  78. - updated to 0.49.0.
  79. - updated macros.meson.
  80. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.44.0-1
  81. - updated to 0.44.0.
  82. * Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.42.0-1
  83. - initial build for Vine Linux.
  84. * Fri Aug 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.42.0-1
  85. - Update to 0.42.0
  86. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41.2-2
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  88. * Wed Jul 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.2-1
  89. - Update to 0.41.2
  90. * Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 0.41.1-3
  91. - Backport various gtk-doc fixes from upstream
  92. * Thu Jul 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.1-2
  93. - Strip trailing slash from pkg-config files
  94. * Mon Jun 19 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.1-1
  95. - Update to 0.41.1
  96. * Tue Jun 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.0-1
  97. - Update to 0.41.0
  98. * Wed May 31 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-2
  99. - Don't run ldc tests
  100. * Fri Apr 28 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-1
  101. - Update to 0.40.1
  102. * Sun Apr 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.0-1
  103. - Update to 0.40.0
  104. * Thu Apr 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-2
  105. - Exclude ldc for module builds
  106. * Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-1
  107. - Update to 0.39.1
  108. * Mon Mar 06 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.39.0-1
  109. - Update to 0.39.0
  110. * Tue Feb 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.1-1
  111. - Update to 0.38.1
  112. * Sun Jan 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.0-1
  113. - Update to 0.38.0
  114. * Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.1-2
  115. - Rebuild for Python 3.6
  116. * Tue Dec 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.1-1
  117. - Update to 0.37.1
  118. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.0-2
  119. - Rebuild for Python 3.6
  120. * Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
  121. - Update to 0.37.0
  122. * Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
  123. - Backport more RPM macro fixes (FPC ticket #655)
  124. * Tue Dec 13 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-3
  125. - Backport fixes to RPM macros
  126. * Sat Dec 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-2
  127. - Print test output during build
  128. * Mon Nov 14 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-1
  129. - Update to 0.36.0
  130. * Tue Oct 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.1-1
  131. - Update to 0.35.1 (RHBZ #1385986)
  132. * Tue Oct 11 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-3
  133. - Backport couple of fixes
  134. * Wed Oct 05 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-2
  135. - Apply patch to fix FTBFS
  136. * Mon Oct 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-1
  137. - Update to 0.35.0
  138. * Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-2
  139. - Run D test suite
  140. * Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-1
  141. - Update to 0.34.0
  142. * Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-2
  143. - Obsoletes fix.
  144. * Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-1
  145. - 0.33.0
  146. - GUI dropped upstream.
  147. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31.0-2
  148. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  149. * Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.31.0-1
  150. - Update to 0.31.0
  151. * Sun Mar 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0-1
  152. - Update to 0.30.0
  153. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  155. * Sun Jan 24 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.29.0-1
  156. - Update to 0.29.0
  157. * Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 0.28.0-2
  158. - Rebuilt for Boost 1.60
  159. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.28.0-1
  160. - 0.28.0
  161. * Wed Nov 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.27.0-1
  162. - 0.27.0
  163. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
  164. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  165. * Fri Oct 30 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-2
  166. - Fix rpm macros for using optflags
  167. * Sun Sep 13 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-1
  168. - 0.26.0
  169. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.25.0-4
  170. - Rebuilt for Boost 1.59
  171. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-3
  172. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  173. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.25.0-2
  174. - rebuild for Boost 1.58
  175. * Sun Jul 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.0-1
  176. - 0.25.0
  177. * Sat Jul 11 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-3
  178. - Update URLs
  179. - drop unneded hacks in install section
  180. - enable print test output for tests
  181. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-2
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  183. * Mon May 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-1
  184. - Update to 0.24.0
  185. * Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
  186. - Update to latest git
  187. * Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
  188. - Add patch to accept .S files
  189. * Wed Apr 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-2
  190. - Add python3 to Requires (Thanks to Ilya Kyznetsov)
  191. * Tue Mar 31 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-1
  192. - 0.23.0
  193. * Sat Mar 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150328git3b49b71
  194. - Update to latest git
  195. * Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150325git18550fe
  196. - Update to latest git
  197. - Include mesonintrospect
  198. * Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150322git78d31ca
  199. - Fix filelists for mesongui (python-bytecode-without-source)
  200. * Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-8.20150322git78d31ca
  201. - Enable C# tests
  202. * Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
  203. - update to latest git
  204. - fix tests on arm
  205. * Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
  206. - update to latest git
  207. * Mon Mar 16 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150316gitfa2c659
  208. - update to latest git
  209. * Tue Mar 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150310gitf9f51b1
  210. - today's git snapshot with support for cool GNOME features
  211. - re-enable wxGTK3 tests, package fixed in rawhide
  212. * Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-6.git7581895
  213. - split gui to subpkg
  214. - update to latest snapshot
  215. - enable tests
  216. * Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-5.gitc6dbf98
  217. - Fix packaging style
  218. - Make package noarch
  219. * Mon Feb 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-4.git.c6dbf98
  220. - Use development version
  221. * Sat Feb 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-3
  222. - Add ninja-build to requires
  223. * Thu Jan 22 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-2
  224. - fix shebang in python files
  225. * Wed Jan 21 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-1
  226. - Initial package