OpenEXR-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. %bcond_with check
  2. Name: OpenEXR
  3. Summary: A high dynamic-range (HDR) image file format
  4. Summary(ja): 高ダイナミックレンジ(HDR)画像ファイルフォーマット
  5. Version: 2.4.1
  6. Release: 1%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Group: Applications/Graphics
  10. License: BSD
  11. URL: http://www.openexr.com/
  12. Source0: https://github.com/openexr/openexr/archive/v%{version}.tar.gz#/openexr-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: zlib-devel
  16. BuildRequires: pkgconfig
  17. # https://github.com/openexr/openexr/issues/130
  18. BuildConflicts: OpenEXR-devel < 2.2.0
  19. Requires: %{name}-libs = %{version}-%{release}
  20. Obsoletes: openexr < %{version}-%{release}
  21. Provides: openexr = %{version}-%{release}
  22. %description
  23. OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
  24. Light & Magic for use in computer imaging applications. This package contains
  25. sample applications for handling the format.
  26. %package libs
  27. Summary: %{name} runtime libraries
  28. Summary(ja): %{name} のランタイムライブラリ
  29. Group: System Environment/Libraries
  30. %description libs
  31. %{summary}.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Summary(ja): %{name} の開発用ファイル
  35. Group: Development/Libraries
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: ilmbase-devel
  38. Obsoletes: openexr-devel < %{version}-%{release}
  39. Provides: openexr-devel = %{version}-%{release}
  40. %description devel
  41. %{summary}.
  42. %package -n ilmbase
  43. Summary: Abraction/convenience libraries
  44. Group: System Environment/Libraries
  45. BuildRequires: libGL-devel
  46. BuildRequires: libGLU-devel
  47. %description -n ilmbase
  48. Half is a class that encapsulates the ilm 16-bit floating-point format.
  49. IlmThread is a thread abstraction library for use with OpenEXR
  50. and other software packages.
  51. Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
  52. and other useful 2D and 3D math functions.
  53. Iex is an exception-handling library.
  54. %package -n ilmbase-devel
  55. Summary: Headers and libraries for building apps that use ilmbase
  56. Summary(ja): ilmbaseを使うアプリケーションをビルドするためのヘッダファイル及びライブラリ
  57. Group: Development/Libraries
  58. Requires: ilmbase = %{version}-%{release}
  59. Requires: pkgconfig
  60. Requires: libGL-devel
  61. Requires: libGLU-devel
  62. %description -n ilmbase-devel
  63. Headers and libraries for building apps that use ilmbase.
  64. %prep
  65. %setup -q -n openexr-%{version}
  66. pushd IlmBase
  67. echo "Requires.private: gl glu" >> IlmBase.pc.in
  68. popd
  69. # *.pc built by cmake is broken
  70. # https://github.com/openexr/openexr/issues/595
  71. sed -i \
  72. -e 's,@exec_prefix@,${prefix}/@exec_prefix@,' \
  73. -e 's,@libdir@,\${prefix}/@libdir@,' \
  74. -e 's,@includedir@,${prefix}/@includedir@,' \
  75. IlmBase/IlmBase.pc.in
  76. sed -i \
  77. -e 's,@exec_prefix@,${prefix}/@exec_prefix@,' \
  78. -e 's,@libdir@,\${prefix}/@libdir@,' \
  79. -e 's,@includedir@,${prefix}/@includedir@,' \
  80. OpenEXR/OpenEXR.pc.in
  81. %build
  82. mkdir build
  83. pushd build
  84. %cmake \
  85. -DPYILMBASE_ENABLE=no \
  86. -DOPENEXR_VIEWERS_ENABLE=no \
  87. ..
  88. make %{?_smp_mflags}
  89. popd
  90. %install
  91. rm -rf %{buildroot}
  92. pushd build
  93. make install DESTDIR=%{buildroot}
  94. popd
  95. # prepare docs
  96. mkdir -p rpmdocs
  97. cp -a %{buildroot}%{_docdir}/OpenEXR/* rpmdocs/
  98. rm -rf %{buildroot}%{_docdir}/OpenEXR
  99. %if %{with check}
  100. %check
  101. pushd build
  102. %ifarch %{ix86}
  103. make %{_smp_mflags} test ||:
  104. %else
  105. make %{_smp_mflags} test
  106. %endif
  107. popd
  108. %endif
  109. %clean
  110. rm -rf %{buildroot}
  111. %post libs -p /sbin/ldconfig
  112. %postun libs -p /sbin/ldconfig
  113. %files
  114. %defattr(-,root,root,-)
  115. %license LICENSE.md
  116. %doc README.md
  117. %{_bindir}/*
  118. %files libs
  119. %defattr(-,root,root,-)
  120. %license LICENSE.md
  121. %doc OpenEXR/README.md
  122. %doc rpmdocs/*
  123. %{_libdir}/libIlmImf*.so.*
  124. %files devel
  125. %defattr(-,root,root,-)
  126. %{_includedir}/OpenEXR/Imf*.h
  127. %{_includedir}/OpenEXR/OpenEXRConfig.h
  128. %{_libdir}/lib*.so
  129. %dir %{_libdir}/pkgconfig
  130. %{_libdir}/pkgconfig/OpenEXR.pc
  131. %dir %{_libdir}/cmake
  132. %{_libdir}/cmake/OpenEXR
  133. %files -n ilmbase
  134. %doc IlmBase/README.md
  135. %license LICENSE.md
  136. %{_libdir}/lib*.so.*
  137. %exclude %{_libdir}/libIlmImf*.so.*
  138. %files -n ilmbase-devel
  139. %dir %{_includedir}/OpenEXR/
  140. %{_includedir}/OpenEXR/Iex*.h
  141. %{_includedir}/OpenEXR/Ilm*.h
  142. %{_includedir}/OpenEXR/Imath*.h
  143. %{_includedir}/OpenEXR/half*.h
  144. %{_libdir}/lib*.so
  145. %exclude %{_libdir}/libIlmImf*.so
  146. %dir %{_libdir}/pkgconfig
  147. %{_libdir}/pkgconfig/IlmBase.pc
  148. %dir %{_libdir}/cmake
  149. %{_libdir}/cmake/IlmBase
  150. %changelog
  151. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  152. - new upstream release.
  153. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
  154. - new upstream release.
  155. - unified IlmBase into OpenEXR.
  156. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
  157. - rebuild with gcc-5.4.0
  158. * Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.0-1
  159. - new upstream release
  160. - removed Patch100 and 101
  161. - built with ilmbase 2.2.0
  162. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  163. - new upstream release
  164. - remove Patch1,2,102
  165. - update Patch100 (openexr-2.1.0-CVE-2009-1720-1.patch)
  166. - update Patch101 (openexr-2.1.0-CVE-2009-1720-2.patch)
  167. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
  168. - rebuilt with rpm-4.8.1 for pkg-config
  169. * Wed Aug 5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
  170. - add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
  171. - add Patch102 for fix CVE-2009-1721
  172. - Patch100-102 are from FC11
  173. * Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
  174. - initial build for Vine Linux
  175. * Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
  176. - drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
  177. * Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
  178. - gcc43 patch
  179. - purge rpaths
  180. * Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
  181. - hack to omit unused-direct-shlib-dependencies
  182. - conditionalize -libs (f8+)
  183. * Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
  184. - openexr-1.6.1
  185. * Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
  186. - multiarch conflicts in OpenEXR (#342781)
  187. - don't own %%_includedir/OpenEXR (leave that to ilmbase)
  188. * Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
  189. - -libs: %%post/%%postun -p /sbin/ldconfig
  190. * Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
  191. - openexr-1.6.0
  192. * Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
  193. - libs: -Requires: %%name
  194. * Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
  195. - -libs: new subpkg to be multilib friendly
  196. - -utils: package exrdisplay separately (separate fltk dep)
  197. * Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
  198. - Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
  199. * Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
  200. - pkgconfig patch to use Libs.private
  201. * Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
  202. - -devel: +Requires: pkgconfig
  203. * Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
  204. - openexr-1.4.0a
  205. * Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
  206. - Further zlib fixes (#165729)
  207. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
  208. - Rebuild for Fedora Extras 5
  209. * Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
  210. - Remove *.a from %%files devel
  211. * Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
  212. - Removed -devel dep on zlib-devel (#165729)
  213. - Added --disable-static to %%configure
  214. - Fixed build with GCC 4.0.1
  215. - Added .so links to -devel
  216. * Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
  217. - Add zlib-devel to BR
  218. - Delete all .la files (#157652)
  219. * Mon May 9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
  220. - Add disttag
  221. * Sun May 8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
  222. - Fix BuildRequires
  223. - Fix Requires on -devel
  224. - Add %%post[un] scriptlets
  225. - Fix ownership in -devel
  226. - Don't have .deps files in %%doc
  227. * Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
  228. - Initial RPM release