tk-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. Summary: A Tcl/Tk development environment: tk
  2. Summary(ja): Tcl/Tk 開発環境: tk
  3. Name: tk
  4. Version: 8.6.10
  5. %global majorver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  6. %global minorver %(echo %{version} | sed -e 's/^.*\.//')
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: TCL
  12. URL: https://tcl.sourceforge.net/
  13. Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: autoconf
  16. BuildRequires: libX11-devel
  17. BuildRequires: libXft-devel
  18. BuildRequires: tcl-devel = %{version}
  19. Requires: tcl >= %{majorver}
  20. Provides: libtk%{majorver}.so
  21. %description
  22. Tk is a X Windows widget set designed to work closely with the tcl
  23. scripting language. It allows you to write simple programs with full
  24. featured GUI's in only a little more time then it takes to write a
  25. text based interface. Tcl/Tk applications can also be run on Windows
  26. and Macintosh platforms.
  27. %description -l ja
  28. Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
  29. System のウィジェットセットです。 テキストベースのインターフェースを
  30. 採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
  31. ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
  32. のプラットフォームで実行することもできます。
  33. %package devel
  34. Summary: Tk graphical toolkit development files
  35. Summary(ja): Tk ツールキットの開発環境
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: tcl-devel = %{version}
  39. Requires: libX11-devel
  40. Requires: libXft-devel
  41. %description devel
  42. Tk is a X Windows widget set designed to work closely with the tcl
  43. scripting language. It allows you to write simple programs with full
  44. featured GUI's in only a little more time then it takes to write a
  45. text based interface. Tcl/Tk applications can also be run on Windows
  46. and Macintosh platforms.
  47. The package contains the development files and man pages for tk.
  48. %prep
  49. %setup -n %{name}%{version} -q
  50. sed -i -e 's/555/755/g' unix/Makefile.in
  51. sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtk%{majorver}.so/' unix/Makefile.in
  52. %build
  53. cd unix
  54. autoconf
  55. export CFLAGS="%{optflags} -fPIC"
  56. %configure \
  57. --disable-rpath
  58. make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  62. ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
  63. # for linking with -l%{name}
  64. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  65. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
  66. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  67. ( cd $RPM_BUILD_ROOT/%{_includedir}
  68. for i in *.h ; do
  69. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  70. done
  71. )
  72. # remove buildroot traces
  73. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  74. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
  75. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %post -p /sbin/ldconfig
  79. %postun -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root,-)
  82. %license license.terms
  83. %doc README changes
  84. %{_bindir}/wish*
  85. %{_datadir}/tk%{majorver}
  86. %{_libdir}/libtk%{majorver}.so
  87. %{_libdir}/tk%{majorver}
  88. %{_libdir}/tkConfig.sh
  89. %{_mandir}/man1/*
  90. %{_mandir}/mann/*
  91. %files devel
  92. %defattr(-,root,root)
  93. %{_includedir}/*
  94. %{_libdir}/libtk.so
  95. %{_libdir}/libtkstub%{majorver}.a
  96. %{_libdir}/tkConfig.sh
  97. %{_libdir}/pkgconfig/tk.pc
  98. %{_mandir}/man3/*
  99. %changelog
  100. * Wed Jul 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.10-1
  101. - new upstream release.
  102. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
  103. - new upstream release.
  104. - dropped Patch102: get same effects by sed and configure options.
  105. - dropped Patch101: get same effects by sed.
  106. - dropped Patch103: fixed in upstream.
  107. - dropped Patch105: fixed in upstream.
  108. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-2
  109. - split development files into devel subpackage
  110. - added BR: libXft-devel
  111. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
  112. - new upstream release
  113. - drop obsolete patche (Patch104)
  114. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  115. - update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
  116. - update License: TCL
  117. - drop obsolete patches
  118. - lib-perm patch (Patch2)
  119. - lastevent patch (Patch3)
  120. - tkBind patch (Patch4)
  121. - add some patches from RHEL tk-8.5.7-6.el6
  122. - make patch (Patch101)
  123. - conf patch (Patch102)
  124. - seg_input patch (Patch103)
  125. - color patch (Patch104)
  126. - nofont sigsegv patch (Patch105)
  127. - add some documents
  128. - update build and install section: sync RHEL tk-8.5.7-6.el6
  129. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  130. - added "BuildRequires: imake".
  131. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  132. - rebuilt with rpm-4.8.1-3
  133. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  134. - rebuilt with tcl-8.4.19-2
  135. - dropt Patch4: tk-8.4.18-tkBind.patch
  136. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  137. - new upstream release
  138. - add Patch3,4 to fix bug (broken if built with xproto-7.x)
  139. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
  140. - spec in utf-8
  141. * Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  142. - rebuild with xorg-x11-7.3
  143. - remove Requires: XFree86-libs
  144. - add BuildRequires: libX11-devel
  145. - use autoconf instead of autoconf217
  146. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  147. - updated tk to 8.4.18
  148. - included CVE-2008-0553
  149. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  150. - updated tk to 8.4.16
  151. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  152. - updated tk to 8.4.15
  153. - rebuilt with new toolchain
  154. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  155. - updated tk to 8.4.13
  156. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  157. - updated tk to 8.4.12
  158. - updated tk-%%{version}-lib-perm.patch
  159. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
  160. - dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
  161. - replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
  162. - dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
  163. - dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
  164. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
  165. - added tk-8.4.6-tkUnixWm.patch
  166. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  167. - updated tk to 8.4.6
  168. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  169. - syncd with fedora
  170. * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
  171. - add private header files needed to build tix in /usr/include/tk-private
  172. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
  173. - removed rpath (patch 3)
  174. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  175. - new package split out from tcltk
  176. - update to tk 8.4.5 (#88429)
  177. - filtered changelog for tk
  178. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  179. - remove build remnants from tkConfig.sh
  180. * Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
  181. - fix buildrequires and requires section
  182. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  183. - update based on BitWalk's tcltk-8.4.2-83bw
  184. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  185. - splite source package
  186. - add include files
  187. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  188. - expand some macros.. (FIXME)
  189. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  190. - use %configure macros
  191. - add Patch 47,50
  192. * Thu May 31 2001 <sagami@vinelinux.org>
  193. - 8.0.5_jp-10
  194. - unexpand old %%{configure}, new one causes build failure
  195. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  196. - install manpages into %%{_mandir} and mode 644
  197. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  198. - 8.0.5_jp-9
  199. - modified %install section to handle compressed man pages
  200. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  201. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  202. - changed default fonts
  203. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  204. - added defattr
  205. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  206. - added some symlinks, such as libtcl8.0.so.
  207. - obsoletes version number using _jp, now 8.0.5-31vl1
  208. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  209. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  210. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  211. - fix tclX symlinks.
  212. - compile on systems where SIGPWR == SIGLOST.
  213. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  214. - update tcl/tk to 8.0.5.
  215. - avoid "containing" in Tix (#2332).
  216. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  217. - use /usr/bin/write in kibitz (#1320).
  218. - use cirrus.sprl.umich.edu in weather (#1926).
  219. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  220. - auto rebuild in the new build environment (release 28)
  221. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  222. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  223. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  224. - expect does unaligned access on alpha (#989)
  225. - upgrade tcl/tk/tclX to 8.0.4
  226. - upgrade expect to 5.28.
  227. - add itcl 3.0.1
  228. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  229. - call libtoolize to allow building on the arm
  230. - build for glibc 2.1
  231. - strip binaries
  232. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  233. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  234. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  235. - expect: mkpasswd needs delay before sending password (problem #576)
  236. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  237. - translations modified for de, fr, tr
  238. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  239. - fixed expect binaries exec permissions
  240. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  241. - updated to Tix 4.1.0.006
  242. - updated version numbers of tcl/tk to relflect includsion of p2
  243. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  244. - updated tcl/tk to patch level 2
  245. - updated tclX to 8.0.2
  246. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  247. - fixed filelist for tix... replacing path to the expect binary in scripts
  248. was leaving junk files around.
  249. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  250. - added patch to remove libieee test in configure.in for tcl and tk.
  251. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  252. solution for all systems
  253. - fixed src urls
  254. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  255. - removed version numbers from descriptions
  256. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  257. - updated to tcl/tk 8.0 and related versions of packages
  258. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  259. - built against glibc
  260. - fixed dangling tclx/tkx symlinks