tcl-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492
  1. %global itcl_version 4.2.0
  2. %global tdbc_version 1.1.1
  3. %global thread_version 2.8.5
  4. %{!?sdt:%define sdt 0}
  5. Summary: A Tcl/Tk development environment: tcl
  6. Summary(ja): Tcl/Tk 開発環境: tcl
  7. Name: tcl
  8. Version: 8.6.10
  9. %global majorver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  10. %global minorver %(echo %{version} | sed -e 's/^.*\.//')
  11. %global htmlver %{version}
  12. Release: 1%{?_dist_release}
  13. Group: Development/Languages
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: TCL
  17. URL: http://tcl.sourceforge.net/
  18. Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  19. Source1: https://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
  20. Patch0: tcl-8.6.10-autopath.patch
  21. Patch1: tcl-8.6.10-conf.patch
  22. Patch2: tcl-8.6.10-hidden.patch
  23. Patch3: tcl-8.6.10-tcltests-path-fix.patch
  24. Buildroot: %{_tmppath}/%{name}-%{version}-root
  25. Buildrequires: autoconf
  26. BuildRequires: zlib-devel
  27. %if %sdt
  28. BuildRequires: systemtap-sdt-devel
  29. %endif
  30. %description
  31. Tcl is a simple scripting language designed to be embedded into
  32. other applications. Tcl is designed to be used with Tk, a widget
  33. set, which is provided in the tk package. This package also includes
  34. tclsh, a simple example of a Tcl application.
  35. %description -l ja
  36. Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
  37. ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
  38. デザインしています。このパッケージにはTclの簡単な例として、tclsh
  39. も含んでいます。
  40. %package devel
  41. Summary: Tcl scripting language development environment
  42. Summary(ja): Tcl スクリプト言語の開発環境
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. Tcl is a simple scripting language designed to be embedded into
  47. other applications. Tcl is designed to be used with Tk, a widget
  48. set, which is provided in the tk package. This package also includes
  49. tclsh, a simple example of a Tcl application.
  50. The package contains the development files and man pages for tcl.
  51. %package itcl
  52. Summary: Object oriented extensions to Tcl and Tk
  53. Summary(ja): Tcl/Tk のオブジェクト指向拡張
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Provides: itcl = %{itcl_version}
  57. Obsoletes: itcl < 4.0.0
  58. %description itcl
  59. [incr Tcl] is Tcl extension that provides object-oriented features that are
  60. missing from the Tcl language.
  61. %package itcl-devel
  62. Summary: Development headers and libraries for linking against tcl-itcl
  63. Summary(ja): tcl-itclとリンクするためのヘッダ・ライブラリ
  64. Group: Development/Libraries
  65. Requires: %{name}-itcl = %{version}-%{release}
  66. Provides: itcl-devel = %{itcl_version}
  67. Obsoletes: itcl-devel < 4.0.0
  68. %description itcl-devel
  69. Development headers and libraries for linking against itcl.
  70. %package tdbc
  71. Summary: database extensions to Tcl and Tk
  72. Summary(ja): Tcl/Tk のデータベース拡張
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. Provides: tdbc = %{tdbc_version}
  76. %description tdbc
  77. tdbc is Tcl extension that provides database features to tcl/tk.
  78. %package tdbc-devel
  79. Summary: Development headers and libraries for linking against tcl-tdbc
  80. Summary(ja): tcl-tdbcとリンクするためのヘッダ・ライブラリ
  81. Group: Development/Libraries
  82. Requires: %{name}-tdbc = %{version}-%{release}
  83. Requires: sqlite3-tcl
  84. Provides: tdbc-devel = %{tdbc_version}
  85. %description tdbc-devel
  86. Development headers and libraries for linking against tdbc.
  87. %package thread
  88. Summary: thread extensions to Tcl and Tk
  89. Summary(ja): Tcl/Tk のスレッド拡張
  90. Group: Development/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. Provides: thread = %{thread_version}
  93. Obsoletes: thread < 2.8.0
  94. %description thread
  95. You can use this extension to gain script-level access to Tcl threading
  96. capabilities.
  97. %prep
  98. %setup -n %{name}%{version} -q -a 1
  99. mv tcl%{htmlver}/html .
  100. %patch0 -p1 -b .autopath
  101. %patch1 -p1 -b .conf
  102. %patch2 -p1 -b .hidden
  103. %patch3 -p1 -b .tcltests-path-fix
  104. pushd unix
  105. sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtcl%{majorver}.so/' Makefile.in
  106. popd
  107. %build
  108. pushd unix
  109. autoconf
  110. %configure \
  111. %if %sdt
  112. --enable-dtrace \
  113. %endif
  114. --disable-threads \
  115. --enable-symbols \
  116. --enable-shared
  117. make %{?_smp_mflags} CFLAGS="%{optflags} -fPIC" TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  118. %install
  119. rm -rf $RPM_BUILD_ROOT
  120. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  121. ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
  122. # for linking with -lib%{name}
  123. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  124. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
  125. # postgresql and maybe other packages too need tclConfig.sh
  126. # paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
  127. ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
  128. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
  129. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  130. pushd $RPM_BUILD_ROOT/%{_includedir}
  131. for i in *.h ; do
  132. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  133. done
  134. popd
  135. # remove buildroot traces
  136. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  137. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
  138. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
  139. # sqlite3 extension is provided by sqlite3-tcl
  140. rm -rf %{buildroot}%{_libdir}/sqlite3*
  141. rm -f %{buildroot}%{_mandir}/mann/sqlite3*
  142. %clean
  143. rm -rf $RPM_BUILD_ROOT
  144. %post -p /sbin/ldconfig
  145. %postun -p /sbin/ldconfig
  146. %files
  147. %defattr(-,root,root,-)
  148. %license license.terms
  149. %doc README changes
  150. %doc html/*
  151. %{_bindir}/tclsh*
  152. %{_libdir}/libtcl%{majorver}.so
  153. %dir %{_libdir}/tcl%{majorver}
  154. %{_datadir}/%{name}8
  155. %{_datadir}/tcl%{majorver}
  156. %{_mandir}/man1/*
  157. %{_mandir}/mann/*
  158. # itcl
  159. %exclude %{_mandir}/mann/body.n*
  160. %exclude %{_mandir}/mann/class.n*
  161. %exclude %{_mandir}/mann/code.n*
  162. %exclude %{_mandir}/mann/configbody.n*
  163. %exclude %{_mandir}/mann/delete.n*
  164. %exclude %{_mandir}/mann/ensemble.n*
  165. %exclude %{_mandir}/mann/find.n*
  166. %exclude %{_mandir}/mann/is.n*
  167. %exclude %{_mandir}/mann/itcl*.n*
  168. %exclude %{_mandir}/mann/local.n*
  169. %exclude %{_mandir}/mann/scope.n*
  170. # tdbc
  171. %exclude %{_mandir}/mann/tdbc*
  172. # thread
  173. %exclude %{_mandir}/mann/thread.n*
  174. %exclude %{_mandir}/mann/tpool.n*
  175. %exclude %{_mandir}/mann/tsv.n*
  176. %exclude %{_mandir}/mann/ttrace.n*
  177. %files devel
  178. %defattr(-,root,root,-)
  179. %{_includedir}/*
  180. %{_libdir}/pkgconfig/tcl.pc
  181. %{_libdir}/libtcl.so
  182. %{_libdir}/libtclstub%{majorver}.a
  183. %{_libdir}/tclConfig.sh
  184. %{_libdir}/tclooConfig.sh
  185. %{_libdir}/tcl%{majorver}/tclConfig.sh
  186. %{_mandir}/man3/*
  187. %files itcl
  188. %{_libdir}/itcl*
  189. %exclude %{_libdir}/itcl*/itclConfig.sh
  190. %exclude %{_libdir}/itcl*/libitclstub*.a
  191. %{_mandir}/mann/body.n*
  192. %{_mandir}/mann/class.n*
  193. %{_mandir}/mann/code.n*
  194. %{_mandir}/mann/configbody.n*
  195. %{_mandir}/mann/delete.n*
  196. %{_mandir}/mann/ensemble.n*
  197. %{_mandir}/mann/find.n*
  198. %{_mandir}/mann/is.n*
  199. %{_mandir}/mann/itcl*.n*
  200. %{_mandir}/mann/local.n*
  201. %{_mandir}/mann/scope.n*
  202. %files itcl-devel
  203. %{_libdir}/itcl*/itclConfig.sh
  204. %{_libdir}/itcl*/libitclstub*.a
  205. %{_includedir}/itcl*.h
  206. %files tdbc
  207. %{_libdir}/tdbc*
  208. %exclude %{_libdir}/tdbc*/libtdbcstub*.a
  209. %exclude %{_libdir}/tdbc*/tdbcConfig.sh
  210. %{_bindir}/sqlite3_analyzer
  211. %{_libdir}/tcl8/%{majorver}/tdbc/sqlite3-*.tm
  212. %{_mandir}/mann/tdbc*
  213. %files tdbc-devel
  214. %{_libdir}/tdbc*/libtdbcstub*.a
  215. %{_libdir}/tdbc*/tdbcConfig.sh
  216. %{_includedir}/tdbc*.h
  217. %files thread
  218. %{_libdir}/thread*
  219. %{_mandir}/mann/thread.n*
  220. %{_mandir}/mann/tpool.n*
  221. %{_mandir}/mann/tsv.n*
  222. %{_mandir}/mann/ttrace.n*
  223. %changelog
  224. * Wed Jul 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.10-1
  225. - new upstream release.
  226. - replaced all patches to the newest rawhide's.
  227. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
  228. - new upstream release.
  229. - dropped Patch101: get same effects by sed and configure options.
  230. - imported Patch103.
  231. - added subpackages: itcl{,-devel}, tdbc{,-devel} and thread.
  232. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-3
  233. - split development files into devel subpackage
  234. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
  235. - rebuilt with the current environment
  236. * Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
  237. - update to 8.5.15
  238. - update Patch101 (tcl-8.5.15-conf.patch)
  239. - remove Patch103 (tcl-8.5.7-sigabrt.patch)
  240. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  241. - update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
  242. - update License: TCL
  243. - drop obsolete patches
  244. - tclm4-soname patch (Patch1)
  245. - lib-perm patch (Patch2)
  246. - configure patch (Patch3)
  247. - no rpath patch (Patch4)
  248. - init lib64 patch (Patch10)
  249. - add some patches from RHEL tcl-8.5.7-6.el6
  250. - autopath patch (Patch100)
  251. - conf patch (Patch101)
  252. - hidden patch (Patch102)
  253. - sigabrt patch (Patch103)
  254. - update build and install section: sync RHEL tcl-8.5.7-6.el6
  255. - add BR: systemtap-sdt-devel: default disable
  256. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  257. - added imake to BR:.
  258. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  259. - rebuilt with rpm-4.8.1-3
  260. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  261. - rebuilt with new environment
  262. - updated Patch3: tcl8.4.16-configure.patch
  263. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  264. - new upstream release
  265. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
  266. - spec in UTF-8
  267. - configure with disabled threads. See:
  268. https://bugzilla.redhat.com/show_bug.cgi?id=443246
  269. http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
  270. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  271. - rebuild with new environment
  272. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  273. - updated tcl to 8.4.18
  274. - updated tcl-html to 8.4.18
  275. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  276. - updated tcl to 8.4.16
  277. - updated tcl-html to 8.4.16
  278. - dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  279. - added Patch3: tcl8.4.16-configure.patch
  280. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  281. - updated tcl to 8.4.15
  282. - updated tcl-html to 8.4.15
  283. - dropt Patch1: tcl-8.3.5-tclm4-soname.patch
  284. - added Patch10: tcl-8.4.15-init.lib64.patch
  285. - rebuilt with new toolchain
  286. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  287. - updated tcl to 8.4.13
  288. - updated tcl-html to 8.4.13
  289. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  290. - updated tcl to 8.4.12
  291. - updated patch4
  292. * Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
  293. - updated tcl to 8.4.11
  294. - updated Patch4
  295. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  296. - updated tcl to 8.4.6
  297. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  298. - merged with fedora
  299. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
  300. - removed rpath (patch 4)
  301. * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
  302. - put private header files under generic and unix subdirs
  303. - include real generic/tclPort.h not just a symlink to tclUnixPort.h
  304. - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
  305. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  306. - new package split out from tcltk
  307. - update to tcl 8.4.5 (#88429)
  308. - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
  309. and tcl8.3.5-koi8-u.enc-88806.patch
  310. - include private include headers under %{_includedir}/tcl-private
  311. - filtered changelog for tcl
  312. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  313. * Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  314. - update based on BitWalk's tcltk-8.4.2-83bw
  315. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  316. - split source package.
  317. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  318. - expand some macros.. (FIXME)
  319. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  320. - use %configure macros
  321. - add Patch 47,50
  322. * Thu May 31 2001 <sagami@vinelinux.org>
  323. - 8.0.5_jp-10
  324. - unexpand old %%{configure}, new one causes build failure
  325. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  326. - install manpages into %%{_mandir} and mode 644
  327. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  328. - 8.0.5_jp-9
  329. - modified %install section to handle compressed man pages
  330. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  331. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  332. - changed default fonts
  333. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  334. - added defattr
  335. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  336. - added some symlinks, such as libtcl8.0.so.
  337. - obsoletes version number using _jp, now 8.0.5-31vl1
  338. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  339. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  340. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  341. - fix tclX symlinks.
  342. - compile on systems where SIGPWR == SIGLOST.
  343. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  344. - update tcl/tk to 8.0.5.
  345. - avoid "containing" in Tix (#2332).
  346. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  347. - use /usr/bin/write in kibitz (#1320).
  348. - use cirrus.sprl.umich.edu in weather (#1926).
  349. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  350. - auto rebuild in the new build environment (release 28)
  351. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  352. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  353. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  354. - expect does unaligned access on alpha (#989)
  355. - upgrade tcl/tk/tclX to 8.0.4
  356. - upgrade expect to 5.28.
  357. - add itcl 3.0.1
  358. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  359. - call libtoolize to allow building on the arm
  360. - build for glibc 2.1
  361. - strip binaries
  362. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  363. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  364. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  365. - expect: mkpasswd needs delay before sending password (problem #576)
  366. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  367. - translations modified for de, fr, tr
  368. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  369. - fixed expect binaries exec permissions
  370. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  371. - updated to Tix 4.1.0.006
  372. - updated version numbers of tcl/tk to relflect includsion of p2
  373. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  374. - updated tcl/tk to patch level 2
  375. - updated tclX to 8.0.2
  376. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  377. - fixed filelist for tix... replacing path to the expect binary in scripts
  378. was leaving junk files around.
  379. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  380. - added patch to remove libieee test in configure.in for tcl and tk.
  381. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  382. solution for all systems
  383. - fixed src urls
  384. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  385. - removed version numbers from descriptions
  386. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  387. - updated to tcl/tk 8.0 and related versions of packages
  388. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  389. - built against glibc
  390. - fixed dangling tclx/tkx symlinks