libgnomeprint-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398
  1. ## this could go, it's really just so we notice if the soname changes
  2. %define sover 0
  3. %define gettext_package libgnomeprint-2.2
  4. %define glib2_base_version 2.18.0
  5. %define glib2_version %{glib2_base_version}
  6. %define pango_version 1.22.0
  7. %define libxml2_version 2.5.8
  8. %define libart_lgpl_version 2.3.16
  9. %define libbonobo_version 2.24.0
  10. %define freetype_version 2.3.7
  11. %define gtk_doc_version 1.1
  12. Summary: Printing library for GNOME.
  13. Summary(ja): GNOME プリントライブラリ
  14. Name: libgnomeprint
  15. Version: 2.18.7
  16. Release: 1%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: glib2-devel >= %{glib2_version}
  22. BuildRequires: pango-devel >= %{pango_version}
  23. BuildRequires: libxml2-devel >= %{libxml2_version}
  24. BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
  25. BuildRequires: libbonobo-devel >= %{libbonobo_version}
  26. BuildRequires: freetype2 >= %{freetype_version}
  27. BuildRequires: gtk-doc >= %{gtk_doc_version}
  28. BuildRequires: libgnomecups-devel >= 0.2.0
  29. BuildRequires: bison
  30. BuildRequires: flex
  31. Requires: libgnomecups >= 0.1.13-0vl2
  32. Requires: urw-fonts
  33. Requires: ghostscript
  34. Requires: ghostscript-fonts
  35. Requires: libxml
  36. Requires: perl
  37. %description
  38. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  39. applications and desktop tools to be used in conjunction with a window
  40. manager for the X Window System. The gnome-print package contains
  41. libraries and fonts needed by GNOME applications for printing.
  42. You should install the gnome-print package if you intend to use any of
  43. the GNOME applications that can print. If you would like to develop
  44. GNOME applications that can print you will also need to install the
  45. gnome-print devel package.
  46. %package devel
  47. Summary: Libraries and include files for developing GNOME applications.
  48. Summary(ja): libgnomeprint のライブラリとヘッダファイル
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: glib2-devel >= %{glib2_version}
  52. Requires: pango-devel >= %{pango_version}
  53. Requires: libxml2-devel >= %{libxml2_version}
  54. Requires: libart_lgpl-devel >= %{libart_lgpl_version}
  55. Requires: libbonobo-devel >= %{libbonobo_version}
  56. Requires: freetype2 >= %{freetype_version}
  57. %description devel
  58. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  59. applications and desktop tools to be used in conjunction with a window
  60. manager for the X Window System. The gnome-print-devel package
  61. includes the libraries and include files needed for developing
  62. applications that use the GNOME printing capabilities.
  63. You should install the gnome-print-devel package if you would like to
  64. develop GNOME applications that will use the GNOME print capabilities.
  65. You do not need to install the gnome-print-devel package if you just
  66. want to use the GNOME desktop environment.
  67. %prep
  68. %setup -q -n %{name}-%{version}
  69. %build
  70. %configure --disable-font-install --disable-gtk-doc
  71. make
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. # It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
  75. # instead of %%makeinstall with this hack.
  76. %makeinstall
  77. # remove unpackaged files
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %files
  86. %defattr(-, root, root)
  87. %doc AUTHORS COPYING ChangeLog NEWS README
  88. %dir %{_libdir}/libgnomeprint/%{version}
  89. %{_libdir}/libgnomeprint/%{version}/modules/*.so
  90. %{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
  91. %{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
  92. %{_libdir}/libgnomeprint*.so.*
  93. %{_datadir}/libgnomeprint
  94. %{_datadir}/locale/*/LC_MESSAGES/*.mo
  95. %files devel
  96. %defattr(-, root, root)
  97. %{_libdir}/libgnomeprint*.so
  98. %{_libdir}/*.a
  99. %{_includedir}/*
  100. %{_libdir}/pkgconfig/*.pc
  101. %{_datadir}/gtk-doc
  102. %changelog
  103. * Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
  104. - new upstream release
  105. - add BuildRequires: bison, flex
  106. * Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
  107. - new upstream release
  108. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
  109. - new upstream release
  110. - build with gtk+2.14
  111. * Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
  112. - new upstream release
  113. - removed BuildRequires: automake17
  114. * Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  115. - new upstream release
  116. * Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
  117. - rebuilt with new toolchain/environment
  118. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
  119. - new upstream release
  120. * Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
  121. - changed Group to System Environment/Libraries
  122. * Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  123. - add missing filter modules to %%files
  124. - remove unneeded static modules
  125. * Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  126. - new upstream release
  127. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  128. - new upstream release
  129. * Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
  130. - new upstream release
  131. * Sun Jul 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
  132. - new upstream version
  133. - drop all patches that are now upstream.
  134. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  135. - new upstream version
  136. - drop all patches that are now upstream.
  137. * Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
  138. - new upstream release
  139. - updated patch7,8 from Fedora Development
  140. - added Japanese summary to devel package
  141. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
  142. - new upstream release
  143. - add patch7,8 from fc
  144. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
  145. - add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
  146. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  147. - new upstream release
  148. * Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  149. - new upstream release
  150. * Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
  151. - Oops, spec was in Shift_JIS. Fixed.
  152. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  153. - new upstream release
  154. * Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
  155. - new upstream release
  156. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  157. - new upstream release
  158. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  159. - new upstream release
  160. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
  161. - new upstream release
  162. * Thu Jan 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
  163. - new upstream release
  164. * Sat Jan 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
  165. - new upstream release
  166. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
  167. - add patch1 to recognize .ttc font as TrueType font.
  168. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
  169. - add %%{_datadir}/libgnomeprint for %%files
  170. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  171. - new upstream release
  172. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  173. - build for Vine Linux
  174. - new upstream release from gnome-2.1.4
  175. * Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
  176. - libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
  177. * Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
  178. - libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
  179. performance issue. (#66715)
  180. * Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
  181. - includes redhat-update-gnome-font-install2 script. (#66899)
  182. - fix the install path for fontmap.
  183. - add some directory owners.
  184. * Thu Jul 11 2002 Tim Powers <timp@redhat.com>
  185. - rebuilt
  186. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  187. - 1.115.0
  188. - include gtk-doc docs
  189. - move pkg-config files to -devel package
  190. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  191. - rebuild in different environment
  192. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  193. - 1.114.0
  194. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  195. - rebuild in different environment
  196. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  197. - rebuild in different environment
  198. - add bonobo-activation requires to make build system happy
  199. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  200. - 1.113.0
  201. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  202. - rebuild for new libraries
  203. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  204. - 1.112.0
  205. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  206. - 1.111.0
  207. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  208. - Version 1.110.0
  209. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  210. - automake14
  211. * Mon Jan 7 2002 Havoc Pennington <hp@redhat.com>
  212. - 1.109.0.90 snap
  213. - remove .options patch which is upstream
  214. - remove .nofontmaps patch, upstream uses sysconfdir sometimes now
  215. and has --disable-font-install configure option
  216. - remove .fontmapdir, now fixed upstream
  217. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  218. - rebuild due to build system fuckup
  219. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  220. - cvs snap 1.106.0.90, glib 1.3.11
  221. * Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
  222. - new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
  223. * Tue Oct 9 2001 Havoc Pennington <hp@redhat.com>
  224. - remove epoch screwup
  225. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  226. - libgnomeprint package based on the gnome-print package
  227. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  228. - use 0.30 tarball
  229. * Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
  230. - new cvs snap, with headers moved
  231. * Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
  232. - Back out freetype change, for now, until we can get it in upstream.
  233. - Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
  234. Making them %config doesn't seem compatible with locating them
  235. in gnome-print/<ver>.
  236. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
  237. - no replace profiles.
  238. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
  239. - Move profiles directory to /etc/gnome-print/<ver>/profiles/
  240. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
  241. - Add freetype support patch. (Bug#50360)
  242. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  243. - Add missing directory
  244. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  245. - Upgrade to 0.29
  246. - Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
  247. - Add BuildPrereq and make -devel package require gdk-pixbuf-devel
  248. - Make libgnomeprint package require gnome-print package; otherwise
  249. packages requiring libgnomeprint might not get a runtime environment
  250. - Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
  251. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  252. - Kill output from run-gnome-font-install
  253. - s/Copyright/License/
  254. - Add post/postun scripts for the libgnomeprint subpackage
  255. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  256. - Bump release + rebuild.
  257. * Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
  258. - new version (0.28)
  259. * Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
  260. - Rebuild for GTK+-1.2.9 include paths
  261. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  262. - langify
  263. - patch it to compile (didn't include locale.h when needed)
  264. - use %%{_tmppath}
  265. * Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
  266. - Fixed font problem for Japanese.
  267. - Fixed library dependency on VFlib (Bug#28331)
  268. * Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
  269. - Fixed bugzilla bug #27417, simple specfile %post fix.
  270. * Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
  271. - Fixed PostScript broken.
  272. - Added autoheader,automake,autoconf stuff.
  273. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  274. - add libtoolize to make porting to new archs easy
  275. * Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
  276. - Updated Japanese patch for Gnumeric.
  277. Created dummy .afm.
  278. * Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
  279. - Fixed gdk_fontset_load().
  280. - Added Japanese patch for Gnumeric.
  281. * Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
  282. - Added Japanese patch.
  283. Fixed Print and Preview with Japanese.
  284. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  285. - 0.25
  286. * Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
  287. - added "|| true" to %%post so that if font-install screws up we don't get a
  288. bad exit status. gnome-font-install expects that the directory specified by
  289. HOME env. var is writable, but it isn't always if you install with 'sudo'
  290. or the equivalent. bad. bad. bad.
  291. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  292. - Up Epoch and release
  293. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  294. - redirect %%post script output to /dev/null
  295. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  296. - automatic rebuild
  297. * Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
  298. - Spec file fixes