webkitgtk4-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245
  1. ## NOTE: Lots of files in various subdirectories have the same name (such as
  2. ## "LICENSE") so this short macro allows us to distinguish them by using their
  3. ## directory names (from the source tree) as prefixes for the files.
  4. %global add_to_license_files() \
  5. mkdir -p _license_files ; \
  6. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  7. Name: webkitgtk4
  8. Version: 2.12.2
  9. Release: 1%{?_dist_release}
  10. Summary: GTK+ Web content engine library
  11. License: LGPLv2
  12. Group: Development/Libraries
  13. URL: http://www.webkitgtk.org/
  14. Source0: http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  15. Patch3: webkitgtk-2.5.2-commit_align.patch
  16. BuildRequires: at-spi2-core-devel
  17. BuildRequires: bison
  18. BuildRequires: cairo-devel
  19. BuildRequires: cmake
  20. BuildRequires: enchant-devel
  21. BuildRequires: flex
  22. BuildRequires: fontconfig-devel
  23. BuildRequires: freetype-devel
  24. BuildRequires: geoclue2-devel
  25. BuildRequires: gettext
  26. BuildRequires: glib2-devel
  27. BuildRequires: gobject-introspection-devel
  28. BuildRequires: gperf
  29. BuildRequires: gstreamer1-devel
  30. BuildRequires: gstreamer1-plugins-base-devel
  31. BuildRequires: gtk2-devel
  32. BuildRequires: gtk3-devel
  33. BuildRequires: harfbuzz-icu-devel
  34. BuildRequires: libicu-devel
  35. BuildRequires: libjpeg-turbo-devel
  36. BuildRequires: libpng-devel
  37. BuildRequires: libsecret-devel
  38. BuildRequires: libsoup-devel
  39. BuildRequires: libwebp-devel
  40. BuildRequires: libxslt-devel
  41. BuildRequires: libXt-devel
  42. BuildRequires: mesa-libGL-devel
  43. BuildRequires: pcre-devel
  44. BuildRequires: ruby
  45. BuildRequires: sqlite3-devel
  46. BuildRequires: libnotify-devel
  47. BuildRequires: hyphen-devel
  48. %ifarch ppc
  49. BuildRequires: libatomic
  50. %endif
  51. Requires: geoclue2
  52. # Obsolete libwebkit2gtk from the webkitgtk3 package
  53. Obsoletes: libwebkit2gtk < 2.4.5-3
  54. Provides: libwebkit2gtk = %{version}-%{release}
  55. # Filter out provides for private libraries
  56. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  57. %description
  58. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  59. GTK+ platform.
  60. This package contains WebKitGTK+ for GTK+ 3.
  61. %package devel
  62. Summary: Development files for %{name}
  63. Group: Development/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. %description devel
  66. The %{name}-devel package contains libraries, build data, and header
  67. files for developing applications that use %{name}.
  68. %prep
  69. %setup -q -n webkitgtk-%{version}
  70. %ifarch %{power64} aarch64 ppc
  71. %patch3 -p1 -b .commit_align
  72. %endif
  73. # Remove bundled libraries
  74. rm -rf Source/ThirdParty/leveldb/
  75. rm -rf Source/ThirdParty/gtest/
  76. rm -rf Source/ThirdParty/qunit/
  77. %build
  78. # binutils-2.23 doesn't support "reduce-memory-overheads"
  79. # Use linker flags to reduce memory consumption
  80. # global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  81. %ifarch s390 %{arm}
  82. # Decrease debuginfo verbosity to reduce memory consumption even more
  83. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  84. %endif
  85. %ifarch ppc
  86. # Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
  87. %global optflags %{optflags} -Wl,-relax -latomic
  88. %endif
  89. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  90. mkdir -p %{_target_platform}
  91. pushd %{_target_platform}
  92. %cmake \
  93. -DPORT=GTK \
  94. -DCMAKE_BUILD_TYPE=Release \
  95. -DENABLE_JIT=OFF \
  96. -DENABLE_LLINT_C_LOOP=ON \
  97. ..
  98. popd
  99. make %{?_smp_mflags} -C %{_target_platform}
  100. %install
  101. %make_install -C %{_target_platform}
  102. %find_lang WebKit2GTK-4.0
  103. # Finally, copy over and rename various files for %%license inclusion
  104. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  105. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  106. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  107. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  108. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
  109. %add_to_license_files Source/WebCore/icu/LICENSE
  110. %add_to_license_files Source/WebCore/LICENSE-APPLE
  111. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  112. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  113. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  114. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  115. %add_to_license_files Source/WTF/icu/LICENSE
  116. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  117. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  118. %post -p /sbin/ldconfig
  119. %postun -p /sbin/ldconfig
  120. %files -f WebKit2GTK-4.0.lang
  121. %license _license_files/*
  122. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  123. %{_libdir}/libwebkit2gtk-4.0.so.*
  124. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  125. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  126. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  127. %{_libdir}/webkit2gtk-4.0/
  128. %{_libexecdir}/webkit2gtk-4.0/
  129. %files devel
  130. %{_bindir}/jsc
  131. %{_includedir}/webkitgtk-4.0/
  132. %{_libdir}/libjavascriptcoregtk-4.0.so
  133. %{_libdir}/libwebkit2gtk-4.0.so
  134. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  135. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  136. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  137. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  138. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  139. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  140. %changelog
  141. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  142. - new upstream release
  143. - remove Patch0
  144. - add BuildRequires: libnotify-devel, hyphen-devel
  145. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  146. - rebuild with gnutls-3.4.7
  147. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  148. - rebuild with icu-56.1
  149. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  150. - new upstream release
  151. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  152. - new upstream release
  153. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  154. - new upstream release
  155. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  156. - new upstream release
  157. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  158. - new upstream release
  159. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  160. - new upstream release
  161. - update Patch0
  162. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  163. - new upstream release
  164. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  165. - add Group tag
  166. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  167. - new upstream release
  168. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  169. - new upstream release
  170. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  171. - initial build for Vine Linux
  172. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  173. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  174. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  175. - Update to 2.6.0
  176. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  177. - Update to 2.5.90
  178. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  179. - Obsolete libwebkit2gtk from the webkitgtk3 package
  180. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  181. - rebuild for ICU 53.1
  182. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  183. - Add support for secondary arches
  184. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  185. - Add webkitgtk-2.5.3-toggle-buttons.patch
  186. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  187. - More package review fixes (#1131284)
  188. - Correct the license tag to read LGPLv2
  189. - Filter out provides for private libraries
  190. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  191. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  192. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  193. - Update to 2.5.3
  194. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  195. - Initial Fedora packaging, based on the webkitgtk3 package