compiler-rt-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: LLVM "compiler-rt" runtime libraries
  6. Summary(ja): LLVM "compiler-rt" ランタイムライブラリ
  7. Name: compiler-rt
  8. Version: 15.0.6
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
  16. # patches
  17. Patch0: add-llvm-cmake-package.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: python3
  22. BuildRequires: python3-devel
  23. BuildRequires: llvm-devel = %{version}
  24. BuildRequires: llvm-static = %{version}
  25. Requires: clang = %{version}-%{release}
  26. # LLVM is not supported on PPC64
  27. # http://llvm.org/bugs/show_bug.cgi?id=3729
  28. ExcludeArch: ppc64
  29. %description
  30. The compiler-rt project is a part of the LLVM project. It provides
  31. implementation of the low-level target-specific hooks required by
  32. code generation, sanitizer runtimes and profiling library for code
  33. instrumentation, and Blocks C language extension.
  34. %debug_package
  35. %prep
  36. %autosetup -n compiler-rt-%{version}.src -p2
  37. pathfix%{python3_version}.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
  38. %build
  39. %cmake \
  40. -GNinja \
  41. -DCMAKE_BUILD_TYPE=Release \
  42. -DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
  43. -DCMAKE_INSTALL_RPATH=";" \
  44. -DCMAKE_SKIP_RPATH:BOOL=ON \
  45. %if 0%{?__isa_bits} == 64
  46. -DLLVM_LIBDIR_SUFFIX=64 \
  47. %else
  48. -DLLVM_LIBDIR_SUFFIX= \
  49. %endif
  50. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  51. %cmake_build
  52. %install
  53. rm -rf %{buildroot}
  54. %cmake_install
  55. # compiler-rt
  56. # move sanitizer lists to better place
  57. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/share
  58. mv -v %{buildroot}%{_datadir}/*list.txt %{buildroot}%{_libdir}/clang/%{version}/share/
  59. # move sanitizer libs to better place
  60. %global libclang_rt_installdir lib/linux
  61. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
  62. mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
  63. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
  64. pushd %{buildroot}%{_libdir}/clang/%{version}/lib
  65. for i in *.a *.so
  66. do
  67. ln -s ../$i linux/$i
  68. done
  69. %if %{with test}
  70. %check
  71. #cmake_build --target check-compiler-rt
  72. %endif
  73. %clean
  74. rm -rf %{buildroot}
  75. %files
  76. %license LICENSE.TXT
  77. %{_includedir}/*
  78. %{_libdir}/clang/%{version}/lib/*
  79. %{_libdir}/clang/%{version}/share/*
  80. %ifarch x86_64 aarch64
  81. %{_bindir}/hwasan_symbolize
  82. %endif
  83. %changelog
  84. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  85. - new upstream release.
  86. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  87. - new upstream release.
  88. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  89. - new upstream release.
  90. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  91. - new upstream release.
  92. - dropped Patch0.
  93. - imported Patch0 from rawhide.
  94. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  95. - new upstream release.
  96. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  97. - new upstream release.
  98. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  99. - new upstream release.
  100. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  101. - devided compiler-rt from llvm.
  102. - new upstream release.
  103. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  104. - enabled to build utils.
  105. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  106. - new upstream release.
  107. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  108. - new upstream release.
  109. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  110. - rebuilt with libffi-3.3.
  111. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  112. - new upstream release.
  113. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  114. - new upstream release.
  115. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  116. - dropped all patches.
  117. - switched build-system to ninja.
  118. - switched python to python3.
  119. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  120. - new upstream release.
  121. - added OpenMP.
  122. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  123. - fixed %%files.
  124. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  125. - new upstream release.
  126. - dropped Patch0, 4, 5, 100 and 200.
  127. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  128. - renamed a subpackage "llvm-libs".
  129. - added a subpackage "lld".
  130. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  131. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  132. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  133. - new upstream release.
  134. - dropped Patch1 and 2: fixed in upstream.
  135. - imported Patch0, 3-5, 100 and 200 from rawhide.
  136. - disabled Patch1002: no longer needed?
  137. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  138. - new upstream release.
  139. - switched to cmake.
  140. - disable ocaml binding as default.
  141. - updated Patch1000 and 1002.
  142. - disabled Patch1000 as default.
  143. - cleanup patches.
  144. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  145. - rebuild with gcc-5.4.0
  146. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  147. - new upstream release
  148. - added BR: ocaml-ctypes
  149. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  150. - new upstream release
  151. - dropt Patch 1, 201 and 1001
  152. - updated Patch 1000
  153. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  154. - updated to 3.5.1
  155. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  156. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  157. - obsoleted clang-doc
  158. - built with ocaml 4.02.1
  159. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  160. - fix <BTS:2832>
  161. - fix configure option "--with-c-include-dirs"
  162. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  163. - update Patch1001: clang-3.5.0-driver-lib64.patch
  164. - update Patch1002: clang-3.5.0-driver-vine.patch
  165. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  166. - update to 3.5.0
  167. - remove Patch11 (clang-hardfloat-hack.patch)
  168. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  169. - rebuild with libffi-3.0.13
  170. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  171. - update to 3.3
  172. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  173. - ld.gold (patch1000,1001)
  174. - add /%{_lib} to ld search path
  175. - add support *-vine-linux gcc (patch1002)
  176. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  177. - update to 3.1
  178. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  179. - updated to 3.0 release
  180. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  181. - added patch 2-4 to support -O4 link-time optimization
  182. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  183. - disable -fno-var-tracking-assignments on ppc
  184. (seems like gcc-4.4.5 still doesn't support this)
  185. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  186. - new upstream release
  187. - add BR: libffi-devel
  188. - add R: libffi-devel to -devel
  189. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  190. - initial build for Vine Linux
  191. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  192. - Update to final 2.7 release
  193. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  194. - Update to first 2.7 pre-release
  195. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  196. - Update to 2.6 pre-release2
  197. - -devel subpackage now virtually provides -static
  198. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  199. - Disable var tracking assignments on PPC
  200. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  201. - Don't adjust clang include dir; files there are noarch (bz#521893)
  202. - Enable clang unit tests
  203. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  204. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  205. - Package Clang's static analyzer tools
  206. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  207. - PIC is now enabled by default; explicitly disable on %%{ix86}
  208. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  209. - First 2.6 prerelease
  210. - Enable Clang front-end
  211. - Enable debuginfo generation
  212. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  213. - Disable assertions (needed by OpenGTL, bz#521261)
  214. - Align spec file with upstream build instructions
  215. - Enable unit tests
  216. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  217. - Only disable PIC on %%ix86; ppc actually needs it
  218. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  219. - Disable use of position-independent code on 32-bit platforms
  220. (buggy in LLVM <= 2.5)
  221. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  222. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  223. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  224. - Remove build scripts; they require the build directory to work
  225. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  226. - Update to 2.5
  227. - Package build scripts (bug #457881)
  228. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  229. - Patched build process for the OCaml binding
  230. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  231. - Update to 2.4
  232. - Package Ocaml binding
  233. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  234. - Add dependency on groff
  235. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  236. - LLVM 2.3
  237. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  238. - fix license tags
  239. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  240. - Fix compilation problems with gcc 4.3
  241. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  242. - Autorebuild for GCC 4.3
  243. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  244. - Fix review comments
  245. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  246. - Initial version