chkconfig-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341
  1. Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
  2. Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
  3. Name: chkconfig
  4. Version: 1.3.60
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source: %{name}-%{version}.tar.bz2
  9. Source2: chkconfig.8
  10. Source3: ntsysv.8
  11. Source4: update-alternatives.ja.8
  12. Patch0: 0001-translation-updates-from-TX.patch
  13. Patch1: chkconfig-1.3.51-vine.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: newt-devel
  16. BuildRequires: popt-devel
  17. Conflicts: initscripts <= 5.30-1
  18. %description
  19. Chkconfig is a basic system utility. It updates and queries runlevel
  20. information for system services. Chkconfig manipulates the numerous
  21. symbolic links in /etc/rc.d, to relieve system administrators of some
  22. of the drudgery of manually editing the symbolic links.
  23. %description -l ja
  24. chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
  25. runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
  26. 多数のシンボリックリンクを操作しますので、システム管理者は手動で
  27. シンボリックリンクをたびたびエディットしなくてもよい。
  28. %package -n ntsysv
  29. Summary: A tool to set the stop/start of system services in a runlevel.
  30. Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
  31. Group: System Environment/Base
  32. %description -n ntsysv
  33. Ntsysv provides a simple interface for setting which system services
  34. are started or stopped in various runlevels (instead of directly
  35. manipulating the numerous symbolic links in /etc/rc.d). Unless you
  36. specify a runlevel or runlevels on the command line (see the man
  37. page), ntsysv configures the current runlevel (5 if you're using X).
  38. %description -n ntsysv -l ja
  39. ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
  40. ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
  41. 操作することから解放する。
  42. %package -n alternatives
  43. Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
  44. Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  45. Group: System Environment/Base
  46. %description -n alternatives
  47. maintain symbolic links determining default commands (from Debian dpkg utilities)
  48. %description -n alternatives -l ja
  49. コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  50. %prep
  51. %setup -q
  52. %patch0 -p1
  53. %patch1 -p1
  54. %build
  55. %ifarch sparc
  56. LIBMHACK=-lm
  57. %endif
  58. %__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. %__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
  62. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  63. ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
  64. for n in 0 1 2 3 4 5 6; do
  65. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
  66. ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
  67. done
  68. mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
  69. cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
  70. # alternatives
  71. mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
  73. mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
  74. install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
  75. ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %files
  79. %defattr(-,root,root)
  80. /sbin/chkconfig
  81. /etc/init.d
  82. /etc/rc.d/init.d
  83. /etc/rc[0-6].d
  84. /etc/rc.d/rc[0-6].d
  85. %{_mandir}/*/chkconfig*
  86. %{_mandir}/ja/*/chkconfig*
  87. %{_localedir}/*/LC_MESSAGES/chkconfig.mo
  88. %files -n ntsysv
  89. %defattr(-,root,root)
  90. /usr/sbin/ntsysv
  91. %{_mandir}/*/ntsysv.8*
  92. %{_mandir}/ja/*/ntsysv.8*
  93. %files -n alternatives
  94. %defattr (-, root, root)
  95. /sbin/alternatives
  96. /sbin/update-alternatives
  97. %{_sysconfdir}/alternatives
  98. %{_mandir}/man8/*
  99. %{_mandir}/ja/man8/*
  100. /var/lib/rpm/alternatives
  101. %changelog
  102. * Thu Jun 06 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.60-1
  103. - update to 1.3.60
  104. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
  105. - change BuildRequires: popt-devel intead of popt
  106. * Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
  107. - new upstream release
  108. - enable fedora version of alternatives
  109. - add alternatives subpackage, replace debian's alternatives
  110. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
  111. - new upstream release
  112. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
  113. - applied new versioning policy and spec in utf-8
  114. * Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
  115. - dropped obsoleted Makefile.x86_64.patch
  116. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
  117. - new upstream release
  118. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
  119. - add Makefile.x86_64.patch
  120. * Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
  121. - add Patch10 to skip xinetd parsing if not exist.
  122. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
  123. - rebuild
  124. * Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
  125. - Requires -> Conflicts.
  126. apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
  127. Conflicts/Pre-Depends-loop does not happen.
  128. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
  129. - Oops not PreReq but Requires. Fixed.
  130. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
  131. - change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
  132. to avoid Conflicts/Pre-Depends loop on apt
  133. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  134. - 1.2.17-1vl3
  135. - change checkbox color
  136. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  137. - 1.2.17-1vl2
  138. - rebuilt for VineSeed
  139. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
  140. - 1.2.17-1vl1
  141. * Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
  142. - ignore .rpmnew files (#18915)
  143. - fix typo in error message (#17575)
  144. * Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  145. - make xinetd config files mode 0644, not 644
  146. * Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
  147. - updated it and es translations
  148. * Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
  149. - get man pages in proper packages
  150. * Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
  151. - new translations
  152. * Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  153. - don't worry about extra whitespace on chkconfig: lines (#16150)
  154. * Thu Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  155. - i18n merge
  156. * Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
  157. - new translations for de fr it es
  158. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  159. - change prereqs
  160. * Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
  161. - fix ntsysv's handling of xinetd/init files with the same name
  162. * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
  163. - fix segv when reading malformed files
  164. * Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
  165. - put links, rc[0-6].d dirs back, those are necessary
  166. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  167. - add quick hack support for reading descriptions from xinetd files
  168. * Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  169. - don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
  170. * Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
  171. - move back to old file layout
  172. * Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
  173. - bump copyright date
  174. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  175. - no %pre today. Maybe tomorrow.
  176. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  177. - put initscripts %pre here too
  178. * Mon Jul 3 2000 Bill Nottingham <notting@redhat.com>
  179. - oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
  180. * Sun Jul 2 2000 Bill Nottingham <notting@redhat.com>
  181. - add xinetd support
  182. * Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
  183. - changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
  184. - fixed sumary and description where a global string replace nuked them
  185. * Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
  186. - what Bill said, but actually build this version
  187. * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
  188. - don't own /etc/rc.*
  189. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  190. - typo in man page
  191. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  192. - fix description
  193. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  194. - link chkconfig statically against popt
  195. * Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
  196. - fix querying alternate levels
  197. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  198. - don't use strchr to skip unwanted files, look at extension instead (#4166).
  199. * Thu Aug 5 1999 Bill Nottingham <notting@redhat.com>
  200. - fix --help, --verson
  201. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  202. - rebuilt ntsysv against newt 0.50
  203. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  204. - fix i18n problem in usage message (#4233).
  205. - add --help and --version.
  206. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  207. - release for Red Hat 6.0
  208. * Thu Apr 8 1999 Matt Wilson <msw@redhat.com>
  209. - added support for a "hide: true" tag in initscripts that will make
  210. services not appear in ntsysv when run with the "--hide" flag
  211. * Thu Apr 1 1999 Matt Wilson <msw@redhat.com>
  212. - added --hide flag for ntsysv that allows you to hide a service from the
  213. user.
  214. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  215. - fix glob, once and for all. Really. We mean it.
  216. * Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
  217. - revert fix for services@levels, it's broken
  218. - change default to only edit the current runlevel
  219. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  220. - don't remove scripts that don't support chkconfig
  221. * Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
  222. - made glob a bit more specific so xinetd and inetd don't cause improper matches
  223. * Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
  224. - removed debugging output when starting ntsysv
  225. * Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
  226. - fixed globbing error
  227. - fixed ntsysv running services not at their specified levels.
  228. * Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
  229. - print the value of errno on glob failures.
  230. * Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
  231. - rebuilt for newt 0.40 (ntsysv)
  232. * Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
  233. - add ru.po.
  234. * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
  235. - build for Raw Hide (slang-1.2.2)
  236. * Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
  237. - translation updates
  238. * Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
  239. - updated czech translation (and use cs instead of cz)
  240. * Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
  241. - added pt_BR translations
  242. - added more translatable strings
  243. - support for i18n init.d scripts description
  244. * Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
  245. - built against newt 0.30
  246. - split ntsysv into a separate package
  247. * Thu May 07 1998 Erik Troan <ewt@redhat.com>
  248. - added numerous translations
  249. * Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
  250. - added i18n support
  251. * Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
  252. - added --back