strongswan-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760
  1. %bcond_with systemd
  2. %bcond_with fips2
  3. %bcond_without tss
  4. %global _unpackaged_files_terminate_build 1
  5. %global _hardened_build 0
  6. #%%define prerelease dr1
  7. Name: strongswan
  8. Version: 5.6.2
  9. Release: 2%{?_dist_release}
  10. Summary: An OpenSource IPsec-based VPN and TNC solution
  11. License: GPLv2+
  12. URL: http://www.strongswan.org/
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: tomop
  16. Source0: http://download.strongswan.org/%{name}-%{version}%{?prerelease}.tar.bz2
  17. Source1000: strongswan.init
  18. Patch1: strongswan-5.6.0-uintptr_t.patch
  19. # only needed for pre-release versions
  20. #BuildRequires: autoconf automake
  21. BuildRequires: gmp-devel
  22. BuildRequires: curl-devel
  23. BuildRequires: openldap-devel
  24. BuildRequires: openssl-devel
  25. BuildRequires: sqlite3-devel
  26. BuildRequires: gettext-devel
  27. BuildRequires: libxml2-devel
  28. BuildRequires: pam-devel
  29. BuildRequires: libgcrypt-devel
  30. BuildRequires: iptables-devel
  31. %if %{with tss}
  32. BuildRequires: trousers-devel
  33. BuildRequires: json-c-devel
  34. %endif
  35. %if "%{?_dist_release}" != "vl6"
  36. BuildRequires: NetworkManager-libnm-devel
  37. %endif
  38. %if %{with systemd}
  39. BuildRequires: systemd-devel
  40. Requires(post): systemd
  41. Requires(preun): systemd
  42. Requires(postun): systemd
  43. %else
  44. Requires(post): /sbin/chkconfig
  45. Requires(preun): /sbin/chkconfig
  46. Requires(postun): /sbin/chkconfig
  47. %endif
  48. %description
  49. The strongSwan IPsec implementation supports both the IKEv1 and IKEv2 key
  50. exchange protocols in conjunction with the native NETKEY IPsec stack of the
  51. Linux kernel.
  52. %package libipsec
  53. Summary: Strongswan's libipsec backend
  54. %description libipsec
  55. The kernel-libipsec plugin provides an IPsec backend that works entirely
  56. in userland, using TUN devices and its own IPsec implementation libipsec.
  57. %package charon-nm
  58. Summary: NetworkManager plugin for Strongswan
  59. Requires: dbus
  60. Obsoletes: %{name}-NetworkManager < 0:5.0.4-5
  61. Conflicts: %{name}-NetworkManger < 0:5.0.4-5
  62. %description charon-nm
  63. NetworkManager plugin integrates a subset of Strongswan capabilities
  64. to NetworkManager.
  65. %if %{with tss}
  66. %package tnc-imcvs
  67. Summary: Trusted network connect (TNC)'s IMC/IMV functionality
  68. Requires: %{name} = %{version}
  69. %description tnc-imcvs
  70. This package provides Trusted Network Connect's (TNC) architecture support.
  71. It includes support for TNC client and server (IF-TNCCS), IMC and IMV message
  72. exchange (IF-M), interface between IMC/IMV and TNC client/server (IF-IMC
  73. and IF-IMV). It also includes PTS based IMC/IMV for TPM based remote
  74. attestation, SWID IMC/IMV, and OS IMC/IMV. It's IMC/IMV dynamic libraries
  75. modules can be used by any third party TNC Client/Server implementation
  76. possessing a standard IF-IMC/IMV interface. In addition, it implements
  77. PT-TLS to support TNC over TLS.
  78. %endif
  79. %prep
  80. %setup -q -n %{name}-%{version}%{?prerelease}
  81. %patch1 -p1
  82. %build
  83. # only for snapshots
  84. #autoreconf
  85. # --with-ipsecdir moves internal commands to /usr/libexec/strongswan
  86. # --bindir moves 'pki' command to /usr/libexec/strongswan
  87. # See: http://wiki.strongswan.org/issues/552
  88. # too broken to enable: --enable-sha3 --enable-rdrand --enable-connmark --enable-forecast
  89. %configure --disable-static \
  90. --with-ipsec-script=strongswan \
  91. --sysconfdir=%{_sysconfdir}/strongswan \
  92. --with-ipsecdir=%{_libexecdir}/strongswan \
  93. --bindir=%{_libexecdir}/strongswan \
  94. --with-ipseclibdir=%{_libdir}/strongswan \
  95. %if %{with fips2}
  96. --with-fips-mode=2 \
  97. %endif
  98. %if "%{?_dist_release}" != "vl6"
  99. --enable-nm \
  100. %endif
  101. --enable-openssl \
  102. --enable-unity \
  103. --enable-ctr \
  104. --enable-ccm \
  105. --enable-gcm \
  106. --enable-chapoly \
  107. --enable-md4 \
  108. --enable-gcrypt \
  109. --enable-newhope \
  110. --enable-xauth-eap \
  111. --enable-xauth-pam \
  112. --enable-xauth-noauth \
  113. --enable-eap-identity \
  114. --enable-eap-md5 \
  115. --enable-eap-gtc \
  116. --enable-eap-tls \
  117. --enable-eap-ttls \
  118. --enable-eap-peap \
  119. --enable-eap-mschapv2 \
  120. --enable-eap-tnc \
  121. --enable-eap-sim \
  122. --enable-eap-sim-file \
  123. --enable-eap-aka \
  124. --enable-eap-aka-3gpp \
  125. --enable-eap-aka-3gpp2 \
  126. --enable-eap-dynamic \
  127. --enable-eap-radius \
  128. --enable-ext-auth \
  129. --enable-ipseckey \
  130. --enable-pkcs11 \
  131. --enable-farp \
  132. --enable-dhcp \
  133. --enable-ha \
  134. --enable-led \
  135. --enable-sqlite \
  136. --enable-tnc-ifmap \
  137. --enable-tnc-pdp \
  138. --enable-tnc-imc \
  139. --enable-tnc-imv \
  140. --enable-tnccs-20 \
  141. --enable-tnccs-11 \
  142. --enable-tnccs-dynamic \
  143. --enable-curl \
  144. --enable-cmd \
  145. --enable-acert \
  146. --enable-vici \
  147. --enable-swanctl \
  148. --enable-duplicheck \
  149. %if %{with tss}
  150. --enable-tss-trousers \
  151. --enable-aikgen \
  152. --enable-tpm \
  153. --enable-imc-test \
  154. --enable-imv-test \
  155. --enable-imc-scanner \
  156. --enable-imv-scanner \
  157. --enable-imc-attestation \
  158. --enable-imv-attestation \
  159. --enable-imv-os \
  160. --enable-imc-os \
  161. --enable-imc-swid \
  162. --enable-imv-swid \
  163. --enable-imc-swima \
  164. --enable-imv-swima \
  165. --enable-imc-hcd \
  166. --enable-imv-hcd \
  167. %endif
  168. %ifarch x86_64 %{ix86}
  169. --enable-aesni \
  170. %endif
  171. %if %{with systemd}
  172. --enable-systemd \
  173. %endif
  174. --enable-kernel-libipsec
  175. make %{?_smp_mflags}
  176. %install
  177. rm -rf %{buildroot}
  178. make install DESTDIR=%{buildroot}
  179. %if "%{?_dist_release}" != "vl6"
  180. mv %{buildroot}%{_sysconfdir}/strongswan/dbus-1 %{buildroot}%{_sysconfdir}/
  181. %endif
  182. # prefix man pages
  183. for i in %{buildroot}%{_mandir}/*/*; do
  184. if echo "$i" | grep -vq '/strongswan[^\/]*$'; then
  185. mv "$i" "`echo "$i" | sed -re 's|/([^/]+)$|/strongswan_\1|'`"
  186. fi
  187. done
  188. find %{buildroot} -type f -name '*.la' -delete
  189. # delete unwanted library files - no consumers, so no -devel package
  190. rm %{buildroot}%{_libdir}/strongswan/*.so
  191. # fix config permissions
  192. chmod 644 %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
  193. # Create ipsec.d directory tree.
  194. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d
  195. for i in aacerts acerts certs cacerts crls ocspcerts private reqs; do
  196. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d/${i}
  197. done
  198. %if ! %{with systemd}
  199. mkdir -p %{buildroot}%{_initdir}
  200. install -m755 %{SOURCE1000} %{buildroot}%{_initdir}/ipsec
  201. %endif
  202. %post
  203. %if %{with systemd}
  204. %systemd_post %{name}.service
  205. %else
  206. /sbin/chkconfig --add ipsec
  207. %endif
  208. %preun
  209. %if %{with systemd}
  210. %systemd_preun %{name}.service
  211. %else
  212. if [ $1 -eq 0 ]; then
  213. /sbin/service ipsec stop
  214. /sbin/chkconfig --del ipsec
  215. fi
  216. %endif
  217. %postun
  218. %if %{with systemd}
  219. %systemd_postun_with_restart %{name}.service
  220. %else
  221. if [ $1 -gt 0 ]; then
  222. /sbin/service ipsec condrestart
  223. fi
  224. %endif
  225. %files
  226. %doc README NEWS TODO ChangeLog
  227. %{!?_licensedir:%global license %%doc}
  228. %license COPYING
  229. %dir %attr(0700,root,root) %{_sysconfdir}/strongswan
  230. %config(noreplace) %{_sysconfdir}/strongswan/*
  231. %dir %{_libdir}/strongswan
  232. %dir %{_libdir}/strongswan/plugins
  233. %dir %{_libexecdir}/strongswan
  234. %{_sbindir}/charon-cmd
  235. %{_sbindir}/strongswan
  236. %{_sbindir}/swanctl
  237. %{_libdir}/strongswan/*.so.*
  238. %exclude %{_libdir}/strongswan/libipsec.so.*
  239. %{_libdir}/strongswan/plugins/*.so
  240. %exclude %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  241. %{_libexecdir}/strongswan/*
  242. %if "%{?_dist_release}" != "vl6"
  243. %exclude %{_libexecdir}/strongswan/charon-nm
  244. %endif
  245. %{_mandir}/man?/*.gz
  246. %{_datadir}/strongswan/templates/config/
  247. %if %{with tss}
  248. %exclude %{_libdir}/strongswan/imcvs
  249. %exclude %{_libdir}/strongswan/libimcv.so.*
  250. %exclude %{_libdir}/strongswan/libtnccs.so.*
  251. %exclude %{_libdir}/strongswan/libradius.so.*
  252. %exclude %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  253. %exclude %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  254. %exclude %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  255. %exclude %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  256. %exclude %{_libexecdir}/strongswan/attest
  257. %exclude %{_libexecdir}/strongswan/pt-tls-client
  258. %{_datadir}/strongswan/templates/database/
  259. %exclude %dir %{_datadir}/strongswan/swidtag
  260. %endif
  261. %if %{with systemd}
  262. %{_sbindir}/charon-systemd
  263. %{_unitdir}/strongswan.service
  264. %{_unitdir}/strongswan-swanctl.service
  265. %else
  266. %{_initdir}/ipsec
  267. %endif
  268. %if %{with tss}
  269. %files tnc-imcvs
  270. %{_sbindir}/sw-collector
  271. %{_sbindir}/sec-updater
  272. %dir %{_libdir}/strongswan/imcvs
  273. %dir %{_libdir}/strongswan/plugins
  274. %{_libdir}/strongswan/libimcv.so.*
  275. %{_libdir}/strongswan/libtnccs.so.*
  276. %{_libdir}/strongswan/libradius.so.*
  277. %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  278. %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  279. %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  280. %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  281. %{_libexecdir}/strongswan/attest
  282. %{_libexecdir}/strongswan/pt-tls-client
  283. %dir %{_datadir}/strongswan/swidtag
  284. %{_datadir}/strongswan/swidtag/*.swidtag
  285. %endif
  286. %files libipsec
  287. %{_libdir}/strongswan/libipsec.so.*
  288. %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  289. %if "%{?_dist_release}" != "vl6"
  290. %files charon-nm
  291. %doc COPYING
  292. %{_sysconfdir}/dbus-1/system.d/nm-strongswan-service.conf
  293. %{_libexecdir}/strongswan/charon-nm
  294. %endif
  295. %changelog
  296. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.2-2
  297. - initial build for Vine Linux.
  298. * Wed Feb 21 2018 Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
  299. - Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)
  300. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-2
  301. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  302. * Fri Dec 22 2017 Paul Wouters <pwouters@redhat.com> - 5.6.1-1
  303. - Updated to 5.6.1 (RSA-PSS support)
  304. * Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 5.6.0-3
  305. - Rebuilt for libjson-c.so.3
  306. * Fri Dec 01 2017 Lubomir Rintel <lkundrak@v3.sk> - 5.6.0-2
  307. - Fix the placement of charon-nm D-Bus policy
  308. * Sat Sep 09 2017 Paul Wouters <pwouters@redhat.com> - 5.6.0-1
  309. - Updated to 5.6.0
  310. - Fixup configure arguments, enabled a bunch of new features
  311. - Added new BuildRequires:
  312. - Fixup Obsolete/Conflicts, use license macro
  313. - Don't require autoconf/autotools for non-snapshots
  314. - Remove macro overuse, remove fedora/rhel checks and sysvinit support
  315. - Make listings/grouping of all plugins/libs to reduce file listing
  316. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-3
  317. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  318. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-2
  319. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  320. * Mon Jun 12 2017 Paul Wouters <pwouters@redhat.com> - 5.5.3-1
  321. - Updated to 5.5.3
  322. * Sat May 27 2017 Paul Wouters <pwouters@redhat.com> - 5.5.2-1
  323. - Updated to 5.5.2
  324. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
  325. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  326. * Thu Sep 15 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-2
  327. - Resolves: #1367796 - Enable the unity plugin
  328. * Mon Aug 08 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-1
  329. - New version 5.5.0
  330. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com>
  331. - Enable IKEv2 GCM (requires gcrypt module as well) - merged from f22 by Paul Wouters
  332. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com> - 5.4.0-1
  333. - New version 5.4.0
  334. * Thu Mar 03 2016 Pavel Šimerda <psimerda@redhat.com> - 5.3.5-1
  335. - New version 5.3.5
  336. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.3-3
  337. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  338. * Fri Jan 15 2016 Paul Wouters <pwouters@redhat.com> - 5.3.3-2
  339. - Enable IKEv2 GCM (requires gcrypt module as well)
  340. * Tue Sep 29 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.3-1
  341. - new version 5.3.3
  342. * Thu Sep 24 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.2-3
  343. - Resolves: #1264598 - strongswan: many configuration files are not protected
  344. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
  345. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  346. * Tue Jun 09 2015 Pavel Šimerda <psimerda@redhat.com>
  347. - new version 5.3.2
  348. * Fri Jun 05 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.1-1
  349. - new version 5.3.1
  350. * Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.0-1
  351. - new version 5.3.0
  352. * Fri Feb 20 2015 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-2
  353. - Fixes strongswan swanctl service issue rhbz#1193106
  354. * Tue Jan 06 2015 Pavel Šimerda <psimerda@redhat.com> - 5.2.2-1
  355. - new version 5.2.2
  356. * Thu Dec 18 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.2.dr1
  357. - Enabled ccm, and ctr plugins as it seems enabling just openssl does
  358. not work for using ccm and ctr algos.
  359. * Mon Dec 8 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.1.dr1
  360. - New strongswan developer release 5.2.2dr1
  361. * Mon Nov 24 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-2
  362. - 1167331: Enabled native systemd support.
  363. - Does not disable old systemd, starter, ipsec.conf support yet.
  364. * Thu Oct 30 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-1
  365. - New upstream release 5.2.1
  366. * Thu Oct 16 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-0.2.rc1
  367. - New upstream release candidate 5.2.1rc1
  368. * Fri Oct 10 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.1-1
  369. - new version 5.2.1dr1
  370. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-7
  371. - use upstream patch for json/json-c dependency
  372. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-6
  373. - Resolves: #1146145 - Strongswan is compiled without xauth-noauth plugin
  374. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.0-5
  375. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  376. * Tue Aug 05 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-4
  377. - Resolves: #1081804 - enable Kernel IPSec support
  378. * Wed Jul 30 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-3
  379. - rebuilt
  380. * Tue Jul 29 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-2
  381. - fix json-c dependency
  382. * Tue Jul 15 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0-1
  383. - New upstream release 5.2.0
  384. - The Attestation IMC/IMV pair supports the IMA-NG
  385. measurement format
  386. - Aikgen tool to generate an Attestation Identity Key bound
  387. to a TPM
  388. - Swanctl tool to provide a portable, complete IKE
  389. configuration and control interface for the command
  390. line using vici interface with libvici library
  391. - PT-EAP transport protocol (RFC 7171) for TNC
  392. - Enabled support for acert for checking X509 attribute certificate
  393. - Updated patches, removed selinux patch as upstream has fixed it
  394. in this release.
  395. - Updated spec file with minor cleanups
  396. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.4.dr6
  397. - improve prerelease macro
  398. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.3
  399. - Resolves: #1111895 - bump to 5.2.0dr6
  400. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.2
  401. - Related: #1087437 - remove or upstream all patches not specific to fedora/epel
  402. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.1.dr5
  403. - fix the pre-release version according to guidelines before it gets branched
  404. * Fri Jun 06 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr5-1
  405. - new version 5.2.0dr5
  406. - add json-c-devel to build deps
  407. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-3
  408. - merge two related patches
  409. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-2
  410. - clean up the patches a bit
  411. * Thu May 22 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0dr4-1
  412. - New upstream developer release 5.2.0dr4
  413. - Attestation IMV/IMC supports IMA-NG measurement format now
  414. - Aikgen tool to generate an Attestation Identity Key bound
  415. to a TPM
  416. - PT-EAP transport protocol (RFC 7171) for TNC
  417. - vici plugin provides IKE Configuration Interface for charon
  418. - Enabled support for acert for checking X509 attribute certificate
  419. - Updated patches
  420. - Updated spec file with minor cleanups
  421. * Tue Apr 15 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3-1
  422. - new version 5.1.3
  423. * Mon Apr 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3rc1-1
  424. - new version 5.1.3rc1
  425. * Mon Mar 24 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-4
  426. - #1069928 - updated libexec patch.
  427. * Tue Mar 18 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-3
  428. - fixed el6 initscript
  429. - fixed pki directory location
  430. * Fri Mar 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-2
  431. - clean up the specfile a bit
  432. - replace the initscript patch with an individual initscript
  433. - patch to build for epel6
  434. * Mon Mar 03 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-1
  435. - #1071353 - bump to 5.1.2
  436. - #1071338 - strongswan is compiled without xauth-pam plugin
  437. - remove obsolete patches
  438. - sent all patches upstream
  439. - added comments to all patches
  440. - don't touch the config with sed
  441. * Thu Feb 20 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-6
  442. - Fixed full hardening for strongswan (full relro and PIE).
  443. The previous macros had a typo and did not work
  444. (see bz#1067119).
  445. - Fixed tnc package description to reflect the current state of
  446. the package.
  447. - Fixed pki binary and moved it to /usr/libexece/strongswan as
  448. others binaries are there too.
  449. * Wed Feb 19 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-5
  450. - #903638 - SELinux is preventing /usr/sbin/xtables-multi from 'read' accesses on the chr_file /dev/random
  451. * Thu Jan 09 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-4
  452. - Removed redundant patches and *.spec commands caused by branch merging
  453. * Wed Jan 08 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-3
  454. - rebuilt
  455. * Mon Dec 2 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-2
  456. - Resolves: 973315
  457. - Resolves: 1036844
  458. * Fri Nov 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-1
  459. - Support for PT-TLS (RFC 6876)
  460. - Support for SWID IMC/IMV
  461. - Support for command line IKE client charon-cmd
  462. - Changed location of pki to /usr/bin
  463. - Added swid tags files
  464. - Added man pages for pki and charon-cmd
  465. - Renamed pki to strongswan-pki to avoid conflict with
  466. pki-core/pki-tools package.
  467. - Update local patches
  468. - Fixes CVE-2013-6075
  469. - Fixes CVE-2013-6076
  470. - Fixed autoconf/automake issue as configure.ac got changed
  471. and it required running autoreconf during the build process.
  472. - added strongswan signature file to the sources.
  473. * Thu Sep 12 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-3
  474. - Fixed initialization crash of IMV and IMC particularly
  475. attestation imv/imc as libstrongswas was not getting
  476. initialized.
  477. * Fri Aug 30 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-2
  478. - Enabled fips support
  479. - Enabled TNC's ifmap support
  480. - Enabled TNC's pdp support
  481. - Fixed hardocded package name in this spec file
  482. * Wed Aug 7 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-1
  483. - rhbz#981429: New upstream release
  484. - Fixes CVE-2013-5018: rhbz#991216, rhbz#991215
  485. - Fixes rhbz#991859 failed to build in rawhide
  486. - Updated local patches and removed which are not needed
  487. - Fixed errors around charon-nm
  488. - Added plugins libstrongswan-pkcs12.so, libstrongswan-rc2.so,
  489. libstrongswan-sshkey.so
  490. - Added utility imv_policy_manager
  491. * Thu Jul 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-5
  492. - rename strongswan-NetworkManager to strongswan-charon-nm
  493. - fix enable_nm macro
  494. * Mon Jul 15 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-4
  495. - %%files tries to package some of the shared objects as directories (#984437)
  496. - fix broken systemd unit file (#984300)
  497. - fix rpmlint error: description-line-too-long
  498. - fix rpmlint error: macro-in-comment
  499. - fix rpmlint error: spelling-error Summary(en_US) fuctionality
  500. - depend on 'systemd' instead of 'systemd-units'
  501. - use new systemd scriptlet macros
  502. - NetworkManager subpackage should have a copy of the license (#984490)
  503. - enable hardened_build as this package meets the PIE criteria (#984429)
  504. - invocation of "ipsec _updown iptables" is broken as ipsec is renamed
  505. to strongswan in this package (#948306)
  506. - invocation of "ipsec scepclient" is broken as ipsec is renamed
  507. to strongswan in this package
  508. - add /etc/strongswan/ipsec.d and missing subdirectories
  509. - conditionalize building of strongswan-NetworkManager subpackage as the
  510. version of NetworkManager in EL6 is too old (#984497)
  511. * Fri Jun 28 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-3
  512. - Patch to fix a major crash issue when Freeradius loads
  513. attestatiom-imv and does not initialize libstrongswan which
  514. causes crash due to calls to PTS algorithms probing APIs.
  515. So this patch fixes the order of initialization. This issues
  516. does not occur with charon because libstrongswan gets
  517. initialized earlier.
  518. - Patch that allows to outputs errors when there are permission
  519. issues when accessing strongswan.conf.
  520. - Patch to make loading of modules configurable when libimcv
  521. is used in stand alone mode without charon with freeradius
  522. and wpa_supplicant.
  523. * Tue Jun 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-2
  524. - Enabled TNCCS 1.1 protocol
  525. - Fixed libxm2-devel build dependency
  526. - Patch to fix the issue with loading of plugins
  527. * Wed May 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-1
  528. - New upstream release
  529. - Fixes for CVE-2013-2944
  530. - Enabled support for OS IMV/IMC
  531. - Created and applied a patch to disable ECP in fedora, because
  532. Openssl in Fedora does not allow ECP_256 and ECP_384. It makes
  533. it non-compliant to TCG's PTS standard, but there is no choice
  534. right now. see redhat bz # 319901.
  535. - Enabled Trousers support for TPM based operations.
  536. * Sat Apr 20 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.3-2
  537. - Rebuilt for a single specfile for rawhide/f19/f18/el6
  538. * Fri Apr 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.3-1
  539. - New upstream release
  540. - Enabled curl and eap-identity plugins
  541. - Enabled support for eap-radius plugin.
  542. * Thu Apr 18 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.2-3
  543. - Add gettext-devel to BuildRequires because of epel6
  544. - Remove unnecessary comments
  545. * Tue Mar 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-2
  546. - Enabled support for eap-radius plugin.
  547. * Mon Mar 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-1
  548. - Update to upstream release 5.0.2
  549. - Created sub package strongswan-tnc-imcvs that provides trusted network
  550. connect's IMC and IMV funtionality. Specifically it includes PTS
  551. based IMC/IMV for TPM based remote attestation and scanner and test
  552. IMCs and IMVs. The Strongswan's IMC/IMV dynamic libraries can be used
  553. by any third party TNC Client/Server implementation possessing a
  554. standard IF-IMC/IMV interface.
  555. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
  556. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  557. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.1-1
  558. - Update to release 5.0.1
  559. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-4.git20120619
  560. - Add plugins to interoperate with Windows 7 and Android (#862472)
  561. (contributed by Haim Gelfenbeyn)
  562. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.0-3.git20120619
  563. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  564. * Sun Jul 08 2012 Pavel Šimerda <pavlix@pavlix.net> - 5.0.0-2.git20120619
  565. - Fix configure substitutions in initscripts
  566. * Wed Jul 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-1.git20120619
  567. - Update to current upstream release
  568. - Comment out all stuff that is only needed for git builds
  569. - Remove renaming patch from git
  570. - Improve init patch used for EPEL
  571. * Thu Jun 21 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.3.git20120619
  572. - Build with openssl plugin enabled
  573. * Wed Jun 20 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.2.git20120619
  574. - Add README.Fedora with link to 4.6 to 5.0 migration information
  575. * Tue Jun 19 2012 Pavel Šimerda - 5.0.0-0.1.git20120619
  576. - Snapshot of upcoming major release
  577. - Move patches and renaming upstream
  578. http://wiki.strongswan.org/issues/194
  579. http://wiki.strongswan.org/issues/195
  580. - Notified upstream about manpage issues
  581. * Tue Jun 19 2012 Pavel Šimerda - 4.6.4-2
  582. - Make initscript patch more distro-neutral
  583. - Add links to bugreports for patches
  584. * Fri Jun 01 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.4-1
  585. - New upstream version (CVE-2012-2388)
  586. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-2
  587. - Add --enable-nm to configure
  588. - Add NetworkManager-devel to BuildRequires
  589. - Add NetworkManager-glib-devel to BuildRequires
  590. - Add strongswan-NetworkManager package
  591. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-1
  592. - New version of Strongswan
  593. - Support for RFC 3110 DNSKEY (see upstream changelog)
  594. - Fix corrupt scriptlets
  595. * Fri Mar 30 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-2
  596. - #808612 - strongswan binary renaming side-effect
  597. * Sun Feb 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-1
  598. - New upstream version
  599. - Changed from .tar.gz to .tar.bz2
  600. - Added libstrongswan-pkcs8.so
  601. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-8
  602. - Fix initscript's status function
  603. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-7
  604. - Expand tabs in config files for better readability
  605. - Add sysvinit script for epel6
  606. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-6
  607. - Fix program name in systemd unit file
  608. * Tue Feb 14 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-5
  609. - Improve fedora/epel conditionals
  610. * Sat Jan 21 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-4
  611. - Protect configuration directory from ordinary users
  612. - Add still missing directory /etc/strongswan
  613. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-3
  614. - Change directory structure to avoid clashes with Openswan
  615. - Prefixed all manpages with 'strongswan_'
  616. - Every file now includes 'strongswan' somewhere in its path
  617. - Removed conflict with Openswan
  618. - Finally fix permissions on strongswan.conf
  619. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-2
  620. - Change license tag from GPL to GPLv2+
  621. - Change permissions on /etc/strongswan.conf to 644
  622. - Rename ipsec.8 manpage to strongswan.8
  623. - Fix empty scriptlets for non-fedora builds
  624. - Add ldconfig scriptlet
  625. - Add missing directories and files
  626. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.1-1
  627. - Bump to version 4.6.1
  628. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.0-3
  629. - Add systemd scriptlets
  630. - Add conditions to also support EPEL6
  631. * Sat Dec 10 2011 Pavel Šimerda <pavlix@pavlix.net> - 4.6.0-2
  632. - Experimental build for development