libdb-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define __soversion_major 5
  3. %define __soversion %{__soversion_major}.3
  4. %bcond_with java
  5. Summary: The Berkeley DB database library for C
  6. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  7. Name: libdb
  8. Version: 5.3.28
  9. Release: 9%{?_dist_release}
  10. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  11. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  12. # For mt19937db.c
  13. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  14. Patch0: libdb-multiarch.patch
  15. # db-1.85 upstream patches
  16. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  17. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  18. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  19. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  20. # other patches
  21. Patch20: db-1.85-errno.patch
  22. Patch22: db-4.6.21-1.85-compat.patch
  23. Patch24: db-4.5.20-jni-include-dir.patch
  24. # License clarification patch
  25. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  26. Patch25: 007-mt19937db.c_license.patch
  27. #Adds missing constant to Optcodes.java and changes ClassReader.java to use it. This makes package to build with Java 8.
  28. Patch26: java8-fix.patch
  29. # memp_stat fix provided by upstream (rhbz#1211871)
  30. Patch27: db-5.3.21-memp_stat-upstream-fix.patch
  31. URL: http://www.oracle.com/database/berkeley-db/
  32. License: BSD and LGPLv2 and Sleepycat
  33. Group: System Environment/Libraries
  34. BuildRequires: perl libtool
  35. BuildRequires: tcl-devel >= 8.5.2-3
  36. %if %{with java}
  37. BuildRequires: java-devel >= 1:1.6.0
  38. %endif
  39. #BuildRequires: chrpath
  40. #Conflicts: filesystem < 3
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. Packager: tomop
  44. %description
  45. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  46. provides embedded database support for both traditional and
  47. client/server applications. The Berkeley DB includes B+tree, Extended
  48. Linear Hashing, Fixed and Variable-length record access methods,
  49. transactions, locking, logging, shared memory caching, and database
  50. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  51. used by many applications, including Python and Perl, so this should
  52. be installed on all systems.
  53. %package utils
  54. Summary: Command line tools for managing Berkeley DB databases
  55. Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
  56. Group: Applications/Databases
  57. Requires: %{name}%{?_isa} = %{version}-%{release}
  58. Obsoletes: db4-utils
  59. Provides: db4-utils
  60. %description utils
  61. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  62. provides embedded database support for both traditional and
  63. client/server applications. Berkeley DB includes B+tree, Extended
  64. Linear Hashing, Fixed and Variable-length record access methods,
  65. transactions, locking, logging, shared memory caching, and database
  66. recovery. DB supports C, C++, Java and Perl APIs.
  67. %package devel
  68. Summary: C development files for the Berkeley DB library
  69. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  70. Group: Development/Libraries
  71. Requires: %{name}%{?_isa} = %{version}-%{release}
  72. Obsoletes: db4-devel
  73. Provides: db4-devel
  74. %description devel
  75. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  76. provides embedded database support for both traditional and
  77. client/server applications. This package contains the header files
  78. and libraries for building programs which use the Berkeley DB.
  79. %package devel-doc
  80. Summary: C development documentation files for the Berkeley DB library
  81. Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
  82. Group: Documentation
  83. Requires: %{name} = %{version}-%{release}
  84. Requires: %{name}-devel = %{version}-%{release}
  85. BuildArch: noarch
  86. %description devel-doc
  87. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  88. provides embedded database support for both traditional and
  89. client/server applications. This package contains the documentation
  90. for building programs which use the Berkeley DB.
  91. %package devel-static
  92. Summary: Berkeley DB static libraries
  93. Summary(ja): Berkeley DB 静的ライブラリ
  94. Group: Development/Libraries
  95. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  96. %description devel-static
  97. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  98. provides embedded database support for both traditional and
  99. client/server applications. This package contains static libraries
  100. needed for applications that require static linking of
  101. Berkeley DB.
  102. %package cxx
  103. Summary: The Berkeley DB database library for C++
  104. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  105. Group: System Environment/Libraries
  106. Requires: %{name}%{?_isa} = %{version}-%{release}
  107. %description cxx
  108. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  109. provides embedded database support for both traditional and
  110. client/server applications. The Berkeley DB includes B+tree, Extended
  111. Linear Hashing, Fixed and Variable-length record access methods,
  112. transactions, locking, logging, shared memory caching, and database
  113. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  114. used by many applications, including Python and Perl, so this should
  115. be installed on all systems.
  116. %package cxx-devel
  117. Summary: C++ development files for the Berkeley DB library
  118. Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
  119. Group: Development/Libraries
  120. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  121. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  122. %description cxx-devel
  123. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  124. provides embedded database support for both traditional and
  125. client/server applications. This package contains the header files,
  126. libraries, and documentation for building programs which use the
  127. Berkeley DB in C++.
  128. %package tcl
  129. Summary: The Berkeley DB library for tcl
  130. Summary(ja): tcl 用 Berkeley DB データベースライブラリ
  131. Group: System Environment/Libraries
  132. Requires: %{name}%{?_isa} = %{version}-%{release}
  133. %description tcl
  134. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  135. provides embedded database support for both traditional and
  136. client/server applications. This package contains the libraries
  137. for building programs which use the Berkeley DB in Tcl.
  138. %package tcl-devel
  139. Summary: Development files for using the Berkeley DB with tcl
  140. Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
  141. Group: Development/Libraries
  142. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  143. %description tcl-devel
  144. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  145. provides embedded database support for both traditional and
  146. client/server applications. This package contains the libraries
  147. for building programs which use the Berkeley DB in Tcl.
  148. %package sql
  149. Summary: The Berkeley DB library for SQL
  150. Summary(ja): SQL 用 Berkeley DB データベースライブラリ
  151. Group: System Environment/Libraries
  152. Requires: %{name}%{?_isa} = %{version}-%{release}
  153. %description sql
  154. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  155. provides embedded database support for both traditional and
  156. client/server applications. This package contains the libraries
  157. for building programs which use the Berkeley DB in SQL.
  158. %package sql-devel
  159. Summary: Development files for using the Berkeley DB with sql
  160. Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
  161. Group: Development/Libraries
  162. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  163. %description sql-devel
  164. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  165. provides embedded database support for both traditional and
  166. client/server applications. This package contains the libraries
  167. for building programs which use the Berkeley DB in SQL.
  168. %if %{with java}
  169. %package java
  170. Summary: The Berkeley DB library for Java
  171. Summary(ja): Java 用 Berkeley DB データベースライブラリ
  172. Group: System Environment/Libraries
  173. Requires: %{name}%{?_isa} = %{version}-%{release}
  174. %description java
  175. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  176. provides embedded database support for both traditional and
  177. client/server applications. This package contains the libraries
  178. for building programs which use the Berkeley DB in Java.
  179. %package java-devel
  180. Summary: Development files for using the Berkeley DB with Java
  181. Summary(ja): Java で Berkeley DB を利用するための開発ファイル
  182. Group: Development/Libraries
  183. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  184. %description java-devel
  185. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  186. provides embedded database support for both traditional and
  187. client/server applications. This package contains the libraries
  188. for building programs which use the Berkeley DB in Java.
  189. %endif
  190. # compat32
  191. %package -n compat32-%{name}
  192. Summary: The Berkeley DB database library for C
  193. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  194. Group: System Environment/Libraries
  195. Requires: libdb = %{version}-%{release}
  196. %description -n compat32-%{name}
  197. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  198. provides embedded database support for both traditional and
  199. client/server applications. The Berkeley DB includes B+tree, Extended
  200. Linear Hashing, Fixed and Variable-length record access methods,
  201. transactions, locking, logging, shared memory caching, and database
  202. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  203. used by many applications, including Python and Perl, so this should
  204. be installed on all systems.
  205. %package -n compat32-%{name}-cxx
  206. Summary: The Berkeley DB database library for C++
  207. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  208. Group: System Environment/Libraries
  209. Requires: %{name}-cxx = %{version}-%{release}
  210. Requires: compat32-%{name} = %{version}-%{release}
  211. %description -n compat32-%{name}-cxx
  212. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  213. provides embedded database support for both traditional and
  214. client/server applications. The Berkeley DB includes B+tree, Extended
  215. Linear Hashing, Fixed and Variable-length record access methods,
  216. transactions, locking, logging, shared memory caching, and database
  217. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  218. used by many applications, including Python and Perl, so this should
  219. be installed on all systems.
  220. %package -n compat32-%{name}-devel
  221. Summary: C development files for the Berkeley DB library
  222. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  223. Group: Development/Libraries
  224. Requires: compat32-%{name} = %{version}-%{release}
  225. Requires: %{name}-devel = %{version}-%{release}
  226. Obsoletes: compat32-db4-devel
  227. Provides: compat32-db4-devel
  228. %description -n compat32-%{name}-devel
  229. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  230. provides embedded database support for both traditional and
  231. client/server applications. This package contains the header files,
  232. libraries, and documentation for building programs which use the
  233. Berkeley DB.
  234. %prep
  235. %setup -q -n db-%{version} -a 1
  236. cp %{SOURCE2} .
  237. %patch0 -p1 -b .multiarch
  238. pushd db.1.85/PORT/linux
  239. %patch10 -p0 -b .1.1
  240. popd
  241. pushd db.1.85
  242. %patch11 -p0 -b .1.2
  243. %patch12 -p0 -b .1.3
  244. %patch13 -p0 -b .1.4
  245. %patch20 -p1 -b .errno
  246. popd
  247. %patch22 -p1 -b .185compat
  248. %patch24 -p1 -b .4.5.20.jni
  249. %patch25 -p1 -b .licensefix
  250. #%patch26 -p1 -b .java8-fix
  251. %patch27 -p1 -b .memp_stat-fix
  252. cd dist
  253. ./s_config
  254. cd ..
  255. %build
  256. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  257. CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  258. export CFLAGS
  259. # Build the old db-185 libraries.
  260. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  261. test -d dist/dist-tls || mkdir dist/dist-tls
  262. # Static link db_dump185 with old db-185 libraries.
  263. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  264. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  265. # Update config files to understand aarch64
  266. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  267. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  268. #done
  269. pushd dist/dist-tls
  270. %define _configure ../configure
  271. %configure -C \
  272. --enable-compat185 \
  273. --enable-dump185 \
  274. --enable-shared \
  275. --enable-static \
  276. --enable-tcl \
  277. --with-tcl=%{_libdir} \
  278. --enable-cxx \
  279. --enable-sql \
  280. --enable-test \
  281. --disable-rpath \
  282. --with-tcl=%{_libdir}/tcl8.5 \
  283. %if %{with java}
  284. --enable-java
  285. %endif
  286. # Remove libtool predep_objects and postdep_objects wonkiness so that
  287. # building without -nostdlib doesn't include them twice. Because we
  288. # already link with g++, weird stuff happens if you don't let the
  289. # compiler handle this.
  290. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  291. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  292. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  293. make %{?_smp_mflags}
  294. %if %{with java}
  295. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  296. LDBJ=./.libs/libdb_java-%{__soversion}.la
  297. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  298. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  299. fi
  300. %endif
  301. popd
  302. %install
  303. rm -rf ${RPM_BUILD_ROOT}
  304. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  305. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  306. %makeinstall STRIP=/bin/true -C dist/dist-tls
  307. # XXX Nuke non-versioned archives and symlinks
  308. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  309. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  310. # Move the header files to a subdirectory, in case we're deploying on a
  311. # system with multiple versions of DB installed.
  312. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  313. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  314. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  315. for i in db.h db_cxx.h db_185.h; do
  316. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  317. done
  318. %if %{with java}
  319. # Move java jar file to the correct place
  320. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  321. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  322. %endif
  323. # Eliminate installed doco
  324. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  325. # XXX Avoid Permission denied. strip when building as non-root.
  326. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  327. # remove unneeded .la files (#225675)
  328. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  329. # remove RPATHs
  330. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  331. # unify documentation and examples, remove stuff we don't need
  332. rm -rf docs/csharp
  333. rm -rf examples/csharp
  334. rm -rf docs/installation
  335. mv examples docs
  336. %clean
  337. rm -rf ${RPM_BUILD_ROOT}
  338. %post -p /sbin/ldconfig
  339. %postun -p /sbin/ldconfig
  340. %post cxx -p /sbin/ldconfig
  341. %postun cxx -p /sbin/ldconfig
  342. %post sql -p /sbin/ldconfig
  343. %postun sql -p /sbin/ldconfig
  344. %post tcl -p /sbin/ldconfig
  345. %postun tcl -p /sbin/ldconfig
  346. %if %{with java}
  347. %post java -p /sbin/ldconfig
  348. %postun java -p /sbin/ldconfig
  349. %endif
  350. %if %{build_compat32}
  351. %post -n compat32-%{name} -p /sbin/ldconfig
  352. %postun -n compat32-%{name} -p /sbin/ldconfig
  353. %post -n compat32-%{name}-cxx -p /sbin/ldconfig
  354. %postun -n compat32-%{name}-cxx -p /sbin/ldconfig
  355. %endif
  356. %files
  357. %defattr(-,root,root,-)
  358. %doc LICENSE README lgpl-2.1.txt
  359. %{_libdir}/libdb-%{__soversion}.so
  360. %{_libdir}/libdb-%{__soversion_major}.so
  361. %files devel
  362. %defattr(-,root,root,-)
  363. %{_libdir}/libdb.so
  364. %dir %{_includedir}/%{name}
  365. %{_includedir}/%{name}/db.h
  366. %{_includedir}/%{name}/db_185.h
  367. %{_includedir}/db.h
  368. %{_includedir}/db_185.h
  369. %files devel-doc
  370. %defattr(-,root,root,-)
  371. %doc docs/*
  372. %files devel-static
  373. %defattr(-,root,root,-)
  374. %{_libdir}/libdb-%{__soversion}.a
  375. %{_libdir}/libdb_cxx-%{__soversion}.a
  376. %{_libdir}/libdb_tcl-%{__soversion}.a
  377. %{_libdir}/libdb_sql-%{__soversion}.a
  378. %if %{with java}
  379. %{_libdir}/libdb_java-%{__soversion}.a
  380. %endif
  381. %files utils
  382. %defattr(-,root,root,-)
  383. %{_bindir}/db*_archive
  384. %{_bindir}/db*_checkpoint
  385. %{_bindir}/db*_deadlock
  386. %{_bindir}/db*_dump*
  387. %{_bindir}/db*_hotbackup
  388. %{_bindir}/db*_load
  389. %{_bindir}/db*_printlog
  390. %{_bindir}/db*_recover
  391. %{_bindir}/db*_replicate
  392. %{_bindir}/db*_stat
  393. %{_bindir}/db*_upgrade
  394. %{_bindir}/db*_verify
  395. %{_bindir}/db*_tuner
  396. %files cxx
  397. %defattr(-,root,root,-)
  398. %{_libdir}/libdb_cxx-%{__soversion}.so
  399. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  400. %files cxx-devel
  401. %defattr(-,root,root,-)
  402. %{_includedir}/%{name}/db_cxx.h
  403. %{_includedir}/db_cxx.h
  404. %{_libdir}/libdb_cxx.so
  405. %files tcl
  406. %defattr(-,root,root,-)
  407. %{_libdir}/libdb_tcl-%{__soversion}.so
  408. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  409. %files tcl-devel
  410. %defattr(-,root,root,-)
  411. %{_libdir}/libdb_tcl.so
  412. %files sql
  413. %defattr(-,root,root,-)
  414. %{_libdir}/libdb_sql-%{__soversion}.so
  415. %{_libdir}/libdb_sql-%{__soversion_major}.so
  416. %files sql-devel
  417. %defattr(-,root,root,-)
  418. %{_bindir}/dbsql
  419. %{_libdir}/libdb_sql.so
  420. %{_includedir}/%{name}/dbsql.h
  421. %if %{with java}
  422. %files java
  423. %defattr(-,root,root,-)
  424. %{_libdir}/libdb_java-%{__soversion_major}*.so
  425. %{_datadir}/java/*.jar
  426. %files java-devel
  427. %defattr(-,root,root,-)
  428. %{_libdir}/libdb_java.so
  429. %endif
  430. %if %{build_compat32}
  431. %files -n compat32-%{name}
  432. %defattr(-,root,root)
  433. %{_libdir}/libdb-%{__soversion}.so
  434. %{_libdir}/libdb-%{__soversion_major}.so
  435. %files -n compat32-%{name}-cxx
  436. %defattr(-,root,root)
  437. %{_libdir}/libdb_cxx-%{__soversion}.so
  438. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  439. %files -n compat32-%{name}-devel
  440. %defattr(-,root,root)
  441. %{_libdir}/libdb.so
  442. %endif
  443. %changelog
  444. * Thu May 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-9
  445. - added Patch27.
  446. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
  447. - added compat32 subpackages
  448. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
  449. - updated Summary and Group
  450. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  451. - added "Provides: db4-{utils,devel}".
  452. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  453. - initial build for Vine Linux.
  454. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  455. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  456. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  457. - Fix configure macro usage for better aarch64 build fix
  458. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  459. - Updated config files to allow build on aarch64 (#1022970)
  460. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  461. - Added Sleepycat to the license list (#1013841)
  462. - Updated to 5.3.28 (#1013233)
  463. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  464. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  465. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  466. - add copy of lgpl-2.1.txt
  467. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  468. - Fix missing debuginfo issue for utils subpackage
  469. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  470. - add license clarification fix
  471. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  472. - Added sqlite compability CFLAGS (#788496)
  473. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  474. - Cleaning the specfile - removed gcc-java dependecy other way
  475. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  476. - Removed dependency on obsolete gcc-java package (#927742)
  477. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  478. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  479. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  480. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  481. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  482. - fix license tag
  483. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  484. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  485. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  486. - Specify tag for libtool (fixes FTBFS # 838334 )
  487. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  488. - update to 5.3.21
  489. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  490. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  491. - move C++ header files to cxx-devel
  492. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  493. - fix -devel packages dependencies yet more (#832225)
  494. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  495. - package -devel packages correctly
  496. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  497. - fix multiarch conflict in libdb-devel (#812901)
  498. - remove unneeded dos2unix BR
  499. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  500. - update to 5.3.15
  501. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  502. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  503. - Resolves rhbz#794472
  504. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  505. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  506. - add filesystem guard
  507. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  508. - install everything in /usr
  509. https://fedoraproject.org/wiki/Features/UsrMove
  510. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  511. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  512. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  513. - update to 5.2.36,
  514. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  515. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  516. - move development documentation to devel-doc subpackage (#705386)
  517. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  518. - update to 5.2.28
  519. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  520. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  521. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  522. - update to 5.1.25
  523. * Wed Sep 29 2010 jkeating - 5.1.19-2
  524. - Rebuilt for gcc bug 634757
  525. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  526. - update to 5.1.19
  527. - rename -devel-static to -static subpackage (#617800)
  528. - build java on all arches
  529. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  530. - update to 5.0.26
  531. - drop BR: ed
  532. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  533. - add Requires: libdb-cxx to libdb-devel
  534. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  535. - initial build
  536. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  537. - remove C# documentation
  538. - disable/remove rpath
  539. - fix description
  540. - tighten dependencies
  541. - run ldconfig for cxx and sql subpackages
  542. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  543. - enable sql
  544. - package 5.0.21