tzdata-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. Summary: Timezone data
  2. Summary(ja): タイムゾーンのデータ
  3. Name: tzdata
  4. Version: 2014e
  5. %define tzdata_version 2014e
  6. %define tzcode_version 2014e
  7. Release: 1%{?_dist_release}
  8. License: Public Domain
  9. Group: System Environment/Base
  10. URL: ftp://elsie.nci.nih.gov/pub/
  11. # The tzdata-base-0.tar.bz2 is a simple building infrastructure and
  12. # a test suite. It is occasionally updated from glibc sources, and as
  13. # such is under LGPLv2+, but none of this ever gets to be part of
  14. # final zoneinfo files.
  15. Source0: tzdata-base-0.tar.bz2
  16. # These are official upstream.
  17. Source1: ftp://munnari.oz.au/pub/tzdata%{tzdata_version}.tar.gz
  18. Source2: ftp://munnari.oz.au/pub/tzcode%{tzcode_version}.tar.gz
  19. Source3: javazic.tar.gz
  20. Patch100: javazic-fixup.patch
  21. Patch101: javazic-exclusion-fix.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. BuildRequires: gawk, glibc, perl
  25. BuildRequires: java-devel
  26. BuildRequires: glibc-common >= 2.5.90-7
  27. Conflicts: glibc-common <= 2.3.2-63
  28. %description
  29. This package contains data files with rules for various timezones around
  30. the world.
  31. %description -l ja
  32. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  33. %package java
  34. Summary: Timezone data for Java
  35. Group: System Environment/Base
  36. %description java
  37. This package contains timezone information for use by Java runtimes.
  38. %prep
  39. %setup -n tzdata
  40. mkdir tzdata%{tzdata_version}
  41. tar xzf %{SOURCE1} -C tzdata%{tzdata_version}
  42. mkdir tzcode%{tzcode_version}
  43. tar xzf %{SOURCE2} -C tzcode%{tzcode_version}
  44. sed -e 's|@objpfx@|'`pwd`'/obj/|' \
  45. -e 's|@datadir@|%{_datadir}|' \
  46. Makeconfig.in > Makeconfig
  47. pushd src
  48. for i in ../tzcode%{tzcode_version}/*.{c,h,ksh,[1-9]}
  49. do
  50. ln -sf $i .
  51. done
  52. popd
  53. mkdir javazic
  54. tar zxf %{SOURCE3} -C javazic
  55. pushd javazic
  56. %patch100
  57. %patch101
  58. # Hack alert! sun.tools may be defined and installed in the
  59. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  60. # for creating the zoneinfo files, rebase all the packages
  61. # from "sun." to "rht.". Unfortunately, gcj does not support
  62. # any of the -Xclasspath options, so we must go this route
  63. # to ensure the greatest compatibility.
  64. mv sun rht
  65. find . -type f -name '*.java' -print0 \
  66. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  67. -e 's:sun\.util\.:rht.util.:g'
  68. popd
  69. %build
  70. make
  71. grep -v tz-art.htm tzcode%{tzcode_version}/tz-link.htm > tzcode%{tzcode_version}/tz-link.html
  72. pushd javazic
  73. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  74. popd
  75. pushd tzdata%{tzdata_version}
  76. java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
  77. -d ../zoneinfo/java \
  78. africa antarctica asia australasia europe northamerica pacificnew \
  79. southamerica backward etcetera \
  80. ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
  81. popd
  82. %install
  83. rm -fr $RPM_BUILD_ROOT
  84. sed -i 's|@install_root@|%{buildroot}|' Makeconfig
  85. make install \
  86. TOPDIR=%{buildroot}%{_prefix} \
  87. TZDIR=%{buildroot}%{_datadir}/zoneinfo
  88. cp -pr zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
  89. rm -f %{buildroot}%{_datadir}/zoneinfo-posix
  90. mkdir %{buildroot}%{_datadir}/zoneinfo-posix
  91. cp -af %{buildroot}%{_datadir}/zoneinfo/* %{buildroot}%{_datadir}/zoneinfo-posix
  92. mkdir %{buildroot}%{_datadir}/zoneinfo/posix
  93. cp -af %{buildroot}%{_datadir}/zoneinfo-posix/* %{buildroot}%{_datadir}/zoneinfo/posix
  94. mkdir -p %{buildroot}%{_datadir}/zoneinfo/right
  95. cp -a %{buildroot}%{_datadir}/zoneinfo-leaps/* %{buildroot}%{_datadir}/zoneinfo/right
  96. rm -rf %{buildroot}%{_datadir}/zoneinfo-{posix,leaps}
  97. rm -rf %{buildroot}%{_prefix}/etc
  98. rm -rf %{buildroot}%{_prefix}/lib
  99. rm -rf %{buildroot}%{_prefix}/man
  100. %clean
  101. rm -fr $RPM_BUILD_ROOT
  102. %files
  103. %defattr(-,root,root)
  104. %{_datadir}/zoneinfo
  105. %doc tzcode%{tzcode_version}/README
  106. %doc tzcode%{tzcode_version}/Theory
  107. %doc tzcode%{tzcode_version}/tz-link.html
  108. %files java
  109. %defattr(-,root,root)
  110. %{_datadir}/javazi
  111. %changelog
  112. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  113. - update to tzdata-2012c, tzcode-2012b
  114. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  115. - rebuilt with rpm-4.8.1-3
  116. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  117. - update to tzdata-2010l, tzcode-2010l
  118. - added java subpackage
  119. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  120. - update to tzdata-2009d, tzcode-2009d
  121. - spec in utf-8
  122. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  123. - update to tzdata-2008b, tzcode-2008a
  124. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  125. - initial build for VineSeed
  126. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  127. - Upstream 2007d
  128. - Mongolia has abolished DST.
  129. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  130. than 01:00 standard time.
  131. - Cuba observed DST starting Sunday.
  132. - Resolute, Nunavut switched from Central to Eastern time last
  133. November.
  134. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  135. - Upstream 2007c
  136. - Pulaski County, Indiana, switched back to eastern time.
  137. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  138. - Upstream 2007b
  139. - Changes to the commentary in "leapseconds".
  140. - Upstream 2007a
  141. - Updates to Bahamas, they will be in sync with 2007 US DST change
  142. - New zone Australia/Eucla
  143. - Africa/Asmera renamed to Africa/Asmara, link created
  144. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  145. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  146. - Upstream 2006p
  147. - Covers changes from 2006m-2 and 2006m-3
  148. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  149. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  150. - Patch for Western Australia DST trial
  151. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  152. - Proposed upstream patch (#210058)
  153. - Jordan will switch to winter time on October 27, not September 29
  154. - Brazil's DST this year is the first Sunday in November to the last
  155. Sunday in February. (Thanks to Frederico A. C. Neves.)
  156. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  157. - Commentary and past timestamps changes
  158. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  159. - Upstream 2006m:
  160. - Adjustments for Egypt, Palestine, Uruguay
  161. - Better description of `until' field in zic (8) manpage
  162. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  163. - Upstream 2006k, 2006l:
  164. - Adjustments for Egypt, Palestine, Cuba, Honduras
  165. - Documentation changes
  166. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  167. - Upstream 2006j
  168. - Honduras stopped observing DST on Monday at 00:00
  169. - America/Bermuda will follow the US's lead next year
  170. - America/Moncton will use US-style rules next year
  171. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  172. year
  173. - New zone: America/Atikokan instead of America/Coral_Harbour
  174. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  175. - Historical changes
  176. - Commentary updates
  177. - Upstream 2006i
  178. - localtime.c fixes
  179. - Upstream 2006h
  180. - zic leapsecond fix
  181. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  182. - rebuild
  183. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  184. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  185. - Nicaragua updates
  186. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  187. - Upstream 2006f
  188. - America/Guatemala observes DST between Apr/30 and Oct/1
  189. - Historical changes for Nicaragua
  190. - Update of America/Indiana/Vincennes in zone table
  191. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  192. - Upstream 2006d
  193. - Haiti observes DST
  194. - Sri Lanka change actually took effect Apr/15
  195. - All Canada is now scheduled for 2007 US DST rules
  196. - Some historical fixes
  197. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  198. - Upstream 2006c
  199. - Time-related changes:
  200. - dozens of historical and commentary changes
  201. - Iran stopped observing DST
  202. - Sri Lanka switches from UTC+6 to UTC+5:30
  203. - America/Thule and America/Edmonton will adopt new US rules,
  204. starting 2007
  205. - Tunisia is adopting regular DST
  206. - Code:
  207. - asctime.c: Chages in format strings to silent gcc warnings
  208. - removing K&R notation from function signatures
  209. - few fixes across the code
  210. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  211. - Patch for Sri Lanka time zone change (#184514)
  212. * Thu Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  213. - Upstream 2006b:
  214. - using tz64code version, as 32 is legacy according to tzdata ML
  215. - new manual pages for ctime, strftime, tzset
  216. - some source code reorganizations
  217. - no timezone/dst rule updates
  218. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  219. - Small changes in tst-timezone.c
  220. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  221. - Upstream 2006a:
  222. - private.h(scheck): changing char* to char const*
  223. - Rule changes for Palestine, zone changes for Indiana/US, both
  224. changes for Canada.
  225. - Many related doc changes.
  226. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  227. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  228. - 2005r-3
  229. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  230. so that it won't clash across updates.
  231. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  232. - 2005r
  233. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  234. northamerica to guard against old files with obsolete information
  235. being left in the time zone binary directory.
  236. - Changes for countries that are supposed to join 2007 US DST
  237. change. This includes most of Canada, however entries already in
  238. the database (Alberta, British Columbia, Newfoundland, Northwest
  239. Territories, and Yukon) were left alone for the time being.
  240. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  241. is checked for emptiness.
  242. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  243. - 2005q
  244. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  245. - SystemV timezone changes
  246. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  247. - 2005n
  248. - changes for Kyrgyzstan and Uruguay
  249. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  250. make check), update tst-timezone.c from glibc CVS (#172102)
  251. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  252. - 2005m
  253. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  254. Australia, Kazakhstan
  255. - historical timezone data changes for Japan, Poland, Northern Ireland and
  256. Mali
  257. - timezone name change for East Timor
  258. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  259. - 2005k
  260. - leap seconds update
  261. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  262. - 2005i
  263. - updates for Iran, Haiti and Nicaragua
  264. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  265. - 2005h
  266. - fixes for Kazakhstan
  267. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  268. - 2005g
  269. - fixes for Uruguay
  270. - include README and Theory from tzcode tarball in %{_docdir};
  271. Theory includes a good summary of how the timezone data files
  272. are supposed to be named
  273. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  274. - 2005f
  275. - more updates for Israel, updates for Azerbaijan
  276. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  277. - 2005c
  278. - updates for Israel and Paraguay
  279. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  280. - 2004g (#141107)
  281. - updates for Cuba
  282. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  283. - 2004e (#135194)
  284. - updates for Brazil, Uruguay and Argentina
  285. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  286. - 2004b
  287. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  288. - 2003d
  289. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  290. - 2003c
  291. - updates for Brazil (#104840)
  292. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  293. - rebuilt
  294. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  295. - initial package