tk-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. %define majorver 8.5
  2. %define minorver 15
  3. Summary: A Tcl/Tk development environment: tk
  4. Summary(ja): Tcl/Tk 開発環境: tk
  5. Name: tk
  6. Version: %{majorver}.%{minorver}
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. License: TCL
  10. URL: http://tcl.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  12. # patches from Red Hat Enterprise Linux tk-8.5.7-6.el6
  13. Patch101: tk8.5-make.patch
  14. Patch102: tk8.5-conf.patch
  15. # this patch isn't needed since tk8.6b1
  16. Patch103: tk-seg_input.patch
  17. # fixes sigsegv if there is no font seen by fontconfig (#606671)
  18. Patch105: tk-8.5.7-nofont-sigsegv.patch
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: tcl = %{version}, autoconf
  21. BuildRequires: libX11-devel
  22. BuildRequires: imake
  23. Requires: tcl >= %{majorver}
  24. Provides: libtk%{majorver}.so
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Tk is a X Windows widget set designed to work closely with the tcl
  29. scripting language. It allows you to write simple programs with full
  30. featured GUI's in only a little more time then it takes to write a
  31. text based interface. Tcl/Tk applications can also be run on Windows
  32. and Macintosh platforms.
  33. %description -l ja
  34. Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
  35. System のウィジェットセットです。 テキストベースのインターフェースを
  36. 採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
  37. ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
  38. のプラットフォームで実行することもできます。
  39. %prep
  40. %setup -n %{name}%{version} -q
  41. %patch101 -p1 -b .make
  42. %patch102 -p1 -b .conf
  43. %patch103 -p1 -b .seg
  44. %patch105 -p1 -b .nofont-sigsegv
  45. %build
  46. cd unix
  47. autoconf
  48. %configure
  49. make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  53. ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
  54. # for linking with -l%{name}
  55. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  56. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
  57. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  58. ( cd $RPM_BUILD_ROOT/%{_includedir}
  59. for i in *.h ; do
  60. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  61. done
  62. )
  63. # remove buildroot traces
  64. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  65. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
  66. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %post
  70. /sbin/ldconfig
  71. %postun
  72. /sbin/ldconfig
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc README changes license.terms
  76. %{_bindir}/wish*
  77. %{_datadir}/tk%{majorver}
  78. %{_libdir}/libtk%{majorver}.so
  79. %{_libdir}/tk%{majorver}
  80. %{_libdir}/tkConfig.sh
  81. %{_mandir}/man1/*
  82. %{_includedir}/*
  83. %{_libdir}/libtk.so
  84. %{_libdir}/libtkstub%{majorver}.a
  85. %{_mandir}/man3/*
  86. %{_mandir}/mann/*
  87. %changelog
  88. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
  89. - new upstream release
  90. - drop obsolete patche (Patch104)
  91. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  92. - update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
  93. - update License: TCL
  94. - drop obsolete patches
  95. - lib-perm patch (Patch2)
  96. - lastevent patch (Patch3)
  97. - tkBind patch (Patch4)
  98. - add some patches from RHEL tk-8.5.7-6.el6
  99. - make patch (Patch101)
  100. - conf patch (Patch102)
  101. - seg_input patch (Patch103)
  102. - color patch (Patch104)
  103. - nofont sigsegv patch (Patch105)
  104. - add some documents
  105. - update build and install section: sync RHEL tk-8.5.7-6.el6
  106. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  107. - added "BuildRequires: imake".
  108. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  109. - rebuilt with rpm-4.8.1-3
  110. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  111. - rebuilt with tcl-8.4.19-2
  112. - dropt Patch4: tk-8.4.18-tkBind.patch
  113. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  114. - new upstream release
  115. - add Patch3,4 to fix bug (broken if built with xproto-7.x)
  116. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
  117. - spec in utf-8
  118. * Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  119. - rebuild with xorg-x11-7.3
  120. - remove Requires: XFree86-libs
  121. - add BuildRequires: libX11-devel
  122. - use autoconf instead of autoconf217
  123. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  124. - updated tk to 8.4.18
  125. - included CVE-2008-0553
  126. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  127. - updated tk to 8.4.16
  128. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  129. - updated tk to 8.4.15
  130. - rebuilt with new toolchain
  131. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  132. - updated tk to 8.4.13
  133. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  134. - updated tk to 8.4.12
  135. - updated tk-%%{version}-lib-perm.patch
  136. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
  137. - dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
  138. - replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
  139. - dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
  140. - dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
  141. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
  142. - added tk-8.4.6-tkUnixWm.patch
  143. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  144. - updated tk to 8.4.6
  145. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  146. - syncd with fedora
  147. * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
  148. - add private header files needed to build tix in /usr/include/tk-private
  149. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
  150. - removed rpath (patch 3)
  151. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  152. - new package split out from tcltk
  153. - update to tk 8.4.5 (#88429)
  154. - filtered changelog for tk
  155. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  156. - remove build remnants from tkConfig.sh
  157. * Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
  158. - fix buildrequires and requires section
  159. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  160. - update based on BitWalk's tcltk-8.4.2-83bw
  161. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  162. - splite source package
  163. - add include files
  164. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  165. - expand some macros.. (FIXME)
  166. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  167. - use %configure macros
  168. - add Patch 47,50
  169. * Thu May 31 2001 <sagami@vinelinux.org>
  170. - 8.0.5_jp-10
  171. - unexpand old %%{configure}, new one causes build failure
  172. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  173. - install manpages into %%{_mandir} and mode 644
  174. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  175. - 8.0.5_jp-9
  176. - modified %install section to handle compressed man pages
  177. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  178. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  179. - changed default fonts
  180. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  181. - added defattr
  182. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  183. - added some symlinks, such as libtcl8.0.so.
  184. - obsoletes version number using _jp, now 8.0.5-31vl1
  185. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  186. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  187. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  188. - fix tclX symlinks.
  189. - compile on systems where SIGPWR == SIGLOST.
  190. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  191. - update tcl/tk to 8.0.5.
  192. - avoid "containing" in Tix (#2332).
  193. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  194. - use /usr/bin/write in kibitz (#1320).
  195. - use cirrus.sprl.umich.edu in weather (#1926).
  196. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  197. - auto rebuild in the new build environment (release 28)
  198. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  199. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  200. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  201. - expect does unaligned access on alpha (#989)
  202. - upgrade tcl/tk/tclX to 8.0.4
  203. - upgrade expect to 5.28.
  204. - add itcl 3.0.1
  205. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  206. - call libtoolize to allow building on the arm
  207. - build for glibc 2.1
  208. - strip binaries
  209. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  210. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  211. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  212. - expect: mkpasswd needs delay before sending password (problem #576)
  213. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  214. - translations modified for de, fr, tr
  215. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  216. - fixed expect binaries exec permissions
  217. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  218. - updated to Tix 4.1.0.006
  219. - updated version numbers of tcl/tk to relflect includsion of p2
  220. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  221. - updated tcl/tk to patch level 2
  222. - updated tclX to 8.0.2
  223. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  224. - fixed filelist for tix... replacing path to the expect binary in scripts
  225. was leaving junk files around.
  226. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  227. - added patch to remove libieee test in configure.in for tcl and tk.
  228. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  229. solution for all systems
  230. - fixed src urls
  231. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  232. - removed version numbers from descriptions
  233. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  234. - updated to tcl/tk 8.0 and related versions of packages
  235. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  236. - built against glibc
  237. - fixed dangling tclx/tkx symlinks