libmemcached-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. %bcond_with tests
  2. Name: libmemcached
  3. Summary: Client library and command line tools for memcached server
  4. Version: 1.0.17
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Libraries
  8. URL: http://libmemcached.org/
  9. # Original sources:
  10. # http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
  11. # The source tarball must be repackaged to remove the Hsieh hash
  12. # code, since the license is non-free. When upgrading, download the new
  13. # source tarball, and run "./strip-hsieh.sh <version>" to produce the
  14. # "-exhsieh" tarball.
  15. Source0: libmemcached-%{version}-exhsieh.tar.gz
  16. Source1: strip-hsieh.sh
  17. # fix https://bugs.launchpad.net/libmemcached/+bug/1220452
  18. Patch0: libmemcached-memcached.patch
  19. # fix https://bugs.launchpad.net/libmemcached/+bug/1169311
  20. Patch1: 0bb781d2-a19f-11e2-90e1-002481e91f22.txt
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  22. BuildRequires: cyrus-sasl-devel
  23. BuildRequires: flex bison
  24. %if %{with tests}
  25. BuildRequires: memcached
  26. %endif
  27. BuildRequires: libevent-devel
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: tomop
  31. %description
  32. libmemcached is a C/C++ client library and tools for the memcached server
  33. (http://memcached.org/). It has been designed to be light on memory
  34. usage, and provide full access to server side methods.
  35. It also implements several command line tools:
  36. memcapable Checking a Memcached server capibilities and compatibility
  37. memcat Copy the value of a key to standard output
  38. memcp Copy data to a server
  39. memdump Dumping your server
  40. memerror Translate an error code to a string
  41. memexist Check for the existance of a key
  42. memflush Flush the contents of your servers
  43. memparse Parse an option string
  44. memping Test to see if a server is available.
  45. memrm Remove a key(s) from the server
  46. memslap Generate testing loads on a memcached cluster
  47. memstat Dump the stats of your servers to standard output
  48. memtouch Touches a key
  49. %package devel
  50. Summary: Header files and development libraries for %{name}
  51. Group: Development/Libraries
  52. Requires: %{name}%{?_isa} = %{version}-%{release}
  53. Requires: pkgconfig
  54. Requires: cyrus-sasl-devel%{?_isa}
  55. %description devel
  56. This package contains the header files and development libraries
  57. for %{name}. If you like to develop programs using %{name},
  58. you will need to install %{name}-devel.
  59. %prep
  60. %setup -q
  61. %patch0 -p1 -b .without-memcached
  62. %patch1 -p0 -b .compile-option
  63. mkdir examples
  64. cp -p tests/*.{cc,h} examples/
  65. # Will be regenerated during build
  66. rm -f libmemcached/csl/{parser,scanner}.cc
  67. # Temporary fix for SASL detection
  68. sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
  69. # fix library dependency
  70. # perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
  71. %build
  72. aclocal
  73. autoconf
  74. automake --add-missing
  75. # option --with-memcached=false to disable server binary check (as we don't run test)
  76. %configure --disable-static \
  77. %if ! %{with tests}
  78. --with-memcached=false
  79. %endif
  80. make %{_smp_mflags}
  81. %install
  82. rm -rf %{buildroot}
  83. make install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
  84. %check
  85. %if %{with tests}
  86. # test suite cannot run in mock (same port use for memcache servers on all arch)
  87. # All tests completed successfully
  88. # diff output.res output.cmp fails but result depend on server version
  89. make test
  90. %else
  91. echo 'Test suite disabled (missing "--with tests" option)'
  92. %endif
  93. %clean
  94. rm -rf %{buildroot}
  95. %post
  96. /sbin/ldconfig
  97. %postun
  98. /sbin/ldconfig
  99. %files
  100. %defattr (-,root,root,-)
  101. %doc AUTHORS COPYING README THANKS TODO ChangeLog
  102. %{_bindir}/mem*
  103. %exclude %{_libdir}/lib*.la
  104. %{_libdir}/lib*.so.*
  105. %{_mandir}/man1/mem*
  106. %files devel
  107. %defattr (-,root,root,-)
  108. %doc examples
  109. %{_datadir}/aclocal/ax_libmemcached.m4
  110. %{_includedir}/*
  111. %{_libdir}/lib*.so
  112. %{_libdir}/pkgconfig/libmemcached.pc
  113. %{_mandir}/man3/libmemcached*
  114. %{_mandir}/man3/libhashkit*
  115. %{_mandir}/man3/memcached*
  116. %{_mandir}/man3/hashkit*
  117. %changelog
  118. * Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
  119. - new upstream release.
  120. * Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
  121. - built for Vine Linux.
  122. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
  123. - update to 1.0.7
  124. - regenerate parser using flex/bison (#816766)
  125. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
  126. - workaround for SASL detection
  127. * Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
  128. - update to 1.0.6
  129. - soname bump to libmemcached.so.10 and libhashkit.so.2
  130. * Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
  131. - update to 1.0.4
  132. - soname bump to libmemcached.so.9
  133. - update description
  134. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
  135. - Rebuilt for c++ ABI breakage
  136. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  138. * Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
  139. - update to 1.0.2
  140. * Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
  141. - update to 0.53
  142. * Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
  143. - update to 0.52
  144. * Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
  145. - update to 0.51 (soname bump libmemcached.so.8)
  146. * Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
  147. - update to 0.49
  148. - add build option : --with tests
  149. * Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
  150. - update to 0.47
  151. - remove patch merged upstream
  152. * Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
  153. - patch Makefile.in instead of include.am (to avoid autoconf)
  154. - donc requires pkgconfig with arch
  155. * Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
  156. - update to 0.46
  157. * Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
  158. - arch specific requires
  159. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  161. * Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
  162. - repackage source tarball to remove non-free Hsieh hash code
  163. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
  164. - improves SASL patch
  165. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
  166. - enable SASL support
  167. * Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
  168. - update to 0.44
  169. - add soname version in %%file to detect change
  170. * Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
  171. - update to 0.43
  172. * Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
  173. - update to 0.42
  174. * Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
  175. - update to 0.40 (new soname for libmemcached.so.5)
  176. - new URI (site + source)
  177. * Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
  178. - update to 0.38
  179. * Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
  180. - update to 0.37 (soname bump)
  181. - new libhashkit (should be a separated project in the futur)
  182. * Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
  183. - update to 0.31
  184. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  186. * Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
  187. - update to 0.30
  188. * Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
  189. - update to 0.29
  190. * Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
  191. - add upstream patch to disable nonfree hsieh hash method
  192. * Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
  193. - Initial RPM from Brian Aker spec
  194. - create -devel subpackage
  195. - add %%post %%postun %%check section