ffmpeg-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %define with_faac 1
  5. %define with_vaapi 1
  6. %define with_libvpx 1
  7. #% define enable_avconv 1
  8. %global prebuild_doc 1
  9. %global major_version 1.2
  10. Summary: Digital VCR and streaming server
  11. Name: ffmpeg
  12. Version: %{major_version}.6
  13. Release: 2%{?svndate:.%svndate}%{?_dist_release}
  14. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  15. ## prebuilt man pages
  16. %{?prebuild_doc:Source10: %{name}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz}
  17. %if 0%{?_with_amr:1}
  18. License: GPLv3+
  19. %else
  20. License: GPLv2+
  21. %endif
  22. Group: Applications/Multimedia
  23. URL: http://ffmpeg.org/
  24. BuildRequires: bzip2-devel
  25. BuildRequires: celt-devel
  26. ##BuildRequires: dirac-devel
  27. BuildRequires: freetype2-devel
  28. ##BuildRequires: frei0r-devel
  29. BuildRequires: gnutls-devel
  30. BuildRequires: gsm-devel
  31. BuildRequires: imlib2-devel
  32. BuildRequires: libdc1394-devel
  33. BuildRequires: libogg-devel
  34. BuildRequires: libass-devel
  35. %{!?_without_cdio:BuildRequires: libcdio-devel}
  36. %{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
  37. #libcrystalhd is currently broken
  38. %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
  39. BuildRequires: libraw1394-devel
  40. BuildRequires: librtmp-devel >= 2.3
  41. BuildRequires: libtheora-devel
  42. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  43. BuildRequires: libvdpau-devel
  44. BuildRequires: libvorbis-devel
  45. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.7}
  46. BuildRequires: libXvMC-devel
  47. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  48. %{!?_without_openal:BuildRequires: openal-soft-devel}
  49. %{?_with_opencv:BuildRequires: opencv-devel}
  50. %{?_with_openjpeg:BuildRequires: openjpeg-devel}
  51. ##BuildRequires: schroedinger-devel
  52. BuildRequires: SDL-devel
  53. BuildRequires: speex-devel
  54. ##BuildRequires: texi2html
  55. BuildRequires: zlib-devel
  56. BuildRequires: yasm
  57. # *-devel packages provided by other self-build-* should only be listed
  58. # in self-build-%{name}.spec as PreReq.
  59. #BuildRequires: a52dec-devel
  60. #BuildRequires: faac-devel
  61. #BuildRequires: lame-devel
  62. #BuildRequires: libdca-devel
  63. #BuildRequires: x264-devel >= 0.0.0-18.20111216
  64. #BuildRequires: xvidcore-devel
  65. Requires: %{name}-libs = %{version}-%{release}
  66. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  67. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  68. %description
  69. FFMpeg is a complete and free Internet live audio and video
  70. broadcasting solution for Linux/Unix. It also includes a digital
  71. VCR. It can encode in real time in many formats including MPEG1 audio
  72. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  73. %package libs
  74. Summary: Libraries for %{name}
  75. Group: System Environment/Libraries
  76. %description libs
  77. FFMpeg is a complete and free Internet live audio and video
  78. broadcasting solution for Linux/Unix. It also includes a digital
  79. VCR. It can encode in real time in many formats including MPEG1 audio
  80. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  81. This package contains the libraries for %{name}.
  82. %package devel
  83. Summary: Development package for %{name}
  84. Group: Development/Libraries
  85. Requires: %{name}-libs = %{version}-%{release}
  86. Requires: pkgconfig
  87. %description devel
  88. FFMpeg is a complete and free Internet live audio and video
  89. broadcasting solution for Linux/Unix. It also includes a digital
  90. VCR. It can encode in real time in many formats including MPEG1 audio
  91. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  92. This package contains development files for %{name}.
  93. %prep
  94. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  95. %{?prebuild_doc:%__tar -C %{_builddir} -xf %{SOURCE10} || exit 1}
  96. %build
  97. %ifarch ppc
  98. # compile with -mlongcall on ppc/ppc64 (rf804)
  99. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  100. %endif
  101. ./configure \
  102. --prefix=%{_prefix} \
  103. --incdir=%{_includedir}/%{name} \
  104. --shlibdir=%{_libdir} \
  105. --libdir=%{_libdir} \
  106. --mandir=%{_mandir} \
  107. --arch=%{_target_cpu} \
  108. %ifarch %{ix86}
  109. --cpu=%{_target_cpu} \
  110. %endif
  111. %ifarch ppc
  112. --cpu=g3 \
  113. --enable-pic \
  114. %endif
  115. --enable-runtime-cpudetect \
  116. --extra-cflags="$RPM_OPT_FLAGS" \
  117. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  118. --enable-bzlib \
  119. %{!?_with_crystalhd:--disable-crystalhd} \
  120. --enable-zlib \
  121. %{?_with_frei0r:--enable-frei0r} \
  122. --enable-gnutls \
  123. --enable-libass \
  124. %{!?_without_cdio:--enable-libcdio} \
  125. --enable-libcelt \
  126. --enable-libdc1394 \
  127. %{?_with_libdirac:--enable-libdirac} \
  128. %{?with_faac:--enable-libfaac --enable-nonfree} \
  129. --enable-libfreetype \
  130. --enable-libgsm \
  131. --enable-libmp3lame \
  132. %{!?_without_openal:--enable-openal} \
  133. %{?_with_opencv:--enable-libopencv} \
  134. %{?_with_openjpeg:--enable-libopenjpeg} \
  135. --enable-librtmp \
  136. --enable-libspeex \
  137. --enable-libtheora \
  138. --enable-libvorbis \
  139. %{?with_libvpx:--enable-libvpx} \
  140. --enable-libx264 \
  141. --enable-libxvid \
  142. \
  143. --enable-x11grab \
  144. --enable-avfilter \
  145. --enable-postproc \
  146. --enable-pthreads \
  147. --disable-static \
  148. --enable-shared \
  149. --enable-gpl \
  150. %{?prebuild_doc:--disable-doc} \
  151. --disable-debug \
  152. --disable-stripping \
  153. \
  154. %{?enable_avconv:--enable-avconv} \
  155. ;
  156. %__make %{?_smp_mflags}
  157. %__make alltools
  158. %install
  159. %__make install DESTDIR=$RPM_BUILD_ROOT
  160. ## install tool/qt-faststart
  161. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  162. ## install man
  163. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  164. %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  165. %clean
  166. %{__rm} -rf $RPM_BUILD_ROOT
  167. %post libs -p /sbin/ldconfig
  168. %postun libs -p /sbin/ldconfig
  169. %files
  170. %defattr(-,root,root,-)
  171. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  172. %{?enable_avconv:%{_bindir}/avconv}
  173. %{_bindir}/ffmpeg
  174. %{_bindir}/ffplay
  175. %{_bindir}/ffprobe
  176. %{_bindir}/ffserver
  177. %{_bindir}/qt-faststart
  178. %{?enable_avconv:%{_mandir}/man1/avconv.1*}
  179. %{_mandir}/man1/ffmpeg.1*
  180. %{_mandir}/man1/ffplay.1*
  181. %{_mandir}/man1/ffprobe.1*
  182. %{_mandir}/man1/ffserver.1*
  183. %{_datadir}/ffmpeg
  184. %files libs
  185. %defattr(-,root,root,-)
  186. %{_libdir}/lib*.so.*
  187. %files devel
  188. %defattr(-,root,root,-)
  189. %doc MAINTAINERS doc/APIchanges doc/*.txt
  190. %{_includedir}/ffmpeg
  191. %{_libdir}/pkgconfig/lib*.pc
  192. %{_libdir}/lib*.so
  193. %changelog
  194. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
  195. - add BuildRequires: libcdio-paranoia-devel
  196. * Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  197. - new upstream release
  198. * Fri Oct 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
  199. - new upstream release
  200. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
  201. - new upstream release
  202. * Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
  203. - new upstream release
  204. - added man pages
  205. - added Source10: ffmpeg-1.2.1-doc.tar.xz
  206. * Thu Apr 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
  207. - new upstream release
  208. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  209. - new upstream release
  210. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  211. - libvpx >= 0.9.7
  212. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  213. - new upstream release /x264-0.129
  214. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  215. - new upstream release
  216. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  217. - new upstream release
  218. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  219. - new upstream release
  220. * Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
  221. - new upstream release
  222. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  223. - new upstream release
  224. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  225. - new upstream release
  226. - enable CELT decoding via libcelt
  227. - enable FreeType support
  228. - drop faad2 support (dropped upstream)
  229. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  230. - change release to sync with self-build-ffmpeg-vl.spec
  231. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  232. - new upstream release
  233. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  234. - new upstream release
  235. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  236. - required latest x264 build
  237. - added BuildRequires: librtmp-devel >= 2.3
  238. - build PIC objects on PPC
  239. #- add qt-faststart tool
  240. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  241. - new upstream release
  242. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  243. - change release to sync with self-build-ffmpeg-vl.spec
  244. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  245. - added BuildRequires: libvpx-devel >= 0.9.1
  246. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  247. - new upstream release
  248. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  249. - bumped version to pre-0.6
  250. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  251. - updated source snapshot 20100410
  252. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  253. - change release to sync with self-build-ffmpeg-vl.spec
  254. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  255. - change release to sync with self-build-ffmpeg-vl.spec
  256. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  257. - updated source snapshot 20100401
  258. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  259. - updated source snapshot 20100326
  260. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  261. - change release to sync with self-build-ffmpeg
  262. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  263. - updated source snapshot 20100216
  264. - rebuild with recent x264-devel
  265. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  266. - added BuildRequires: libvdpau-devel
  267. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  268. - change release to sync with self-build-ffmpeg
  269. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  270. - change release to sync with self-build-ffmpeg
  271. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  272. - applied ffmpeg-0.5-disable-texi2html.patch
  273. - dropped BuildRequires: texi2html
  274. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  275. - change release to sync with self-build-ffmpeg
  276. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  277. - corrected release number
  278. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  279. - new upstream release
  280. - added BuildRequires:
  281. - speex-devel
  282. - bzip2-devel
  283. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  284. - 20090227 snapshot
  285. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  286. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  287. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  288. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  289. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  290. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  291. - 20090202 snapshot
  292. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  293. - 20090110 snapshot
  294. - dropped some patches
  295. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  296. - source updated (r15488)
  297. - fixed License: GPLv2+
  298. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  299. - added BuildRequires: yasm (only %%ix86)
  300. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  301. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  302. - spec in utf8
  303. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  304. - change release to sync with self-build-ffmpeg
  305. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  306. - drop "Patch100: ffmpeg-vine.patch".
  307. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  308. - build with new versioning policy
  309. - change to use svn export from svn checkout on post install
  310. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  311. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  312. - [self-build-ffmpeg.spec]
  313. For all pre-required package that is provied by self-build,
  314. changed to its self-build package
  315. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  316. - initial build for Vine Linux 4.2
  317. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  318. ### end of file