libcrystalhd-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171
  1. Summary: Broadcom Crystal HD device interface library
  2. Name: libcrystalhd
  3. Version: 3.5.1
  4. Release: 3%{?_dist_release}
  5. License: LGPLv2
  6. Group: System Environment/Libraries
  7. #Source: http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
  8. # This tarball and README are inside the above zip file...
  9. Source0: crystalhd_07032010.tbz2
  10. Source1: README_07032010
  11. # We're going to use even newer firmware for now
  12. Source2: bcm70012fw.bin
  13. Source3: bcm70015fw.bin
  14. # LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
  15. Source4: LICENSE
  16. Requires: crystalhd-firmware
  17. URL: http://www.broadcom.com/support/crystal_hd/
  18. # Patch generated from http://git.wilsonet.com/crystalhd.git/
  19. Patch0: libcrystalhd-updates.patch
  20. # patch for ppc
  21. Patch1: libcrystalhd-ppc.patch
  22. # patch for gcc4.6 based on
  23. # http://git.wilsonet.com/?p=crystalhd.git;a=patch;h=dd4f01a0f9861425406c9ead7e326324d525d19a
  24. Patch10: libcrystalhd-3.5.1-gcc46.patch
  25. # fix building failures
  26. Patch11: libcrystalhd-3.5.1-define-first.patch
  27. ExcludeArch: s390 s390x
  28. BuildRequires: autoconf automake
  29. %description
  30. The libcrystalhd library provides userspace access to Broadcom Crystal HD
  31. video decoder devices. The device supports hardware decoding of MPEG-2,
  32. h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
  33. bcm970012 hardware, and up to 1080p at 60fps for the second-generation
  34. bcm970015 hardware.
  35. %package devel
  36. Summary: Development libs for libcrystalhd
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description devel
  40. Development libraries needed to build applications against libcrystalhd.
  41. %package -n crystalhd-firmware
  42. Summary: Firmware for the Broadcom Crystal HD video decoder
  43. License: Redistributable, no modification permitted
  44. BuildArch: noarch
  45. Group: System Environment/Kernel
  46. Requires: %{name} = %{version}-%{release}
  47. %description -n crystalhd-firmware
  48. Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
  49. video decoders.
  50. %define majorminor 0.10
  51. %define _gst 0.10.30
  52. %define _gstpb 0.10.30
  53. %package -n gstreamer-plugin-crystalhd
  54. Summary: Gstreamer crystalhd decoder plugin
  55. Group: Applications/Multimedia
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: gstreamer-plugins-base
  58. BuildRequires: gstreamer-devel >= %{_gst}
  59. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb}
  60. %description -n gstreamer-plugin-crystalhd
  61. Gstreamer crystalhd decoder plugin
  62. %prep
  63. %setup -q -n 07032010
  64. %patch0 -p1 -b .git
  65. %ifarch ppc
  66. %patch1 -p1 -b .ppc
  67. %endif
  68. %patch10 -p1 -b .gcc46
  69. %patch11 -p1 -b .boolian
  70. cp %{SOURCE1} %{SOURCE4} .
  71. %build
  72. pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
  73. # FIXME: this doesn't work just yet...
  74. #make CPPFLAGS="%{optflags}" %{?_smp_mflags}
  75. make %{?_smp_mflags}
  76. popd > /dev/null 2>&1
  77. pushd filters/gst/gst-plugin/ > /dev/null 2>&1
  78. %configure
  79. make %{?_smp_mflags}
  80. popd > /dev/null 2>&1
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
  84. make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
  85. popd > /dev/null 2>&1
  86. pushd filters/gst/gst-plugin/ > /dev/null 2>&1
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
  89. popd > /dev/null 2>&1
  90. cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
  91. cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %files
  97. %defattr(-,root,root,0755)
  98. %doc README_07032010 LICENSE
  99. %{_libdir}/libcrystalhd.so.*
  100. %files devel
  101. %defattr(-,root,root,0755)
  102. %dir %{_includedir}/libcrystalhd
  103. %{_includedir}/libcrystalhd/*
  104. %{_libdir}/libcrystalhd.so
  105. %files -n crystalhd-firmware
  106. %defattr(-,root,root,0755)
  107. %doc LICENSE
  108. /lib/firmware/bcm70012fw.bin
  109. /lib/firmware/bcm70015fw.bin
  110. %files -n gstreamer-plugin-crystalhd
  111. %defattr(-,root,root,0755)
  112. %{_libdir}/gstreamer-%{majorminor}/*.so
  113. %changelog
  114. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.5.1-3
  115. - applied libcrystalhd-3.5.1-define-first.patch
  116. * Sun May 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.1-2
  117. - add Patch1 for ppc (libcrystalhd-ppc.patch)
  118. * Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
  119. - initial build based on Fedora rawhide
  120. * Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
  121. - Update to v3.5.1, now with nv12 support
  122. * Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
  123. - Tarball had object files in it, clean them out before building
  124. * Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
  125. - Rebase to 07032010 crystalhd sources
  126. - Large version-bump as driver and lib are now essentially 100%
  127. in sync with the Windows driver and lib
  128. - Ship firmware, now that Broadcom has posted a redistribution,
  129. no modification license to cover it
  130. - Build the gstreamer decoder plugin (will be moved to its own
  131. package sooner or later)
  132. * Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
  133. - Fix segfault on firmware upload
  134. * Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
  135. - Update to pre-0.9.26 libcrystalhd, which contains support
  136. for the new Broadcom BCM970015 Crystal HD decoder card
  137. * Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
  138. - Minor fixups to the as-yet-not-enabled firmware sub-package
  139. * Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
  140. - Initial package