golang-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568
  1. # temporalily ignore test failures
  2. %ifarch %{ix86} x86_64
  3. %bcond_without ignore_tests
  4. %else
  5. %bcond_with ignore_tests
  6. %endif
  7. # Define arches for PA and SA
  8. %global golang_arches %{ix86} x86_64
  9. %global go_arches %{golang_arches}
  10. # Where to set GOPATH for builds
  11. %global gopath %{_datadir}/gocode
  12. # build ids are not currently generated:
  13. # https://code.google.com/p/go/issues/detail?id=5238
  14. #
  15. # also, debuginfo extraction currently fails with
  16. # "Failed to write file: invalid section alignment"
  17. %global debug_package %{nil}
  18. # we are shipping the full contents of src in the data subpackage, which
  19. # contains binary-like things (ELF data for tests, etc)
  20. %global _binaries_in_noarch_packages_terminate_build 0
  21. # Do not check any files in doc or src for requires
  22. #global __requires_exclude_from ^(%{_datadir}|/usr/lib)/%{name}/(doc|src)/.*$
  23. # Don't alter timestamps of especially the .a files (or else go will rebuild later)
  24. # Actually, don't strip at all since we are not even building debug packages and this corrupts the dwarf testdata
  25. %global __strip /bin/true
  26. # rpmbuild magic to keep from having meta dependency on libc.so.6
  27. %global __requires_exclude_from ^.*$
  28. %global __spec_install_post /usr/lib/rpm/check-rpaths \
  29. /usr/lib/rpm/check-buildroot \
  30. /usr/lib/rpm/brp-compress
  31. # Golang build options.
  32. # Buid golang using external/internal(close to cgo disabled) linking.
  33. %global external_linker 1
  34. # Build golang with cgo enabled/disabled(later equals more or less to internal linking).
  35. %global cgo_enabled 1
  36. # Use golang/gcc-go as bootstrap compiler
  37. %global golang_bootstrap 1
  38. # boostrap(with internal linking) using gcc-go fails due to bug in tests(https://github.com/golang/go/issues/12629)
  39. # make check not to fail due to it
  40. # Controls what ever we fail on failed tests
  41. %if %{with ignore_tests}
  42. %global fail_on_tests 0
  43. %else
  44. %global fail_on_tests 1
  45. %endif
  46. # TODO get more support for shared objects
  47. # Build golang shared objects for stdlib
  48. %ifarch x86_64
  49. %global shared 1
  50. %else
  51. %global shared 0
  52. %endif
  53. # Fedora GOROOT
  54. %global goroot /usr/lib/%{name}
  55. %ifarch x86_64
  56. %global gohostarch amd64
  57. %endif
  58. %ifarch %{ix86}
  59. %global gohostarch 386
  60. %endif
  61. Summary: The Go Programming Language
  62. Summary(ja): プログラミング言語 Go
  63. Name: golang
  64. Version: 1.16.6
  65. Release: 1%{?_dist_release}
  66. Group: programming
  67. Vendor: Project Vine
  68. Distribution: Vine Linux
  69. # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
  70. License: BSD and Public Domain
  71. URL: https://golang.org/
  72. # pre-processed by source.sh to make Mark.Twain-Tom.Sawyer.txt free again
  73. Source0: https://dl.google.com/go/go%{version}.src.tar.gz
  74. Source100: golang-gdbinit
  75. Source101: golang-prelink.conf
  76. Source102: macros.golang
  77. %global go_api %(echo "%{version}" | cut -d . -f 1,2)
  78. # These are the only RHEL/Fedora architectures that we compile this package for
  79. ExclusiveArch: %{golang_arches}
  80. # The compiler is written in Go. Needs go(1.4+) compiler for build.
  81. BuildRequires: golang > 1.4
  82. BuildRequires: net-tools
  83. # for tests
  84. BuildRequires: pcre-devel, glibc-static
  85. Provides: go = %{version}-%{release}
  86. Requires: %{name}-bin
  87. Requires: %{name}-src = %{version}-%{release}
  88. %description
  89. %{summary}.
  90. %package docs
  91. Summary: Golang compiler docs
  92. Group: documentation
  93. Requires: %{name} = %{version}-%{release}
  94. #BuildArch: noarch
  95. Obsoletes: %{name}-docs < 1.1-4
  96. %description docs
  97. %{summary}.
  98. %package misc
  99. Summary: Golang compiler miscellaneous sources
  100. Group: programming
  101. Requires: %{name} = %{version}-%{release}
  102. #BuildArch: noarch
  103. %description misc
  104. %{summary}.
  105. %package tests
  106. Summary: Golang compiler tests for stdlib
  107. Group: programming
  108. Requires: %{name} = %{version}-%{release}
  109. #BuildArch: noarch
  110. %description tests
  111. %{summary}.
  112. %package src
  113. Summary: Golang compiler source tree
  114. Group: programming
  115. #BuildArch: noarch
  116. %description src
  117. %{summary}
  118. %package bin
  119. Summary: Golang core compiler tools
  120. Group: programming
  121. Requires: go = %{version}-%{release}
  122. Requires(post): %{_sbindir}/update-alternatives
  123. Requires(postun): %{_sbindir}/update-alternatives
  124. # We strip the meta dependency, but go does require glibc.
  125. # This is an odd issue, still looking for a better fix.
  126. Requires: glibc
  127. Requires: gcc
  128. %description bin
  129. %{summary}
  130. # Workaround old RPM bug of symlink-replaced-with-dir failure
  131. %pretrans -p <lua>
  132. for _,d in pairs({"api", "doc", "include", "lib", "src"}) do
  133. path = "%{goroot}/" .. d
  134. if posix.stat(path, "type") == "link" then
  135. os.remove(path)
  136. posix.mkdir(path)
  137. end
  138. end
  139. %if %{shared}
  140. %package shared
  141. Summary: Golang shared object libraries
  142. Group: system
  143. %description shared
  144. %{summary}.
  145. %endif
  146. %debug_package
  147. %prep
  148. %setup -q -n go
  149. %build
  150. # bootstrap compiler GOROOT
  151. %if !%{golang_bootstrap}
  152. export GOROOT_BOOTSTRAP=/
  153. %else
  154. export GOROOT_BOOTSTRAP=%{goroot}
  155. %endif
  156. # set up final install location
  157. export GOROOT_FINAL=%{goroot}
  158. export GOHOSTOS=linux
  159. export GOHOSTARCH=%{gohostarch}
  160. pushd src
  161. # use our gcc options for this build, but store gcc as default for compiler
  162. export CFLAGS="$RPM_OPT_FLAGS"
  163. export LDFLAGS="$RPM_LD_FLAGS"
  164. export CC="gcc"
  165. export CC_FOR_TARGET="gcc"
  166. export GOOS=linux
  167. export GOARCH=%{gohostarch}
  168. %if !%{external_linker}
  169. export GO_LDFLAGS="-linkmode internal"
  170. %endif
  171. %if !%{cgo_enabled}
  172. export CGO_ENABLED=0
  173. %endif
  174. ./make.bash --no-clean
  175. popd
  176. # build shared std lib
  177. %if %{shared}
  178. GOROOT=$(pwd) PATH=$(pwd)/bin:$PATH go install -buildmode=shared std
  179. %endif
  180. %install
  181. rm -rf $RPM_BUILD_ROOT
  182. # create the top level directories
  183. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  184. mkdir -p $RPM_BUILD_ROOT%{goroot}
  185. # install everything into libdir (until symlink problems are fixed)
  186. # https://code.google.com/p/go/issues/detail?id=5830
  187. cp -apv api bin doc favicon.ico lib pkg robots.txt src misc test VERSION \
  188. $RPM_BUILD_ROOT%{goroot}
  189. # bz1099206
  190. find $RPM_BUILD_ROOT%{goroot}/src -exec touch -r $RPM_BUILD_ROOT%{goroot}/VERSION "{}" \;
  191. # and level out all the built archives
  192. touch $RPM_BUILD_ROOT%{goroot}/pkg
  193. find $RPM_BUILD_ROOT%{goroot}/pkg -exec touch -r $RPM_BUILD_ROOT%{goroot}/pkg "{}" \;
  194. # generate the spec file ownership of this source tree and packages
  195. cwd=$(pwd)
  196. src_list=$cwd/go-src.list
  197. pkg_list=$cwd/go-pkg.list
  198. shared_list=$cwd/go-shared.list
  199. misc_list=$cwd/go-misc.list
  200. docs_list=$cwd/go-docs.list
  201. tests_list=$cwd/go-tests.list
  202. rm -f $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list
  203. touch $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list
  204. pushd $RPM_BUILD_ROOT%{goroot}
  205. find src/ -type d -a \( ! -name testdata -a ! -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $src_list
  206. find src/ ! -type d -a \( ! -ipath '*/testdata/*' -a ! -name '*_test*.go' \) -printf '%{goroot}/%p\n' >> $src_list
  207. find bin/ pkg/ -type d -a ! -path '*_dynlink/*' -printf '%%%dir %{goroot}/%p\n' >> $pkg_list
  208. find bin/ pkg/ ! -type d -a ! -path '*_dynlink/*' -printf '%{goroot}/%p\n' >> $pkg_list
  209. find doc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $docs_list
  210. find doc/ ! -type d -printf '%{goroot}/%p\n' >> $docs_list
  211. find misc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $misc_list
  212. find misc/ ! -type d -printf '%{goroot}/%p\n' >> $misc_list
  213. %if %{shared}
  214. find pkg/*_dynlink/ -type d -printf '%%%dir %{goroot}/%p\n' >> $shared_list
  215. find pkg/*_dynlink/ ! -type d -printf '%{goroot}/%p\n' >> $shared_list
  216. %endif
  217. find test/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  218. find test/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
  219. find src/ -type d -a \( -name testdata -o -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  220. find src/ ! -type d -a \( -ipath '*/testdata/*' -o -name '*_test*.go' \) -printf '%{goroot}/%p\n' >> $tests_list
  221. # this is only the zoneinfo.zip
  222. find lib/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  223. find lib/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
  224. popd
  225. # remove the doc Makefile
  226. rm -rfv $RPM_BUILD_ROOT%{goroot}/doc/Makefile
  227. # put binaries to bindir, linked to the arch we're building,
  228. # leave the arch independent pieces in %{goroot}
  229. mkdir -p $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}
  230. ln -sf %{goroot}/bin/go $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}/go
  231. ln -sf %{goroot}/bin/gofmt $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}/gofmt
  232. # ensure these exist and are owned
  233. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/github.com
  234. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/bitbucket.org
  235. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/code.google.com/p
  236. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/golang.org/x
  237. # make sure these files exist and point to alternatives
  238. rm -f $RPM_BUILD_ROOT%{_bindir}/go
  239. ln -sf /etc/alternatives/go $RPM_BUILD_ROOT%{_bindir}/go
  240. rm -f $RPM_BUILD_ROOT%{_bindir}/gofmt
  241. ln -sf /etc/alternatives/gofmt $RPM_BUILD_ROOT%{_bindir}/gofmt
  242. # gdbinit
  243. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d
  244. cp -av %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d/golang.gdb
  245. # prelink blacklist
  246. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d
  247. cp -av %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d/golang.conf
  248. # rpm macros
  249. mkdir -p %{buildroot}
  250. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
  251. cp -av %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.golang
  252. %check
  253. export GOROOT=$(pwd -P)
  254. export PATH="$GOROOT"/bin:"$PATH"
  255. cd src
  256. export CC="gcc"
  257. export CFLAGS="$RPM_OPT_FLAGS"
  258. export LDFLAGS="$RPM_LD_FLAGS"
  259. %if !%{external_linker}
  260. export GO_LDFLAGS="-linkmode internal"
  261. %endif
  262. %if !%{cgo_enabled} || !%{external_linker}
  263. export CGO_ENABLED=0
  264. %endif
  265. # make sure to not timeout
  266. export GO_TEST_TIMEOUT_SCALE=2
  267. %if %{fail_on_tests}
  268. ./run.bash --no-rebuild -v -v -v -k
  269. %else
  270. ./run.bash --no-rebuild -v -v -v -k || :
  271. %endif
  272. cd ..
  273. %post bin
  274. %{_sbindir}/update-alternatives --install %{_bindir}/go \
  275. go %{goroot}/bin/go 90 \
  276. --slave %{_bindir}/gofmt gofmt %{goroot}/bin/gofmt
  277. %preun bin
  278. if [ $1 = 0 ]; then
  279. %{_sbindir}/update-alternatives --remove go %{goroot}/bin/go
  280. fi
  281. %files
  282. %license LICENSE
  283. %doc AUTHORS CONTRIBUTORS PATENTS
  284. # VERSION has to be present in the GOROOT, for `go install std` to work
  285. %doc %{goroot}/VERSION
  286. %dir %{goroot}/doc
  287. %doc %{goroot}/doc/*
  288. # go files
  289. %dir %{goroot}
  290. %exclude %{goroot}/bin/
  291. %exclude %{goroot}/pkg/
  292. %exclude %{goroot}/src/
  293. %exclude %{goroot}/doc/
  294. %exclude %{goroot}/misc/
  295. %{goroot}/*
  296. # ensure directory ownership, so they are cleaned up if empty
  297. %dir %{gopath}
  298. %dir %{gopath}/src
  299. %dir %{gopath}/src/github.com/
  300. %dir %{gopath}/src/bitbucket.org/
  301. %dir %{gopath}/src/code.google.com/
  302. %dir %{gopath}/src/code.google.com/p/
  303. %dir %{gopath}/src/golang.org
  304. %dir %{gopath}/src/golang.org/x
  305. # gdbinit (for gdb debugging)
  306. %{_sysconfdir}/gdbinit.d
  307. # prelink blacklist
  308. %{_sysconfdir}/prelink.conf.d
  309. %{_sysconfdir}/rpm/macros.golang
  310. %files -f go-src.list src
  311. %files -f go-docs.list docs
  312. %files -f go-misc.list misc
  313. %files -f go-tests.list tests
  314. %files -f go-pkg.list bin
  315. %{_bindir}/go
  316. %{_bindir}/gofmt
  317. %if %{shared}
  318. %files -f go-shared.list shared
  319. %endif
  320. %changelog
  321. * Sat Jul 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.6-1
  322. - new upstream release.
  323. * Tue Jun 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.5-1
  324. - new upstream release.
  325. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
  326. - new upstream release.
  327. * Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.7-1
  328. - new upstream release.
  329. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.6-1
  330. - new upstream release.
  331. * Thu Nov 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
  332. - new upstream release.
  333. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.1-1
  334. - new upstream release.
  335. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15-1
  336. - new upstream release.
  337. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.6-1
  338. - new upstream release.
  339. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-1
  340. - new upstream release.
  341. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.5-1
  342. - new upstream release.
  343. * Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.4-1
  344. - new upstream release.
  345. * Tue Jun 26 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.10.3-1
  346. - update to 1.10.3
  347. - drop patches (Patch0, 212, 215)
  348. - export 'GO_TEST_TIMEOUT_SCALE=2' in %%check
  349. - add bcond for tests
  350. * Tue Jun 06 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.3-1
  351. - update to 1.8.3
  352. * Mon Jun 5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.1-1
  353. - update to 1.8.1
  354. - remove BuildArch tags
  355. - drop Source1
  356. - drop patches
  357. - remove ECC p224 patch (Patch1)
  358. - X.509 patch (Patch2): upstream merged
  359. - disable TestGdbPython patch (Patch213)
  360. - disable TestCloneNEWUSERAndRemapNoRootDisableSetgroups patch (Patch214)
  361. - drop Patch216: upstream fixed
  362. - update bootstrap binary path patch (Patch212)
  363. * Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
  364. - new upstream release.
  365. * Sun Mar 8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
  366. - new upstream release.
  367. * Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2-2
  368. - added Group tag
  369. * Sat Feb 1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.2
  370. - initial build for Vine Linux
  371. - drop emacs and vim package
  372. * Fri Jan 24 2014 Vincent Batts <vbatts@redhat.com> 1.2-4
  373. - skip a flaky test that is sporadically failing on the build server
  374. * Thu Jan 16 2014 Vincent Batts <vbatts@redhat.com> 1.2-3
  375. - remove golang-godoc dependency. cyclic dependency on compiling godoc
  376. * Wed Dec 18 2013 Vincent Batts <vbatts@redhat.com> - 1.2-2
  377. - removing P224 ECC curve
  378. * Mon Dec 2 2013 Vincent Batts <vbatts@fedoraproject.org> - 1.2-1
  379. - Update to upstream 1.2 release
  380. - remove the pax tar patches
  381. * Tue Nov 26 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-8
  382. - fix the rpmspec conditional for rhel and fedora
  383. * Thu Nov 21 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-7
  384. - patch tests for testing on rawhide
  385. - let the same spec work for rhel and fedora
  386. * Wed Nov 20 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-6
  387. - don't symlink /usr/bin out to ../lib..., move the file
  388. - seperate out godoc, to accomodate the go.tools godoc
  389. * Fri Sep 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-5
  390. - Pull upstream patches for BZ#1010271
  391. - Add glibc requirement that got dropped because of meta dep fix
  392. * Fri Aug 30 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-4
  393. - fix the libc meta dependency (thanks to vbatts [at] redhat.com for the fix)
  394. * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-3
  395. - Revert incorrect merged changelog
  396. * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-2
  397. - This was reverted, just a placeholder changelog entry for bad merge
  398. * Tue Aug 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-1
  399. - Update to latest upstream
  400. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-7
  401. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  402. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.1.1-6
  403. - Perl 5.18 rebuild
  404. * Wed Jul 10 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-5
  405. - Blacklist testdata files from prelink
  406. - Again try to fix #973842
  407. * Fri Jul 5 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-4
  408. - Move src to libdir for now (#973842) (upstream issue https://code.google.com/p/go/issues/detail?id=5830)
  409. - Eliminate noarch data package to work around RPM bug (#975909)
  410. - Try to add runtime-gdb.py to the gdb safe-path (#981356)
  411. * Wed Jun 19 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-3
  412. - Use lua for pretrans (http://fedoraproject.org/wiki/Packaging:Guidelines#The_.25pretrans_scriptlet)
  413. * Mon Jun 17 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-2
  414. - Hopefully really fix #973842
  415. - Fix update from pre-1.1.1 (#974840)
  416. * Thu Jun 13 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-1
  417. - Update to 1.1.1
  418. - Fix basically useless package (#973842)
  419. * Sat May 25 2013 Dan Horák <dan[at]danny.cz> - 1.1-3
  420. - set ExclusiveArch
  421. * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-2
  422. - Fix noarch package discrepancies
  423. * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-1
  424. - Initial Fedora release.
  425. - Update to 1.1
  426. * Thu May 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.3.rc3
  427. - Update to rc3
  428. * Thu Apr 11 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.2.beta2
  429. - Update to beta2
  430. * Tue Apr 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.1.beta1
  431. - Initial packaging.