at-spi-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define atk_version 1.32.0
  3. %define gtk2_version 2.22.0
  4. %define libbonobo_version 2.32.0
  5. %define orbit2_version 2.14.19
  6. %define pango_version 1.28.3
  7. %define gconf2_version 2.32.0
  8. %define dbus_glib_version 0.88
  9. Summary: Assistive Technology Service Provider Interface
  10. Name: at-spi
  11. Version: 1.32.0
  12. Release: 1%{?_dist_release}
  13. URL: http://developer.gnome.org/projects/gap/
  14. Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
  15. License: LGPLv2+
  16. Group: System Environment/Libraries
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: pango-devel >= %{pango_version}
  19. BuildRequires: gtk2-devel >= %{gtk2_version}
  20. BuildRequires: libbonobo-devel >= %{libbonobo_version}
  21. BuildRequires: ORBit2-devel >= %{orbit2_version}
  22. BuildRequires: atk-devel >= %{atk_version}
  23. BuildRequires: GConf2-devel >= %{gconf2_version}
  24. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  25. BuildRequires: popt-devel
  26. BuildRequires: fontconfig
  27. BuildRequires: gettext
  28. BuildRequires: intltool
  29. BuildRequires: perl(XML::Parser)
  30. BuildRequires: libX11-devel
  31. BuildRequires: libXtst-devel
  32. BuildRequires: libXi-devel
  33. BuildRequires: libXevie-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: desktop-file-utils
  36. Patch2: at-spi-silence-no-event-spew.patch
  37. %description
  38. at-spi allows assistive technologies to access GTK-based
  39. applications. Essentially it exposes the internals of applications for
  40. automation, so tools such as screen readers, magnifiers, or even
  41. scripting interfaces can query and interact with GUI controls.
  42. %package devel
  43. Summary: Development libraries and headers for at-spi
  44. Group: Development/Libraries
  45. Requires: %name = %{version}-%{release}
  46. Requires: atk-devel
  47. Requires: gtk2-devel
  48. Requires: libbonobo-devel
  49. Requires: ORBit2-devel
  50. Requires: pkgconfig
  51. %description devel
  52. Libraries and header files allowing compilation of apps that use at-spi.
  53. %package python
  54. Summary: Python bindings for at-spi
  55. Group: Development/Libraries
  56. Requires: %name = %{version}-%{release}
  57. Requires: python
  58. %description python
  59. Python bindings allowing to use at-spi in python programs.
  60. %prep
  61. %setup -q
  62. ## %patch2 -p1 -b .spew
  63. %build
  64. %configure --disable-gtk-doc --disable-static
  65. make
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install DESTDIR=$RPM_BUILD_ROOT
  69. %find_lang at-spi
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  71. rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
  73. %post
  74. /sbin/ldconfig
  75. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  76. gconftool-2 --makefile-install-rule \
  77. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  78. %pre
  79. if [ "$1" -gt 1 ]; then
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-uninstall-rule \
  82. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  83. fi
  84. %preun
  85. if [ "$1" -eq 0 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  89. fi
  90. %postun -p /sbin/ldconfig
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %files -f at-spi.lang
  94. %defattr(-,root,root)
  95. %doc AUTHORS COPYING NEWS README
  96. %{_sysconfdir}/gconf/schemas/at-spi.schemas
  97. %{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
  98. %{_libdir}/lib*.so.*
  99. %{_libdir}/bonobo/servers/*
  100. %{_libdir}/orbit-2.0/*
  101. %{_libdir}/gtk-2.0/modules/*
  102. %{_libexecdir}/*
  103. %files devel
  104. %defattr(-,root,root)
  105. %{_datadir}/gtk-doc/html/*
  106. %{_datadir}/idl/*
  107. %{_libdir}/lib*.so
  108. %{_libdir}/pkgconfig/*
  109. %{_includedir}/*
  110. %files python
  111. %defattr(-,root,root)
  112. %{python_sitearch}/pyatspi/
  113. %changelog
  114. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
  115. - new upstream release
  116. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
  117. - rebuild with rpm-4.8.1 for pkg-config file
  118. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  119. - new upstream release
  120. * Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  121. - new upstream release
  122. - drop Patch2
  123. - add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
  124. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
  125. - rebuild with python-2.6
  126. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
  127. - remove BuildRequires gail-devel
  128. (gtk2-2.14.x now includes/provides gail)
  129. * Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  130. - initial build for Vine Linux
  131. * Mon Sep 8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
  132. - Update to 1.23.92
  133. - Drop upstreamed patch
  134. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
  135. - Fix an evo crash caused by the greeter crash fix
  136. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
  137. - Fix a greeter crash
  138. * Tue Sep 2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
  139. - Update to 1.23.91
  140. * Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
  141. - Silence incessant atk-bridge spew filling xsession-errors (#459275)
  142. * Mon Aug 4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
  143. - Update to 1.23.6
  144. * Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
  145. - Update to 1.23.5
  146. * Tue Jun 3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
  147. - Update to 1.23.3
  148. * Mon May 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
  149. - Bump rev
  150. * Mon Apr 7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
  151. - Update to 1.22.1
  152. * Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
  153. - Update to 1.22.0
  154. * Wed Mar 5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
  155. - Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
  156. * Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
  157. - Update to 1.21.92
  158. * Fri Feb 8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
  159. - Rebuild for gcc 4.3
  160. * Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
  161. - Update to 1.21.5
  162. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
  163. - Update to 1.21.3
  164. * Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
  165. - Update to 1.21.1
  166. * Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
  167. - Update to 1.20.1
  168. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
  169. - Update to 1.20.0
  170. * Mon Aug 6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
  171. - Update license field
  172. * Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
  173. - Update to 1.19.5
  174. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
  175. - Update to 1.19.3
  176. - Add a -python subpackage
  177. * Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
  178. - Update to 1.19.1
  179. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
  180. - Don't ship .la files
  181. * Mon Apr 9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
  182. - Update to 1.18.1, which includes the previous patch
  183. - Drop obsolete patch
  184. - Fix a small memory leak
  185. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
  186. - Backport a patch to fix deadlocks in applications
  187. * Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
  188. - Update to 1.18.0
  189. - Drop obsolete patch
  190. * Thu Mar 8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
  191. - add a patch that might fix some deadlock issues (bug 329454)
  192. * Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
  193. - Update to 1.17.2
  194. * Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
  195. - Update to 1.17.1
  196. * Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
  197. - Bump atk requirement
  198. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
  199. - Update to 1.17.0
  200. * Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
  201. - Update to 1.7.16
  202. * Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
  203. - Update to 1.7.15
  204. * Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
  205. - Update to 1.7.14
  206. * Sat Dec 9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
  207. - Small spec file cleanups
  208. * Tue Nov 7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
  209. - Update to 1.7.13
  210. * Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
  211. - Update to 1.7.12
  212. * Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
  213. - Remove debug spew
  214. * Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
  215. - Update to 1.7.11
  216. - Drop upstreamed patch
  217. - Require pkgconfig in the -devel package
  218. * Wed Aug 2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
  219. - Update to 1.7.10
  220. * Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
  221. - Fix segfault if a11y enabled on x86-64 (#196063)
  222. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
  223. - Rebuild
  224. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
  225. - Update to 1.7.9
  226. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
  227. - Update to 1.7.8
  228. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
  229. - rebuild
  230. * Thu Jun 8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
  231. - Add a BuildRequires
  232. * Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
  233. - Make it build in mock
  234. * Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
  235. - Revert the previous change
  236. * Tue Apr 4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
  237. - Fix a missing declaration
  238. - Fix segfaults on x86_64
  239. * Tue Apr 4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
  240. - Update to 1.7.7
  241. * Thu Mar 9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
  242. - Fix a crash on x86_64
  243. * Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
  244. - Update to 1.7.6
  245. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
  246. - Update to 1.7.5
  247. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
  248. - bump again for double-long bug on ppc(64)
  249. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
  250. - rebuilt for new gcc4.1 snapshot and glibc changes
  251. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
  252. - Update to 1.7.4
  253. * Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
  254. - Update to 1.7.3
  255. * Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
  256. - Update to 1.7.2
  257. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  258. - rebuilt
  259. * Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
  260. - Switch requires to modular X
  261. * Wed Sep 7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
  262. - Update to 1.6.6
  263. * Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
  264. - Rebuilt
  265. * Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
  266. - Update to 1.6.4
  267. * Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
  268. - Update to 1.6.3
  269. * Wed Mar 2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
  270. - Rebuilt with gcc4
  271. * Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
  272. - Update to 1.6.2
  273. * Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
  274. - Remove dependency on linc-devel
  275. * Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
  276. - Fix some random spec file issues (fixes #133430?)
  277. * Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
  278. - bump version
  279. * Wed Aug 4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
  280. - Update to 1.5.3
  281. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  282. - rebuilt
  283. * Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
  284. - Update to 1.4.0
  285. * Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
  286. - Update to 1.3.15
  287. * Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
  288. - Update to 1.3.14
  289. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  290. - rebuilt
  291. * Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
  292. - update to 1.3.13
  293. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  294. - rebuilt
  295. * Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
  296. - new version
  297. * Thu Oct 2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
  298. - new version
  299. * Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
  300. - Fix rebuild failure (stderr.patch)
  301. * Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
  302. - disable gtk doc
  303. * Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
  304. - automated rebuild
  305. * Mon Jul 7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
  306. - 1.1.9
  307. - remove multilib patch fixed upstream
  308. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  309. - rebuilt
  310. * Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
  311. - kill Xft buildreq
  312. * Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
  313. - rebuild to fix self-dependency
  314. * Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
  315. - extend multilib patch to cover -lXi
  316. * Tue Feb 4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
  317. - 1.1.8
  318. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  319. - rebuilt
  320. * Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
  321. - Add patch to help multilib systems find libXtst
  322. * Fri Dec 6 2002 Havoc Pennington <hp@redhat.com>
  323. - rebuild
  324. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  325. - rebuild with new libbonobo and gail
  326. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  327. - automated rebuild
  328. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  329. - add libatk-bridge.so to the file list
  330. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  331. - 1.0.1
  332. - add at-spi-registryd to file list
  333. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  334. - rebuild in different environment
  335. * Tue Jun 4 2002 Havoc Pennington <hp@redhat.com>
  336. - 1.0.0
  337. - add post/postun ldconfig
  338. * Wed May 29 2002 Bill Nottingham <notting@redhat.com>
  339. - rebuild again?
  340. * Tue May 28 2002 Havoc Pennington <hp@redhat.com>
  341. - rebuild in different environment
  342. * Tue May 28 2002 Havoc Pennington <hp@redhat.com>
  343. - 0.12.1
  344. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  345. - Version 0.0.6
  346. * Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
  347. - rebuild in rawhide, seems to have been linked incorrectly
  348. * Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
  349. - rebuild in rawhide, upgrade to 0.0.5
  350. - add gail deps
  351. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  352. - Initial build.