swig-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220
  1. %define tcl 1
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
  5. Name: swig
  6. Version: 3.0.12
  7. Release: 1%{?_dist_release}
  8. License: GPLv3+ and BSD
  9. Group: Development/Tools
  10. URL: http://swig.sourceforge.net/
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: lua-devel
  16. BuildRequires: pcre-devel
  17. BuildRequires: perl
  18. BuildRequires: python-devel
  19. BuildRequires: ruby-devel
  20. %if %{tcl}
  21. BuildRequires: tcl-devel
  22. %endif
  23. %if %{guile}
  24. BuildRequires: guile-devel
  25. %endif
  26. BuildRequires: autoconf, automake, gawk, nkf
  27. Obsoletes: swig-runtime
  28. %description
  29. Simplified Wrapper and Interface Generator (SWIG) is a software
  30. development tool for connecting C, C++ and Objective C programs with a
  31. variety of high-level programming languages. SWIG is primarily used
  32. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  33. Eiffel and Guile. SWIG is normally used to create high-level
  34. interpreted programming environments, systems integration, and as a
  35. tool for building user interfaces
  36. %package doc
  37. Summary: Documentation files for SWIG
  38. Summary(ja): SWIG のドキュメント
  39. License: BSD
  40. Group: Documentation
  41. BuildArch: noarch
  42. %description doc
  43. This package contains documentation for SWIG and useful examples
  44. %prep
  45. %setup -q -n swig-%{version}
  46. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  47. # (specific req/prov filtering). Before you remove this hack make sure you don't
  48. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  49. cat << \EOF > %{name}-prov
  50. #!/bin/sh
  51. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  52. EOF
  53. %global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  54. chmod +x %{__perl_provides}
  55. cat << \EOF > %{name}-req
  56. #!/bin/sh
  57. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  58. EOF
  59. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  60. chmod +x %{__perl_requires}
  61. for all in CHANGES README; do
  62. iconv -f ISO88591 -t UTF8 < $all > $all.new
  63. touch -r $all $all.new
  64. mv -f $all.new $all
  65. done
  66. %build
  67. ./autogen.sh
  68. %configure
  69. make %{?_smp_mflags}
  70. # Test suite is currently broken
  71. #make check
  72. %install
  73. rm -rf %{buildroot}
  74. make clean-examples
  75. pushd Examples/
  76. # Remove all arch dependent files in Examples/
  77. find -type f -name 'Makefile.in' | xargs rm -f --
  78. # We don't want to ship files below.
  79. rm -rf test-suite
  80. find -type f -name '*.dsp' | xargs rm -f --
  81. find -type f -name '*.dsw' | xargs rm -f --
  82. # Convert files to UNIX format
  83. for all in `find -type f`; do
  84. nkf --unix $all
  85. chmod -x $all
  86. done
  87. popd
  88. make DESTDIR=%{buildroot} install
  89. %clean
  90. rm -rf %{buildroot}
  91. %files
  92. %defattr(-,root,root,-)
  93. %{_bindir}/*
  94. %{_datadir}/swig
  95. %doc ANNOUNCE CHANGES CHANGES.current INSTALL
  96. %doc README TODO
  97. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  98. %files doc
  99. %defattr(-,root,root,-)
  100. %doc Doc Examples
  101. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  102. %changelog
  103. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.12-1
  104. - new upstream release.
  105. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
  106. - new upstream release.
  107. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
  108. - new upstream release
  109. - moved doc subpackage to Documentation Group
  110. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
  111. - update to 3.0.2
  112. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  113. - update to 3.0.0
  114. - add BR: ruby-devel, lua-devel
  115. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  116. - update to 2.0.8
  117. - build with pcre-8.31
  118. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  119. - rebuild with python-2.7.2
  120. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  121. - update to 2.0.4
  122. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  123. - add missing man file(s) to the filelist
  124. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  125. - new upstream release
  126. - rebuild with new toolchain
  127. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  128. - new upstream release
  129. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  130. - new upstream release
  131. - removed php-devel and ruby-devel from BuildPreReq:.
  132. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  133. - new upstream release
  134. - use %%configure
  135. - remove runtime subpackage
  136. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  137. - 1.3.21-0vl2
  138. - un-libtoolize (tarball have already been libtoolized).
  139. - fix %%clean.
  140. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  141. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  142. - 1.3.21-0vl1
  143. - update version
  144. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  145. - 1.3.20-0vl1
  146. - update version
  147. * Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  148. - update version
  149. * Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  150. - update version
  151. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  152. - import to Vine Linux
  153. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  154. - BM.
  155. - Clean up specs.
  156. - 1.3a3.
  157. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  158. - Use makeinstall macros.
  159. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  160. - Provides: swig
  161. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  162. - rebuild with new perl
  163. - cleanup
  164. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  165. - Rebuilt on kenobi
  166. - Don't use prefix
  167. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  168. - First RPM for Mandrake