herqq-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384
  1. %define _qt4_ver 4.7.2
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
  4. %define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
  5. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  6. Name: herqq
  7. Summary: A software library for building UPnP devices and control points
  8. Version: 1.0.0
  9. Release: 2%{?_dist_release}
  10. # test application is GPLv3 but we do not ship it
  11. License: LGPLv3+
  12. URL: http://herqq.org/
  13. Source0: http://downloads.sourceforge.net/project/hupnp/hupnp/%{name}-%{version}.zip
  14. Patch2: herqq-1.0.0-qtsoap-library.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: desktop-file-utils
  17. BuildRequires: qt4-devel
  18. BuildRequires: qtsoap-devel
  19. Requires: qt4 >= %{_qt4_version}
  20. %description
  21. Herqq UPnP (HUPnP) is a software library for building UPnP
  22. devices and control points conforming to the UPnP Device
  23. Architecture version 1.1.
  24. %package devel
  25. Summary: Development files for %{name}
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: qt4-devel = %{_qt4_version}
  28. %description devel
  29. Header files for developing applications using %{name}.
  30. %prep
  31. %setup -q
  32. # lQtSolutions to lqtsoap
  33. %patch2 -p1 -b .qtsoap-library
  34. %build
  35. # we have to disable bundled QtSOAP library
  36. qmake PREFIX=%{_prefix} -config DISABLE_QTSOAP \
  37. -config DISABLE_TESTAPP -config USE_QT_INSTALL_LOC
  38. make %{?_smp_mflags}
  39. %install
  40. make INSTALL_ROOT=%{buildroot} install
  41. %post -p /sbin/ldconfig
  42. %postun -p /sbin/ldconfig
  43. %files
  44. %doc hupnp/ChangeLog hupnp/LICENSE_LGPLv3.txt
  45. %{_qt4_libdir}/libHUpnp.so.1*
  46. %files devel
  47. %{_qt4_libdir}/libHUpnp.so
  48. %{_qt4_headerdir}/HUpnpCore/
  49. %changelog
  50. * Sat Jul 31 2011 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  51. - Initial build for Vine Linux
  52. * Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 1.0.0-1
  53. - post-review update to 1.0.0
  54. * Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-3
  55. - fix license to LGPLv3+
  56. - qt4 header dir for consistency
  57. - shlib soname tracked in %files
  58. - -devel should not duplicate COPYING
  59. * Tue Jul 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-2
  60. - qtsoap library
  61. - cleanup SPEC file
  62. * Tue Feb 22 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-1
  63. - Initial spec file